Linux v4.1-rc6
This commit is contained in:
parent
7bff8aca7d
commit
4741bb0739
@ -163,10 +163,10 @@ index cdc46a791b9d..0c1edd33a42c 100644
|
|||||||
|
|
||||||
extern int modules_disabled; /* for sysctl */
|
extern int modules_disabled; /* for sysctl */
|
||||||
diff --git a/kernel/module.c b/kernel/module.c
|
diff --git a/kernel/module.c b/kernel/module.c
|
||||||
index f43cbdd52546..feb6736fec91 100644
|
index 17738285d7a2..e7065d683640 100644
|
||||||
--- a/kernel/module.c
|
--- a/kernel/module.c
|
||||||
+++ b/kernel/module.c
|
+++ b/kernel/module.c
|
||||||
@@ -3913,6 +3913,13 @@ void module_layout(struct module *mod,
|
@@ -3916,6 +3916,13 @@ void module_layout(struct module *mod,
|
||||||
EXPORT_SYMBOL(module_layout);
|
EXPORT_SYMBOL(module_layout);
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
@ -41,10 +41,10 @@ index c883b86ea964..cdc46a791b9d 100644
|
|||||||
|
|
||||||
#ifdef CONFIG_SYSFS
|
#ifdef CONFIG_SYSFS
|
||||||
diff --git a/kernel/module.c b/kernel/module.c
|
diff --git a/kernel/module.c b/kernel/module.c
|
||||||
index 42a1d2afb217..f43cbdd52546 100644
|
index cfc9e843a924..17738285d7a2 100644
|
||||||
--- a/kernel/module.c
|
--- a/kernel/module.c
|
||||||
+++ b/kernel/module.c
|
+++ b/kernel/module.c
|
||||||
@@ -3912,3 +3912,13 @@ void module_layout(struct module *mod,
|
@@ -3915,3 +3915,13 @@ void module_layout(struct module *mod,
|
||||||
}
|
}
|
||||||
EXPORT_SYMBOL(module_layout);
|
EXPORT_SYMBOL(module_layout);
|
||||||
#endif
|
#endif
|
||||||
|
@ -228,7 +228,7 @@ index 4121345498e0..0ff3cef5df96 100644
|
|||||||
|
|
||||||
return 0;
|
return 0;
|
||||||
diff --git a/kernel/module.c b/kernel/module.c
|
diff --git a/kernel/module.c b/kernel/module.c
|
||||||
index feb6736fec91..5ea645737f23 100644
|
index e7065d683640..731d2653c60d 100644
|
||||||
--- a/kernel/module.c
|
--- a/kernel/module.c
|
||||||
+++ b/kernel/module.c
|
+++ b/kernel/module.c
|
||||||
@@ -107,9 +107,9 @@ struct list_head *kdb_modules = &modules; /* kdb needs the list of modules */
|
@@ -107,9 +107,9 @@ struct list_head *kdb_modules = &modules; /* kdb needs the list of modules */
|
||||||
|
@ -43,7 +43,7 @@ Signed-off-by: Josh Stone <jistone@redhat.com>
|
|||||||
2 files changed, 21 insertions(+), 1 deletion(-)
|
2 files changed, 21 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 92a707859205..24bd79cbc379 100644
|
index aee7e5cb4c15..febebdf01b8b 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -704,7 +704,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer
|
@@ -704,7 +704,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer
|
||||||
|
@ -8,7 +8,7 @@ Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
|
|||||||
1 file changed, 18 insertions(+)
|
1 file changed, 18 insertions(+)
|
||||||
|
|
||||||
diff --git a/arch/arm/boot/dts/am335x-boneblack.dts b/arch/arm/boot/dts/am335x-boneblack.dts
|
diff --git a/arch/arm/boot/dts/am335x-boneblack.dts b/arch/arm/boot/dts/am335x-boneblack.dts
|
||||||
index 0fd89c38cf02..20660917a06f 100644
|
index 5dcdcd173572..38439e097b26 100644
|
||||||
--- a/arch/arm/boot/dts/am335x-boneblack.dts
|
--- a/arch/arm/boot/dts/am335x-boneblack.dts
|
||||||
+++ b/arch/arm/boot/dts/am335x-boneblack.dts
|
+++ b/arch/arm/boot/dts/am335x-boneblack.dts
|
||||||
@@ -71,6 +71,24 @@
|
@@ -71,6 +71,24 @@
|
||||||
|
@ -11,10 +11,10 @@ Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
|
|||||||
1 file changed, 13 insertions(+)
|
1 file changed, 13 insertions(+)
|
||||||
|
|
||||||
diff --git a/arch/arm/boot/dts/am335x-boneblack.dts b/arch/arm/boot/dts/am335x-boneblack.dts
|
diff --git a/arch/arm/boot/dts/am335x-boneblack.dts b/arch/arm/boot/dts/am335x-boneblack.dts
|
||||||
index 5c42d259fa68..0fd89c38cf02 100644
|
index 901739fcb85a..5dcdcd173572 100644
|
||||||
--- a/arch/arm/boot/dts/am335x-boneblack.dts
|
--- a/arch/arm/boot/dts/am335x-boneblack.dts
|
||||||
+++ b/arch/arm/boot/dts/am335x-boneblack.dts
|
+++ b/arch/arm/boot/dts/am335x-boneblack.dts
|
||||||
@@ -78,6 +78,19 @@
|
@@ -78,5 +78,18 @@
|
||||||
pinctrl-0 = <&nxp_hdmi_bonelt_pins>;
|
pinctrl-0 = <&nxp_hdmi_bonelt_pins>;
|
||||||
pinctrl-1 = <&nxp_hdmi_bonelt_off_pins>;
|
pinctrl-1 = <&nxp_hdmi_bonelt_off_pins>;
|
||||||
status = "okay";
|
status = "okay";
|
||||||
@ -33,4 +33,3 @@ index 5c42d259fa68..0fd89c38cf02 100644
|
|||||||
+ };
|
+ };
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
|
|
||||||
|
11
kernel.spec
11
kernel.spec
@ -65,7 +65,7 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 5
|
%define rcrev 6
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 0
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
@ -601,9 +601,6 @@ Patch26176: Input-synaptics-pin-3-touches-when-the-firmware-repo.patch
|
|||||||
#rhbz 1210857
|
#rhbz 1210857
|
||||||
Patch26192: blk-loop-avoid-too-many-pending-per-work-IO.patch
|
Patch26192: blk-loop-avoid-too-many-pending-per-work-IO.patch
|
||||||
|
|
||||||
#rhbz 1220915
|
|
||||||
Patch26201: ovl-don-t-remove-non-empty-opaque-directory.patch
|
|
||||||
|
|
||||||
#rhbz 1220118
|
#rhbz 1220118
|
||||||
Patch26202: media-Fix-regression-in-some-more-dib0700-based-devi.patch
|
Patch26202: media-Fix-regression-in-some-more-dib0700-based-devi.patch
|
||||||
|
|
||||||
@ -1331,9 +1328,6 @@ ApplyPatch Input-synaptics-pin-3-touches-when-the-firmware-repo.patch
|
|||||||
#rhbz 1210857
|
#rhbz 1210857
|
||||||
ApplyPatch blk-loop-avoid-too-many-pending-per-work-IO.patch
|
ApplyPatch blk-loop-avoid-too-many-pending-per-work-IO.patch
|
||||||
|
|
||||||
#rhbz 1220915
|
|
||||||
ApplyPatch ovl-don-t-remove-non-empty-opaque-directory.patch
|
|
||||||
|
|
||||||
#rhbz 1220118
|
#rhbz 1220118
|
||||||
ApplyPatch media-Fix-regression-in-some-more-dib0700-based-devi.patch
|
ApplyPatch media-Fix-regression-in-some-more-dib0700-based-devi.patch
|
||||||
|
|
||||||
@ -2202,6 +2196,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 01 2015 Josh Boyer <jwboyer@fedoraproject.org> - 4.1.0-0.rc6.git0.1
|
||||||
|
- Linux v4.1-rc6
|
||||||
|
|
||||||
* Thu May 28 2015 Josh Boyer <jwboyer@fedoraproject.org>
|
* Thu May 28 2015 Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
- Add quirk for Mac Pro backlight (rhbz 1217249)
|
- Add quirk for Mac Pro backlight (rhbz 1217249)
|
||||||
|
|
||||||
|
@ -1,57 +0,0 @@
|
|||||||
From: Miklos Szeredi <mszeredi@suse.cz>
|
|
||||||
Date: Thu, 14 May 2015 10:04:44 +0200
|
|
||||||
Subject: [PATCH] ovl: don't remove non-empty opaque directory
|
|
||||||
|
|
||||||
When removing an opaque directory we can't just call rmdir() to check for
|
|
||||||
emptiness, because the directory will need to be replaced with a whiteout.
|
|
||||||
The replacement is done with RENAME_EXCHANGE, which doesn't check
|
|
||||||
emptiness.
|
|
||||||
|
|
||||||
Solution is just to check emptiness by reading the directory. In the
|
|
||||||
future we could add a new rename flag to check for emptiness even for
|
|
||||||
RENAME_EXCHANGE to optimize this case.
|
|
||||||
|
|
||||||
Reported-by: Vincent Batts <vbatts@gmail.com>
|
|
||||||
Signed-off-by: Miklos Szeredi <mszeredi@suse.cz>
|
|
||||||
Tested-by: Jordi Pujol Palomer <jordipujolp@gmail.com>
|
|
||||||
Fixes: 263b4a0fee43 ("ovl: dont replace opaque dir")
|
|
||||||
Cc: <stable@vger.kernel.org> # v4.0+
|
|
||||||
---
|
|
||||||
fs/overlayfs/dir.c | 24 +++++++++++++++++++-----
|
|
||||||
1 file changed, 19 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/fs/overlayfs/dir.c b/fs/overlayfs/dir.c
|
|
||||||
index d139405d2bfa..2578a0c0677d 100644
|
|
||||||
--- a/fs/overlayfs/dir.c
|
|
||||||
+++ b/fs/overlayfs/dir.c
|
|
||||||
@@ -506,11 +506,25 @@ static int ovl_remove_and_whiteout(struct dentry *dentry, bool is_dir)
|
|
||||||
struct dentry *opaquedir = NULL;
|
|
||||||
int err;
|
|
||||||
|
|
||||||
- if (is_dir && OVL_TYPE_MERGE_OR_LOWER(ovl_path_type(dentry))) {
|
|
||||||
- opaquedir = ovl_check_empty_and_clear(dentry);
|
|
||||||
- err = PTR_ERR(opaquedir);
|
|
||||||
- if (IS_ERR(opaquedir))
|
|
||||||
- goto out;
|
|
||||||
+ if (is_dir) {
|
|
||||||
+ if (OVL_TYPE_MERGE_OR_LOWER(ovl_path_type(dentry))) {
|
|
||||||
+ opaquedir = ovl_check_empty_and_clear(dentry);
|
|
||||||
+ err = PTR_ERR(opaquedir);
|
|
||||||
+ if (IS_ERR(opaquedir))
|
|
||||||
+ goto out;
|
|
||||||
+ } else {
|
|
||||||
+ LIST_HEAD(list);
|
|
||||||
+
|
|
||||||
+ /*
|
|
||||||
+ * When removing an empty opaque directory, then it
|
|
||||||
+ * makes no sense to replace it with an exact replica of
|
|
||||||
+ * itself. But emptiness still needs to be checked.
|
|
||||||
+ */
|
|
||||||
+ err = ovl_check_empty_dir(dentry, &list);
|
|
||||||
+ ovl_cache_free(&list);
|
|
||||||
+ if (err)
|
|
||||||
+ goto out;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
err = ovl_lock_rename_workdir(workdir, upperdir);
|
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
a86916bd12798220da9eb4a1eec3616d linux-4.0.tar.xz
|
a86916bd12798220da9eb4a1eec3616d linux-4.0.tar.xz
|
||||||
d125eecce68ab6fb5f1f23523c2c04b8 perf-man-4.0.tar.gz
|
d125eecce68ab6fb5f1f23523c2c04b8 perf-man-4.0.tar.gz
|
||||||
5c417954755b5e19b826a7794e224dac patch-4.1-rc5.xz
|
85b103229fdd302a650adbd1d3473fd1 patch-4.1-rc6.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user