update to 3.0-rc4-git3
drop linux-3.0-fix-uts-release.patch and just perl the Makefile instead linux-2.6-silence-noise.patch: fix context
This commit is contained in:
parent
761d1c022e
commit
472d463edc
14
kernel.spec
14
kernel.spec
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||||
# for example a 3 here will become 0.3
|
# for example a 3 here will become 0.3
|
||||||
#
|
#
|
||||||
%global baserelease 2
|
%global baserelease 1
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -85,7 +85,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 4
|
%define rcrev 4
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 0
|
%define gitrev 3
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}
|
%define rpmversion 3.%{upstream_sublevel}
|
||||||
%endif
|
%endif
|
||||||
@ -602,8 +602,6 @@ Patch00: patch-3.%{base_sublevel}-git%{gitrev}.bz2
|
|||||||
|
|
||||||
Patch02: git-linus.diff
|
Patch02: git-linus.diff
|
||||||
|
|
||||||
Patch03: linux-3.0-fix-uts-release.patch
|
|
||||||
|
|
||||||
# we also need compile fixes for -vanilla
|
# we also need compile fixes for -vanilla
|
||||||
Patch04: linux-2.6-compile-fixes.patch
|
Patch04: linux-2.6-compile-fixes.patch
|
||||||
|
|
||||||
@ -1119,7 +1117,6 @@ done
|
|||||||
|
|
||||||
ApplyOptionalPatch git-linus.diff
|
ApplyOptionalPatch git-linus.diff
|
||||||
|
|
||||||
ApplyPatch linux-3.0-fix-uts-release.patch
|
|
||||||
ApplyPatch linux-2.6-makefile-after_link.patch
|
ApplyPatch linux-2.6-makefile-after_link.patch
|
||||||
|
|
||||||
#
|
#
|
||||||
@ -1372,8 +1369,10 @@ BuildKernel() {
|
|||||||
|
|
||||||
# make sure EXTRAVERSION says what we want it to say
|
# make sure EXTRAVERSION says what we want it to say
|
||||||
perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?stablerev}-%{release}.%{_target_cpu}${Flavour:+.${Flavour}}/" Makefile
|
perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?stablerev}-%{release}.%{_target_cpu}${Flavour:+.${Flavour}}/" Makefile
|
||||||
|
perl -p -i -e 's/^SUBLEVEL.*/SUBLEVEL = /' Makefile
|
||||||
|
|
||||||
# if pre-rc1 devel kernel, must fix up SUBLEVEL for our versioning scheme
|
# if pre-rc1 devel kernel, must fix up SUBLEVEL for our versioning scheme
|
||||||
|
### XXX this will probably be dead code in 3.0 --kyle
|
||||||
%if !0%{?rcrev}
|
%if !0%{?rcrev}
|
||||||
%if 0%{?gitrev}
|
%if 0%{?gitrev}
|
||||||
perl -p -i -e 's/^SUBLEVEL.*/SUBLEVEL = %{upstream_sublevel}/' Makefile
|
perl -p -i -e 's/^SUBLEVEL.*/SUBLEVEL = %{upstream_sublevel}/' Makefile
|
||||||
@ -1877,6 +1876,11 @@ fi
|
|||||||
# and build.
|
# and build.
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 23 2011 Kyle McMartin <kmcmartin@redhat.com> 3.0-0.rc4.git3.1
|
||||||
|
- Linux 3.0-rc4-git3
|
||||||
|
- Drop linux-3.0-fix-uts-release.patch, and instead just perl the Makefile
|
||||||
|
- linux-2.6-silence-noise.patch: fix context
|
||||||
|
|
||||||
* Wed Jun 22 2011 Kyle McMartin <kmcmartin@redhat.com> 3.0-0.rc4.git0.2
|
* Wed Jun 22 2011 Kyle McMartin <kmcmartin@redhat.com> 3.0-0.rc4.git0.2
|
||||||
- Re-enable debuginfo generation. Thanks to Richard Jones for noticing... no
|
- Re-enable debuginfo generation. Thanks to Richard Jones for noticing... no
|
||||||
wonder builds had been so quick lately.
|
wonder builds had been so quick lately.
|
||||||
|
@ -69,5 +69,5 @@ index 2a52270..bacbdd2 100644
|
|||||||
- pr_debug("PM: Adding info for %s:%s\n",
|
- pr_debug("PM: Adding info for %s:%s\n",
|
||||||
- dev->bus ? dev->bus->name : "No Bus", dev_name(dev));
|
- dev->bus ? dev->bus->name : "No Bus", dev_name(dev));
|
||||||
mutex_lock(&dpm_list_mtx);
|
mutex_lock(&dpm_list_mtx);
|
||||||
if (dev->parent && dev->parent->power.in_suspend)
|
if (dev->parent && dev->parent->power.is_prepared)
|
||||||
dev_warn(dev, "parent %s should not be sleeping\n",
|
dev_warn(dev, "parent %s should not be sleeping\n",
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index 0499c2e..86b01e8 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
VERSION = 3
|
|
||||||
PATCHLEVEL = 0
|
|
||||||
-SUBLEVEL = 0
|
|
||||||
+SUBLEVEL =
|
|
||||||
EXTRAVERSION = -rc4
|
|
||||||
NAME = Sneaky Weasel
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user