Linux 3.2-rc2-git5 (upstream 6fe4c6d466e9)
Disable PM_DEVFREQ as it seems to be embedded (ARM?) specific even though the Kconfig dependencies don't mark it as such any longer.
This commit is contained in:
parent
09eae387a1
commit
43864d3d09
@ -4659,3 +4659,4 @@ CONFIG_INTEL_MID_PTI=m
|
|||||||
|
|
||||||
CONFIG_IOMMU_SUPPORT=y
|
CONFIG_IOMMU_SUPPORT=y
|
||||||
|
|
||||||
|
# CONFIG_PM_DEVFREQ is not set
|
||||||
|
@ -1,76 +0,0 @@
|
|||||||
From 731abb9cb27aef6013ce60808a04e04a545f3f4e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Josh Boyer <jwboyer@redhat.com>
|
|
||||||
Date: Thu, 10 Nov 2011 15:10:23 +0000
|
|
||||||
Subject: [PATCH] ip6_tunnel: copy parms.name after register_netdevice
|
|
||||||
|
|
||||||
Commit 1c5cae815d removed an explicit call to dev_alloc_name in ip6_tnl_create
|
|
||||||
because register_netdevice will now create a valid name. This works for the
|
|
||||||
net_device itself.
|
|
||||||
|
|
||||||
However the tunnel keeps a copy of the name in the parms structure for the
|
|
||||||
ip6_tnl associated with the tunnel. parms.name is set by copying the net_device
|
|
||||||
name in ip6_tnl_dev_init_gen. That function is called from ip6_tnl_dev_init in
|
|
||||||
ip6_tnl_create, but it is done before register_netdevice is called so the name
|
|
||||||
is set to a bogus value in the parms.name structure.
|
|
||||||
|
|
||||||
This shows up if you do a simple tunnel add, followed by a tunnel show:
|
|
||||||
|
|
||||||
[root@localhost ~]# ip -6 tunnel add remote fec0::100 local fec0::200
|
|
||||||
[root@localhost ~]# ip -6 tunnel show
|
|
||||||
ip6tnl0: ipv6/ipv6 remote :: local :: encaplimit 0 hoplimit 0 tclass 0x00 flowlabel 0x00000 (flowinfo 0x00000000)
|
|
||||||
ip6tnl%d: ipv6/ipv6 remote fec0::100 local fec0::200 encaplimit 4 hoplimit 64 tclass 0x00 flowlabel 0x00000 (flowinfo 0x00000000)
|
|
||||||
[root@localhost ~]#
|
|
||||||
|
|
||||||
Fix this by moving the strcpy out of ip6_tnl_dev_init_gen, and calling it after
|
|
||||||
register_netdevice has successfully returned.
|
|
||||||
|
|
||||||
Cc: stable@vger.kernel.org
|
|
||||||
Signed-off-by: Josh Boyer <jwboyer@redhat.com>
|
|
||||||
Signed-off-by: David S. Miller <davem@davemloft.net>
|
|
||||||
---
|
|
||||||
net/ipv6/ip6_tunnel.c | 8 +++++++-
|
|
||||||
1 files changed, 7 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/net/ipv6/ip6_tunnel.c b/net/ipv6/ip6_tunnel.c
|
|
||||||
index bdc15c9..4e2e9ff 100644
|
|
||||||
--- a/net/ipv6/ip6_tunnel.c
|
|
||||||
+++ b/net/ipv6/ip6_tunnel.c
|
|
||||||
@@ -289,6 +289,8 @@ static struct ip6_tnl *ip6_tnl_create(struct net *net, struct ip6_tnl_parm *p)
|
|
||||||
if ((err = register_netdevice(dev)) < 0)
|
|
||||||
goto failed_free;
|
|
||||||
|
|
||||||
+ strcpy(t->parms.name, dev->name);
|
|
||||||
+
|
|
||||||
dev_hold(dev);
|
|
||||||
ip6_tnl_link(ip6n, t);
|
|
||||||
return t;
|
|
||||||
@@ -1407,7 +1409,6 @@ ip6_tnl_dev_init_gen(struct net_device *dev)
|
|
||||||
struct ip6_tnl *t = netdev_priv(dev);
|
|
||||||
|
|
||||||
t->dev = dev;
|
|
||||||
- strcpy(t->parms.name, dev->name);
|
|
||||||
dev->tstats = alloc_percpu(struct pcpu_tstats);
|
|
||||||
if (!dev->tstats)
|
|
||||||
return -ENOMEM;
|
|
||||||
@@ -1487,6 +1488,7 @@ static void __net_exit ip6_tnl_destroy_tunnels(struct ip6_tnl_net *ip6n)
|
|
||||||
static int __net_init ip6_tnl_init_net(struct net *net)
|
|
||||||
{
|
|
||||||
struct ip6_tnl_net *ip6n = net_generic(net, ip6_tnl_net_id);
|
|
||||||
+ struct ip6_tnl *t = NULL;
|
|
||||||
int err;
|
|
||||||
|
|
||||||
ip6n->tnls[0] = ip6n->tnls_wc;
|
|
||||||
@@ -1507,6 +1509,10 @@ static int __net_init ip6_tnl_init_net(struct net *net)
|
|
||||||
err = register_netdev(ip6n->fb_tnl_dev);
|
|
||||||
if (err < 0)
|
|
||||||
goto err_register;
|
|
||||||
+
|
|
||||||
+ t = netdev_priv(ip6n->fb_tnl_dev);
|
|
||||||
+
|
|
||||||
+ strcpy(t->parms.name, ip6n->fb_tnl_dev->name);
|
|
||||||
return 0;
|
|
||||||
|
|
||||||
err_register:
|
|
||||||
--
|
|
||||||
1.7.6.2
|
|
||||||
|
|
11
kernel.spec
11
kernel.spec
@ -87,7 +87,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 2
|
%define rcrev 2
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 4
|
%define gitrev 5
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -703,9 +703,6 @@ Patch12303: dmar-disable-when-ricoh-multifunction.patch
|
|||||||
Patch13002: revert-efi-rtclock.patch
|
Patch13002: revert-efi-rtclock.patch
|
||||||
Patch13003: efi-dont-map-boot-services-on-32bit.patch
|
Patch13003: efi-dont-map-boot-services-on-32bit.patch
|
||||||
|
|
||||||
#rhbz 751165
|
|
||||||
Patch13010: ip6_tunnel-copy-parms.name-after-register_netdevice.patch
|
|
||||||
|
|
||||||
Patch20000: utrace.patch
|
Patch20000: utrace.patch
|
||||||
|
|
||||||
# Flattened devicetree support
|
# Flattened devicetree support
|
||||||
@ -1348,9 +1345,6 @@ ApplyPatch dmar-disable-when-ricoh-multifunction.patch
|
|||||||
ApplyPatch revert-efi-rtclock.patch
|
ApplyPatch revert-efi-rtclock.patch
|
||||||
ApplyPatch efi-dont-map-boot-services-on-32bit.patch
|
ApplyPatch efi-dont-map-boot-services-on-32bit.patch
|
||||||
|
|
||||||
#rhbz 751165
|
|
||||||
ApplyPatch ip6_tunnel-copy-parms.name-after-register_netdevice.patch
|
|
||||||
|
|
||||||
# utrace.
|
# utrace.
|
||||||
ApplyPatch utrace.patch
|
ApplyPatch utrace.patch
|
||||||
|
|
||||||
@ -2106,6 +2100,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 21 2011 Josh Boyer <jwboyer@redhat.com> 3.2.0-0.rc2.git5.1
|
||||||
|
- Linux 3.2-rc2-git5
|
||||||
|
|
||||||
* Sun Nov 20 2011 Josh Boyer <jwboyer@redhat.com> 3.2.0-0.rc2.git4.1
|
* Sun Nov 20 2011 Josh Boyer <jwboyer@redhat.com> 3.2.0-0.rc2.git4.1
|
||||||
- Linux 3.2-rc2-git4
|
- Linux 3.2-rc2-git4
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
|||||||
8d43453f8159b2332ad410b19d86a931 linux-3.1.tar.bz2
|
8d43453f8159b2332ad410b19d86a931 linux-3.1.tar.bz2
|
||||||
210b6056f364be58cb95e11a529e158d patch-3.2-rc2.bz2
|
210b6056f364be58cb95e11a529e158d patch-3.2-rc2.bz2
|
||||||
9f2c497c472a58e7334a72d91adf1986 patch-3.2-rc2-git4.bz2
|
43e126b13c8511a39441e0b3225ae4ad patch-3.2-rc2-git5.bz2
|
||||||
77da243ea639c14679d67788b2b72f41 compat-wireless-2011-11-15.tar.bz2
|
77da243ea639c14679d67788b2b72f41 compat-wireless-2011-11-15.tar.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user