kernel-6.3.0-0.rc0.20230302gitee3f96b16468.12
* Thu Mar 02 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc0.ee3f96b16468.12] - Add rtla-hwnoise files (Justin M. Forbes) - fix tools build after vm to mm rename (Justin M. Forbes) Resolves: Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
053618ba13
commit
43359330a0
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 11
|
||||
RHEL_RELEASE = 12
|
||||
|
||||
#
|
||||
# ZSTREAM
|
||||
|
@ -1,3 +1,6 @@
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/7bfeffd1d37b3bc7d86247c53843762b4e97c62b
|
||||
7bfeffd1d37b3bc7d86247c53843762b4e97c62b redhat: adapt to upstream Makefile change
|
||||
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/f383ce172fb496d4eaccb0001d6b54a67a181ced
|
||||
f383ce172fb496d4eaccb0001d6b54a67a181ced kernel/rh_messages.c: gcc12 warning on redundant NULL test
|
||||
|
||||
|
15
kernel.spec
15
kernel.spec
@ -141,13 +141,13 @@ Summary: The Linux kernel
|
||||
# define buildid .local
|
||||
%define specversion 6.3.0
|
||||
%define patchversion 6.3
|
||||
%define pkgrelease 0.rc0.20230301gitc0927a7a5391.11
|
||||
%define pkgrelease 0.rc0.20230302gitee3f96b16468.12
|
||||
%define kversion 6
|
||||
%define tarfile_release 6.2-12998-gc0927a7a5391
|
||||
%define tarfile_release 6.2-13115-gee3f96b16468
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 3
|
||||
# This allows pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc0.20230301gitc0927a7a5391.11%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc0.20230302gitee3f96b16468.12%{?buildid}%{?dist}
|
||||
# This defines the kabi tarball version
|
||||
%define kabiversion 6.3.0
|
||||
|
||||
@ -3352,13 +3352,14 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Wed Mar 01 2023 Justin M. Forbes <jforbes@fedoraproject.org> [6.3.0-0.rc0.20230301gitc0927a7a5391.11]
|
||||
* Thu Mar 02 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc0.ee3f96b16468.12]
|
||||
- Add rtla-hwnoise files (Justin M. Forbes)
|
||||
- Revert "redhat/kernel.spec.template: Fix RHEL systemd-boot-unsigned dependency" (Justin M. Forbes)
|
||||
|
||||
* Wed Mar 01 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc0.c0927a7a5391.11]
|
||||
- fix tools build after vm to mm rename (Justin M. Forbes)
|
||||
|
||||
* Thu Mar 02 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc0.ee3f96b16468.11]
|
||||
- redhat: adapt to upstream Makefile change (Clark Williams)
|
||||
- Linux v6.3.0-0.rc0.ee3f96b16468
|
||||
|
||||
* Wed Mar 01 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.3.0-0.rc0.c0927a7a5391.10]
|
||||
- redhat: modify efiuki specfile changes to use variants convention (Clark Williams)
|
||||
- Turn off DEBUG_INFO_COMPRESSED_ZLIB for Fedora (Justin M. Forbes)
|
||||
|
@ -1,7 +1,7 @@
|
||||
Documentation/admin-guide/kernel-parameters.txt | 9 +
|
||||
Kconfig | 2 +
|
||||
Kconfig.redhat | 17 +
|
||||
Makefile | 12 +-
|
||||
Makefile | 11 +-
|
||||
arch/arm/Kconfig | 4 +-
|
||||
arch/arm64/Kconfig | 3 +-
|
||||
arch/arm64/kernel/acpi.c | 4 +
|
||||
@ -64,7 +64,7 @@
|
||||
security/lockdown/Kconfig | 13 +
|
||||
security/lockdown/lockdown.c | 1 +
|
||||
security/security.c | 6 +
|
||||
66 files changed, 1540 insertions(+), 189 deletions(-)
|
||||
66 files changed, 1539 insertions(+), 189 deletions(-)
|
||||
|
||||
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
||||
index 6221a1d057dd..90c169923eda 100644
|
||||
@ -120,21 +120,20 @@ index 000000000000..effb81d04bfd
|
||||
+
|
||||
+endmenu
|
||||
diff --git a/Makefile b/Makefile
|
||||
index aa26f34a9b52..f8ca2e66f4ef 100644
|
||||
index aa26f34a9b52..25ad60532278 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -22,6 +22,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
PHONY := __all
|
||||
__all:
|
||||
@@ -199,6 +199,9 @@ endif
|
||||
this-makefile := $(lastword $(MAKEFILE_LIST))
|
||||
abs_srctree := $(realpath $(dir $(this-makefile)))
|
||||
|
||||
+# Set RHEL variables
|
||||
+# Use this spot to avoid future merge conflicts
|
||||
+include Makefile.rhelver
|
||||
+include $(abs_srctree)/Makefile.rhelver
|
||||
+
|
||||
# We are using a recursive build, so we need to do a little thinking
|
||||
# to get the ordering right.
|
||||
#
|
||||
@@ -1335,7 +1339,13 @@ define filechk_version.h
|
||||
ifneq ($(words $(subst :, ,$(abs_srctree))), 1)
|
||||
$(error source directory cannot contain spaces or colons)
|
||||
endif
|
||||
@@ -1335,7 +1338,13 @@ define filechk_version.h
|
||||
((c) > 255 ? 255 : (c)))'; \
|
||||
echo \#define LINUX_VERSION_MAJOR $(VERSION); \
|
||||
echo \#define LINUX_VERSION_PATCHLEVEL $(PATCHLEVEL); \
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-6.2-12998-gc0927a7a5391.tar.xz) = a42f48d3291f10079aa29ce04656fff0dd53429d56fabe468cb719c57fc7ee13e94219fe3fbaeeff51cd980c0df5f1b9277ad2b5ed58f658cca21c65cc8fbd68
|
||||
SHA512 (kernel-abi-stablelists-6.3.0.tar.bz2) = 49c3824e52b304c882bfc906bd3573960c65ba64af89f428278d4d6937420b0e4d5db04fe6ee95e9f733fbfac7c90dd4863599568a1923ab2a06499495397ad1
|
||||
SHA512 (kernel-kabi-dw-6.3.0.tar.bz2) = eeb40dded21f47b22dfe9eb1ba7698e15701d687999cf7170409735fea317d0f5085e768003f2ce7a7a6f00beac8c72629c11ca7c6dfd93332d0b13d4fce7d0e
|
||||
SHA512 (linux-6.2-13115-gee3f96b16468.tar.xz) = 0447b5e3859be379737ccff426732fe7bdb3336202c569821a0a8d8abc35af7257c9bdb966863939d28865407b1b2a5a03757d326a1e64842698f2ab99858199
|
||||
SHA512 (kernel-abi-stablelists-6.3.0.tar.bz2) = 6a67ea9adc8c7b6388e79a71c0dbd05747d51c0d277f9bbdd853e015f5692bce13001336649acf068a5022ec5e676f209157e95c1ac7d245093f12721f9d0bc0
|
||||
SHA512 (kernel-kabi-dw-6.3.0.tar.bz2) = 3abdf0af54c4bf5e7a42dd488db8388d87d1f04c323e27ef9beeba54a314de19187a85e27f6976f3039d715846a27438e60c026f2a455d8a5437c767bd43c704
|
||||
|
Loading…
Reference in New Issue
Block a user