kernel-5.9.0-0.rc2.1
* Mon Aug 24 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc2.1] - v5.9-rc2 rebase - Updated changelog for the release based on c3d8f220d012 (Fedora Kernel Team) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
b22144999f
commit
427e0b0cd9
@ -15,7 +15,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
|||||||
2 files changed, 96 insertions(+), 31 deletions(-)
|
2 files changed, 96 insertions(+), 31 deletions(-)
|
||||||
|
|
||||||
diff --git a/drivers/firmware/efi/efi.c b/drivers/firmware/efi/efi.c
|
diff --git a/drivers/firmware/efi/efi.c b/drivers/firmware/efi/efi.c
|
||||||
index fdd1db025dbf..8ef7d1df09dd 100644
|
index 3aa07c3b5136..833c35abd009 100644
|
||||||
--- a/drivers/firmware/efi/efi.c
|
--- a/drivers/firmware/efi/efi.c
|
||||||
+++ b/drivers/firmware/efi/efi.c
|
+++ b/drivers/firmware/efi/efi.c
|
||||||
@@ -31,6 +31,7 @@
|
@@ -31,6 +31,7 @@
|
||||||
@ -26,7 +26,7 @@ index fdd1db025dbf..8ef7d1df09dd 100644
|
|||||||
|
|
||||||
#include <asm/early_ioremap.h>
|
#include <asm/early_ioremap.h>
|
||||||
|
|
||||||
@@ -831,40 +832,101 @@ int efi_mem_type(unsigned long phys_addr)
|
@@ -833,40 +834,101 @@ int efi_mem_type(unsigned long phys_addr)
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
@ -8,10 +8,10 @@ Subject: [PATCH] Drop that for now
|
|||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 1434a354290f..9c0083343ea1 100644
|
index 83033334b565..824e2caf4067 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -498,7 +498,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
|
@@ -497,7 +497,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
|
||||||
KBUILD_CFLAGS := -Wall -Wundef -Werror=strict-prototypes -Wno-trigraphs \
|
KBUILD_CFLAGS := -Wall -Wundef -Werror=strict-prototypes -Wno-trigraphs \
|
||||||
-fno-strict-aliasing -fno-common -fshort-wchar -fno-PIE \
|
-fno-strict-aliasing -fno-common -fshort-wchar -fno-PIE \
|
||||||
-Werror=implicit-function-declaration -Werror=implicit-int \
|
-Werror=implicit-function-declaration -Werror=implicit-int \
|
||||||
|
@ -34,10 +34,10 @@ Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
|
|||||||
4 files changed, 30 insertions(+), 3 deletions(-)
|
4 files changed, 30 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
||||||
index bdc1f33fd3d1..f3ffc38c4aa4 100644
|
index a1068742a6df..aba9439caec9 100644
|
||||||
--- a/Documentation/admin-guide/kernel-parameters.txt
|
--- a/Documentation/admin-guide/kernel-parameters.txt
|
||||||
+++ b/Documentation/admin-guide/kernel-parameters.txt
|
+++ b/Documentation/admin-guide/kernel-parameters.txt
|
||||||
@@ -5373,6 +5373,14 @@
|
@@ -5370,6 +5370,14 @@
|
||||||
unknown_nmi_panic
|
unknown_nmi_panic
|
||||||
[X86] Cause panic on unknown NMI.
|
[X86] Cause panic on unknown NMI.
|
||||||
|
|
||||||
|
@ -59,10 +59,10 @@ Acked-by: Prarit Bhargava <prarit@redhat.com>
|
|||||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 9cac6fde3479..1434a354290f 100644
|
index f21168154160..83033334b565 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -1250,7 +1250,13 @@ endef
|
@@ -1249,7 +1249,13 @@ endef
|
||||||
define filechk_version.h
|
define filechk_version.h
|
||||||
echo \#define LINUX_VERSION_CODE $(shell \
|
echo \#define LINUX_VERSION_CODE $(shell \
|
||||||
expr $(VERSION) \* 65536 + 0$(PATCHLEVEL) \* 256 + 0$(SUBLEVEL)); \
|
expr $(VERSION) \* 65536 + 0$(PATCHLEVEL) \* 256 + 0$(SUBLEVEL)); \
|
||||||
|
@ -44,10 +44,10 @@ Note: Simplified backport to just pci-ids
|
|||||||
1 file changed, 6 insertions(+)
|
1 file changed, 6 insertions(+)
|
||||||
|
|
||||||
diff --git a/drivers/scsi/qla2xxx/qla_os.c b/drivers/scsi/qla2xxx/qla_os.c
|
diff --git a/drivers/scsi/qla2xxx/qla_os.c b/drivers/scsi/qla2xxx/qla_os.c
|
||||||
index 9b59f032a569..c27e39378aa9 100644
|
index 8da00ba54aec..cf5ccbdd7fbc 100644
|
||||||
--- a/drivers/scsi/qla2xxx/qla_os.c
|
--- a/drivers/scsi/qla2xxx/qla_os.c
|
||||||
+++ b/drivers/scsi/qla2xxx/qla_os.c
|
+++ b/drivers/scsi/qla2xxx/qla_os.c
|
||||||
@@ -7795,6 +7795,7 @@ static const struct pci_error_handlers qla2xxx_err_handler = {
|
@@ -7796,6 +7796,7 @@ static const struct pci_error_handlers qla2xxx_err_handler = {
|
||||||
};
|
};
|
||||||
|
|
||||||
static struct pci_device_id qla2xxx_pci_tbl[] = {
|
static struct pci_device_id qla2xxx_pci_tbl[] = {
|
||||||
@ -55,7 +55,7 @@ index 9b59f032a569..c27e39378aa9 100644
|
|||||||
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2100) },
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2100) },
|
||||||
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2200) },
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2200) },
|
||||||
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2300) },
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2300) },
|
||||||
@@ -7807,13 +7808,18 @@ static struct pci_device_id qla2xxx_pci_tbl[] = {
|
@@ -7808,13 +7809,18 @@ static struct pci_device_id qla2xxx_pci_tbl[] = {
|
||||||
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP8432) },
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP8432) },
|
||||||
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP5422) },
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP5422) },
|
||||||
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP5432) },
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP5432) },
|
||||||
|
@ -11,4 +11,4 @@
|
|||||||
|
|
||||||
driverdirs="atm auxdisplay bcma bluetooth firewire fmc fpga infiniband isdn leds media memstick message mmc mtd nfc ntb pcmcia platform power ssb staging tty uio uwb w1"
|
driverdirs="atm auxdisplay bcma bluetooth firewire fmc fpga infiniband isdn leds media memstick message mmc mtd nfc ntb pcmcia platform power ssb staging tty uio uwb w1"
|
||||||
|
|
||||||
singlemods="ntb_netdev iscsi_ibft iscsi_boot_sysfs megaraid pmcraid qedi qla1280 9pnet_rdma rpcrdma nvmet-rdma nvme-rdma hid-picolcd hid-prodikeys hwa-hc hwpoison-inject target_core_user sbp_target cxgbit iw_cxgb3 iw_cxgb4 cxgb3i cxgb3i cxgb3i_ddp cxgb4i chcr chtls rnbd-client rnbd-server mlx5_vdpa"
|
singlemods="ntb_netdev iscsi_ibft iscsi_boot_sysfs megaraid pmcraid qedi qla1280 9pnet_rdma rpcrdma nvmet-rdma nvme-rdma hid-picolcd hid-prodikeys hwa-hc hwpoison-inject target_core_user sbp_target cxgbit iw_cxgb3 iw_cxgb4 cxgb3i cxgb3i cxgb3i_ddp cxgb4i chcr chtls rnbd-client rnbd-server"
|
||||||
|
@ -13,7 +13,11 @@ if [ -z $2 ]; then
|
|||||||
exit 1
|
exit 1
|
||||||
fi
|
fi
|
||||||
|
|
||||||
if [ $PRIMARY == "fedora" ]; then
|
if [ -z "$PRIMARY" ]; then
|
||||||
|
PRIMARY=rhel
|
||||||
|
fi
|
||||||
|
|
||||||
|
if [ "$PRIMARY" == "fedora" ]; then
|
||||||
SECONDARY=rhel
|
SECONDARY=rhel
|
||||||
else
|
else
|
||||||
SECONDARY=fedora
|
SECONDARY=fedora
|
||||||
@ -25,7 +29,7 @@ for i in kernel-*-$PRIMARY.config; do
|
|||||||
mv $i $NEW
|
mv $i $NEW
|
||||||
done
|
done
|
||||||
|
|
||||||
rm kernel-*-$SECONDARY.config
|
rm -f kernel-*-$SECONDARY.config
|
||||||
|
|
||||||
if [ $DEBUGBUILDSENABLED -eq 0 ]; then
|
if [ $DEBUGBUILDSENABLED -eq 0 ]; then
|
||||||
for i in kernel-*debug*.config; do
|
for i in kernel-*debug*.config; do
|
||||||
|
26
kernel.spec
26
kernel.spec
@ -30,7 +30,7 @@ Summary: The Linux kernel
|
|||||||
# For a stable, released kernel, released_kernel should be 1.
|
# For a stable, released kernel, released_kernel should be 1.
|
||||||
%global released_kernel 0
|
%global released_kernel 0
|
||||||
|
|
||||||
%global distro_build 0.rc1.20200821gitda2968ff879b.1
|
%global distro_build 0.rc2.1
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%define secure_boot_arch x86_64
|
%define secure_boot_arch x86_64
|
||||||
@ -69,13 +69,13 @@ Summary: The Linux kernel
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%define rpmversion 5.9.0
|
%define rpmversion 5.9.0
|
||||||
%define pkgrelease 0.rc1.20200821gitda2968ff879b.1
|
%define pkgrelease 0.rc2.1
|
||||||
|
|
||||||
# This is needed to do merge window version magic
|
# This is needed to do merge window version magic
|
||||||
%define patchlevel 9
|
%define patchlevel 9
|
||||||
|
|
||||||
# allow pkg_release to have configurable %%{?dist} tag
|
# allow pkg_release to have configurable %%{?dist} tag
|
||||||
%define specrelease 0.rc1.20200821gitda2968ff879b.1%{?buildid}%{?dist}
|
%define specrelease 0.rc2.1%{?buildid}%{?dist}
|
||||||
|
|
||||||
%define pkg_release %{specrelease}
|
%define pkg_release %{specrelease}
|
||||||
|
|
||||||
@ -166,7 +166,7 @@ Summary: The Linux kernel
|
|||||||
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
||||||
# and 0 for rawhide (all kernels are debug kernels).
|
# and 0 for rawhide (all kernels are debug kernels).
|
||||||
# See also 'make debug' and 'make release'.
|
# See also 'make debug' and 'make release'.
|
||||||
%define debugbuildsenabled 0
|
%define debugbuildsenabled 1
|
||||||
|
|
||||||
# The kernel tarball/base version
|
# The kernel tarball/base version
|
||||||
%define kversion 5.9
|
%define kversion 5.9
|
||||||
@ -567,7 +567,7 @@ BuildRequires: asciidoc
|
|||||||
# exact git commit you can run
|
# exact git commit you can run
|
||||||
#
|
#
|
||||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||||
Source0: linux-20200821gitda2968ff879b.tar.xz
|
Source0: linux-5.9-rc2.tar.xz
|
||||||
|
|
||||||
Source1: Makefile.rhelver
|
Source1: Makefile.rhelver
|
||||||
|
|
||||||
@ -1284,8 +1284,8 @@ ApplyOptionalPatch()
|
|||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
%setup -q -n kernel-20200821gitda2968ff879b -c
|
%setup -q -n kernel-5.9-rc2 -c
|
||||||
mv linux-20200821gitda2968ff879b linux-%{KVERREL}
|
mv linux-5.9-rc2 linux-%{KVERREL}
|
||||||
|
|
||||||
cd linux-%{KVERREL}
|
cd linux-%{KVERREL}
|
||||||
cp -a %{SOURCE1} .
|
cp -a %{SOURCE1} .
|
||||||
@ -2793,6 +2793,18 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 24 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc2.1]
|
||||||
|
- v5.9-rc2 rebase
|
||||||
|
- Updated changelog for the release based on c3d8f220d012 (Fedora Kernel Team)
|
||||||
|
|
||||||
|
* Sun Aug 23 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc1.20200823gitc3d8f220d012.1]
|
||||||
|
- c3d8f220d012 rebase
|
||||||
|
- Updated changelog for the release based on f873db9acd3c (Fedora Kernel Team)
|
||||||
|
|
||||||
|
* Sat Aug 22 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc1.20200822gitf873db9acd3c.1]
|
||||||
|
- f873db9acd3c rebase
|
||||||
|
- Updated changelog for the release based on da2968ff879b (Fedora Kernel Team)
|
||||||
|
|
||||||
* Fri Aug 21 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc1.20200821gitda2968ff879b.1]
|
* Fri Aug 21 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc1.20200821gitda2968ff879b.1]
|
||||||
- da2968ff879b rebase
|
- da2968ff879b rebase
|
||||||
- Temporarily remove cdomain from sphinx documentation ("Justin M. Forbes")
|
- Temporarily remove cdomain from sphinx documentation ("Justin M. Forbes")
|
||||||
|
@ -15,6 +15,11 @@ usage()
|
|||||||
echo " -t: test run, do not overwrite original config"
|
echo " -t: test run, do not overwrite original config"
|
||||||
echo " -w: error on misconfigured config options"
|
echo " -w: error on misconfigured config options"
|
||||||
echo " -z: commit new configs to pending directory"
|
echo " -z: commit new configs to pending directory"
|
||||||
|
echo ""
|
||||||
|
echo " A special CONFIG file tag, process_configs_known_broken can be added as a"
|
||||||
|
echo " comment to any CONFIG file. This tag indicates that there is no way to "
|
||||||
|
echo " fix a CONFIG's entry. This tag should only be used in extreme cases"
|
||||||
|
echo " and is not to be used as a workaround to solve CONFIG problems."
|
||||||
exit 1
|
exit 1
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -67,8 +72,23 @@ checkoptions()
|
|||||||
}
|
}
|
||||||
' $1 $2 > .mismatches
|
' $1 $2 > .mismatches
|
||||||
|
|
||||||
|
checkoptions_error=false
|
||||||
if test -s .mismatches
|
if test -s .mismatches
|
||||||
then
|
then
|
||||||
|
while read LINE
|
||||||
|
do
|
||||||
|
if find ./ -name $(echo $LINE | awk -F "=" ' { print $1 } ' | awk ' { print $2 }') | xargs grep ^ | grep -q "process_configs_known_broken"; then
|
||||||
|
# This is a known broken config.
|
||||||
|
# See script help warning.
|
||||||
|
checkoptions_error=false
|
||||||
|
else
|
||||||
|
checkoptions_error=true
|
||||||
|
break
|
||||||
|
fi
|
||||||
|
done < .mismatches
|
||||||
|
|
||||||
|
! $checkoptions_error && return
|
||||||
|
|
||||||
echo "Error: Mismatches found in configuration files"
|
echo "Error: Mismatches found in configuration files"
|
||||||
cat .mismatches
|
cat .mismatches
|
||||||
RETURNCODE=1
|
RETURNCODE=1
|
||||||
@ -167,6 +187,7 @@ function commit_new_configs()
|
|||||||
if [ "$arch" = "EMPTY" ]
|
if [ "$arch" = "EMPTY" ]
|
||||||
then
|
then
|
||||||
# This arch is intentionally left blank
|
# This arch is intentionally left blank
|
||||||
|
rm -f "${cfg}.orig"
|
||||||
continue
|
continue
|
||||||
fi
|
fi
|
||||||
echo -n "Checking for new configs in $cfg ... "
|
echo -n "Checking for new configs in $cfg ... "
|
||||||
@ -201,6 +222,7 @@ function process_configs()
|
|||||||
if [ "$arch" = "EMPTY" ]
|
if [ "$arch" = "EMPTY" ]
|
||||||
then
|
then
|
||||||
# This arch is intentionally left blank
|
# This arch is intentionally left blank
|
||||||
|
rm -f "${cfg}.orig"
|
||||||
continue
|
continue
|
||||||
fi
|
fi
|
||||||
echo -n "Processing $cfg ... "
|
echo -n "Processing $cfg ... "
|
||||||
@ -244,7 +266,7 @@ function process_configs()
|
|||||||
else
|
else
|
||||||
mv ${cfgtmp} ${cfg}
|
mv ${cfgtmp} ${cfg}
|
||||||
fi
|
fi
|
||||||
rm ${cfgorig}
|
rm -f ${cfgorig}
|
||||||
echo "done"
|
echo "done"
|
||||||
done
|
done
|
||||||
rm "$SCRIPT_DIR"/*.config*.old
|
rm "$SCRIPT_DIR"/*.config*.old
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (linux-20200821gitda2968ff879b.tar.xz) = 347deb4ccf7f3fbafe6aa365864539988cb54fb8adb052c2695eb271713cb426582727d4c79134fed42551a54699c592bd2be592d3cc8e4c3e01de371140d034
|
SHA512 (linux-5.9-rc2.tar.xz) = de2df1c257c2015126310414da0bc1f23d92c4610e7358d01c7163960c8fb13ef69044567d5b0a6c7b9152dbe606d5af7e6c6b09535ddd04f67b1ec7b5fbeffb
|
||||||
SHA512 (kernel-abi-whitelists-5.9.0-0.rc1.20200821gitda2968ff879b.1.tar.bz2) = b9257351ac39bcc4766853cf1e31eafa283f4e58683db9b8b0d5d44ce218b670ecb14aaff5e050b1a43460f97642a89dd555dcb4b978c72cdf2a290c5fe13547
|
SHA512 (kernel-abi-whitelists-5.9.0-0.rc2.1.tar.bz2) = 10e2054d004f33c60cdf7733a34b36915393e052678d1e73fede8f132d7e65c029d40d72c11838bbc96f9e9e0321ba2a17d6686513ea7398aa6d87e25a158c67
|
||||||
SHA512 (kernel-kabi-dw-5.9.0-0.rc1.20200821gitda2968ff879b.1.tar.bz2) = 1f398ce5dac24d244bb50836a026b75d3c362d51e12026a7cfbdc7d365408beb8a38eafaa353f93c2b23481b88e3ba12e745c8b0998bd89c9172ff033262989b
|
SHA512 (kernel-kabi-dw-5.9.0-0.rc2.1.tar.bz2) = 51d3ab54724399c4f0dd1467151adb6475412a896734c9955f810f89234a6a8db28948079c39795195505ced71fb70d11369a1fa12530f23e0cb2ce1c3dc5e53
|
||||||
|
Loading…
Reference in New Issue
Block a user