Bring back deprecated PCI ids
This commit is contained in:
parent
95295e2263
commit
3d80ff5551
@ -0,0 +1,95 @@
|
|||||||
|
From 122ad46137ec1fae695b8047c5ae1eafef0a7491 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Lukoshko <alukoshko@almalinux.org>
|
||||||
|
Date: Thu, 8 Aug 2024 16:36:33 +0000
|
||||||
|
Subject: [PATCH 01/10] Enable all disabled pci devices by moving to
|
||||||
|
unmaintained list
|
||||||
|
|
||||||
|
---
|
||||||
|
kernel/rh_messages.h | 66 ++++++++++++++++++++++----------------------
|
||||||
|
1 file changed, 33 insertions(+), 33 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/kernel/rh_messages.h b/kernel/rh_messages.h
|
||||||
|
index 3ac7e00e0..c0737616b 100644
|
||||||
|
--- a/kernel/rh_messages.h
|
||||||
|
+++ b/kernel/rh_messages.h
|
||||||
|
@@ -123,6 +123,39 @@ static const struct pci_device_id rh_deprecated_pci_devices[] = {
|
||||||
|
};
|
||||||
|
|
||||||
|
static const struct pci_device_id rh_disabled_pci_devices[] = {
|
||||||
|
+ {0} /* Terminating entry */
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+static const struct pci_device_id rh_unmaintained_pci_devices[] = {
|
||||||
|
+ { 0x10df, 0xe220, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x10df, 0x0724, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x10df, 0xe200, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x10df, 0xf011, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x10df, 0xf015, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x10df, 0xf100, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x10df, 0xfc40, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1000, 0x005b, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1000, 0x0071, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1000, 0x0073, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1000, 0x0079, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x15B3, 0xA2DC, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1000, 0x006E, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1000, 0x0080, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1000, 0x0081, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1000, 0x0082, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1000, 0x0083, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1000, 0x0084, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1000, 0x0085, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1000, 0x0086, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1000, 0x0087, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x177d, 0xa01e, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x177d, 0xa034, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x177d, 0x0011, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1077, 0x2031, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1077, 0x2532, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1077, 0x8031, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1924, 0x0803, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
+ { 0x1924, 0x0813, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
{ 0x1011, 0x0046, 0x103c, 0x10c2 },
|
||||||
|
{ 0x1011, 0x0046, 0x9005, 0x0364 },
|
||||||
|
{ 0x1011, 0x0046, 0x9005, 0x0365 },
|
||||||
|
@@ -289,37 +322,4 @@ static const struct pci_device_id rh_disabled_pci_devices[] = {
|
||||||
|
{0} /* Terminating entry */
|
||||||
|
};
|
||||||
|
|
||||||
|
-static const struct pci_device_id rh_unmaintained_pci_devices[] = {
|
||||||
|
- { 0x10df, 0xe220, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x10df, 0x0724, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x10df, 0xe200, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x10df, 0xf011, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x10df, 0xf015, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x10df, 0xf100, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x10df, 0xfc40, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1000, 0x005b, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1000, 0x0071, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1000, 0x0073, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1000, 0x0079, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x15B3, 0xA2DC, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1000, 0x006E, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1000, 0x0080, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1000, 0x0081, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1000, 0x0082, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1000, 0x0083, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1000, 0x0084, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1000, 0x0085, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1000, 0x0086, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1000, 0x0087, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x177d, 0xa01e, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x177d, 0xa034, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x177d, 0x0011, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1077, 0x2031, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1077, 0x2532, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1077, 0x8031, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1924, 0x0803, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- { 0x1924, 0x0813, PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
- {0} /* Terminating entry */
|
||||||
|
-};
|
||||||
|
-
|
||||||
|
#endif /* __RH_MESSAGES_H */
|
||||||
|
--
|
||||||
|
2.43.5
|
||||||
|
|
@ -0,0 +1,39 @@
|
|||||||
|
From 0437ffb56aa745a623adce7232efca23c6788d62 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Lukoshko <alukoshko@almalinux.org>
|
||||||
|
Date: Thu, 8 Aug 2024 16:38:01 +0000
|
||||||
|
Subject: [PATCH 02/10] Bring back deprecated pci ids to mptsas-mptspi driver
|
||||||
|
|
||||||
|
---
|
||||||
|
drivers/message/fusion/mptsas.c | 2 +-
|
||||||
|
drivers/message/fusion/mptspi.c | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/message/fusion/mptsas.c b/drivers/message/fusion/mptsas.c
|
||||||
|
index d5f52a128..5f10cbd35 100644
|
||||||
|
--- a/drivers/message/fusion/mptsas.c
|
||||||
|
+++ b/drivers/message/fusion/mptsas.c
|
||||||
|
@@ -5380,7 +5380,7 @@ static void mptsas_remove(struct pci_dev *pdev)
|
||||||
|
}
|
||||||
|
|
||||||
|
static struct pci_device_id mptsas_pci_table[] = {
|
||||||
|
-#ifdef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifdef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{ PCI_VENDOR_ID_LSI_LOGIC, MPI_MANUFACTPAGE_DEVID_SAS1068,
|
||||||
|
PCI_VENDOR_ID_VMWARE, PCI_ANY_ID },
|
||||||
|
#else
|
||||||
|
diff --git a/drivers/message/fusion/mptspi.c b/drivers/message/fusion/mptspi.c
|
||||||
|
index 5a8b2ea73..b1cff4289 100644
|
||||||
|
--- a/drivers/message/fusion/mptspi.c
|
||||||
|
+++ b/drivers/message/fusion/mptspi.c
|
||||||
|
@@ -1239,7 +1239,7 @@ static struct spi_function_template mptspi_transport_functions = {
|
||||||
|
*/
|
||||||
|
|
||||||
|
static struct pci_device_id mptspi_pci_table[] = {
|
||||||
|
-#ifdef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifdef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{ PCI_VENDOR_ID_LSI_LOGIC, MPI_MANUFACTPAGE_DEVID_53C1030,
|
||||||
|
PCI_VENDOR_ID_VMWARE, PCI_ANY_ID },
|
||||||
|
#else
|
||||||
|
--
|
||||||
|
2.43.5
|
||||||
|
|
46
0003-Bring-back-deprecated-pci-ids-to-hpsa-driver.patch
Normal file
46
0003-Bring-back-deprecated-pci-ids-to-hpsa-driver.patch
Normal file
@ -0,0 +1,46 @@
|
|||||||
|
From 21a3bf14f10c6129864fe7049c15baec679fbd24 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Lukoshko <alukoshko@almalinux.org>
|
||||||
|
Date: Thu, 8 Aug 2024 16:40:30 +0000
|
||||||
|
Subject: [PATCH 03/10] Bring back deprecated pci ids to hpsa driver
|
||||||
|
|
||||||
|
---
|
||||||
|
drivers/scsi/hpsa.c | 9 +++++++--
|
||||||
|
1 file changed, 7 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/scsi/hpsa.c b/drivers/scsi/hpsa.c
|
||||||
|
index aa5f9c19d..03226fe8f 100644
|
||||||
|
--- a/drivers/scsi/hpsa.c
|
||||||
|
+++ b/drivers/scsi/hpsa.c
|
||||||
|
@@ -82,7 +82,7 @@ MODULE_DESCRIPTION("Driver for HP Smart Array Controller version " \
|
||||||
|
HPSA_DRIVER_VERSION);
|
||||||
|
MODULE_VERSION(HPSA_DRIVER_VERSION);
|
||||||
|
MODULE_LICENSE("GPL");
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
MODULE_ALIAS("cciss");
|
||||||
|
#endif
|
||||||
|
|
||||||
|
@@ -93,6 +93,11 @@ MODULE_PARM_DESC(hpsa_simple_mode,
|
||||||
|
|
||||||
|
/* define the PCI info for the cards we can control */
|
||||||
|
static const struct pci_device_id hpsa_pci_device_id[] = {
|
||||||
|
+ {PCI_VENDOR_ID_HP, PCI_DEVICE_ID_HP_CISSC, 0x103C, 0x3223},
|
||||||
|
+ {PCI_VENDOR_ID_HP, PCI_DEVICE_ID_HP_CISSC, 0x103C, 0x3234},
|
||||||
|
+ {PCI_VENDOR_ID_HP, PCI_DEVICE_ID_HP_CISSC, 0x103C, 0x3235},
|
||||||
|
+ {PCI_VENDOR_ID_HP, PCI_DEVICE_ID_HP_CISSC, 0x103C, 0x3237},
|
||||||
|
+ {PCI_VENDOR_ID_HP, PCI_DEVICE_ID_HP_CISSC, 0x103C, 0x323D},
|
||||||
|
{PCI_VENDOR_ID_HP, PCI_DEVICE_ID_HP_CISSE, 0x103C, 0x3241},
|
||||||
|
{PCI_VENDOR_ID_HP, PCI_DEVICE_ID_HP_CISSE, 0x103C, 0x3243},
|
||||||
|
{PCI_VENDOR_ID_HP, PCI_DEVICE_ID_HP_CISSE, 0x103C, 0x3245},
|
||||||
|
@@ -146,7 +151,7 @@ static const struct pci_device_id hpsa_pci_device_id[] = {
|
||||||
|
{PCI_VENDOR_ID_HP_3PAR, 0x0075, 0x1590, 0x007D},
|
||||||
|
{PCI_VENDOR_ID_HP_3PAR, 0x0075, 0x1590, 0x0088},
|
||||||
|
{PCI_VENDOR_ID_HP, 0x333f, 0x103c, 0x333f},
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{PCI_VENDOR_ID_HP, PCI_ANY_ID, PCI_ANY_ID, PCI_ANY_ID,
|
||||||
|
PCI_CLASS_STORAGE_RAID << 8, 0xffff << 8, 0},
|
||||||
|
{PCI_VENDOR_ID_COMPAQ, PCI_ANY_ID, PCI_ANY_ID, PCI_ANY_ID,
|
||||||
|
--
|
||||||
|
2.43.5
|
||||||
|
|
40
0004-Bring-back-deprecated-pci-ids-to-qla2xxx-driver.patch
Normal file
40
0004-Bring-back-deprecated-pci-ids-to-qla2xxx-driver.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
From 18a57b9cd3833462356c3b4df180840f3fede7c6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Lukoshko <alukoshko@almalinux.org>
|
||||||
|
Date: Thu, 8 Aug 2024 16:41:35 +0000
|
||||||
|
Subject: [PATCH 04/10] Bring back deprecated pci ids to qla2xxx driver
|
||||||
|
|
||||||
|
---
|
||||||
|
drivers/scsi/qla2xxx/qla_os.c | 6 +++---
|
||||||
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/scsi/qla2xxx/qla_os.c b/drivers/scsi/qla2xxx/qla_os.c
|
||||||
|
index 26089872a..8018c68f2 100644
|
||||||
|
--- a/drivers/scsi/qla2xxx/qla_os.c
|
||||||
|
+++ b/drivers/scsi/qla2xxx/qla_os.c
|
||||||
|
@@ -8123,7 +8123,7 @@ static const struct pci_error_handlers qla2xxx_err_handler = {
|
||||||
|
};
|
||||||
|
|
||||||
|
static struct pci_device_id qla2xxx_pci_tbl[] = {
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2100) },
|
||||||
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2200) },
|
||||||
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2300) },
|
||||||
|
@@ -8139,12 +8139,12 @@ static struct pci_device_id qla2xxx_pci_tbl[] = {
|
||||||
|
#endif
|
||||||
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2532) },
|
||||||
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2031) },
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP8001) },
|
||||||
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP8021) },
|
||||||
|
#endif
|
||||||
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP8031) },
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISPF001) },
|
||||||
|
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP8044) },
|
||||||
|
#endif
|
||||||
|
--
|
||||||
|
2.43.5
|
||||||
|
|
68
0005-Bring-back-deprecated-pci-ids-to-lpfc-driver.patch
Normal file
68
0005-Bring-back-deprecated-pci-ids-to-lpfc-driver.patch
Normal file
@ -0,0 +1,68 @@
|
|||||||
|
From 4ad65faf019bfae8aec7b4e24d41c62184266ba1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Lukoshko <alukoshko@almalinux.org>
|
||||||
|
Date: Thu, 8 Aug 2024 16:42:21 +0000
|
||||||
|
Subject: [PATCH 05/10] Bring back deprecated pci ids to lpfc driver
|
||||||
|
|
||||||
|
---
|
||||||
|
drivers/scsi/lpfc/lpfc_ids.h | 12 ++++++------
|
||||||
|
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/scsi/lpfc/lpfc_ids.h b/drivers/scsi/lpfc/lpfc_ids.h
|
||||||
|
index 85fc52038..83dc9f4c7 100644
|
||||||
|
--- a/drivers/scsi/lpfc/lpfc_ids.h
|
||||||
|
+++ b/drivers/scsi/lpfc/lpfc_ids.h
|
||||||
|
@@ -24,7 +24,7 @@
|
||||||
|
#include <linux/pci.h>
|
||||||
|
|
||||||
|
const struct pci_device_id lpfc_id_table[] = {
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_VIPER,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID, },
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_FIREFLY,
|
||||||
|
@@ -58,7 +58,7 @@ const struct pci_device_id lpfc_id_table[] = {
|
||||||
|
#endif
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_BMID,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID, },
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_BSMB,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID, },
|
||||||
|
#endif
|
||||||
|
@@ -72,7 +72,7 @@ const struct pci_device_id lpfc_id_table[] = {
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID, },
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_ZSMB,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID, },
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_TFLY,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID, },
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_LP101,
|
||||||
|
@@ -96,7 +96,7 @@ const struct pci_device_id lpfc_id_table[] = {
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID, },
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_SAT_S,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID, },
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_PROTEUS_VF,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID, },
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_PROTEUS_PF,
|
||||||
|
@@ -110,13 +110,13 @@ const struct pci_device_id lpfc_id_table[] = {
|
||||||
|
#endif
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_FALCON,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID, },
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_BALIUS,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID, },
|
||||||
|
#endif
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_LANCER_FC,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID, },
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_LANCER_FCOE,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID, },
|
||||||
|
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_LANCER_FC_VF,
|
||||||
|
--
|
||||||
|
2.43.5
|
||||||
|
|
25
0006-Bring-back-deprecated-pci-ids-to-qla4xxx-driver.patch
Normal file
25
0006-Bring-back-deprecated-pci-ids-to-qla4xxx-driver.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 03c58c504f05b1682b29686a5783338a4bb1e9ad Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Lukoshko <alukoshko@almalinux.org>
|
||||||
|
Date: Thu, 8 Aug 2024 16:43:03 +0000
|
||||||
|
Subject: [PATCH 06/10] Bring back deprecated pci ids to qla4xxx driver
|
||||||
|
|
||||||
|
---
|
||||||
|
drivers/scsi/qla4xxx/ql4_os.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/scsi/qla4xxx/ql4_os.c b/drivers/scsi/qla4xxx/ql4_os.c
|
||||||
|
index 7f0cef737..3b6005f55 100644
|
||||||
|
--- a/drivers/scsi/qla4xxx/ql4_os.c
|
||||||
|
+++ b/drivers/scsi/qla4xxx/ql4_os.c
|
||||||
|
@@ -9865,7 +9865,7 @@ static struct pci_device_id qla4xxx_pci_tbl[] = {
|
||||||
|
.subvendor = PCI_ANY_ID,
|
||||||
|
.subdevice = PCI_ANY_ID,
|
||||||
|
},
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{
|
||||||
|
.vendor = PCI_VENDOR_ID_QLOGIC,
|
||||||
|
.device = PCI_DEVICE_ID_QLOGIC_ISP8022,
|
||||||
|
--
|
||||||
|
2.43.5
|
||||||
|
|
25
0007-Bring-back-deprecated-pci-ids-to-be2iscsi-driver.patch
Normal file
25
0007-Bring-back-deprecated-pci-ids-to-be2iscsi-driver.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From c4966c5288bd0cfc3c25526364c6332914131596 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Lukoshko <alukoshko@almalinux.org>
|
||||||
|
Date: Thu, 8 Aug 2024 16:43:41 +0000
|
||||||
|
Subject: [PATCH 07/10] Bring back deprecated pci ids to be2iscsi driver
|
||||||
|
|
||||||
|
---
|
||||||
|
drivers/scsi/be2iscsi/be_main.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/scsi/be2iscsi/be_main.c b/drivers/scsi/be2iscsi/be_main.c
|
||||||
|
index a54ea7cf7..46833f122 100644
|
||||||
|
--- a/drivers/scsi/be2iscsi/be_main.c
|
||||||
|
+++ b/drivers/scsi/be2iscsi/be_main.c
|
||||||
|
@@ -387,7 +387,7 @@ static int beiscsi_eh_device_reset(struct scsi_cmnd *sc)
|
||||||
|
|
||||||
|
/*------------------- PCI Driver operations and data ----------------- */
|
||||||
|
static const struct pci_device_id beiscsi_pci_id_table[] = {
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{ PCI_DEVICE(BE_VENDOR_ID, BE_DEVICE_ID1) },
|
||||||
|
{ PCI_DEVICE(BE_VENDOR_ID, BE_DEVICE_ID2) },
|
||||||
|
{ PCI_DEVICE(BE_VENDOR_ID, OC_DEVICE_ID1) },
|
||||||
|
--
|
||||||
|
2.43.5
|
||||||
|
|
@ -0,0 +1,34 @@
|
|||||||
|
From e5609c1f01d0d018484e4d517c725fab3e1bd723 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Lukoshko <alukoshko@almalinux.org>
|
||||||
|
Date: Thu, 8 Aug 2024 16:48:24 +0000
|
||||||
|
Subject: [PATCH 08/10] Bring back deprecated pci ids to megaraid_sas driver
|
||||||
|
|
||||||
|
---
|
||||||
|
drivers/scsi/megaraid/megaraid_sas_base.c | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/scsi/megaraid/megaraid_sas_base.c b/drivers/scsi/megaraid/megaraid_sas_base.c
|
||||||
|
index bf57fd3b9..0eaed98ac 100644
|
||||||
|
--- a/drivers/scsi/megaraid/megaraid_sas_base.c
|
||||||
|
+++ b/drivers/scsi/megaraid/megaraid_sas_base.c
|
||||||
|
@@ -149,7 +149,7 @@ megasas_set_ld_removed_by_fw(struct megasas_instance *instance);
|
||||||
|
*/
|
||||||
|
static struct pci_device_id megasas_pci_table[] = {
|
||||||
|
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{PCI_DEVICE(PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_LSI_SAS1064R)},
|
||||||
|
/* xscale IOP */
|
||||||
|
{PCI_DEVICE(PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_LSI_SAS1078R)},
|
||||||
|
@@ -165,7 +165,7 @@ static struct pci_device_id megasas_pci_table[] = {
|
||||||
|
/* skinny*/
|
||||||
|
{PCI_DEVICE(PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_LSI_SAS0071SKINNY)},
|
||||||
|
/* skinny*/
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{PCI_DEVICE(PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_LSI_VERDE_ZCR)},
|
||||||
|
/* xscale IOP, vega */
|
||||||
|
{PCI_DEVICE(PCI_VENDOR_ID_DELL, PCI_DEVICE_ID_DELL_PERC5)},
|
||||||
|
--
|
||||||
|
2.43.5
|
||||||
|
|
34
0009-Bring-back-deprecated-pci-ids-to-mpt3sas-driver.patch
Normal file
34
0009-Bring-back-deprecated-pci-ids-to-mpt3sas-driver.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
From cf4290fb89163ec4eb55e682063972035f40c648 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Lukoshko <alukoshko@almalinux.org>
|
||||||
|
Date: Thu, 8 Aug 2024 16:49:54 +0000
|
||||||
|
Subject: [PATCH 09/10] Bring back deprecated pci ids to mpt3sas driver
|
||||||
|
|
||||||
|
---
|
||||||
|
drivers/scsi/mpt3sas/mpt3sas_scsih.c | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/scsi/mpt3sas/mpt3sas_scsih.c b/drivers/scsi/mpt3sas/mpt3sas_scsih.c
|
||||||
|
index 21af6aff1..7f8add3e6 100644
|
||||||
|
--- a/drivers/scsi/mpt3sas/mpt3sas_scsih.c
|
||||||
|
+++ b/drivers/scsi/mpt3sas/mpt3sas_scsih.c
|
||||||
|
@@ -12575,7 +12575,7 @@ scsih_pci_mmio_enabled(struct pci_dev *pdev)
|
||||||
|
* The pci device ids are defined in mpi/mpi2_cnfg.h.
|
||||||
|
*/
|
||||||
|
static const struct pci_device_id mpt3sas_pci_table[] = {
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
/* Spitfire ~ 2004 */
|
||||||
|
{ MPI2_MFGPAGE_VENDORID_LSI, MPI2_MFGPAGE_DEVID_SAS2004,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
@@ -12619,7 +12619,7 @@ static const struct pci_device_id mpt3sas_pci_table[] = {
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
{ MPI2_MFGPAGE_VENDORID_LSI, MPI2_MFGPAGE_DEVID_SWITCH_MPI_EP_1,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
/* SSS6200 */
|
||||||
|
{ MPI2_MFGPAGE_VENDORID_LSI, MPI2_MFGPAGE_DEVID_SSS6200,
|
||||||
|
PCI_ANY_ID, PCI_ANY_ID },
|
||||||
|
--
|
||||||
|
2.43.5
|
||||||
|
|
25
0010-Bring-back-deprecated-pci-ids-to-aacraid-driver.patch
Normal file
25
0010-Bring-back-deprecated-pci-ids-to-aacraid-driver.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From c462f778d114958a05afed7f5ba199417fbc7f1a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Lukoshko <alukoshko@almalinux.org>
|
||||||
|
Date: Thu, 8 Aug 2024 16:50:33 +0000
|
||||||
|
Subject: [PATCH 10/10] Bring back deprecated pci ids to aacraid driver
|
||||||
|
|
||||||
|
---
|
||||||
|
drivers/scsi/aacraid/linit.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/scsi/aacraid/linit.c b/drivers/scsi/aacraid/linit.c
|
||||||
|
index 90a6070a1..e6d12db09 100644
|
||||||
|
--- a/drivers/scsi/aacraid/linit.c
|
||||||
|
+++ b/drivers/scsi/aacraid/linit.c
|
||||||
|
@@ -77,7 +77,7 @@ char aac_driver_version[] = AAC_DRIVER_FULL_VERSION;
|
||||||
|
* Note: The last field is used to index into aac_drivers below.
|
||||||
|
*/
|
||||||
|
static const struct pci_device_id aac_pci_tbl[] = {
|
||||||
|
-#ifndef CONFIG_RHEL_DIFFERENCES
|
||||||
|
+#ifndef CONFIG_ALMALINUX_DIFFERENCES
|
||||||
|
{ 0x1028, 0x0001, 0x1028, 0x0001, 0, 0, 0 }, /* PERC 2/Si (Iguana/PERC2Si) */
|
||||||
|
{ 0x1028, 0x0002, 0x1028, 0x0002, 0, 0, 1 }, /* PERC 3/Di (Opal/PERC3Di) */
|
||||||
|
{ 0x1028, 0x0003, 0x1028, 0x0003, 0, 0, 2 }, /* PERC 3/Si (SlimFast/PERC3Si */
|
||||||
|
--
|
||||||
|
2.43.5
|
||||||
|
|
23
kernel.spec
23
kernel.spec
@ -996,6 +996,18 @@ Source4002: gating.yaml
|
|||||||
Patch1: patch-%{patchversion}-redhat.patch
|
Patch1: patch-%{patchversion}-redhat.patch
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# Bring back deprecated PCI ids #CFHack #CFHack2024
|
||||||
|
Patch2001: 0001-Enable-all-disabled-pci-devices-by-moving-to-unmaint.patch
|
||||||
|
Patch2002: 0002-Bring-back-deprecated-pci-ids-to-mptsas-mptspi-drive.patch
|
||||||
|
Patch2003: 0003-Bring-back-deprecated-pci-ids-to-hpsa-driver.patch
|
||||||
|
Patch2004: 0004-Bring-back-deprecated-pci-ids-to-qla2xxx-driver.patch
|
||||||
|
Patch2005: 0005-Bring-back-deprecated-pci-ids-to-lpfc-driver.patch
|
||||||
|
Patch2006: 0006-Bring-back-deprecated-pci-ids-to-qla4xxx-driver.patch
|
||||||
|
Patch2007: 0007-Bring-back-deprecated-pci-ids-to-be2iscsi-driver.patch
|
||||||
|
Patch2008: 0008-Bring-back-deprecated-pci-ids-to-megaraid_sas-driver.patch
|
||||||
|
Patch2009: 0009-Bring-back-deprecated-pci-ids-to-mpt3sas-driver.patch
|
||||||
|
Patch2010: 0010-Bring-back-deprecated-pci-ids-to-aacraid-driver.patch
|
||||||
|
|
||||||
# empty final patch to facilitate testing of kernel patches
|
# empty final patch to facilitate testing of kernel patches
|
||||||
Patch999999: linux-kernel-test.patch
|
Patch999999: linux-kernel-test.patch
|
||||||
|
|
||||||
@ -1813,6 +1825,17 @@ cp -a %{SOURCE1} .
|
|||||||
%{log_msg "Start of patch applications"}
|
%{log_msg "Start of patch applications"}
|
||||||
%if !%{nopatches}
|
%if !%{nopatches}
|
||||||
|
|
||||||
|
ApplyPatch 0001-Enable-all-disabled-pci-devices-by-moving-to-unmaint.patch
|
||||||
|
ApplyPatch 0002-Bring-back-deprecated-pci-ids-to-mptsas-mptspi-drive.patch
|
||||||
|
ApplyPatch 0003-Bring-back-deprecated-pci-ids-to-hpsa-driver.patch
|
||||||
|
ApplyPatch 0004-Bring-back-deprecated-pci-ids-to-qla2xxx-driver.patch
|
||||||
|
ApplyPatch 0005-Bring-back-deprecated-pci-ids-to-lpfc-driver.patch
|
||||||
|
ApplyPatch 0006-Bring-back-deprecated-pci-ids-to-qla4xxx-driver.patch
|
||||||
|
ApplyPatch 0007-Bring-back-deprecated-pci-ids-to-be2iscsi-driver.patch
|
||||||
|
ApplyPatch 0008-Bring-back-deprecated-pci-ids-to-megaraid_sas-driver.patch
|
||||||
|
ApplyPatch 0009-Bring-back-deprecated-pci-ids-to-mpt3sas-driver.patch
|
||||||
|
ApplyPatch 0010-Bring-back-deprecated-pci-ids-to-aacraid-driver.patch
|
||||||
|
|
||||||
ApplyOptionalPatch patch-%{patchversion}-redhat.patch
|
ApplyOptionalPatch patch-%{patchversion}-redhat.patch
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user