aarch64: add AFTER_LINK to $vdsold for debuginfo generation of the vdso.
This commit is contained in:
parent
1113a8cf60
commit
3b5c960f8b
@ -2264,6 +2264,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 21 2013 Kyle McMartin <kyle@fedoraproject.org>
|
||||||
|
- aarch64: add AFTER_LINK to $vdsold for debuginfo generation of the vdso.
|
||||||
|
|
||||||
* Sun Oct 20 2013 Josh Boyer <jwboyer@fedoraproject.org>
|
* Sun Oct 20 2013 Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
- Build BIG_KEYS into the kernel (rhbz 1017683)
|
- Build BIG_KEYS into the kernel (rhbz 1017683)
|
||||||
|
|
||||||
|
@ -8,11 +8,25 @@ after each final link. This includes vmlinux itself and vDSO images.
|
|||||||
|
|
||||||
Signed-off-by: Roland McGrath <roland@redhat.com>
|
Signed-off-by: Roland McGrath <roland@redhat.com>
|
||||||
|
|
||||||
|
diff --git a/arch/arm64/kernel/vdso/Makefile b/arch/arm64/kernel/vdso/Makefile
|
||||||
|
index d8064af..04dcfe1 100644
|
||||||
|
--- a/arch/arm64/kernel/vdso/Makefile
|
||||||
|
+++ b/arch/arm64/kernel/vdso/Makefile
|
||||||
|
@@ -48,7 +48,8 @@ $(obj-vdso): %.o: %.S
|
||||||
|
|
||||||
|
# Actual build commands
|
||||||
|
quiet_cmd_vdsold = VDSOL $@
|
||||||
|
- cmd_vdsold = $(CC) $(c_flags) -Wl,-T $^ -o $@
|
||||||
|
+ cmd_vdsold = $(CC) $(c_flags) -Wl,-T $^ -o $@ \
|
||||||
|
+ $(if $(AFTER_LINK),; $(AFTER_LINK))
|
||||||
|
quiet_cmd_vdsoas = VDSOA $@
|
||||||
|
cmd_vdsoas = $(CC) $(a_flags) -c -o $@ $<
|
||||||
|
|
||||||
diff --git a/arch/powerpc/kernel/vdso32/Makefile b/arch/powerpc/kernel/vdso32/Makefile
|
diff --git a/arch/powerpc/kernel/vdso32/Makefile b/arch/powerpc/kernel/vdso32/Makefile
|
||||||
index 9a7946c..28d6765 100644
|
index 53e6c9b..e427844 100644
|
||||||
--- a/arch/powerpc/kernel/vdso32/Makefile
|
--- a/arch/powerpc/kernel/vdso32/Makefile
|
||||||
+++ b/arch/powerpc/kernel/vdso32/Makefile
|
+++ b/arch/powerpc/kernel/vdso32/Makefile
|
||||||
@@ -41,7 +41,8 @@ $(obj-vdso32): %.o: %.S
|
@@ -43,7 +43,8 @@ $(obj-vdso32): %.o: %.S
|
||||||
|
|
||||||
# actual build commands
|
# actual build commands
|
||||||
quiet_cmd_vdso32ld = VDSO32L $@
|
quiet_cmd_vdso32ld = VDSO32L $@
|
||||||
@ -23,7 +37,7 @@ index 9a7946c..28d6765 100644
|
|||||||
cmd_vdso32as = $(CROSS32CC) $(a_flags) -c -o $@ $<
|
cmd_vdso32as = $(CROSS32CC) $(a_flags) -c -o $@ $<
|
||||||
|
|
||||||
diff --git a/arch/powerpc/kernel/vdso64/Makefile b/arch/powerpc/kernel/vdso64/Makefile
|
diff --git a/arch/powerpc/kernel/vdso64/Makefile b/arch/powerpc/kernel/vdso64/Makefile
|
||||||
index 8c500d8..d27737b 100644
|
index effca94..713891a 100644
|
||||||
--- a/arch/powerpc/kernel/vdso64/Makefile
|
--- a/arch/powerpc/kernel/vdso64/Makefile
|
||||||
+++ b/arch/powerpc/kernel/vdso64/Makefile
|
+++ b/arch/powerpc/kernel/vdso64/Makefile
|
||||||
@@ -36,7 +36,8 @@ $(obj-vdso64): %.o: %.S
|
@@ -36,7 +36,8 @@ $(obj-vdso64): %.o: %.S
|
||||||
@ -81,7 +95,7 @@ index fd14be1..1f3eb19 100644
|
|||||||
VDSO_LDFLAGS = -fPIC -shared $(call cc-ldoption, -Wl$(comma)--hash-style=sysv)
|
VDSO_LDFLAGS = -fPIC -shared $(call cc-ldoption, -Wl$(comma)--hash-style=sysv)
|
||||||
GCOV_PROFILE := n
|
GCOV_PROFILE := n
|
||||||
diff --git a/scripts/link-vmlinux.sh b/scripts/link-vmlinux.sh
|
diff --git a/scripts/link-vmlinux.sh b/scripts/link-vmlinux.sh
|
||||||
index cd9c6c6..3edf048 100644
|
index 0149949..e307cda 100644
|
||||||
--- a/scripts/link-vmlinux.sh
|
--- a/scripts/link-vmlinux.sh
|
||||||
+++ b/scripts/link-vmlinux.sh
|
+++ b/scripts/link-vmlinux.sh
|
||||||
@@ -65,6 +65,10 @@ vmlinux_link()
|
@@ -65,6 +65,10 @@ vmlinux_link()
|
||||||
@ -95,6 +109,3 @@ index cd9c6c6..3edf048 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.7.6
|
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user