Linux v4.18-rc6
This commit is contained in:
parent
c835242b85
commit
39deac3020
@ -1,79 +0,0 @@
|
|||||||
From patchwork Wed Jul 11 13:48:46 2018
|
|
||||||
Content-Type: text/plain; charset="utf-8"
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Transfer-Encoding: 7bit
|
|
||||||
Subject: aio: don't expose __aio_sigset in uapi
|
|
||||||
From: Christoph Hellwig <hch@lst.de>
|
|
||||||
X-Patchwork-Id: 10519793
|
|
||||||
Message-Id: <20180711134846.18944-1-hch@lst.de>
|
|
||||||
To: viro@zeniv.linux.org.uk
|
|
||||||
Cc: linux-aio@kvack.org, linux-fsdevel@vger.kernel.org,
|
|
||||||
adrian@lisas.de, smueller@chronox.de, avagin@virtuozzo.com
|
|
||||||
Date: Wed, 11 Jul 2018 15:48:46 +0200
|
|
||||||
|
|
||||||
glibc uses a different defintion of sigset_t than the kernel does,
|
|
||||||
and the current version would pull in both. To fix this just do not
|
|
||||||
expose the type at all - this somewhat mirrors pselect() where we
|
|
||||||
do not even have a type for the magic sigmask argument, but just
|
|
||||||
use pointer arithmetics.
|
|
||||||
|
|
||||||
Fixes: 7a074e96 ("aio: implement io_pgetevents")
|
|
||||||
Signed-off-by: Christoph Hellwig <hch@lst.de>
|
|
||||||
Reported-by: Adrian Reber <adrian@lisas.de>
|
|
||||||
---
|
|
||||||
fs/aio.c | 5 +++++
|
|
||||||
include/linux/syscalls.h | 1 +
|
|
||||||
include/uapi/linux/aio_abi.h | 6 ------
|
|
||||||
3 files changed, 6 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/fs/aio.c b/fs/aio.c
|
|
||||||
index 210df9da1283..27454594e37a 100644
|
|
||||||
--- a/fs/aio.c
|
|
||||||
+++ b/fs/aio.c
|
|
||||||
@@ -1896,6 +1896,11 @@ SYSCALL_DEFINE5(io_getevents, aio_context_t, ctx_id,
|
|
||||||
return ret;
|
|
||||||
}
|
|
||||||
|
|
||||||
+struct __aio_sigset {
|
|
||||||
+ const sigset_t __user *sigmask;
|
|
||||||
+ size_t sigsetsize;
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
SYSCALL_DEFINE6(io_pgetevents,
|
|
||||||
aio_context_t, ctx_id,
|
|
||||||
long, min_nr,
|
|
||||||
diff --git a/include/linux/syscalls.h b/include/linux/syscalls.h
|
|
||||||
index a368a68cb667..5c1a0933768e 100644
|
|
||||||
--- a/include/linux/syscalls.h
|
|
||||||
+++ b/include/linux/syscalls.h
|
|
||||||
@@ -11,6 +11,7 @@
|
|
||||||
#ifndef _LINUX_SYSCALLS_H
|
|
||||||
#define _LINUX_SYSCALLS_H
|
|
||||||
|
|
||||||
+struct __aio_sigset;
|
|
||||||
struct epoll_event;
|
|
||||||
struct iattr;
|
|
||||||
struct inode;
|
|
||||||
diff --git a/include/uapi/linux/aio_abi.h b/include/uapi/linux/aio_abi.h
|
|
||||||
index 3c5038b587ba..d4593a6062ef 100644
|
|
||||||
--- a/include/uapi/linux/aio_abi.h
|
|
||||||
+++ b/include/uapi/linux/aio_abi.h
|
|
||||||
@@ -29,7 +29,6 @@
|
|
||||||
|
|
||||||
#include <linux/types.h>
|
|
||||||
#include <linux/fs.h>
|
|
||||||
-#include <linux/signal.h>
|
|
||||||
#include <asm/byteorder.h>
|
|
||||||
|
|
||||||
typedef __kernel_ulong_t aio_context_t;
|
|
||||||
@@ -110,10 +109,5 @@ struct iocb {
|
|
||||||
#undef IFBIG
|
|
||||||
#undef IFLITTLE
|
|
||||||
|
|
||||||
-struct __aio_sigset {
|
|
||||||
- const sigset_t __user *sigmask;
|
|
||||||
- size_t sigsetsize;
|
|
||||||
-};
|
|
||||||
-
|
|
||||||
#endif /* __LINUX__AIO_ABI_H */
|
|
||||||
|
|
10
kernel.spec
10
kernel.spec
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%global rcrev 5
|
%global rcrev 6
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 4
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 4.%{upstream_sublevel}.0
|
%define rpmversion 4.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -619,9 +619,6 @@ Patch514: 0005-treewide-Rename-HOSTLDFLAGS-to-KBUILD_HOSTLDFLAGS.patch
|
|||||||
Patch515: 0006-treewide-Rename-HOST_LOADLIBES-to-KBUILD_HOSTLDLIBS.patch
|
Patch515: 0006-treewide-Rename-HOST_LOADLIBES-to-KBUILD_HOSTLDLIBS.patch
|
||||||
Patch516: 0007-Kbuild-Use-HOST-FLAGS-options-from-the-command-line.patch
|
Patch516: 0007-Kbuild-Use-HOST-FLAGS-options-from-the-command-line.patch
|
||||||
|
|
||||||
# rhbz 1601529
|
|
||||||
Patch517: aio-don-t-expose-__aio_sigset-in-uapi.patch
|
|
||||||
|
|
||||||
# END OF PATCH DEFINITIONS
|
# END OF PATCH DEFINITIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1875,6 +1872,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 23 2018 Laura Abbott <labbott@redhat.com> - 4.18.0-0.rc6.git0.1
|
||||||
|
- Linux v4.18-rc6
|
||||||
|
|
||||||
* Mon Jul 23 2018 Laura Abbott <labbott@redhat.com>
|
* Mon Jul 23 2018 Laura Abbott <labbott@redhat.com>
|
||||||
- Disable debugging options.
|
- Disable debugging options.
|
||||||
|
|
||||||
|
3
sources
3
sources
@ -1,3 +1,2 @@
|
|||||||
SHA512 (linux-4.17.tar.xz) = 4d9de340a26155a89ea8773131c76220cc2057f2b5d031b467b60e8b14c1842518e2d60a863d8c695f0f7640f3f18d43826201984a238dade857b6cef79837db
|
SHA512 (linux-4.17.tar.xz) = 4d9de340a26155a89ea8773131c76220cc2057f2b5d031b467b60e8b14c1842518e2d60a863d8c695f0f7640f3f18d43826201984a238dade857b6cef79837db
|
||||||
SHA512 (patch-4.18-rc5.xz) = 238685483f0eb95d95678dd4ddd83c044d3888bd4ccc6966c6f9e8209a21aea86c18ba4a8e10c9e0d78037bc4809a93196f44ee23e8f9463641a16ca1ea97574
|
SHA512 (patch-4.18-rc6.xz) = ac2983a05b10138fbe2a254c56110ef0e31e6d8868c363959d7b219902b7f84e02cc321e9176161be654fddab1765a448b32c4afa4b30ce3f85a5a10b6fc12c2
|
||||||
SHA512 (patch-4.18-rc5-git4.xz) = 2cc23a53a29200a4d8b50e4f81cd731ca282a4d5d8c96fb6b57a62abbd6cf6bd2be7af83d95d9009289e9b839674feb12285caeafd7eeb1938b52d6145c1f166
|
|
||||||
|
Loading…
Reference in New Issue
Block a user