3.0-git11 snapshot
Add patch from linux-next to fix udlfb binding (rhbz 726163)
This commit is contained in:
parent
4e3ef44362
commit
37a65c7868
@ -1478,6 +1478,7 @@ CONFIG_ATMEL=m
|
|||||||
CONFIG_B43=m
|
CONFIG_B43=m
|
||||||
CONFIG_B43_PCMCIA=y
|
CONFIG_B43_PCMCIA=y
|
||||||
CONFIG_B43_SDIO=y
|
CONFIG_B43_SDIO=y
|
||||||
|
CONFIG_B43_BCMA=y
|
||||||
CONFIG_B43_DEBUG=y
|
CONFIG_B43_DEBUG=y
|
||||||
CONFIG_B43_PHY_LP=y
|
CONFIG_B43_PHY_LP=y
|
||||||
CONFIG_B43_PHY_N=y
|
CONFIG_B43_PHY_N=y
|
||||||
|
10
kernel.spec
10
kernel.spec
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 9
|
%define gitrev 11
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -679,6 +679,8 @@ Patch12016: disable-i8042-check-on-apple-mac.patch
|
|||||||
|
|
||||||
Patch12018: neuter_intel_microcode_load.patch
|
Patch12018: neuter_intel_microcode_load.patch
|
||||||
|
|
||||||
|
Patch12021: udlfb-bind-framebuffer-to-interface.patch
|
||||||
|
|
||||||
# Runtime power management
|
# Runtime power management
|
||||||
Patch12203: linux-2.6-usb-pci-autosuspend.patch
|
Patch12203: linux-2.6-usb-pci-autosuspend.patch
|
||||||
Patch12204: linux-2.6-enable-more-pci-autosuspend.patch
|
Patch12204: linux-2.6-enable-more-pci-autosuspend.patch
|
||||||
@ -1252,6 +1254,8 @@ ApplyPatch add-appleir-usb-driver.patch
|
|||||||
|
|
||||||
ApplyPatch neuter_intel_microcode_load.patch
|
ApplyPatch neuter_intel_microcode_load.patch
|
||||||
|
|
||||||
|
ApplyPatch udlfb-bind-framebuffer-to-interface.patch
|
||||||
|
|
||||||
# Runtime PM
|
# Runtime PM
|
||||||
#ApplyPatch linux-2.6-usb-pci-autosuspend.patch
|
#ApplyPatch linux-2.6-usb-pci-autosuspend.patch
|
||||||
### Broken by implicit notify support & ACPICA rebase
|
### Broken by implicit notify support & ACPICA rebase
|
||||||
@ -1873,6 +1877,10 @@ fi
|
|||||||
# and build.
|
# and build.
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 29 2011 Josh Boyer <jwboyer@redhat.com>
|
||||||
|
- Linux 3.0-git11
|
||||||
|
- Backport patch to correct udlfb removal events (rhbz 726163)
|
||||||
|
|
||||||
* Thu Jul 28 2011 Dave Jones <davej@redhat.com>
|
* Thu Jul 28 2011 Dave Jones <davej@redhat.com>
|
||||||
- module-init-tools needs to be a prereq not a conflict.
|
- module-init-tools needs to be a prereq not a conflict.
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
398e95866794def22b12dfbc15ce89c0 linux-3.0.tar.bz2
|
398e95866794def22b12dfbc15ce89c0 linux-3.0.tar.bz2
|
||||||
4e5417eac273458e78fcb380e8996fec patch-3.0-git9.bz2
|
f7c0bce1da05a9fde516132fa7f85256 patch-3.0-git11.bz2
|
||||||
|
33
udlfb-bind-framebuffer-to-interface.patch
Normal file
33
udlfb-bind-framebuffer-to-interface.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
From c91a793f66d5b06292aa431ae3a36c8aca991fa3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kay Sievers <kay.sievers@vrfy.org>
|
||||||
|
Date: Tue, 5 Jul 2011 17:04:11 -0700
|
||||||
|
Subject: [PATCH] drivers/video/udlfb bind framebuffer to interface.
|
||||||
|
|
||||||
|
Udlfb has been binding the framebuffer device to its parent, which
|
||||||
|
isn't correct and causes confusion with operations like udev remove.
|
||||||
|
|
||||||
|
Coming plug and play multiseat support is dependent on this fix.
|
||||||
|
|
||||||
|
Signed-off-by: Kay Sievers <kay.sievers@vrfy.org>
|
||||||
|
Signed-off-by: Bernie Thompson <bernie@plugable.com>
|
||||||
|
Signed-off-by: Paul Mundt <lethal@linux-sh.org>
|
||||||
|
---
|
||||||
|
drivers/video/udlfb.c | 2 +-
|
||||||
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/video/udlfb.c b/drivers/video/udlfb.c
|
||||||
|
index 816a4fd..c6584c9 100644
|
||||||
|
--- a/drivers/video/udlfb.c
|
||||||
|
+++ b/drivers/video/udlfb.c
|
||||||
|
@@ -1549,7 +1549,7 @@ static int dlfb_usb_probe(struct usb_interface *interface,
|
||||||
|
/* We don't register a new USB class. Our client interface is fbdev */
|
||||||
|
|
||||||
|
/* allocates framebuffer driver structure, not framebuffer memory */
|
||||||
|
- info = framebuffer_alloc(0, &usbdev->dev);
|
||||||
|
+ info = framebuffer_alloc(0, &interface->dev);
|
||||||
|
if (!info) {
|
||||||
|
retval = -ENOMEM;
|
||||||
|
pr_err("framebuffer_alloc failed\n");
|
||||||
|
--
|
||||||
|
1.7.4.4
|
||||||
|
|
Loading…
Reference in New Issue
Block a user