Linux v3.4-rc1-246-g6c216ec
This commit is contained in:
parent
0930ea3e98
commit
374b223109
@ -4296,7 +4296,7 @@ CONFIG_LSM_MMAP_MIN_ADDR=65536
|
|||||||
CONFIG_STRIP_ASM_SYMS=y
|
CONFIG_STRIP_ASM_SYMS=y
|
||||||
|
|
||||||
# CONFIG_RCU_FANOUT_EXACT is not set
|
# CONFIG_RCU_FANOUT_EXACT is not set
|
||||||
CONFIG_RCU_FAST_NO_HZ=y
|
# CONFIG_RCU_FAST_NO_HZ is not set
|
||||||
CONFIG_RCU_CPU_STALL_TIMEOUT=60
|
CONFIG_RCU_CPU_STALL_TIMEOUT=60
|
||||||
# CONFIG_RCU_TORTURE_TEST is not set
|
# CONFIG_RCU_TORTURE_TEST is not set
|
||||||
# CONFIG_RCU_TRACE is not set
|
# CONFIG_RCU_TRACE is not set
|
||||||
|
@ -1,107 +0,0 @@
|
|||||||
From 5c21b39ab123ada8ce248efc733420bd8c9ea255 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Josh Boyer <jwboyer@redhat.com>
|
|
||||||
Date: Fri, 28 Oct 2011 15:38:06 -0400
|
|
||||||
Subject: [PATCH] floppy: Remove _hlt related functions
|
|
||||||
|
|
||||||
It's close enough to 2012 and the WARN_ONCE is causing things like abrt to
|
|
||||||
auto-file bugs that aren't really bugs.
|
|
||||||
|
|
||||||
Signed-off-by: Josh Boyer <jwboyer@redhat.com>
|
|
||||||
|
|
||||||
diff --git a/Documentation/feature-removal-schedule.txt b/Documentation/feature-removal-schedule.txt
|
|
||||||
index d5ac362..df1e87c 100644
|
|
||||||
--- a/Documentation/feature-removal-schedule.txt
|
|
||||||
+++ b/Documentation/feature-removal-schedule.txt
|
|
||||||
@@ -6,14 +6,6 @@ be removed from this file.
|
|
||||||
|
|
||||||
---------------------------
|
|
||||||
|
|
||||||
-What: x86 floppy disable_hlt
|
|
||||||
-When: 2012
|
|
||||||
-Why: ancient workaround of dubious utility clutters the
|
|
||||||
- code used by everybody else.
|
|
||||||
-Who: Len Brown <len.brown@intel.com>
|
|
||||||
-
|
|
||||||
----------------------------
|
|
||||||
-
|
|
||||||
What: CONFIG_APM_CPU_IDLE, and its ability to call APM BIOS in idle
|
|
||||||
When: 2012
|
|
||||||
Why: This optional sub-feature of APM is of dubious reliability,
|
|
||||||
diff --git a/drivers/block/floppy.c b/drivers/block/floppy.c
|
|
||||||
index 9955a53..40bf4c2 100644
|
|
||||||
--- a/drivers/block/floppy.c
|
|
||||||
+++ b/drivers/block/floppy.c
|
|
||||||
@@ -1032,37 +1032,6 @@ static int fd_wait_for_completion(unsigned long delay, timeout_fn function)
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
-static DEFINE_SPINLOCK(floppy_hlt_lock);
|
|
||||||
-static int hlt_disabled;
|
|
||||||
-static void floppy_disable_hlt(void)
|
|
||||||
-{
|
|
||||||
- unsigned long flags;
|
|
||||||
-
|
|
||||||
- WARN_ONCE(1, "floppy_disable_hlt() scheduled for removal in 2012");
|
|
||||||
- spin_lock_irqsave(&floppy_hlt_lock, flags);
|
|
||||||
- if (!hlt_disabled) {
|
|
||||||
- hlt_disabled = 1;
|
|
||||||
-#ifdef HAVE_DISABLE_HLT
|
|
||||||
- disable_hlt();
|
|
||||||
-#endif
|
|
||||||
- }
|
|
||||||
- spin_unlock_irqrestore(&floppy_hlt_lock, flags);
|
|
||||||
-}
|
|
||||||
-
|
|
||||||
-static void floppy_enable_hlt(void)
|
|
||||||
-{
|
|
||||||
- unsigned long flags;
|
|
||||||
-
|
|
||||||
- spin_lock_irqsave(&floppy_hlt_lock, flags);
|
|
||||||
- if (hlt_disabled) {
|
|
||||||
- hlt_disabled = 0;
|
|
||||||
-#ifdef HAVE_DISABLE_HLT
|
|
||||||
- enable_hlt();
|
|
||||||
-#endif
|
|
||||||
- }
|
|
||||||
- spin_unlock_irqrestore(&floppy_hlt_lock, flags);
|
|
||||||
-}
|
|
||||||
-
|
|
||||||
static void setup_DMA(void)
|
|
||||||
{
|
|
||||||
unsigned long f;
|
|
||||||
@@ -1107,7 +1076,6 @@ static void setup_DMA(void)
|
|
||||||
fd_enable_dma();
|
|
||||||
release_dma_lock(f);
|
|
||||||
#endif
|
|
||||||
- floppy_disable_hlt();
|
|
||||||
}
|
|
||||||
|
|
||||||
static void show_floppy(void);
|
|
||||||
@@ -1709,7 +1677,6 @@ irqreturn_t floppy_interrupt(int irq, void *dev_id)
|
|
||||||
fd_disable_dma();
|
|
||||||
release_dma_lock(f);
|
|
||||||
|
|
||||||
- floppy_enable_hlt();
|
|
||||||
do_floppy = NULL;
|
|
||||||
if (fdc >= N_FDC || FDCS->address == -1) {
|
|
||||||
/* we don't even know which FDC is the culprit */
|
|
||||||
@@ -1858,8 +1825,6 @@ static void floppy_shutdown(unsigned long data)
|
|
||||||
show_floppy();
|
|
||||||
cancel_activity();
|
|
||||||
|
|
||||||
- floppy_enable_hlt();
|
|
||||||
-
|
|
||||||
flags = claim_dma_lock();
|
|
||||||
fd_disable_dma();
|
|
||||||
release_dma_lock(flags);
|
|
||||||
@@ -4504,7 +4469,6 @@ static void floppy_release_irq_and_dma(void)
|
|
||||||
#if N_FDC > 1
|
|
||||||
set_dor(1, ~8, 0);
|
|
||||||
#endif
|
|
||||||
- floppy_enable_hlt();
|
|
||||||
|
|
||||||
if (floppy_track_buffer && max_buffer_sectors) {
|
|
||||||
tmpsize = max_buffer_sectors * 1024;
|
|
||||||
--
|
|
||||||
1.7.6.4
|
|
||||||
|
|
10
kernel.spec
10
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 3
|
%global baserelease 1
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 1
|
%define rcrev 1
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 1
|
%define gitrev 2
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -665,7 +665,6 @@ Patch452: linux-2.6.30-no-pcspkr-modalias.patch
|
|||||||
Patch460: linux-2.6-serial-460800.patch
|
Patch460: linux-2.6-serial-460800.patch
|
||||||
|
|
||||||
Patch470: die-floppy-die.patch
|
Patch470: die-floppy-die.patch
|
||||||
Patch471: floppy-Remove-_hlt-related-functions.patch
|
|
||||||
|
|
||||||
Patch510: linux-2.6-silence-noise.patch
|
Patch510: linux-2.6-silence-noise.patch
|
||||||
Patch520: quite-apm.patch
|
Patch520: quite-apm.patch
|
||||||
@ -1355,7 +1354,6 @@ ApplyPatch linux-2.6-input-kill-stupid-messages.patch
|
|||||||
|
|
||||||
# stop floppy.ko from autoloading during udev...
|
# stop floppy.ko from autoloading during udev...
|
||||||
ApplyPatch die-floppy-die.patch
|
ApplyPatch die-floppy-die.patch
|
||||||
ApplyPatch floppy-Remove-_hlt-related-functions.patch
|
|
||||||
|
|
||||||
ApplyPatch linux-2.6.30-no-pcspkr-modalias.patch
|
ApplyPatch linux-2.6.30-no-pcspkr-modalias.patch
|
||||||
|
|
||||||
@ -2295,6 +2293,10 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 05 2012 Justin M. Forbes <jforbes@redhat.com> - 3.4.0-0.rc1.git2.1
|
||||||
|
- Linux v3.4-rc1-246-g6c216ec
|
||||||
|
- Turn off CONFIG_RCU_FAST_NO_HZ until it is fixed upstream
|
||||||
|
|
||||||
* Thu Apr 05 2012 Dave Jones <davej@redhat.com>
|
* Thu Apr 05 2012 Dave Jones <davej@redhat.com>
|
||||||
- Better watermark the number of pages used by hibernation I/O (Bojan Smojver) (rhbz 785384)
|
- Better watermark the number of pages used by hibernation I/O (Bojan Smojver) (rhbz 785384)
|
||||||
|
|
||||||
|
1
sources
1
sources
@ -1,3 +1,4 @@
|
|||||||
7133f5a2086a7d7ef97abac610c094f5 linux-3.3.tar.xz
|
7133f5a2086a7d7ef97abac610c094f5 linux-3.3.tar.xz
|
||||||
ffba5507a7cc555cdbdac58842481d36 patch-3.4-rc1.xz
|
ffba5507a7cc555cdbdac58842481d36 patch-3.4-rc1.xz
|
||||||
8876a2b09caafef334279f352e62f426 patch-3.4-rc1-git1.xz
|
8876a2b09caafef334279f352e62f426 patch-3.4-rc1-git1.xz
|
||||||
|
1edc881abb1053425b1ba2780816a4c1 patch-3.4-rc1-git2.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user