kernel-5.8.0-0.rc4.1
* Mon Jul 06 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc4.1] - v5.8-rc4 rebase - Updated changelog for the release based on cd77006e01b3 (Fedora Kernel Team) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
675db5ebad
commit
358c00f77f
@ -8,7 +8,7 @@ Subject: [PATCH] Drop that for now
|
|||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index a3ec72fe1d8a..8dd82ad14236 100644
|
index 45081a0c4dcc..d22698a301b9 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -496,7 +496,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
|
@@ -496,7 +496,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
|
||||||
|
@ -77,7 +77,7 @@ index da6510af1221..2ec02cbfda72 100644
|
|||||||
struct pci_driver *drv;
|
struct pci_driver *drv;
|
||||||
struct pci_dev *dev;
|
struct pci_dev *dev;
|
||||||
diff --git a/include/linux/pci.h b/include/linux/pci.h
|
diff --git a/include/linux/pci.h b/include/linux/pci.h
|
||||||
index c79d83304e52..695efeea48f0 100644
|
index 34c1c4f45288..6d9a405feea5 100644
|
||||||
--- a/include/linux/pci.h
|
--- a/include/linux/pci.h
|
||||||
+++ b/include/linux/pci.h
|
+++ b/include/linux/pci.h
|
||||||
@@ -1406,6 +1406,10 @@ int pci_add_dynid(struct pci_driver *drv,
|
@@ -1406,6 +1406,10 @@ int pci_add_dynid(struct pci_driver *drv,
|
||||||
|
@ -94,7 +94,7 @@ index 2e6670860d27..8c35a5db7d7e 100644
|
|||||||
|
|
||||||
/* Exported symbols */
|
/* Exported symbols */
|
||||||
diff --git a/kernel/module.c b/kernel/module.c
|
diff --git a/kernel/module.c b/kernel/module.c
|
||||||
index 0c6573b98c36..4898faa4e8e1 100644
|
index bee1c25ca5c5..6f97025b27d7 100644
|
||||||
--- a/kernel/module.c
|
--- a/kernel/module.c
|
||||||
+++ b/kernel/module.c
|
+++ b/kernel/module.c
|
||||||
@@ -802,6 +802,7 @@ static struct module_attribute modinfo_##field = { \
|
@@ -802,6 +802,7 @@ static struct module_attribute modinfo_##field = { \
|
||||||
|
@ -59,7 +59,7 @@ Acked-by: Prarit Bhargava <prarit@redhat.com>
|
|||||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index a60c98519c37..a3ec72fe1d8a 100644
|
index fe0164a654c7..45081a0c4dcc 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -1217,7 +1217,13 @@ endef
|
@@ -1217,7 +1217,13 @@ endef
|
||||||
|
@ -17,7 +17,7 @@ Signed-off-by: Jeremy Cline <jcline@redhat.com>
|
|||||||
5 files changed, 20 insertions(+)
|
5 files changed, 20 insertions(+)
|
||||||
|
|
||||||
diff --git a/include/linux/lsm_hook_defs.h b/include/linux/lsm_hook_defs.h
|
diff --git a/include/linux/lsm_hook_defs.h b/include/linux/lsm_hook_defs.h
|
||||||
index 6791813cd439..501e14cff79c 100644
|
index af998f93d256..3c33f00cd4d6 100644
|
||||||
--- a/include/linux/lsm_hook_defs.h
|
--- a/include/linux/lsm_hook_defs.h
|
||||||
+++ b/include/linux/lsm_hook_defs.h
|
+++ b/include/linux/lsm_hook_defs.h
|
||||||
@@ -383,6 +383,8 @@ LSM_HOOK(void, LSM_RET_VOID, bpf_prog_free_security, struct bpf_prog_aux *aux)
|
@@ -383,6 +383,8 @@ LSM_HOOK(void, LSM_RET_VOID, bpf_prog_free_security, struct bpf_prog_aux *aux)
|
||||||
@ -82,10 +82,10 @@ index 87cbdc64d272..18555cf18da7 100644
|
|||||||
|
|
||||||
static int __init lockdown_lsm_init(void)
|
static int __init lockdown_lsm_init(void)
|
||||||
diff --git a/security/security.c b/security/security.c
|
diff --git a/security/security.c b/security/security.c
|
||||||
index 0ce3e73edd42..8fe9a9911261 100644
|
index 70a7ad357bc6..23e16e773bc2 100644
|
||||||
--- a/security/security.c
|
--- a/security/security.c
|
||||||
+++ b/security/security.c
|
+++ b/security/security.c
|
||||||
@@ -2501,6 +2501,12 @@ int security_locked_down(enum lockdown_reason what)
|
@@ -2516,6 +2516,12 @@ int security_locked_down(enum lockdown_reason what)
|
||||||
}
|
}
|
||||||
EXPORT_SYMBOL(security_locked_down);
|
EXPORT_SYMBOL(security_locked_down);
|
||||||
|
|
||||||
|
22
kernel.spec
22
kernel.spec
@ -30,7 +30,7 @@ Summary: The Linux kernel
|
|||||||
# For a stable, released kernel, released_kernel should be 1.
|
# For a stable, released kernel, released_kernel should be 1.
|
||||||
%global released_kernel 0
|
%global released_kernel 0
|
||||||
|
|
||||||
%global distro_build 0.rc3.20200701git7c30b859a947.1
|
%global distro_build 0.rc4.1
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%define secure_boot_arch x86_64
|
%define secure_boot_arch x86_64
|
||||||
@ -69,13 +69,13 @@ Summary: The Linux kernel
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%define rpmversion 5.8.0
|
%define rpmversion 5.8.0
|
||||||
%define pkgrelease 0.rc3.20200701git7c30b859a947.1
|
%define pkgrelease 0.rc4.1
|
||||||
|
|
||||||
# This is needed to do merge window version magic
|
# This is needed to do merge window version magic
|
||||||
%define patchlevel 8
|
%define patchlevel 8
|
||||||
|
|
||||||
# allow pkg_release to have configurable %%{?dist} tag
|
# allow pkg_release to have configurable %%{?dist} tag
|
||||||
%define specrelease 0.rc3.20200701git7c30b859a947.1%{?buildid}%{?dist}
|
%define specrelease 0.rc4.1%{?buildid}%{?dist}
|
||||||
|
|
||||||
%define pkg_release %{specrelease}
|
%define pkg_release %{specrelease}
|
||||||
|
|
||||||
@ -166,7 +166,7 @@ Summary: The Linux kernel
|
|||||||
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
||||||
# and 0 for rawhide (all kernels are debug kernels).
|
# and 0 for rawhide (all kernels are debug kernels).
|
||||||
# See also 'make debug' and 'make release'.
|
# See also 'make debug' and 'make release'.
|
||||||
%define debugbuildsenabled 0
|
%define debugbuildsenabled 1
|
||||||
|
|
||||||
# The kernel tarball/base version
|
# The kernel tarball/base version
|
||||||
%define kversion 5.8
|
%define kversion 5.8
|
||||||
@ -567,7 +567,7 @@ BuildRequires: asciidoc
|
|||||||
# exact git commit you can run
|
# exact git commit you can run
|
||||||
#
|
#
|
||||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||||
Source0: linux-20200701git7c30b859a947.tar.xz
|
Source0: linux-5.8-rc4.tar.xz
|
||||||
|
|
||||||
Source1: Makefile.rhelver
|
Source1: Makefile.rhelver
|
||||||
|
|
||||||
@ -1280,8 +1280,8 @@ ApplyOptionalPatch()
|
|||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
%setup -q -n kernel-20200701git7c30b859a947 -c
|
%setup -q -n kernel-5.8-rc4 -c
|
||||||
mv linux-20200701git7c30b859a947 linux-%{KVERREL}
|
mv linux-5.8-rc4 linux-%{KVERREL}
|
||||||
|
|
||||||
cd linux-%{KVERREL}
|
cd linux-%{KVERREL}
|
||||||
cp -a %{SOURCE1} .
|
cp -a %{SOURCE1} .
|
||||||
@ -2792,8 +2792,12 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
* Tue Jun 30 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc3.20200630git7c30b859a947.1]
|
* Mon Jul 06 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc4.1]
|
||||||
- 7c30b859a947 rebase
|
- v5.8-rc4 rebase
|
||||||
|
- Updated changelog for the release based on cd77006e01b3 (Fedora Kernel Team)
|
||||||
|
|
||||||
|
* Thu Jul 02 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc3.20200702gitcd77006e01b3.1]
|
||||||
|
- cd77006e01b3 rebase
|
||||||
- Updated changelog for the release based on v5.8-rc3 (Fedora Kernel Team)
|
- Updated changelog for the release based on v5.8-rc3 (Fedora Kernel Team)
|
||||||
|
|
||||||
* Mon Jun 29 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc3.1]
|
* Mon Jun 29 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc3.1]
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (linux-20200701git7c30b859a947.tar.xz) = 9e4867418521fda44467725eb68652591a557e9171b68520ce3848b47342979ceb1e190a83f155c7a9eccba06e02daf513567952e41a98fb92ca04db318df44e
|
SHA512 (linux-5.8-rc4.tar.xz) = 4d691460552753ec9e8a1f7e28939268dc5846ddb0bf741be6effd8bced8b7ba572a45d9d55b94234433cb5297bd328a0895d3ce2c954d4d4cdb3821e02c2354
|
||||||
SHA512 (kernel-abi-whitelists-5.8.0-0.rc3.20200701git7c30b859a947.1.tar.bz2) = 6a3517feff2e4a8f60456cc10307ae8c0542a08af09de59b0de3e17a752ea2a7bb16e9acffd5122c8bb1b16c8fe0d150b6eb2db7d283f2a7aa3d75e10017289e
|
SHA512 (kernel-abi-whitelists-5.8.0-0.rc4.1.tar.bz2) = 6cf6916e50824dd5f1260cf7931446a02a5c1f5decd7e9ce67f35aac05d19ffb71190d837c109dc44b05ba66780515d9ef41f7a4c317c9da929ac22c08952528
|
||||||
SHA512 (kernel-kabi-dw-5.8.0-0.rc3.20200701git7c30b859a947.1.tar.bz2) = fab0339e3cf80e3b980e04ddc40c65f184be0fe101e55a117b1248b446aba0105d5d1a5d5c0e769ff87671d597ecbc0e95c5756b850644cf597386ce8c7d0895
|
SHA512 (kernel-kabi-dw-5.8.0-0.rc4.1.tar.bz2) = c9588c59b60f7e774b8900d3e7ce308b6c4aaf97b69d7e5f0db6ef05f4833851b066436e0f099a975cfae6bf5a5d1c634e9049899736f7444274d61cfa200f47
|
||||||
|
Loading…
Reference in New Issue
Block a user