Drop upstreamed quirk patches that still apply
Yay patch(1) for letting these get doubly applied.
This commit is contained in:
parent
5db764fdeb
commit
35466ad3b6
@ -1,35 +0,0 @@
|
|||||||
From: Stanislaw Gruszka <sgruszka@redhat.com>
|
|
||||||
Date: Wed, 22 Oct 2014 14:32:52 +0200
|
|
||||||
Subject: [PATCH] asus-nb-wmi: Add wapf4 quirk for the X550VB
|
|
||||||
|
|
||||||
As reported here: http://bugzilla.redhat.com/show_bug.cgi?id=1089731#c23
|
|
||||||
the X550VB needs wapf=4 too.
|
|
||||||
|
|
||||||
Signed-off-by: Stanislaw Gruszka <sgruszka@redhat.com>
|
|
||||||
---
|
|
||||||
drivers/platform/x86/asus-nb-wmi.c | 9 +++++++++
|
|
||||||
1 file changed, 9 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/drivers/platform/x86/asus-nb-wmi.c b/drivers/platform/x86/asus-nb-wmi.c
|
|
||||||
index 3a4951f46065..c1a6cd66af42 100644
|
|
||||||
--- a/drivers/platform/x86/asus-nb-wmi.c
|
|
||||||
+++ b/drivers/platform/x86/asus-nb-wmi.c
|
|
||||||
@@ -182,6 +182,15 @@ static const struct dmi_system_id asus_quirks[] = {
|
|
||||||
},
|
|
||||||
{
|
|
||||||
.callback = dmi_matched,
|
|
||||||
+ .ident = "ASUSTeK COMPUTER INC. X550VB",
|
|
||||||
+ .matches = {
|
|
||||||
+ DMI_MATCH(DMI_SYS_VENDOR, "ASUSTeK COMPUTER INC."),
|
|
||||||
+ DMI_MATCH(DMI_PRODUCT_NAME, "X550VB"),
|
|
||||||
+ },
|
|
||||||
+ .driver_data = &quirk_asus_wapf4,
|
|
||||||
+ },
|
|
||||||
+ {
|
|
||||||
+ .callback = dmi_matched,
|
|
||||||
.ident = "ASUSTeK COMPUTER INC. X55A",
|
|
||||||
.matches = {
|
|
||||||
DMI_MATCH(DMI_SYS_VENDOR, "ASUSTeK COMPUTER INC."),
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
@ -1,45 +0,0 @@
|
|||||||
From: Hans de Goede <hdegoede@redhat.com>
|
|
||||||
Date: Fri, 24 Oct 2014 11:30:19 +0200
|
|
||||||
Subject: [PATCH] i8042: Add notimeout quirk for Fujitsu Lifebook A544 and
|
|
||||||
Lifebook AH544
|
|
||||||
|
|
||||||
These models need i8042.notimeout, otherwise the touchpad will not work.
|
|
||||||
|
|
||||||
BugLink: https://bugzilla.kernel.org/show_bug.cgi?id=69731
|
|
||||||
BugLink: https://bugzilla.redhat.com/show_bug.cgi?id=1111138
|
|
||||||
Cc: stable@vger.kernel.org
|
|
||||||
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
|
||||||
---
|
|
||||||
drivers/input/serio/i8042-x86ia64io.h | 16 ++++++++++++++++
|
|
||||||
1 file changed, 16 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/drivers/input/serio/i8042-x86ia64io.h b/drivers/input/serio/i8042-x86ia64io.h
|
|
||||||
index a0bcbb64d06d..aa9b299f4e26 100644
|
|
||||||
--- a/drivers/input/serio/i8042-x86ia64io.h
|
|
||||||
+++ b/drivers/input/serio/i8042-x86ia64io.h
|
|
||||||
@@ -364,6 +364,22 @@ static const struct dmi_system_id __initconst i8042_dmi_notimeout_table[] = {
|
|
||||||
},
|
|
||||||
},
|
|
||||||
{
|
|
||||||
+ /* Fujitsu A544 laptop */
|
|
||||||
+ /* https://bugzilla.redhat.com/show_bug.cgi?id=1111138 */
|
|
||||||
+ .matches = {
|
|
||||||
+ DMI_MATCH(DMI_SYS_VENDOR, "FUJITSU"),
|
|
||||||
+ DMI_MATCH(DMI_PRODUCT_NAME, "LIFEBOOK A544"),
|
|
||||||
+ },
|
|
||||||
+ },
|
|
||||||
+ {
|
|
||||||
+ /* Fujitsu AH544 laptop */
|
|
||||||
+ /* https://bugzilla.kernel.org/show_bug.cgi?id=69731 */
|
|
||||||
+ .matches = {
|
|
||||||
+ DMI_MATCH(DMI_SYS_VENDOR, "FUJITSU"),
|
|
||||||
+ DMI_MATCH(DMI_PRODUCT_NAME, "LIFEBOOK AH544"),
|
|
||||||
+ },
|
|
||||||
+ },
|
|
||||||
+ {
|
|
||||||
/* Fujitsu U574 laptop */
|
|
||||||
/* https://bugzilla.kernel.org/show_bug.cgi?id=69731 */
|
|
||||||
.matches = {
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
10
kernel.spec
10
kernel.spec
@ -608,11 +608,6 @@ Patch21247: ath9k-rx-dma-stop-check.patch
|
|||||||
|
|
||||||
Patch22000: weird-root-dentry-name-debug.patch
|
Patch22000: weird-root-dentry-name-debug.patch
|
||||||
|
|
||||||
Patch26058: asus-nb-wmi-Add-wapf4-quirk-for-the-X550VB.patch
|
|
||||||
|
|
||||||
#rhbz 1111138
|
|
||||||
Patch26059: i8042-Add-notimeout-quirk-for-Fujitsu-Lifebook-A544-.patch
|
|
||||||
|
|
||||||
#rhbz 1094948
|
#rhbz 1094948
|
||||||
Patch26131: acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
Patch26131: acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
||||||
|
|
||||||
@ -1364,11 +1359,6 @@ ApplyPatch criu-no-expert.patch
|
|||||||
#rhbz 892811
|
#rhbz 892811
|
||||||
ApplyPatch ath9k-rx-dma-stop-check.patch
|
ApplyPatch ath9k-rx-dma-stop-check.patch
|
||||||
|
|
||||||
ApplyPatch asus-nb-wmi-Add-wapf4-quirk-for-the-X550VB.patch
|
|
||||||
|
|
||||||
#rhbz 1111138
|
|
||||||
ApplyPatch i8042-Add-notimeout-quirk-for-Fujitsu-Lifebook-A544-.patch
|
|
||||||
|
|
||||||
#rhbz 1094948
|
#rhbz 1094948
|
||||||
ApplyPatch acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
ApplyPatch acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user