kernel-5.16-0.rc5.35
* Mon Dec 13 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.16-0.rc5.35] - pci.h: Fix static include (Prarit Bhargava) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
59ae253b39
commit
33509b1f24
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
|||||||
#
|
#
|
||||||
# Use this spot to avoid future merge conflicts.
|
# Use this spot to avoid future merge conflicts.
|
||||||
# Do not trim this comment.
|
# Do not trim this comment.
|
||||||
RHEL_RELEASE = 32
|
RHEL_RELEASE = 35
|
||||||
|
|
||||||
#
|
#
|
||||||
# Early y+1 numbering
|
# Early y+1 numbering
|
||||||
|
@ -1,3 +1,6 @@
|
|||||||
|
https://gitlab.com/cki-project/kernel-ark/-/commit/e92cffb3ade9c9013c04bf608ba1019b393c23ea
|
||||||
|
e92cffb3ade9c9013c04bf608ba1019b393c23ea pci.h: Fix static include
|
||||||
|
|
||||||
https://gitlab.com/cki-project/kernel-ark/-/commit/f56e8c23f21528d48b494c2762b7d7674468273d
|
https://gitlab.com/cki-project/kernel-ark/-/commit/f56e8c23f21528d48b494c2762b7d7674468273d
|
||||||
f56e8c23f21528d48b494c2762b7d7674468273d drivers/pci/pci-driver.c: Fix if/ifdef typo
|
f56e8c23f21528d48b494c2762b7d7674468273d drivers/pci/pci-driver.c: Fix if/ifdef typo
|
||||||
|
|
||||||
|
@ -2826,6 +2826,7 @@ CONFIG_IMX2_WDT=m
|
|||||||
CONFIG_IMX7D_ADC=m
|
CONFIG_IMX7D_ADC=m
|
||||||
# CONFIG_IMX7ULP_WDT is not set
|
# CONFIG_IMX7ULP_WDT is not set
|
||||||
CONFIG_IMX8MM_THERMAL=m
|
CONFIG_IMX8MM_THERMAL=m
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_IMX_DMA is not set
|
# CONFIG_IMX_DMA is not set
|
||||||
CONFIG_IMX_DSP=m
|
CONFIG_IMX_DSP=m
|
||||||
CONFIG_IMX_DSP_REMOTEPROC=m
|
CONFIG_IMX_DSP_REMOTEPROC=m
|
||||||
@ -8138,7 +8139,7 @@ CONFIG_VFIO_FSL_MC=m
|
|||||||
CONFIG_VFIO_IOMMU_TYPE1=m
|
CONFIG_VFIO_IOMMU_TYPE1=m
|
||||||
CONFIG_VFIO=m
|
CONFIG_VFIO=m
|
||||||
CONFIG_VFIO_MDEV=m
|
CONFIG_VFIO_MDEV=m
|
||||||
# CONFIG_VFIO_NOIOMMU is not set
|
CONFIG_VFIO_NOIOMMU=y
|
||||||
CONFIG_VFIO_PCI=m
|
CONFIG_VFIO_PCI=m
|
||||||
CONFIG_VFIO_PLATFORM_AMDXGBE_RESET=m
|
CONFIG_VFIO_PLATFORM_AMDXGBE_RESET=m
|
||||||
# CONFIG_VFIO_PLATFORM_CALXEDAXGMAC_RESET is not set
|
# CONFIG_VFIO_PLATFORM_CALXEDAXGMAC_RESET is not set
|
||||||
|
@ -2810,6 +2810,7 @@ CONFIG_IMX2_WDT=m
|
|||||||
CONFIG_IMX7D_ADC=m
|
CONFIG_IMX7D_ADC=m
|
||||||
# CONFIG_IMX7ULP_WDT is not set
|
# CONFIG_IMX7ULP_WDT is not set
|
||||||
CONFIG_IMX8MM_THERMAL=m
|
CONFIG_IMX8MM_THERMAL=m
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_IMX_DMA is not set
|
# CONFIG_IMX_DMA is not set
|
||||||
CONFIG_IMX_DSP=m
|
CONFIG_IMX_DSP=m
|
||||||
CONFIG_IMX_DSP_REMOTEPROC=m
|
CONFIG_IMX_DSP_REMOTEPROC=m
|
||||||
@ -8112,7 +8113,7 @@ CONFIG_VFIO_FSL_MC=m
|
|||||||
CONFIG_VFIO_IOMMU_TYPE1=m
|
CONFIG_VFIO_IOMMU_TYPE1=m
|
||||||
CONFIG_VFIO=m
|
CONFIG_VFIO=m
|
||||||
CONFIG_VFIO_MDEV=m
|
CONFIG_VFIO_MDEV=m
|
||||||
# CONFIG_VFIO_NOIOMMU is not set
|
CONFIG_VFIO_NOIOMMU=y
|
||||||
CONFIG_VFIO_PCI=m
|
CONFIG_VFIO_PCI=m
|
||||||
CONFIG_VFIO_PLATFORM_AMDXGBE_RESET=m
|
CONFIG_VFIO_PLATFORM_AMDXGBE_RESET=m
|
||||||
# CONFIG_VFIO_PLATFORM_CALXEDAXGMAC_RESET is not set
|
# CONFIG_VFIO_PLATFORM_CALXEDAXGMAC_RESET is not set
|
||||||
|
@ -2851,6 +2851,7 @@ CONFIG_IMX2_WDT=m
|
|||||||
CONFIG_IMX7D_ADC=m
|
CONFIG_IMX7D_ADC=m
|
||||||
# CONFIG_IMX7ULP_WDT is not set
|
# CONFIG_IMX7ULP_WDT is not set
|
||||||
CONFIG_IMX8MM_THERMAL=m
|
CONFIG_IMX8MM_THERMAL=m
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_IMX_DMA is not set
|
# CONFIG_IMX_DMA is not set
|
||||||
CONFIG_IMX_DSP=m
|
CONFIG_IMX_DSP=m
|
||||||
CONFIG_IMX_DSP_REMOTEPROC=m
|
CONFIG_IMX_DSP_REMOTEPROC=m
|
||||||
|
@ -2836,6 +2836,7 @@ CONFIG_IMX2_WDT=m
|
|||||||
CONFIG_IMX7D_ADC=m
|
CONFIG_IMX7D_ADC=m
|
||||||
# CONFIG_IMX7ULP_WDT is not set
|
# CONFIG_IMX7ULP_WDT is not set
|
||||||
CONFIG_IMX8MM_THERMAL=m
|
CONFIG_IMX8MM_THERMAL=m
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_IMX_DMA is not set
|
# CONFIG_IMX_DMA is not set
|
||||||
CONFIG_IMX_DSP=m
|
CONFIG_IMX_DSP=m
|
||||||
CONFIG_IMX_DSP_REMOTEPROC=m
|
CONFIG_IMX_DSP_REMOTEPROC=m
|
||||||
|
@ -2796,6 +2796,7 @@ CONFIG_IMX2_WDT=m
|
|||||||
CONFIG_IMX7D_ADC=m
|
CONFIG_IMX7D_ADC=m
|
||||||
# CONFIG_IMX7ULP_WDT is not set
|
# CONFIG_IMX7ULP_WDT is not set
|
||||||
CONFIG_IMX8MM_THERMAL=m
|
CONFIG_IMX8MM_THERMAL=m
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_IMX_DMA is not set
|
# CONFIG_IMX_DMA is not set
|
||||||
CONFIG_IMX_DSP=m
|
CONFIG_IMX_DSP=m
|
||||||
CONFIG_IMX_DSP_REMOTEPROC=m
|
CONFIG_IMX_DSP_REMOTEPROC=m
|
||||||
|
@ -2781,6 +2781,7 @@ CONFIG_IMX2_WDT=m
|
|||||||
CONFIG_IMX7D_ADC=m
|
CONFIG_IMX7D_ADC=m
|
||||||
# CONFIG_IMX7ULP_WDT is not set
|
# CONFIG_IMX7ULP_WDT is not set
|
||||||
CONFIG_IMX8MM_THERMAL=m
|
CONFIG_IMX8MM_THERMAL=m
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_IMX_DMA is not set
|
# CONFIG_IMX_DMA is not set
|
||||||
CONFIG_IMX_DSP=m
|
CONFIG_IMX_DSP=m
|
||||||
CONFIG_IMX_DSP_REMOTEPROC=m
|
CONFIG_IMX_DSP_REMOTEPROC=m
|
||||||
|
@ -2467,6 +2467,7 @@ CONFIG_IMA_SECURE_AND_OR_TRUSTED_BOOT=y
|
|||||||
CONFIG_IMA_WRITE_POLICY=y
|
CONFIG_IMA_WRITE_POLICY=y
|
||||||
CONFIG_IMA=y
|
CONFIG_IMA=y
|
||||||
# CONFIG_IMG_ASCII_LCD is not set
|
# CONFIG_IMG_ASCII_LCD is not set
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_INA2XX_ADC is not set
|
# CONFIG_INA2XX_ADC is not set
|
||||||
CONFIG_INET6_AH=m
|
CONFIG_INET6_AH=m
|
||||||
CONFIG_INET6_ESPINTCP=y
|
CONFIG_INET6_ESPINTCP=y
|
||||||
|
@ -2450,6 +2450,7 @@ CONFIG_IMA_SECURE_AND_OR_TRUSTED_BOOT=y
|
|||||||
CONFIG_IMA_WRITE_POLICY=y
|
CONFIG_IMA_WRITE_POLICY=y
|
||||||
CONFIG_IMA=y
|
CONFIG_IMA=y
|
||||||
# CONFIG_IMG_ASCII_LCD is not set
|
# CONFIG_IMG_ASCII_LCD is not set
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_INA2XX_ADC is not set
|
# CONFIG_INA2XX_ADC is not set
|
||||||
CONFIG_INET6_AH=m
|
CONFIG_INET6_AH=m
|
||||||
CONFIG_INET6_ESPINTCP=y
|
CONFIG_INET6_ESPINTCP=y
|
||||||
|
@ -2323,6 +2323,7 @@ CONFIG_IMA_SECURE_AND_OR_TRUSTED_BOOT=y
|
|||||||
CONFIG_IMA_WRITE_POLICY=y
|
CONFIG_IMA_WRITE_POLICY=y
|
||||||
CONFIG_IMA=y
|
CONFIG_IMA=y
|
||||||
# CONFIG_IMG_ASCII_LCD is not set
|
# CONFIG_IMG_ASCII_LCD is not set
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_INA2XX_ADC is not set
|
# CONFIG_INA2XX_ADC is not set
|
||||||
CONFIG_INET6_AH=m
|
CONFIG_INET6_AH=m
|
||||||
CONFIG_INET6_ESPINTCP=y
|
CONFIG_INET6_ESPINTCP=y
|
||||||
|
@ -2306,6 +2306,7 @@ CONFIG_IMA_SECURE_AND_OR_TRUSTED_BOOT=y
|
|||||||
CONFIG_IMA_WRITE_POLICY=y
|
CONFIG_IMA_WRITE_POLICY=y
|
||||||
CONFIG_IMA=y
|
CONFIG_IMA=y
|
||||||
# CONFIG_IMG_ASCII_LCD is not set
|
# CONFIG_IMG_ASCII_LCD is not set
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_INA2XX_ADC is not set
|
# CONFIG_INA2XX_ADC is not set
|
||||||
CONFIG_INET6_AH=m
|
CONFIG_INET6_AH=m
|
||||||
CONFIG_INET6_ESPINTCP=y
|
CONFIG_INET6_ESPINTCP=y
|
||||||
|
@ -2300,6 +2300,7 @@ CONFIG_IMA_READ_POLICY=y
|
|||||||
CONFIG_IMA_WRITE_POLICY=y
|
CONFIG_IMA_WRITE_POLICY=y
|
||||||
CONFIG_IMA=y
|
CONFIG_IMA=y
|
||||||
# CONFIG_IMG_ASCII_LCD is not set
|
# CONFIG_IMG_ASCII_LCD is not set
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_INA2XX_ADC is not set
|
# CONFIG_INA2XX_ADC is not set
|
||||||
CONFIG_INET6_AH=m
|
CONFIG_INET6_AH=m
|
||||||
CONFIG_INET6_ESPINTCP=y
|
CONFIG_INET6_ESPINTCP=y
|
||||||
|
@ -2283,6 +2283,7 @@ CONFIG_IMA_READ_POLICY=y
|
|||||||
CONFIG_IMA_WRITE_POLICY=y
|
CONFIG_IMA_WRITE_POLICY=y
|
||||||
CONFIG_IMA=y
|
CONFIG_IMA=y
|
||||||
# CONFIG_IMG_ASCII_LCD is not set
|
# CONFIG_IMG_ASCII_LCD is not set
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_INA2XX_ADC is not set
|
# CONFIG_INA2XX_ADC is not set
|
||||||
CONFIG_INET6_AH=m
|
CONFIG_INET6_AH=m
|
||||||
CONFIG_INET6_ESPINTCP=y
|
CONFIG_INET6_ESPINTCP=y
|
||||||
|
@ -2509,6 +2509,7 @@ CONFIG_IMA_SECURE_AND_OR_TRUSTED_BOOT=y
|
|||||||
CONFIG_IMA_WRITE_POLICY=y
|
CONFIG_IMA_WRITE_POLICY=y
|
||||||
CONFIG_IMA=y
|
CONFIG_IMA=y
|
||||||
# CONFIG_IMG_ASCII_LCD is not set
|
# CONFIG_IMG_ASCII_LCD is not set
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_INA2XX_ADC is not set
|
# CONFIG_INA2XX_ADC is not set
|
||||||
CONFIG_INET6_AH=m
|
CONFIG_INET6_AH=m
|
||||||
CONFIG_INET6_ESPINTCP=y
|
CONFIG_INET6_ESPINTCP=y
|
||||||
@ -7345,7 +7346,7 @@ CONFIG_VFAT_FS=m
|
|||||||
CONFIG_VFIO_IOMMU_TYPE1=m
|
CONFIG_VFIO_IOMMU_TYPE1=m
|
||||||
CONFIG_VFIO=m
|
CONFIG_VFIO=m
|
||||||
CONFIG_VFIO_MDEV=m
|
CONFIG_VFIO_MDEV=m
|
||||||
# CONFIG_VFIO_NOIOMMU is not set
|
CONFIG_VFIO_NOIOMMU=y
|
||||||
CONFIG_VFIO_PCI_IGD=y
|
CONFIG_VFIO_PCI_IGD=y
|
||||||
CONFIG_VFIO_PCI=m
|
CONFIG_VFIO_PCI=m
|
||||||
CONFIG_VFIO_PCI_VGA=y
|
CONFIG_VFIO_PCI_VGA=y
|
||||||
|
@ -2492,6 +2492,7 @@ CONFIG_IMA_SECURE_AND_OR_TRUSTED_BOOT=y
|
|||||||
CONFIG_IMA_WRITE_POLICY=y
|
CONFIG_IMA_WRITE_POLICY=y
|
||||||
CONFIG_IMA=y
|
CONFIG_IMA=y
|
||||||
# CONFIG_IMG_ASCII_LCD is not set
|
# CONFIG_IMG_ASCII_LCD is not set
|
||||||
|
# CONFIG_IMX8QXP_ADC is not set
|
||||||
# CONFIG_INA2XX_ADC is not set
|
# CONFIG_INA2XX_ADC is not set
|
||||||
CONFIG_INET6_AH=m
|
CONFIG_INET6_AH=m
|
||||||
CONFIG_INET6_ESPINTCP=y
|
CONFIG_INET6_ESPINTCP=y
|
||||||
@ -7320,7 +7321,7 @@ CONFIG_VFAT_FS=m
|
|||||||
CONFIG_VFIO_IOMMU_TYPE1=m
|
CONFIG_VFIO_IOMMU_TYPE1=m
|
||||||
CONFIG_VFIO=m
|
CONFIG_VFIO=m
|
||||||
CONFIG_VFIO_MDEV=m
|
CONFIG_VFIO_MDEV=m
|
||||||
# CONFIG_VFIO_NOIOMMU is not set
|
CONFIG_VFIO_NOIOMMU=y
|
||||||
CONFIG_VFIO_PCI_IGD=y
|
CONFIG_VFIO_PCI_IGD=y
|
||||||
CONFIG_VFIO_PCI=m
|
CONFIG_VFIO_PCI=m
|
||||||
CONFIG_VFIO_PCI_VGA=y
|
CONFIG_VFIO_PCI_VGA=y
|
||||||
|
22
kernel.spec
22
kernel.spec
@ -85,9 +85,9 @@ Summary: The Linux kernel
|
|||||||
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
||||||
# to build the base kernel using the debug configuration. (Specifying
|
# to build the base kernel using the debug configuration. (Specifying
|
||||||
# the --with-release option overrides this setting.)
|
# the --with-release option overrides this setting.)
|
||||||
%define debugbuildsenabled 0
|
%define debugbuildsenabled 1
|
||||||
|
|
||||||
%global distro_build 0.rc4.20211210gitc741e49150db.32
|
%global distro_build 0.rc5.35
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%define secure_boot_arch x86_64
|
%define secure_boot_arch x86_64
|
||||||
@ -132,13 +132,13 @@ Summary: The Linux kernel
|
|||||||
|
|
||||||
%define rpmversion 5.16.0
|
%define rpmversion 5.16.0
|
||||||
%define patchversion 5.16
|
%define patchversion 5.16
|
||||||
%define pkgrelease 0.rc4.20211210gitc741e49150db.32
|
%define pkgrelease 0.rc5.35
|
||||||
|
|
||||||
# This is needed to do merge window version magic
|
# This is needed to do merge window version magic
|
||||||
%define patchlevel 16
|
%define patchlevel 16
|
||||||
|
|
||||||
# allow pkg_release to have configurable %%{?dist} tag
|
# allow pkg_release to have configurable %%{?dist} tag
|
||||||
%define specrelease 0.rc4.20211210gitc741e49150db.32%{?buildid}%{?dist}
|
%define specrelease 0.rc5.35%{?buildid}%{?dist}
|
||||||
|
|
||||||
%define pkg_release %{specrelease}
|
%define pkg_release %{specrelease}
|
||||||
|
|
||||||
@ -689,7 +689,7 @@ BuildRequires: lld
|
|||||||
# exact git commit you can run
|
# exact git commit you can run
|
||||||
#
|
#
|
||||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||||
Source0: linux-5.16-rc4-163-gc741e49150db.tar.xz
|
Source0: linux-5.16-rc5.tar.xz
|
||||||
|
|
||||||
Source1: Makefile.rhelver
|
Source1: Makefile.rhelver
|
||||||
|
|
||||||
@ -1383,8 +1383,8 @@ ApplyOptionalPatch()
|
|||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
%setup -q -n kernel-5.16-rc4-163-gc741e49150db -c
|
%setup -q -n kernel-5.16-rc5 -c
|
||||||
mv linux-5.16-rc4-163-gc741e49150db linux-%{KVERREL}
|
mv linux-5.16-rc5 linux-%{KVERREL}
|
||||||
|
|
||||||
cd linux-%{KVERREL}
|
cd linux-%{KVERREL}
|
||||||
cp -a %{SOURCE1} .
|
cp -a %{SOURCE1} .
|
||||||
@ -2193,7 +2193,7 @@ InitBuildVars
|
|||||||
%global perf_build_extra_opts CORESIGHT=1
|
%global perf_build_extra_opts CORESIGHT=1
|
||||||
%endif
|
%endif
|
||||||
%global perf_make \
|
%global perf_make \
|
||||||
%{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBTRACEEVENT_DYNAMIC=1 %{?perf_build_extra_opts} prefix=%{_prefix} PYTHON=%{__python3}
|
%{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBBPF_DYNAMIC=1 LIBTRACEEVENT_DYNAMIC=1 %{?perf_build_extra_opts} prefix=%{_prefix} PYTHON=%{__python3}
|
||||||
%if %{with_perf}
|
%if %{with_perf}
|
||||||
# perf
|
# perf
|
||||||
# make sure check-headers.sh is executable
|
# make sure check-headers.sh is executable
|
||||||
@ -2981,6 +2981,12 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 13 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.16-0.rc5.35]
|
||||||
|
- pci.h: Fix static include (Prarit Bhargava)
|
||||||
|
|
||||||
|
* Sun Dec 12 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc4.20211212gita763d5a5abd6.34]
|
||||||
|
- Enable CONFIG_VFIO_NOIOMMU for Fedora (Justin M. Forbes)
|
||||||
|
|
||||||
* Fri Dec 10 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc4.20211210gitc741e49150db.32]
|
* Fri Dec 10 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc4.20211210gitc741e49150db.32]
|
||||||
- redhat/configs: enable CONFIG_NTB_NETDEV for ark (John W. Linville)
|
- redhat/configs: enable CONFIG_NTB_NETDEV for ark (John W. Linville)
|
||||||
- drivers/pci/pci-driver.c: Fix if/ifdef typo (Prarit Bhargava)
|
- drivers/pci/pci-driver.c: Fix if/ifdef typo (Prarit Bhargava)
|
||||||
|
@ -33,7 +33,7 @@
|
|||||||
drivers/nvme/host/core.c | 22 +-
|
drivers/nvme/host/core.c | 22 +-
|
||||||
drivers/nvme/host/multipath.c | 19 +-
|
drivers/nvme/host/multipath.c | 19 +-
|
||||||
drivers/nvme/host/nvme.h | 4 +
|
drivers/nvme/host/nvme.h | 4 +
|
||||||
drivers/pci/pci-driver.c | 79 ++++++
|
drivers/pci/pci-driver.c | 78 ++++++
|
||||||
drivers/pci/quirks.c | 24 ++
|
drivers/pci/quirks.c | 24 ++
|
||||||
drivers/scsi/aacraid/linit.c | 2 +
|
drivers/scsi/aacraid/linit.c | 2 +
|
||||||
drivers/scsi/be2iscsi/be_main.c | 2 +
|
drivers/scsi/be2iscsi/be_main.c | 2 +
|
||||||
@ -72,7 +72,7 @@
|
|||||||
security/lockdown/Kconfig | 13 +
|
security/lockdown/Kconfig | 13 +
|
||||||
security/lockdown/lockdown.c | 1 +
|
security/lockdown/lockdown.c | 1 +
|
||||||
security/security.c | 6 +
|
security/security.c | 6 +
|
||||||
74 files changed, 1513 insertions(+), 188 deletions(-)
|
74 files changed, 1512 insertions(+), 188 deletions(-)
|
||||||
|
|
||||||
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
||||||
index 9725c546a0d4..4d440bdcf5b9 100644
|
index 9725c546a0d4..4d440bdcf5b9 100644
|
||||||
@ -128,7 +128,7 @@ index 000000000000..effb81d04bfd
|
|||||||
+
|
+
|
||||||
+endmenu
|
+endmenu
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index ef967a26bcd3..ebaf1fbd54b4 100644
|
index 765115c99655..a57d974abf71 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||||
@ -1550,7 +1550,7 @@ index ee4da9ab8013..0f217997a764 100644
|
|||||||
|
|
||||||
err_netlink:
|
err_netlink:
|
||||||
diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c
|
diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c
|
||||||
index 4c63564adeaa..3541ddd16644 100644
|
index 1af8a4513708..5a23e077ab86 100644
|
||||||
--- a/drivers/nvme/host/core.c
|
--- a/drivers/nvme/host/core.c
|
||||||
+++ b/drivers/nvme/host/core.c
|
+++ b/drivers/nvme/host/core.c
|
||||||
@@ -244,6 +244,9 @@ static void nvme_delete_ctrl_sync(struct nvme_ctrl *ctrl)
|
@@ -244,6 +244,9 @@ static void nvme_delete_ctrl_sync(struct nvme_ctrl *ctrl)
|
||||||
@ -1617,7 +1617,7 @@ index 4c63564adeaa..3541ddd16644 100644
|
|||||||
}
|
}
|
||||||
EXPORT_SYMBOL_GPL(nvme_complete_rq);
|
EXPORT_SYMBOL_GPL(nvme_complete_rq);
|
||||||
diff --git a/drivers/nvme/host/multipath.c b/drivers/nvme/host/multipath.c
|
diff --git a/drivers/nvme/host/multipath.c b/drivers/nvme/host/multipath.c
|
||||||
index 7f2071f2460c..2e9f83901c77 100644
|
index 13e5d503ed07..daaeb316f624 100644
|
||||||
--- a/drivers/nvme/host/multipath.c
|
--- a/drivers/nvme/host/multipath.c
|
||||||
+++ b/drivers/nvme/host/multipath.c
|
+++ b/drivers/nvme/host/multipath.c
|
||||||
@@ -65,14 +65,10 @@ bool nvme_mpath_set_disk_name(struct nvme_ns *ns, char *disk_name, int *flags)
|
@@ -65,14 +65,10 @@ bool nvme_mpath_set_disk_name(struct nvme_ns *ns, char *disk_name, int *flags)
|
||||||
@ -1664,7 +1664,7 @@ index 7f2071f2460c..2e9f83901c77 100644
|
|||||||
|
|
||||||
if (!ctrl->max_namespaces ||
|
if (!ctrl->max_namespaces ||
|
||||||
diff --git a/drivers/nvme/host/nvme.h b/drivers/nvme/host/nvme.h
|
diff --git a/drivers/nvme/host/nvme.h b/drivers/nvme/host/nvme.h
|
||||||
index b334af8aa264..b2a0e2fc6d47 100644
|
index 9b095ee01364..bf25ef206cd2 100644
|
||||||
--- a/drivers/nvme/host/nvme.h
|
--- a/drivers/nvme/host/nvme.h
|
||||||
+++ b/drivers/nvme/host/nvme.h
|
+++ b/drivers/nvme/host/nvme.h
|
||||||
@@ -765,6 +765,7 @@ void nvme_mpath_wait_freeze(struct nvme_subsystem *subsys);
|
@@ -765,6 +765,7 @@ void nvme_mpath_wait_freeze(struct nvme_subsystem *subsys);
|
||||||
@ -1686,7 +1686,7 @@ index b334af8aa264..b2a0e2fc6d47 100644
|
|||||||
{
|
{
|
||||||
}
|
}
|
||||||
diff --git a/drivers/pci/pci-driver.c b/drivers/pci/pci-driver.c
|
diff --git a/drivers/pci/pci-driver.c b/drivers/pci/pci-driver.c
|
||||||
index 588588cfda48..f0b7f4661f3a 100644
|
index 588588cfda48..adb3a91b0ba3 100644
|
||||||
--- a/drivers/pci/pci-driver.c
|
--- a/drivers/pci/pci-driver.c
|
||||||
+++ b/drivers/pci/pci-driver.c
|
+++ b/drivers/pci/pci-driver.c
|
||||||
@@ -19,6 +19,7 @@
|
@@ -19,6 +19,7 @@
|
||||||
@ -1697,7 +1697,7 @@ index 588588cfda48..f0b7f4661f3a 100644
|
|||||||
#include <linux/dma-map-ops.h>
|
#include <linux/dma-map-ops.h>
|
||||||
#include "pci.h"
|
#include "pci.h"
|
||||||
#include "pcie/portdrv.h"
|
#include "pcie/portdrv.h"
|
||||||
@@ -295,6 +296,84 @@ static struct attribute *pci_drv_attrs[] = {
|
@@ -295,6 +296,83 @@ static struct attribute *pci_drv_attrs[] = {
|
||||||
};
|
};
|
||||||
ATTRIBUTE_GROUPS(pci_drv);
|
ATTRIBUTE_GROUPS(pci_drv);
|
||||||
|
|
||||||
@ -1776,7 +1776,6 @@ index 588588cfda48..f0b7f4661f3a 100644
|
|||||||
+ return ret;
|
+ return ret;
|
||||||
+}
|
+}
|
||||||
+EXPORT_SYMBOL(pci_hw_disabled);
|
+EXPORT_SYMBOL(pci_hw_disabled);
|
||||||
+
|
|
||||||
+#endif
|
+#endif
|
||||||
+
|
+
|
||||||
struct drv_dev_and_id {
|
struct drv_dev_and_id {
|
||||||
@ -2119,7 +2118,7 @@ index 4e33b5eca694..b480ca4934de 100644
|
|||||||
|
|
||||||
if (ext4_has_feature_encrypt(sb) && es->s_encryption_level) {
|
if (ext4_has_feature_encrypt(sb) && es->s_encryption_level) {
|
||||||
diff --git a/fs/xfs/xfs_super.c b/fs/xfs/xfs_super.c
|
diff --git a/fs/xfs/xfs_super.c b/fs/xfs/xfs_super.c
|
||||||
index e21459f9923a..c37903d09a45 100644
|
index 778b57b1f020..2a152330076d 100644
|
||||||
--- a/fs/xfs/xfs_super.c
|
--- a/fs/xfs/xfs_super.c
|
||||||
+++ b/fs/xfs/xfs_super.c
|
+++ b/fs/xfs/xfs_super.c
|
||||||
@@ -1594,6 +1594,7 @@ xfs_fs_fill_super(
|
@@ -1594,6 +1594,7 @@ xfs_fs_fill_super(
|
||||||
@ -2310,7 +2309,7 @@ index f5844908a089..901d51012738 100644
|
|||||||
|
|
||||||
struct taint_flag {
|
struct taint_flag {
|
||||||
diff --git a/include/linux/pci.h b/include/linux/pci.h
|
diff --git a/include/linux/pci.h b/include/linux/pci.h
|
||||||
index 18a75c8e615c..fb9af56f5fec 100644
|
index 18a75c8e615c..8cc24460267e 100644
|
||||||
--- a/include/linux/pci.h
|
--- a/include/linux/pci.h
|
||||||
+++ b/include/linux/pci.h
|
+++ b/include/linux/pci.h
|
||||||
@@ -1478,6 +1478,22 @@ int pci_add_dynid(struct pci_driver *drv,
|
@@ -1478,6 +1478,22 @@ int pci_add_dynid(struct pci_driver *drv,
|
||||||
@ -2330,8 +2329,8 @@ index 18a75c8e615c..fb9af56f5fec 100644
|
|||||||
+ struct pci_dev *dev) { return NULL; }
|
+ struct pci_dev *dev) { return NULL; }
|
||||||
+static inline const struct pci_device_id *pci_hw_unmaintained(const struct pci_device_id *ids,
|
+static inline const struct pci_device_id *pci_hw_unmaintained(const struct pci_device_id *ids,
|
||||||
+ struct pci_dev *dev) { return NULL; }
|
+ struct pci_dev *dev) { return NULL; }
|
||||||
+const struct pci_device_id *pci_hw_disabled(const struct pci_device_id *ids,
|
+static inline const struct pci_device_id *pci_hw_disabled(const struct pci_device_id *ids,
|
||||||
+ struct pci_dev *dev) {return NULL; }
|
+ struct pci_dev *dev) {return NULL; }
|
||||||
+#endif
|
+#endif
|
||||||
int pci_scan_bridge(struct pci_bus *bus, struct pci_dev *dev, int max,
|
int pci_scan_bridge(struct pci_bus *bus, struct pci_dev *dev, int max,
|
||||||
int pass);
|
int pass);
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (linux-5.16-rc4-163-gc741e49150db.tar.xz) = 850765934dffb6e21449d4a2927c144657f0d800fef2470ae9b511b08ad0a2ebd5b02bb771cc20d7cc061bde903bf8829dd99be0aad0235eb4e09fa190e1bc4e
|
SHA512 (linux-5.16-rc5.tar.xz) = bc209ab036eef329b928b3d27e08aa40aa800853098ea845181f7bec7dbc93a11f5680c3ac39f718ffe57cd1b7ff93fd689268021cabdb5bdfb515164b8a3200
|
||||||
SHA512 (kernel-abi-stablelists-5.16.0-0.rc4.20211210gitc741e49150db.32.tar.bz2) = da340f634885c959a99dc9b09894ed2e09f788adaee5aa04de13b9a24bce1201cd7e41d1520d1c84f85f1d5b58387fbf1e34f09b0995d7640933ab76c2521a2f
|
SHA512 (kernel-abi-stablelists-5.16.0-0.rc5.35.tar.bz2) = ea3fd7e739b73e0d045ccdacbe80862426f43365e072c916002e31b1a104d9e6c82d1a9a9570ba455c25e804a288b4886ab71f8e6a426481586d7fb4785b051a
|
||||||
SHA512 (kernel-kabi-dw-5.16.0-0.rc4.20211210gitc741e49150db.32.tar.bz2) = 5f523df9c72e0ca907882a93ad3bf0dd7c70f1b13cac50952df5136780775c1fdab6392b53e5b48955a7213d1707be098e034c1989dc0a86782d357a6527af11
|
SHA512 (kernel-kabi-dw-5.16.0-0.rc5.35.tar.bz2) = 905132c702436411c9e4928e258da7a2aa174c6ef1ecdfb4010ea663482c1d30f2a62c5bb0cd3fa3233ce54a8f81ed00480f9f6b58fa1644f505631f1cc3679e
|
||||||
|
Loading…
Reference in New Issue
Block a user