Linux v4.9-rc5
This commit is contained in:
parent
ac0f995f81
commit
30f2fba936
@ -1,49 +0,0 @@
|
|||||||
From 9f692cbe4a01dd9e3c3e954ec6b59662b68f9ce4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Laura Abbott <labbott@redhat.com>
|
|
||||||
Date: Fri, 9 Sep 2016 10:19:02 -0700
|
|
||||||
Subject: [PATCH] cpupower: Correct return type of cpu_power_is_cpu_online in
|
|
||||||
cpufreq
|
|
||||||
To: Thomas Renninger <trenn@suse.com>
|
|
||||||
Cc: linux-pm@vger.kernel.org
|
|
||||||
Cc: linux-kernel@vger.kernel.org
|
|
||||||
|
|
||||||
When converting to a shared library in ac5a181d065d ("cpupower: Add
|
|
||||||
cpuidle parts into library"), cpu_freq_cpu_exists was converted to
|
|
||||||
cpupower_is_cpu_online. cpu_req_cpu_exists returned 0 on success and
|
|
||||||
-ENOSYS on failure whereas cpupower_is_cpu_online returns 1 on success.
|
|
||||||
Check for the correct return value in cpufreq-set.
|
|
||||||
|
|
||||||
See https://bugzilla.redhat.com/show_bug.cgi?id=1374212
|
|
||||||
|
|
||||||
Fixes: ac5a181d065d ("cpupower: Add cpuidle parts into library")
|
|
||||||
Reported-by: Julian Seward <jseward@acm.org>
|
|
||||||
Signed-off-by: Laura Abbott <labbott@redhat.com>
|
|
||||||
---
|
|
||||||
tools/power/cpupower/utils/cpufreq-set.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tools/power/cpupower/utils/cpufreq-set.c b/tools/power/cpupower/utils/cpufreq-set.c
|
|
||||||
index b4bf769..8971d71 100644
|
|
||||||
--- a/tools/power/cpupower/utils/cpufreq-set.c
|
|
||||||
+++ b/tools/power/cpupower/utils/cpufreq-set.c
|
|
||||||
@@ -296,7 +296,7 @@ int cmd_freq_set(int argc, char **argv)
|
|
||||||
struct cpufreq_affected_cpus *cpus;
|
|
||||||
|
|
||||||
if (!bitmask_isbitset(cpus_chosen, cpu) ||
|
|
||||||
- cpupower_is_cpu_online(cpu))
|
|
||||||
+ cpupower_is_cpu_online(cpu) != 1)
|
|
||||||
continue;
|
|
||||||
|
|
||||||
cpus = cpufreq_get_related_cpus(cpu);
|
|
||||||
@@ -316,7 +316,7 @@ int cmd_freq_set(int argc, char **argv)
|
|
||||||
cpu <= bitmask_last(cpus_chosen); cpu++) {
|
|
||||||
|
|
||||||
if (!bitmask_isbitset(cpus_chosen, cpu) ||
|
|
||||||
- cpupower_is_cpu_online(cpu))
|
|
||||||
+ cpupower_is_cpu_online(cpu) != 1)
|
|
||||||
continue;
|
|
||||||
|
|
||||||
if (cpupower_is_cpu_online(cpu) != 1)
|
|
||||||
--
|
|
||||||
2.10.0
|
|
||||||
|
|
10
kernel.spec
10
kernel.spec
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%global rcrev 4
|
%global rcrev 5
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 4
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 4.%{upstream_sublevel}.0
|
%define rpmversion 4.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -614,9 +614,6 @@ Patch509: MODSIGN-Don-t-try-secure-boot-if-EFI-runtime-is-disa.patch
|
|||||||
#CVE-2016-3134 rhbz 1317383 1317384
|
#CVE-2016-3134 rhbz 1317383 1317384
|
||||||
Patch665: netfilter-x_tables-deal-with-bogus-nextoffset-values.patch
|
Patch665: netfilter-x_tables-deal-with-bogus-nextoffset-values.patch
|
||||||
|
|
||||||
#rhbz 1374212
|
|
||||||
Patch848: 0001-cpupower-Correct-return-type-of-cpu_power_is_cpu_onl.patch
|
|
||||||
|
|
||||||
#ongoing complaint, full discussion delayed until ksummit/plumbers
|
#ongoing complaint, full discussion delayed until ksummit/plumbers
|
||||||
Patch849: 0001-iio-Use-event-header-from-kernel-tree.patch
|
Patch849: 0001-iio-Use-event-header-from-kernel-tree.patch
|
||||||
|
|
||||||
@ -2158,6 +2155,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 14 2016 Laura Abbott <labbott@redhat.com> - 4.9.0-0.rc5.git0.1
|
||||||
|
- Linux v4.9-rc5
|
||||||
|
|
||||||
* Mon Nov 14 2016 Laura Abbott <labbott@redhat.com>
|
* Mon Nov 14 2016 Laura Abbott <labbott@redhat.com>
|
||||||
- Disable debugging options.
|
- Disable debugging options.
|
||||||
|
|
||||||
|
3
sources
3
sources
@ -1,4 +1,3 @@
|
|||||||
c1af0afbd3df35c1ccdc7a5118cd2d07 linux-4.8.tar.xz
|
c1af0afbd3df35c1ccdc7a5118cd2d07 linux-4.8.tar.xz
|
||||||
0dad03f586e835d538d3e0d2cbdb9a28 perf-man-4.8.tar.gz
|
0dad03f586e835d538d3e0d2cbdb9a28 perf-man-4.8.tar.gz
|
||||||
b79a02341fe9b28a7b374814ad99031a patch-4.9-rc4.xz
|
fd321483a21a5aec8b8795be3b2a292b patch-4.9-rc5.xz
|
||||||
0ef64c0a656120c1e7ca2b8982b496c7 patch-4.9-rc4-git4.xz
|
|
||||||
|
Loading…
Reference in New Issue
Block a user