Linux v3.18-rc1-221-gc3351dfabf5c
- Add patch to fix wifi on X550VB machines (rhbz 1089731)
This commit is contained in:
parent
3aeb248035
commit
300a55307c
@ -15,10 +15,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
|||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/Documentation/kernel-parameters.txt b/Documentation/kernel-parameters.txt
|
diff --git a/Documentation/kernel-parameters.txt b/Documentation/kernel-parameters.txt
|
||||||
index 7dbe5ec9d9cd..ad59dd188c5b 100644
|
index 988160a4ad31..5b6cdde792a4 100644
|
||||||
--- a/Documentation/kernel-parameters.txt
|
--- a/Documentation/kernel-parameters.txt
|
||||||
+++ b/Documentation/kernel-parameters.txt
|
+++ b/Documentation/kernel-parameters.txt
|
||||||
@@ -3695,7 +3695,7 @@ bytes respectively. Such letter suffixes can also be entirely omitted.
|
@@ -3701,7 +3701,7 @@ bytes respectively. Such letter suffixes can also be entirely omitted.
|
||||||
the allocated input device; If set to 0, video driver
|
the allocated input device; If set to 0, video driver
|
||||||
will only send out the event without touching backlight
|
will only send out the event without touching backlight
|
||||||
brightness level.
|
brightness level.
|
||||||
|
@ -9,7 +9,7 @@ Will debug upstream separately, but we need F22/21 running there. (#1139762)
|
|||||||
1 file changed, 12 insertions(+), 9 deletions(-)
|
1 file changed, 12 insertions(+), 9 deletions(-)
|
||||||
|
|
||||||
diff --git a/arch/arm/mach-highbank/highbank.c b/arch/arm/mach-highbank/highbank.c
|
diff --git a/arch/arm/mach-highbank/highbank.c b/arch/arm/mach-highbank/highbank.c
|
||||||
index 8c35ae4ff176..38e1dc3b4c6e 100644
|
index 07a09570175d..5db6d14fcd67 100644
|
||||||
--- a/arch/arm/mach-highbank/highbank.c
|
--- a/arch/arm/mach-highbank/highbank.c
|
||||||
+++ b/arch/arm/mach-highbank/highbank.c
|
+++ b/arch/arm/mach-highbank/highbank.c
|
||||||
@@ -51,13 +51,11 @@ static void __init highbank_scu_map_io(void)
|
@@ -51,13 +51,11 @@ static void __init highbank_scu_map_io(void)
|
||||||
|
35
asus-nb-wmi-Add-wapf4-quirk-for-the-X550VB.patch
Normal file
35
asus-nb-wmi-Add-wapf4-quirk-for-the-X550VB.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
From: Stanislaw Gruszka <sgruszka@redhat.com>
|
||||||
|
Date: Wed, 22 Oct 2014 14:32:52 +0200
|
||||||
|
Subject: [PATCH] asus-nb-wmi: Add wapf4 quirk for the X550VB
|
||||||
|
|
||||||
|
As reported here: http://bugzilla.redhat.com/show_bug.cgi?id=1089731#c23
|
||||||
|
the X550VB needs wapf=4 too.
|
||||||
|
|
||||||
|
Signed-off-by: Stanislaw Gruszka <sgruszka@redhat.com>
|
||||||
|
---
|
||||||
|
drivers/platform/x86/asus-nb-wmi.c | 9 +++++++++
|
||||||
|
1 file changed, 9 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/drivers/platform/x86/asus-nb-wmi.c b/drivers/platform/x86/asus-nb-wmi.c
|
||||||
|
index 3a4951f46065..c1a6cd66af42 100644
|
||||||
|
--- a/drivers/platform/x86/asus-nb-wmi.c
|
||||||
|
+++ b/drivers/platform/x86/asus-nb-wmi.c
|
||||||
|
@@ -182,6 +182,15 @@ static const struct dmi_system_id asus_quirks[] = {
|
||||||
|
},
|
||||||
|
{
|
||||||
|
.callback = dmi_matched,
|
||||||
|
+ .ident = "ASUSTeK COMPUTER INC. X550VB",
|
||||||
|
+ .matches = {
|
||||||
|
+ DMI_MATCH(DMI_SYS_VENDOR, "ASUSTeK COMPUTER INC."),
|
||||||
|
+ DMI_MATCH(DMI_PRODUCT_NAME, "X550VB"),
|
||||||
|
+ },
|
||||||
|
+ .driver_data = &quirk_asus_wapf4,
|
||||||
|
+ },
|
||||||
|
+ {
|
||||||
|
+ .callback = dmi_matched,
|
||||||
|
.ident = "ASUSTeK COMPUTER INC. X55A",
|
||||||
|
.matches = {
|
||||||
|
DMI_MATCH(DMI_SYS_VENDOR, "ASUSTeK COMPUTER INC."),
|
||||||
|
--
|
||||||
|
1.9.3
|
||||||
|
|
@ -187,6 +187,8 @@ CONFIG_CMA_AREAS=7
|
|||||||
# CONFIG_IRQ_DOMAIN_DEBUG is not set
|
# CONFIG_IRQ_DOMAIN_DEBUG is not set
|
||||||
# CONFIG_LOCK_STAT is not set
|
# CONFIG_LOCK_STAT is not set
|
||||||
|
|
||||||
|
# CONFIG_CADENCE_WATCHDOG is not set
|
||||||
|
|
||||||
# CONFIG_DRM_ARMADA is not set
|
# CONFIG_DRM_ARMADA is not set
|
||||||
# CONFIG_DRM_TEGRA is not set
|
# CONFIG_DRM_TEGRA is not set
|
||||||
# CONFIG_SHMOBILE_IOMMU is not set
|
# CONFIG_SHMOBILE_IOMMU is not set
|
||||||
|
@ -354,6 +354,7 @@ CONFIG_DRM_MSM=m
|
|||||||
CONFIG_DRM_MSM_FBDEV=y
|
CONFIG_DRM_MSM_FBDEV=y
|
||||||
CONFIG_USB_EHCI_MSM=m
|
CONFIG_USB_EHCI_MSM=m
|
||||||
# CONFIG_DRM_MSM_REGISTER_LOGGING is not set
|
# CONFIG_DRM_MSM_REGISTER_LOGGING is not set
|
||||||
|
CONFIG_QCOM_WDT=m
|
||||||
|
|
||||||
# i.MX
|
# i.MX
|
||||||
# CONFIG_MXC_DEBUG_BOARD is not set
|
# CONFIG_MXC_DEBUG_BOARD is not set
|
||||||
@ -619,6 +620,7 @@ CONFIG_XILLYBUS_OF=m
|
|||||||
CONFIG_GS_FPGABOOT=m
|
CONFIG_GS_FPGABOOT=m
|
||||||
CONFIG_USB_GADGET_XILINX=m
|
CONFIG_USB_GADGET_XILINX=m
|
||||||
CONFIG_PCIE_XILINX=y
|
CONFIG_PCIE_XILINX=y
|
||||||
|
CONFIG_CADENCE_WATCHDOG=m
|
||||||
|
|
||||||
# Multi function devices
|
# Multi function devices
|
||||||
CONFIG_MFD_88PM800=m
|
CONFIG_MFD_88PM800=m
|
||||||
|
@ -5197,6 +5197,7 @@ CONFIG_TCM_IBLOCK=m
|
|||||||
CONFIG_TCM_FILEIO=m
|
CONFIG_TCM_FILEIO=m
|
||||||
CONFIG_TCM_PSCSI=m
|
CONFIG_TCM_PSCSI=m
|
||||||
CONFIG_TCM_FC=m
|
CONFIG_TCM_FC=m
|
||||||
|
# CONFIG_TCM_USER is not set
|
||||||
|
|
||||||
CONFIG_HWSPINLOCK=m
|
CONFIG_HWSPINLOCK=m
|
||||||
|
|
||||||
|
@ -484,6 +484,8 @@ CONFIG_X86_INTEL_LPSS=y
|
|||||||
CONFIG_IOSF_MBI=m
|
CONFIG_IOSF_MBI=m
|
||||||
# CONFIG_IOSF_MBI_DEBUG is not set
|
# CONFIG_IOSF_MBI_DEBUG is not set
|
||||||
CONFIG_PWM_LPSS=m
|
CONFIG_PWM_LPSS=m
|
||||||
|
CONFIG_PWM_LPSS_PCI=m
|
||||||
|
CONFIG_PWM_LPSS_PLATFORM=m
|
||||||
CONFIG_PINCTRL=y
|
CONFIG_PINCTRL=y
|
||||||
CONFIG_PINCTRL_BAYTRAIL=y
|
CONFIG_PINCTRL_BAYTRAIL=y
|
||||||
|
|
||||||
|
@ -6019,19 +6019,19 @@ index 57ff20f..681efd5 100644
|
|||||||
--- a/drivers/leds/leds-gpio.c
|
--- a/drivers/leds/leds-gpio.c
|
||||||
+++ b/drivers/leds/leds-gpio.c
|
+++ b/drivers/leds/leds-gpio.c
|
||||||
@@ -13,22 +13,20 @@
|
@@ -13,22 +13,20 @@
|
||||||
#include <linux/kernel.h>
|
#include <linux/err.h>
|
||||||
#include <linux/platform_device.h>
|
|
||||||
#include <linux/gpio.h>
|
#include <linux/gpio.h>
|
||||||
+#include <linux/gpio/consumer.h>
|
+#include <linux/gpio/consumer.h>
|
||||||
|
#include <linux/kernel.h>
|
||||||
#include <linux/leds.h>
|
#include <linux/leds.h>
|
||||||
|
#include <linux/module.h>
|
||||||
-#include <linux/of.h>
|
-#include <linux/of.h>
|
||||||
-#include <linux/of_platform.h>
|
|
||||||
-#include <linux/of_gpio.h>
|
-#include <linux/of_gpio.h>
|
||||||
|
-#include <linux/of_platform.h>
|
||||||
|
#include <linux/platform_device.h>
|
||||||
|
+#include <linux/property.h>
|
||||||
#include <linux/slab.h>
|
#include <linux/slab.h>
|
||||||
#include <linux/workqueue.h>
|
#include <linux/workqueue.h>
|
||||||
#include <linux/module.h>
|
|
||||||
#include <linux/err.h>
|
|
||||||
+#include <linux/property.h>
|
|
||||||
|
|
||||||
struct gpio_led_data {
|
struct gpio_led_data {
|
||||||
struct led_classdev cdev;
|
struct led_classdev cdev;
|
||||||
@ -6293,7 +6293,7 @@ index 57ff20f..681efd5 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
static const struct of_device_id of_gpio_leds_match[] = {
|
static const struct of_device_id of_gpio_leds_match[] = {
|
||||||
@@ -228,13 +230,13 @@ static const struct of_device_id of_gpio_leds_match[] = {
|
@@ -228,12 +228,13 @@ static const struct of_device_id of_gpio_leds_match[] = {
|
||||||
};
|
};
|
||||||
|
|
||||||
MODULE_DEVICE_TABLE(of, of_gpio_leds_match);
|
MODULE_DEVICE_TABLE(of, of_gpio_leds_match);
|
||||||
@ -6303,10 +6303,10 @@ index 57ff20f..681efd5 100644
|
|||||||
- return ERR_PTR(-ENODEV);
|
- return ERR_PTR(-ENODEV);
|
||||||
-}
|
-}
|
||||||
-#endif /* CONFIG_OF_GPIO */
|
-#endif /* CONFIG_OF_GPIO */
|
||||||
|
+
|
||||||
+static const struct acpi_device_id acpi_gpio_leds_match[] = {
|
+static const struct acpi_device_id acpi_gpio_leds_match[] = {
|
||||||
+ { "PRP0001" }, /* Device Tree shoehorned into ACPI */
|
+ { "PRP0001" }, /* Device Tree shoehorned into ACPI */
|
||||||
+ {},
|
+ {},
|
||||||
+};
|
+};
|
||||||
+
|
+
|
||||||
+MODULE_DEVICE_TABLE(acpi, acpi_gpio_leds_match);
|
+MODULE_DEVICE_TABLE(acpi, acpi_gpio_leds_match);
|
||||||
|
12
kernel.spec
12
kernel.spec
@ -42,7 +42,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 2
|
%global baserelease 1
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -69,7 +69,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 1
|
%define rcrev 1
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 1
|
%define gitrev 2
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -612,6 +612,8 @@ Patch26056: ext4-fix-race-between-write-and-fcntl-F_SETFL.patch
|
|||||||
|
|
||||||
Patch26057: virtio_console-move-early-VQ-enablement.patch
|
Patch26057: virtio_console-move-early-VQ-enablement.patch
|
||||||
|
|
||||||
|
Patch26058: asus-nb-wmi-Add-wapf4-quirk-for-the-X550VB.patch
|
||||||
|
|
||||||
# git clone ssh://git.fedorahosted.org/git/kernel-arm64.git, git diff master...devel
|
# git clone ssh://git.fedorahosted.org/git/kernel-arm64.git, git diff master...devel
|
||||||
Patch30000: kernel-arm64.patch
|
Patch30000: kernel-arm64.patch
|
||||||
|
|
||||||
@ -1336,6 +1338,8 @@ ApplyPatch ext4-fix-race-between-write-and-fcntl-F_SETFL.patch
|
|||||||
|
|
||||||
ApplyPatch virtio_console-move-early-VQ-enablement.patch
|
ApplyPatch virtio_console-move-early-VQ-enablement.patch
|
||||||
|
|
||||||
|
ApplyPatch asus-nb-wmi-Add-wapf4-quirk-for-the-X550VB.patch
|
||||||
|
|
||||||
%if 0%{?aarch64patches}
|
%if 0%{?aarch64patches}
|
||||||
ApplyPatch kernel-arm64.patch
|
ApplyPatch kernel-arm64.patch
|
||||||
%ifnarch aarch64 # this is stupid, but i want to notice before secondary koji does.
|
%ifnarch aarch64 # this is stupid, but i want to notice before secondary koji does.
|
||||||
@ -2204,6 +2208,10 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 22 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.18.0-0.rc1.git2.1
|
||||||
|
- Linux v3.18-rc1-221-gc3351dfabf5c
|
||||||
|
- Add patch to fix wifi on X550VB machines (rhbz 1089731)
|
||||||
|
|
||||||
* Tue Oct 21 2014 Josh Boyer <jwboyer@fedoraproject.org>
|
* Tue Oct 21 2014 Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
- Drop pinctrl qcom revert now that it's dependencies should be merged
|
- Drop pinctrl qcom revert now that it's dependencies should be merged
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user