kernel-5.16-0.rc1.20211120gita90af8f15bdc.17
* Sat Nov 20 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc1.20211120gita90af8f15bdc.17] - spec: add bpf_testmod.ko to kselftests/bpf (Viktor Malik) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
a514e7dbf8
commit
2b9339aa81
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
|||||||
#
|
#
|
||||||
# Use this spot to avoid future merge conflicts.
|
# Use this spot to avoid future merge conflicts.
|
||||||
# Do not trim this comment.
|
# Do not trim this comment.
|
||||||
RHEL_RELEASE = 17
|
RHEL_RELEASE = 18
|
||||||
|
|
||||||
#
|
#
|
||||||
# Early y+1 numbering
|
# Early y+1 numbering
|
||||||
|
@ -1,6 +1,3 @@
|
|||||||
https://gitlab.com/cki-project/kernel-ark/-/commit/37c6a888c3a748451024ad31436cf3f4e2ceaa34
|
|
||||||
37c6a888c3a748451024ad31436cf3f4e2ceaa34 kasan: test: Silence intentional read overflow warnings
|
|
||||||
|
|
||||||
https://gitlab.com/cki-project/kernel-ark/-/commit/07b3d9b051aa347237b4c637a1984c1915c750b2
|
https://gitlab.com/cki-project/kernel-ark/-/commit/07b3d9b051aa347237b4c637a1984c1915c750b2
|
||||||
07b3d9b051aa347237b4c637a1984c1915c750b2 Enable e1000 in rhel9 as unsupported
|
07b3d9b051aa347237b4c637a1984c1915c750b2 Enable e1000 in rhel9 as unsupported
|
||||||
|
|
||||||
|
20
kernel.spec
20
kernel.spec
@ -83,9 +83,9 @@ Summary: The Linux kernel
|
|||||||
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
||||||
# to build the base kernel using the debug configuration. (Specifying
|
# to build the base kernel using the debug configuration. (Specifying
|
||||||
# the --with-release option overrides this setting.)
|
# the --with-release option overrides this setting.)
|
||||||
%define debugbuildsenabled 0
|
%define debugbuildsenabled 1
|
||||||
|
|
||||||
%global distro_build 0.rc1.20211119git4c388a8e740d.17
|
%global distro_build 0.rc2.18
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%define secure_boot_arch x86_64
|
%define secure_boot_arch x86_64
|
||||||
@ -130,13 +130,13 @@ Summary: The Linux kernel
|
|||||||
|
|
||||||
%define rpmversion 5.16.0
|
%define rpmversion 5.16.0
|
||||||
%define patchversion 5.16
|
%define patchversion 5.16
|
||||||
%define pkgrelease 0.rc1.20211119git4c388a8e740d.17
|
%define pkgrelease 0.rc2.18
|
||||||
|
|
||||||
# This is needed to do merge window version magic
|
# This is needed to do merge window version magic
|
||||||
%define patchlevel 16
|
%define patchlevel 16
|
||||||
|
|
||||||
# allow pkg_release to have configurable %%{?dist} tag
|
# allow pkg_release to have configurable %%{?dist} tag
|
||||||
%define specrelease 0.rc1.20211119git4c388a8e740d.17%{?buildid}%{?dist}
|
%define specrelease 0.rc2.18%{?buildid}%{?dist}
|
||||||
|
|
||||||
%define pkg_release %{specrelease}
|
%define pkg_release %{specrelease}
|
||||||
|
|
||||||
@ -682,7 +682,7 @@ BuildRequires: lld
|
|||||||
# exact git commit you can run
|
# exact git commit you can run
|
||||||
#
|
#
|
||||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||||
Source0: linux-5.16-rc1-236-g4c388a8e740d.tar.xz
|
Source0: linux-5.16-rc2.tar.xz
|
||||||
|
|
||||||
Source1: Makefile.rhelver
|
Source1: Makefile.rhelver
|
||||||
|
|
||||||
@ -1374,8 +1374,8 @@ ApplyOptionalPatch()
|
|||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
%setup -q -n kernel-5.16-rc1-236-g4c388a8e740d -c
|
%setup -q -n kernel-5.16-rc2 -c
|
||||||
mv linux-5.16-rc1-236-g4c388a8e740d linux-%{KVERREL}
|
mv linux-5.16-rc2 linux-%{KVERREL}
|
||||||
|
|
||||||
cd linux-%{KVERREL}
|
cd linux-%{KVERREL}
|
||||||
cp -a %{SOURCE1} .
|
cp -a %{SOURCE1} .
|
||||||
@ -2270,7 +2270,7 @@ for dir in bpf bpf/no_alu32 bpf/progs; do
|
|||||||
test -d $dir || continue
|
test -d $dir || continue
|
||||||
mkdir -p %{buildroot}%{_libexecdir}/kselftests/$dir
|
mkdir -p %{buildroot}%{_libexecdir}/kselftests/$dir
|
||||||
find $dir -maxdepth 1 -type f \( -executable -o -name '*.py' -o -name settings -o \
|
find $dir -maxdepth 1 -type f \( -executable -o -name '*.py' -o -name settings -o \
|
||||||
-name 'btf_dump_test_case_*.c' -o \
|
-name 'btf_dump_test_case_*.c' -o -name '*.ko' -o \
|
||||||
-name '*.o' -exec sh -c 'readelf -h "{}" | grep -q "^ Machine:.*BPF"' \; \) -print0 | \
|
-name '*.o' -exec sh -c 'readelf -h "{}" | grep -q "^ Machine:.*BPF"' \; \) -print0 | \
|
||||||
xargs -0 cp -t %{buildroot}%{_libexecdir}/kselftests/$dir || true
|
xargs -0 cp -t %{buildroot}%{_libexecdir}/kselftests/$dir || true
|
||||||
done
|
done
|
||||||
@ -2972,8 +2972,8 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
* Fri Nov 19 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc1.20211119git4c388a8e740d.17]
|
* Sat Nov 20 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc1.20211120gita90af8f15bdc.17]
|
||||||
- kasan: test: Silence intentional read overflow warnings (Kees Cook)
|
- spec: add bpf_testmod.ko to kselftests/bpf (Viktor Malik)
|
||||||
|
|
||||||
* Thu Nov 18 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc1.20211118git42eb8fdac2fc.15]
|
* Thu Nov 18 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc1.20211118git42eb8fdac2fc.15]
|
||||||
- New configs in drivers/net/wwan (Fedora Kernel Team)
|
- New configs in drivers/net/wwan (Fedora Kernel Team)
|
||||||
|
@ -65,7 +65,6 @@
|
|||||||
kernel/panic.c | 14 +
|
kernel/panic.c | 14 +
|
||||||
kernel/rh_taint.c | 109 ++++++++
|
kernel/rh_taint.c | 109 ++++++++
|
||||||
kernel/sysctl.c | 5 +
|
kernel/sysctl.c | 5 +
|
||||||
lib/test_kasan.c | 2 +
|
|
||||||
mm/cma.c | 10 +
|
mm/cma.c | 10 +
|
||||||
scripts/mod/modpost.c | 8 +
|
scripts/mod/modpost.c | 8 +
|
||||||
scripts/tags.sh | 2 +
|
scripts/tags.sh | 2 +
|
||||||
@ -73,7 +72,7 @@
|
|||||||
security/lockdown/Kconfig | 13 +
|
security/lockdown/Kconfig | 13 +
|
||||||
security/lockdown/lockdown.c | 1 +
|
security/lockdown/lockdown.c | 1 +
|
||||||
security/security.c | 6 +
|
security/security.c | 6 +
|
||||||
75 files changed, 1383 insertions(+), 188 deletions(-)
|
74 files changed, 1381 insertions(+), 188 deletions(-)
|
||||||
|
|
||||||
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
||||||
index 9725c546a0d4..4d440bdcf5b9 100644
|
index 9725c546a0d4..4d440bdcf5b9 100644
|
||||||
@ -129,7 +128,7 @@ index 000000000000..effb81d04bfd
|
|||||||
+
|
+
|
||||||
+endmenu
|
+endmenu
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 9e12c14ea0fb..c0a784684f99 100644
|
index daf95a574b08..17a521cc03d7 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||||
@ -159,10 +158,10 @@ index 9e12c14ea0fb..c0a784684f99 100644
|
|||||||
|
|
||||||
$(version_h): PATCHLEVEL := $(if $(PATCHLEVEL), $(PATCHLEVEL), 0)
|
$(version_h): PATCHLEVEL := $(if $(PATCHLEVEL), $(PATCHLEVEL), 0)
|
||||||
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
|
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
|
||||||
index f0f9e8bec83a..041a3934cf4f 100644
|
index c2724d986fa0..8063dcef65f7 100644
|
||||||
--- a/arch/arm/Kconfig
|
--- a/arch/arm/Kconfig
|
||||||
+++ b/arch/arm/Kconfig
|
+++ b/arch/arm/Kconfig
|
||||||
@@ -1478,9 +1478,9 @@ config HIGHMEM
|
@@ -1479,9 +1479,9 @@ config HIGHMEM
|
||||||
If unsure, say n.
|
If unsure, say n.
|
||||||
|
|
||||||
config HIGHPTE
|
config HIGHPTE
|
||||||
@ -224,10 +223,10 @@ index 3f8ee257f9aa..3ab92feb6241 100644
|
|||||||
/*
|
/*
|
||||||
* DIAG 308 support
|
* DIAG 308 support
|
||||||
diff --git a/arch/s390/kernel/ipl.c b/arch/s390/kernel/ipl.c
|
diff --git a/arch/s390/kernel/ipl.c b/arch/s390/kernel/ipl.c
|
||||||
index e2cc35775b99..96fc8134f056 100644
|
index 5ad1dde23dc5..b6192d58eed3 100644
|
||||||
--- a/arch/s390/kernel/ipl.c
|
--- a/arch/s390/kernel/ipl.c
|
||||||
+++ b/arch/s390/kernel/ipl.c
|
+++ b/arch/s390/kernel/ipl.c
|
||||||
@@ -2215,3 +2215,8 @@ int ipl_report_free(struct ipl_report *report)
|
@@ -2216,3 +2216,8 @@ int ipl_report_free(struct ipl_report *report)
|
||||||
}
|
}
|
||||||
|
|
||||||
#endif
|
#endif
|
||||||
@ -237,7 +236,7 @@ index e2cc35775b99..96fc8134f056 100644
|
|||||||
+ return !!ipl_secure_flag;
|
+ return !!ipl_secure_flag;
|
||||||
+}
|
+}
|
||||||
diff --git a/arch/s390/kernel/setup.c b/arch/s390/kernel/setup.c
|
diff --git a/arch/s390/kernel/setup.c b/arch/s390/kernel/setup.c
|
||||||
index 40405f2304f1..a6f5f1cae2fe 100644
|
index 225ab2d0a4c6..6a06cde25ca2 100644
|
||||||
--- a/arch/s390/kernel/setup.c
|
--- a/arch/s390/kernel/setup.c
|
||||||
+++ b/arch/s390/kernel/setup.c
|
+++ b/arch/s390/kernel/setup.c
|
||||||
@@ -49,6 +49,7 @@
|
@@ -49,6 +49,7 @@
|
||||||
@ -248,7 +247,7 @@ index 40405f2304f1..a6f5f1cae2fe 100644
|
|||||||
#include <linux/hugetlb.h>
|
#include <linux/hugetlb.h>
|
||||||
#include <linux/kmemleak.h>
|
#include <linux/kmemleak.h>
|
||||||
|
|
||||||
@@ -975,6 +976,9 @@ void __init setup_arch(char **cmdline_p)
|
@@ -963,6 +964,9 @@ void __init setup_arch(char **cmdline_p)
|
||||||
|
|
||||||
log_component_list();
|
log_component_list();
|
||||||
|
|
||||||
@ -271,7 +270,7 @@ index 0083464de5e3..2de5f417f3f2 100644
|
|||||||
setup_force_cpu_cap(X86_FEATURE_CPUID);
|
setup_force_cpu_cap(X86_FEATURE_CPUID);
|
||||||
cpu_parse_early_param();
|
cpu_parse_early_param();
|
||||||
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
||||||
index 49b596db5631..69468eebf8a0 100644
|
index c410be738ae7..dcbff059b842 100644
|
||||||
--- a/arch/x86/kernel/setup.c
|
--- a/arch/x86/kernel/setup.c
|
||||||
+++ b/arch/x86/kernel/setup.c
|
+++ b/arch/x86/kernel/setup.c
|
||||||
@@ -20,6 +20,7 @@
|
@@ -20,6 +20,7 @@
|
||||||
@ -341,7 +340,7 @@ index 49b596db5631..69468eebf8a0 100644
|
|||||||
/*
|
/*
|
||||||
* Dump out kernel offset information on panic.
|
* Dump out kernel offset information on panic.
|
||||||
*/
|
*/
|
||||||
@@ -929,6 +975,13 @@ void __init setup_arch(char **cmdline_p)
|
@@ -941,6 +987,13 @@ void __init setup_arch(char **cmdline_p)
|
||||||
if (efi_enabled(EFI_BOOT))
|
if (efi_enabled(EFI_BOOT))
|
||||||
efi_init();
|
efi_init();
|
||||||
|
|
||||||
@ -355,7 +354,7 @@ index 49b596db5631..69468eebf8a0 100644
|
|||||||
dmi_setup();
|
dmi_setup();
|
||||||
|
|
||||||
/*
|
/*
|
||||||
@@ -1094,19 +1147,7 @@ void __init setup_arch(char **cmdline_p)
|
@@ -1106,19 +1159,7 @@ void __init setup_arch(char **cmdline_p)
|
||||||
/* Allocate bigger log buffer */
|
/* Allocate bigger log buffer */
|
||||||
setup_log_buf(1);
|
setup_log_buf(1);
|
||||||
|
|
||||||
@ -376,7 +375,7 @@ index 49b596db5631..69468eebf8a0 100644
|
|||||||
|
|
||||||
reserve_initrd();
|
reserve_initrd();
|
||||||
|
|
||||||
@@ -1219,6 +1260,8 @@ void __init setup_arch(char **cmdline_p)
|
@@ -1231,6 +1272,8 @@ void __init setup_arch(char **cmdline_p)
|
||||||
efi_apply_memmap_quirks();
|
efi_apply_memmap_quirks();
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -565,7 +564,7 @@ index 2c80765670bc..5245fad951d8 100644
|
|||||||
acpi_dev_get_resources(device, &resource_list,
|
acpi_dev_get_resources(device, &resource_list,
|
||||||
acpi_check_serial_bus_slave,
|
acpi_check_serial_bus_slave,
|
||||||
diff --git a/drivers/ata/libahci.c b/drivers/ata/libahci.c
|
diff --git a/drivers/ata/libahci.c b/drivers/ata/libahci.c
|
||||||
index 8a6835bfd18a..e7fc078e8621 100644
|
index f76b8418e6fb..350e52fccc30 100644
|
||||||
--- a/drivers/ata/libahci.c
|
--- a/drivers/ata/libahci.c
|
||||||
+++ b/drivers/ata/libahci.c
|
+++ b/drivers/ata/libahci.c
|
||||||
@@ -690,6 +690,24 @@ int ahci_stop_engine(struct ata_port *ap)
|
@@ -690,6 +690,24 @@ int ahci_stop_engine(struct ata_port *ap)
|
||||||
@ -2896,26 +2895,6 @@ index 083be6af29d7..4f271712be5e 100644
|
|||||||
*(int *)table->data = unpriv_enable;
|
*(int *)table->data = unpriv_enable;
|
||||||
}
|
}
|
||||||
return ret;
|
return ret;
|
||||||
diff --git a/lib/test_kasan.c b/lib/test_kasan.c
|
|
||||||
index 67ed689a0b1b..0643573f8686 100644
|
|
||||||
--- a/lib/test_kasan.c
|
|
||||||
+++ b/lib/test_kasan.c
|
|
||||||
@@ -869,6 +869,7 @@ static void kasan_memchr(struct kunit *test)
|
|
||||||
ptr = kmalloc(size, GFP_KERNEL | __GFP_ZERO);
|
|
||||||
KUNIT_ASSERT_NOT_ERR_OR_NULL(test, ptr);
|
|
||||||
|
|
||||||
+ OPTIMIZER_HIDE_VAR(size);
|
|
||||||
KUNIT_EXPECT_KASAN_FAIL(test,
|
|
||||||
kasan_ptr_result = memchr(ptr, '1', size + 1));
|
|
||||||
|
|
||||||
@@ -894,6 +895,7 @@ static void kasan_memcmp(struct kunit *test)
|
|
||||||
KUNIT_ASSERT_NOT_ERR_OR_NULL(test, ptr);
|
|
||||||
memset(arr, 0, sizeof(arr));
|
|
||||||
|
|
||||||
+ OPTIMIZER_HIDE_VAR(size);
|
|
||||||
KUNIT_EXPECT_KASAN_FAIL(test,
|
|
||||||
kasan_int_result = memcmp(ptr, arr, size+1));
|
|
||||||
kfree(ptr);
|
|
||||||
diff --git a/mm/cma.c b/mm/cma.c
|
diff --git a/mm/cma.c b/mm/cma.c
|
||||||
index bc9ca8f3c487..9fa9a485eb3a 100644
|
index bc9ca8f3c487..9fa9a485eb3a 100644
|
||||||
--- a/mm/cma.c
|
--- a/mm/cma.c
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (linux-5.16-rc1-236-g4c388a8e740d.tar.xz) = b9d309f2ea385081847b4165cd5b87012f71a8851e351d2c373e7451a25535b62bf36c96f18727d0491aba47e42248ebfde165d2de1715fcaf4ba9ead8498f48
|
SHA512 (linux-5.16-rc2.tar.xz) = 9d4b59ad6e6e64429dea5c44e7dee3cbe987f39ea2e98a345d5a08a324e464a0cd8af1cf80e455fbfad23517a0a31822aa2a837521be97fe9177a5a6c6872e7d
|
||||||
SHA512 (kernel-abi-stablelists-5.16.0-0.rc1.20211119git4c388a8e740d.17.tar.bz2) = c86abd17f2ce76f92d5ab848b327dfc729843cdd800bbe1eec183ddd8a325868bf9758d4f681b32682fe927161ccb6527ab3a3429c713868d92e87174ea7c34f
|
SHA512 (kernel-abi-stablelists-5.16.0-0.rc2.18.tar.bz2) = c39eceb4b1dd8711c57782ede8b781353ef0f6f19aa109130f6db908fdde97f34f2b3e1bd2696b40fd34ff3e4d83badc33db5b5b4c61cd510faa6b893e452e12
|
||||||
SHA512 (kernel-kabi-dw-5.16.0-0.rc1.20211119git4c388a8e740d.17.tar.bz2) = 5b2de2f56591cc6f9ecd3a100483a757d1c173b5bba5097b8ca49ddcc3de63117545fbfe5bdf5e7bb25b305838c495cc100687631249f551103b30ff78a504c4
|
SHA512 (kernel-kabi-dw-5.16.0-0.rc2.18.tar.bz2) = 5495b5ea8887089ae9629867a7c18cb02082ef9f32bfe3b58f6b7ec8b6a479c6bb39521f60346e60f4fde6f92318682fbca09fd38f32283458dd9835596f87ef
|
||||||
|
Loading…
Reference in New Issue
Block a user