Linux v4.0-rc5-80-g4c4fe4c24782

This commit is contained in:
Josh Boyer 2015-03-26 09:21:41 -04:00
parent 984fc80fab
commit 2aa3606074
5 changed files with 16 additions and 16 deletions

View File

@ -1,7 +1,6 @@
From 12d65e98ceb4238b749feeb56523b90f19396820 Mon Sep 17 00:00:00 2001
From: Tom Lendacky <thomas.lendacky@amd.com> From: Tom Lendacky <thomas.lendacky@amd.com>
Date: Tue, 17 Mar 2015 10:58:38 -0500 Date: Tue, 17 Mar 2015 10:58:38 -0500
Subject: [PATCH 2/4] amd-xgbe-phy-a0: Add support for XGBE PHY on A0 Subject: [PATCH] amd-xgbe-phy-a0: Add support for XGBE PHY on A0
Add XGBE phy driver support for A0 hardware. Add XGBE phy driver support for A0 hardware.
@ -13,7 +12,7 @@ Signed-off-by: Tom Lendacky <thomas.lendacky@amd.com>
create mode 100644 drivers/net/phy/amd-xgbe-phy-a0.c create mode 100644 drivers/net/phy/amd-xgbe-phy-a0.c
diff --git a/drivers/net/phy/Makefile b/drivers/net/phy/Makefile diff --git a/drivers/net/phy/Makefile b/drivers/net/phy/Makefile
index 501ea76..92e7644 100644 index 501ea7699a2d..92e76446033e 100644
--- a/drivers/net/phy/Makefile --- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile +++ b/drivers/net/phy/Makefile
@@ -34,4 +34,5 @@ obj-$(CONFIG_MDIO_BUS_MUX_MMIOREG) += mdio-mux-mmioreg.o @@ -34,4 +34,5 @@ obj-$(CONFIG_MDIO_BUS_MUX_MMIOREG) += mdio-mux-mmioreg.o
@ -24,7 +23,7 @@ index 501ea76..92e7644 100644
obj-$(CONFIG_MDIO_BCM_UNIMAC) += mdio-bcm-unimac.o obj-$(CONFIG_MDIO_BCM_UNIMAC) += mdio-bcm-unimac.o
diff --git a/drivers/net/phy/amd-xgbe-phy-a0.c b/drivers/net/phy/amd-xgbe-phy-a0.c diff --git a/drivers/net/phy/amd-xgbe-phy-a0.c b/drivers/net/phy/amd-xgbe-phy-a0.c
new file mode 100644 new file mode 100644
index 0000000..c352d5c index 000000000000..c352d5c2989b
--- /dev/null --- /dev/null
+++ b/drivers/net/phy/amd-xgbe-phy-a0.c +++ b/drivers/net/phy/amd-xgbe-phy-a0.c
@@ -0,0 +1,1814 @@ @@ -0,0 +1,1814 @@
@ -1843,5 +1842,5 @@ index 0000000..c352d5c
+}; +};
+MODULE_DEVICE_TABLE(mdio, amd_xgbe_phy_a0_ids); +MODULE_DEVICE_TABLE(mdio, amd_xgbe_phy_a0_ids);
-- --
1.9.3 2.1.0

View File

@ -1,7 +1,6 @@
From 3bba3a1990d065e30630c5c67ed32689106aef57 Mon Sep 17 00:00:00 2001
From: Mark Salter <msalter@redhat.com> From: Mark Salter <msalter@redhat.com>
Date: Wed, 25 Mar 2015 14:17:50 -0400 Date: Wed, 25 Mar 2015 14:17:50 -0400
Subject: [PATCH 4/4] arm64: avoid needing console= to enable serial console Subject: [PATCH] arm64: avoid needing console= to enable serial console
Tell kernel to prefer one of the serial ports for console on Tell kernel to prefer one of the serial ports for console on
platforms currently supported (pl011 or 8250). console= on platforms currently supported (pl011 or 8250). console= on
@ -15,7 +14,7 @@ Signed-off-by: Mark Salter <msalter@redhat.com>
1 file changed, 19 insertions(+) 1 file changed, 19 insertions(+)
diff --git a/arch/arm64/kernel/setup.c b/arch/arm64/kernel/setup.c diff --git a/arch/arm64/kernel/setup.c b/arch/arm64/kernel/setup.c
index e8420f6..8473381 100644 index e8420f635bd4..84733810614c 100644
--- a/arch/arm64/kernel/setup.c --- a/arch/arm64/kernel/setup.c
+++ b/arch/arm64/kernel/setup.c +++ b/arch/arm64/kernel/setup.c
@@ -547,3 +547,22 @@ const struct seq_operations cpuinfo_op = { @@ -547,3 +547,22 @@ const struct seq_operations cpuinfo_op = {
@ -42,5 +41,5 @@ index e8420f6..8473381 100644
+} +}
+early_initcall(arm64_console_setup); +early_initcall(arm64_console_setup);
-- --
1.9.3 2.1.0

View File

@ -40,7 +40,7 @@ Summary: The Linux kernel
# For non-released -rc kernels, this will be appended after the rcX and # For non-released -rc kernels, this will be appended after the rcX and
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3" # gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
# #
%global baserelease 4 %global baserelease 1
%global fedora_build %{baserelease} %global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching # base_sublevel is the kernel version we're starting with and patching
@ -68,7 +68,7 @@ Summary: The Linux kernel
# The rc snapshot level # The rc snapshot level
%define rcrev 5 %define rcrev 5
# The git snapshot level # The git snapshot level
%define gitrev 2 %define gitrev 3
# Set rpm version accordingly # Set rpm version accordingly
%define rpmversion 4.%{upstream_sublevel}.0 %define rpmversion 4.%{upstream_sublevel}.0
%endif %endif
@ -2233,6 +2233,9 @@ fi
# #
# #
%changelog %changelog
* Thu Mar 26 2015 Josh Boyer <jwboyer@fedoraproject.org> - 4.0.0-0.rc5.git3.1
- Linux v4.0-rc5-80-g4c4fe4c24782
* Wed Mar 25 2015 Peter Robinson <pbrobinson@fedoraproject.org> * Wed Mar 25 2015 Peter Robinson <pbrobinson@fedoraproject.org>
- Add aarch64 patches to fix mustang usb, seattle eth, and console settings - Add aarch64 patches to fix mustang usb, seattle eth, and console settings

View File

@ -1,3 +1,3 @@
b26150c980099ef554b26d07f470e647 linux-4.0-rc5.tar.xz b26150c980099ef554b26d07f470e647 linux-4.0-rc5.tar.xz
7614f559a09f0242827fc7783c7adf3f perf-man-4.0-rc5.tar.gz 7614f559a09f0242827fc7783c7adf3f perf-man-4.0-rc5.tar.gz
61c3daa783863786c20ec38d27363b88 patch-4.0-rc5-git2.xz ee2f45f001bd0764920024894631f061 patch-4.0-rc5-git3.xz

View File

@ -1,7 +1,6 @@
From 30b01a7a85c0a2993870f7ed93059f9957bff59f Mon Sep 17 00:00:00 2001
From: Mark Langsdorf <mlangsdo@redhat.com> From: Mark Langsdorf <mlangsdo@redhat.com>
Date: Wed, 25 Mar 2015 14:12:51 -0400 Date: Wed, 25 Mar 2015 14:12:51 -0400
Subject: [PATCH 3/4] usb: make xhci platform driver use 64 bit or 32 bit DMA Subject: [PATCH] usb: make xhci platform driver use 64 bit or 32 bit DMA
The xhci platform driver needs to work on systems that either only The xhci platform driver needs to work on systems that either only
support 64-bit DMA or only support 32-bit DMA. Attempt to set a support 64-bit DMA or only support 32-bit DMA. Attempt to set a
@ -14,7 +13,7 @@ Signed-off-by: Mark Langsdorf <mlangsdo@redhat.com>
1 file changed, 7 insertions(+), 8 deletions(-) 1 file changed, 7 insertions(+), 8 deletions(-)
diff --git a/drivers/usb/host/xhci-plat.c b/drivers/usb/host/xhci-plat.c diff --git a/drivers/usb/host/xhci-plat.c b/drivers/usb/host/xhci-plat.c
index 0e11d61..cc5ca2c 100644 index 0e11d61408ff..cc5ca2cac706 100644
--- a/drivers/usb/host/xhci-plat.c --- a/drivers/usb/host/xhci-plat.c
+++ b/drivers/usb/host/xhci-plat.c +++ b/drivers/usb/host/xhci-plat.c
@@ -83,14 +83,13 @@ static int xhci_plat_probe(struct platform_device *pdev) @@ -83,14 +83,13 @@ static int xhci_plat_probe(struct platform_device *pdev)
@ -40,5 +39,5 @@ index 0e11d61..cc5ca2c 100644
hcd = usb_create_hcd(driver, &pdev->dev, dev_name(&pdev->dev)); hcd = usb_create_hcd(driver, &pdev->dev, dev_name(&pdev->dev));
if (!hcd) if (!hcd)
-- --
1.9.3 2.1.0