ARM: create a dtb for wandboard quad
This commit is contained in:
parent
26ffc4cdb7
commit
289de5293a
61
arm-wandboard-quad.patch
Normal file
61
arm-wandboard-quad.patch
Normal file
@ -0,0 +1,61 @@
|
||||
diff -uNr linux-3.10.0-0.rc7.git0.2.fc20.x86_64/arch/arm/boot/dts/imx6q-wandboard.dts linux-3.10.0-0.rc7.git0.2.fc20.armv7hl/arch/arm/boot/dts/imx6q-wandboard.dts
|
||||
--- linux-3.10.0-0.rc7.git0.2.fc20.x86_64/arch/arm/boot/dts/imx6q-wandboard.dts 1969-12-31 18:00:00.000000000 -0600
|
||||
+++ linux-3.10.0-0.rc7.git0.2.fc20.armv7hl/arch/arm/boot/dts/imx6q-wandboard.dts 2013-06-30 15:09:21.350610898 -0500
|
||||
@@ -0,0 +1,44 @@
|
||||
+/*
|
||||
+ * Copyright 2013 Freescale Semiconductor, Inc.
|
||||
+ *
|
||||
+ * Author: Fabio Estevam <fabio.estevam@freescale.com>
|
||||
+ *
|
||||
+ * This program is free software; you can redistribute it and/or modify
|
||||
+ * it under the terms of the GNU General Public License version 2 as
|
||||
+ * published by the Free Software Foundation.
|
||||
+ *
|
||||
+ */
|
||||
+/dts-v1/;
|
||||
+#include "imx6q.dtsi"
|
||||
+
|
||||
+/ {
|
||||
+ model = "Wandboard i.MX6 Quad Board";
|
||||
+ compatible = "wand,imx6q-wandboard", "fsl,imx6q";
|
||||
+
|
||||
+ memory {
|
||||
+ reg = <0x10000000 0x80000000>;
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&fec {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_enet_1>;
|
||||
+ phy-mode = "rgmii";
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&uart1 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_uart1_1>;
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&usbh1 {
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&usdhc3 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_usdhc3_2>;
|
||||
+ status = "okay";
|
||||
+};
|
||||
diff -uNr linux-3.10.0-0.rc7.git0.2.fc20.x86_64/arch/arm/boot/dts/Makefile linux-3.10.0-0.rc7.git0.2.fc20.armv7hl/arch/arm/boot/dts/Makefile
|
||||
--- linux-3.10.0-0.rc7.git0.2.fc20.x86_64/arch/arm/boot/dts/Makefile 2013-06-30 15:04:21.224500036 -0500
|
||||
+++ linux-3.10.0-0.rc7.git0.2.fc20.armv7hl/arch/arm/boot/dts/Makefile 2013-06-30 15:08:11.259884856 -0500
|
||||
@@ -120,7 +120,8 @@
|
||||
imx6q-sabreauto.dtb \
|
||||
imx6q-sabrelite.dtb \
|
||||
imx6q-sabresd.dtb \
|
||||
- imx6q-sbc6x.dtb
|
||||
+ imx6q-sbc6x.dtb \
|
||||
+ imx6q-wandboard.dtb
|
||||
dtb-$(CONFIG_ARCH_MXS) += imx23-evk.dtb \
|
||||
imx23-olinuxino.dtb \
|
||||
imx23-stmp378x_devb.dtb \
|
@ -732,6 +732,9 @@ Patch21004: arm-omap-load-tfp410.patch
|
||||
# ARM tegra
|
||||
Patch21005: arm-tegra-usb-no-reset-linux33.patch
|
||||
|
||||
# ARM wandboard
|
||||
Patch21006: arm-wandboard-quad.patch
|
||||
|
||||
#rhbz 754518
|
||||
Patch21235: scsi-sd_revalidate_disk-prevent-NULL-ptr-deref.patch
|
||||
|
||||
@ -1342,7 +1345,7 @@ ApplyPatch drm-exynos-fix-multiple-definition-build-error.patch
|
||||
ApplyPatch arm-omap-load-tfp410.patch
|
||||
ApplyPatch v2-thermal-cpu_cooling-fix-stub-function.patch
|
||||
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
||||
|
||||
ApplyPatch arm-wandboard-quad.patch
|
||||
#
|
||||
# bugfixes to drivers and filesystems
|
||||
#
|
||||
@ -2294,6 +2297,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Tue Jul 02 2013 Dennis Gilmore <dennis@ausil.us> - 3.10-2
|
||||
- create a dtb for wandboard quad
|
||||
|
||||
* Mon Jul 01 2013 Justin M. Forbes <jforbes@redhat.com> - 3.10-1
|
||||
- Linux v3.10
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user