Linux v4.11-rc4
This commit is contained in:
parent
561ce6ac05
commit
1fd0030165
10
kernel.spec
10
kernel.spec
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%global rcrev 3
|
||||
%global rcrev 4
|
||||
# The git snapshot level
|
||||
%define gitrev 2
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 4.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -602,9 +602,6 @@ Patch509: MODSIGN-Don-t-try-secure-boot-if-EFI-runtime-is-disa.patch
|
||||
#CVE-2016-3134 rhbz 1317383 1317384
|
||||
Patch665: netfilter-x_tables-deal-with-bogus-nextoffset-values.patch
|
||||
|
||||
# grabbed from mailing list
|
||||
Patch667: v3-Revert-tty-serial-pl011-add-ttyAMA-for-matching-pl011-console.patch
|
||||
|
||||
# Fix virtio devices rhbz 1430297
|
||||
Patch669: virtio_pci-fix-out-of-bound-access-for-msix_names.patch
|
||||
|
||||
@ -2172,6 +2169,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Mon Mar 27 2017 Laura Abbott <labbott@fedoraproject.org> - 4.11.0-0.rc4.git0.1
|
||||
- Linux v4.11-rc4
|
||||
|
||||
* Mon Mar 27 2017 Laura Abbott <labbott@fedoraproject.org>
|
||||
- Disable debugging options.
|
||||
|
||||
|
3
sources
3
sources
@ -1,4 +1,3 @@
|
||||
SHA512 (linux-4.10.tar.xz) = c3690125a8402df638095bd98a613fcf1a257b81de7611c84711d315cd11e2634ab4636302b3742aedf1e3ba9ce0fea53fe8c7d48e37865d8ee5db3565220d90
|
||||
SHA512 (perf-man-4.10.tar.gz) = 2c830e06f47211d70a8330961487af73a8bc01073019475e6b6131d3bb8c95658b77ca0ae5f1b44371accf103658bc5a3a4366b3e017a4088a8fd408dd6867e8
|
||||
SHA512 (patch-4.11-rc3.xz) = 88ff442fdcc41cd3734ddabc3cee54ea15ff5fef6b3bc1edc8f8c904ac888b45942a483ae35e3fee1a3b050d925755501b53de2e241a98905f63bb763a389086
|
||||
SHA512 (patch-4.11-rc3-git2.xz) = 67b5ce2c19c6c5723bc30444d7fc5f50cc42839bbd678822453365252317523cf4a396bed30f712cd58a601697f34aaf6c31326e546e55fe908d7f44e808f1d0
|
||||
SHA512 (patch-4.11-rc4.xz) = d92866ffe4997a5e489c034fc1c378d7e588f76cfa18d642854ce0bf412cdbc82d8e850d6665fa5175084ec0b7662b0f53435231d2b46b13cefbb9ba63f73791
|
||||
|
@ -1,52 +0,0 @@
|
||||
From patchwork Wed Mar 1 15:23:02 2017
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: [v3] Revert "tty: serial: pl011: add ttyAMA for matching pl011
|
||||
console"
|
||||
From: Aleksey Makarov <aleksey.makarov@linaro.org>
|
||||
X-Patchwork-Id: 9598601
|
||||
Message-Id: <20170301152304.29635-1-aleksey.makarov@linaro.org>
|
||||
To: linux-serial@vger.kernel.org
|
||||
Cc: linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
|
||||
Aleksey Makarov <aleksey.makarov@linaro.org>,
|
||||
Sudeep Holla <sudeep.holla@arm.com>,
|
||||
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
|
||||
Peter Hurley <peter@hurleysoftware.com>,
|
||||
Russell King <linux@armlinux.org.uk>, Jiri Slaby <jslaby@suse.com>,
|
||||
Robin Murphy <robin.murphy@arm.com>
|
||||
Date: Wed, 1 Mar 2017 18:23:02 +0300
|
||||
|
||||
The original patch makes the condition always true, so it is wrong.
|
||||
|
||||
It masks (but not fixes) the bug described in the commit message
|
||||
but introduces a regression (no console is selected by SPCR)
|
||||
in regular (no 'console=ttyAMA') case.
|
||||
|
||||
s/||/&&/ would not fix the problem as the root cause was identified
|
||||
incorrectly.
|
||||
|
||||
This reverts commit aea9a80ba98a0c9b4de88850260e9fbdcc98360b.
|
||||
|
||||
Signed-off-by: Aleksey Makarov <aleksey.makarov@linaro.org>
|
||||
---
|
||||
|
||||
v3: fix commit message (Robin Murphy)
|
||||
v2: add Signed-off-by:
|
||||
|
||||
drivers/tty/serial/amba-pl011.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/tty/serial/amba-pl011.c b/drivers/tty/serial/amba-pl011.c
|
||||
index 8789ea423ccf..56f92d7348bf 100644
|
||||
--- a/drivers/tty/serial/amba-pl011.c
|
||||
+++ b/drivers/tty/serial/amba-pl011.c
|
||||
@@ -2373,7 +2373,7 @@ static int __init pl011_console_match(struct console *co, char *name, int idx,
|
||||
if (strcmp(name, "qdf2400_e44") == 0) {
|
||||
pr_info_once("UART: Working around QDF2400 SoC erratum 44");
|
||||
qdf2400_e44_present = true;
|
||||
- } else if (strcmp(name, "pl011") != 0 || strcmp(name, "ttyAMA") != 0) {
|
||||
+ } else if (strcmp(name, "pl011") != 0) {
|
||||
return -ENODEV;
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user