Linux v3.19-463-g3e8c04eb1174
- Reenable debugging options. - Temporarily disable aarch64 patches
This commit is contained in:
parent
7681e91720
commit
1ef071e4db
@ -14,7 +14,7 @@ Signed-off-by: David Howells <dhowells@redhat.com>
|
|||||||
1 file changed, 20 insertions(+)
|
1 file changed, 20 insertions(+)
|
||||||
|
|
||||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||||
index 16ec1c00919d..b7cb7dc5ebb4 100644
|
index 33d555e5d8e7..02068cc2883d 100644
|
||||||
--- a/include/linux/efi.h
|
--- a/include/linux/efi.h
|
||||||
+++ b/include/linux/efi.h
|
+++ b/include/linux/efi.h
|
||||||
@@ -589,6 +589,12 @@ void efi_native_runtime_setup(void);
|
@@ -589,6 +589,12 @@ void efi_native_runtime_setup(void);
|
||||||
|
@ -159,7 +159,7 @@ index 000000000000..424896a0b169
|
|||||||
+ return 0;
|
+ return 0;
|
||||||
+}
|
+}
|
||||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||||
index b7cb7dc5ebb4..fb972b96959a 100644
|
index 02068cc2883d..f71d1700a187 100644
|
||||||
--- a/include/linux/efi.h
|
--- a/include/linux/efi.h
|
||||||
+++ b/include/linux/efi.h
|
+++ b/include/linux/efi.h
|
||||||
@@ -923,6 +923,10 @@ extern bool efi_poweroff_required(void);
|
@@ -923,6 +923,10 @@ extern bool efi_poweroff_required(void);
|
||||||
|
@ -33,10 +33,10 @@ index 199f453cb4de..ec38acf00b40 100644
|
|||||||
290/040 ALL edd_mbr_sig_buffer EDD MBR signatures
|
290/040 ALL edd_mbr_sig_buffer EDD MBR signatures
|
||||||
2D0/A00 ALL e820_map E820 memory map table
|
2D0/A00 ALL e820_map E820 memory map table
|
||||||
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
|
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
|
||||||
index 0dc9d0144a27..58273956750d 100644
|
index 5e28e2be3a41..aca51ef7f0db 100644
|
||||||
--- a/arch/x86/Kconfig
|
--- a/arch/x86/Kconfig
|
||||||
+++ b/arch/x86/Kconfig
|
+++ b/arch/x86/Kconfig
|
||||||
@@ -1660,6 +1660,16 @@ config EFI_MIXED
|
@@ -1665,6 +1665,16 @@ config EFI_MIXED
|
||||||
|
|
||||||
If unsure, say N.
|
If unsure, say N.
|
||||||
|
|
||||||
@ -129,10 +129,10 @@ index 225b0988043a..90dbfb73e11f 100644
|
|||||||
* The sentinel is set to a nonzero value (0xff) in header.S.
|
* The sentinel is set to a nonzero value (0xff) in header.S.
|
||||||
*
|
*
|
||||||
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
||||||
index ab4734e5411d..5d52d67d5097 100644
|
index c4648adadd7d..90de17f70b16 100644
|
||||||
--- a/arch/x86/kernel/setup.c
|
--- a/arch/x86/kernel/setup.c
|
||||||
+++ b/arch/x86/kernel/setup.c
|
+++ b/arch/x86/kernel/setup.c
|
||||||
@@ -1152,6 +1152,12 @@ void __init setup_arch(char **cmdline_p)
|
@@ -1150,6 +1150,12 @@ void __init setup_arch(char **cmdline_p)
|
||||||
|
|
||||||
io_delay_init();
|
io_delay_init();
|
||||||
|
|
||||||
|
@ -15,7 +15,7 @@ Upstream-status: Fedora mustard
|
|||||||
7 files changed, 65 insertions(+), 10 deletions(-)
|
7 files changed, 65 insertions(+), 10 deletions(-)
|
||||||
|
|
||||||
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
||||||
index b40d6174242f..0ee7749bad74 100644
|
index c5a7fe1c197c..f476de69248d 100644
|
||||||
--- a/arch/x86/kernel/setup.c
|
--- a/arch/x86/kernel/setup.c
|
||||||
+++ b/arch/x86/kernel/setup.c
|
+++ b/arch/x86/kernel/setup.c
|
||||||
@@ -70,6 +70,11 @@
|
@@ -70,6 +70,11 @@
|
||||||
@ -30,7 +30,7 @@ index b40d6174242f..0ee7749bad74 100644
|
|||||||
#include <video/edid.h>
|
#include <video/edid.h>
|
||||||
|
|
||||||
#include <asm/mtrr.h>
|
#include <asm/mtrr.h>
|
||||||
@@ -1277,6 +1282,37 @@ void __init i386_reserve_resources(void)
|
@@ -1275,6 +1280,37 @@ void __init i386_reserve_resources(void)
|
||||||
|
|
||||||
#endif /* CONFIG_X86_32 */
|
#endif /* CONFIG_X86_32 */
|
||||||
|
|
||||||
|
@ -29,10 +29,10 @@ index 72665eb80692..2c7b80d31366 100644
|
|||||||
+
|
+
|
||||||
#endif /* _KEYS_SYSTEM_KEYRING_H */
|
#endif /* _KEYS_SYSTEM_KEYRING_H */
|
||||||
diff --git a/init/Kconfig b/init/Kconfig
|
diff --git a/init/Kconfig b/init/Kconfig
|
||||||
index 9afb971497f4..ea0dbdf29b75 100644
|
index 1354ac09b516..ac49b6e83436 100644
|
||||||
--- a/init/Kconfig
|
--- a/init/Kconfig
|
||||||
+++ b/init/Kconfig
|
+++ b/init/Kconfig
|
||||||
@@ -1742,6 +1742,15 @@ config SYSTEM_TRUSTED_KEYRING
|
@@ -1750,6 +1750,15 @@ config SYSTEM_TRUSTED_KEYRING
|
||||||
|
|
||||||
Keys in this keyring are used by module signature checking.
|
Keys in this keyring are used by module signature checking.
|
||||||
|
|
||||||
|
@ -59,7 +59,7 @@ index b15036b1890c..0fbc68ed4ce9 100644
|
|||||||
ifdef CONFIG_DEBUG_INFO
|
ifdef CONFIG_DEBUG_INFO
|
||||||
ifdef CONFIG_DEBUG_INFO_SPLIT
|
ifdef CONFIG_DEBUG_INFO_SPLIT
|
||||||
diff --git a/lib/Kconfig.debug b/lib/Kconfig.debug
|
diff --git a/lib/Kconfig.debug b/lib/Kconfig.debug
|
||||||
index 5f2ce616c046..6525e2a5619a 100644
|
index a2ca213c71ca..032c4d549c49 100644
|
||||||
--- a/lib/Kconfig.debug
|
--- a/lib/Kconfig.debug
|
||||||
+++ b/lib/Kconfig.debug
|
+++ b/lib/Kconfig.debug
|
||||||
@@ -165,7 +165,23 @@ config DEBUG_INFO_DWARF4
|
@@ -165,7 +165,23 @@ config DEBUG_INFO_DWARF4
|
||||||
|
@ -25,7 +25,7 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
|||||||
create mode 100644 kernel/modsign_uefi.c
|
create mode 100644 kernel/modsign_uefi.c
|
||||||
|
|
||||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||||
index fb972b96959a..581878071c85 100644
|
index f71d1700a187..9d3f61593d9a 100644
|
||||||
--- a/include/linux/efi.h
|
--- a/include/linux/efi.h
|
||||||
+++ b/include/linux/efi.h
|
+++ b/include/linux/efi.h
|
||||||
@@ -595,6 +595,12 @@ void efi_native_runtime_setup(void);
|
@@ -595,6 +595,12 @@ void efi_native_runtime_setup(void);
|
||||||
@ -42,10 +42,10 @@ index fb972b96959a..581878071c85 100644
|
|||||||
efi_guid_t guid;
|
efi_guid_t guid;
|
||||||
u64 table;
|
u64 table;
|
||||||
diff --git a/init/Kconfig b/init/Kconfig
|
diff --git a/init/Kconfig b/init/Kconfig
|
||||||
index ea0dbdf29b75..dac9ed0f01f7 100644
|
index ac49b6e83436..5cdb1c323f62 100644
|
||||||
--- a/init/Kconfig
|
--- a/init/Kconfig
|
||||||
+++ b/init/Kconfig
|
+++ b/init/Kconfig
|
||||||
@@ -1896,6 +1896,15 @@ config MODULE_SIG_ALL
|
@@ -1904,6 +1904,15 @@ config MODULE_SIG_ALL
|
||||||
comment "Do not forget to sign required modules with scripts/sign-file"
|
comment "Do not forget to sign required modules with scripts/sign-file"
|
||||||
depends on MODULE_SIG_FORCE && !MODULE_SIG_ALL
|
depends on MODULE_SIG_FORCE && !MODULE_SIG_ALL
|
||||||
|
|
||||||
|
@ -628,6 +628,7 @@ CONFIG_USB_GADGET_XILINX=m
|
|||||||
CONFIG_PCIE_XILINX=y
|
CONFIG_PCIE_XILINX=y
|
||||||
CONFIG_CADENCE_WATCHDOG=m
|
CONFIG_CADENCE_WATCHDOG=m
|
||||||
CONFIG_REGULATOR_ISL9305=m
|
CONFIG_REGULATOR_ISL9305=m
|
||||||
|
CONFIG_EDAC_SYNOPSYS=m
|
||||||
|
|
||||||
# Multi function devices
|
# Multi function devices
|
||||||
CONFIG_MFD_88PM800=m
|
CONFIG_MFD_88PM800=m
|
||||||
|
@ -1707,13 +1707,13 @@ CONFIG_B43_PCMCIA=y
|
|||||||
CONFIG_B43_SDIO=y
|
CONFIG_B43_SDIO=y
|
||||||
CONFIG_B43_BCMA=y
|
CONFIG_B43_BCMA=y
|
||||||
CONFIG_B43_BCMA_PIO=y
|
CONFIG_B43_BCMA_PIO=y
|
||||||
# CONFIG_B43_DEBUG is not set
|
CONFIG_B43_DEBUG=y
|
||||||
CONFIG_B43_PHY_LP=y
|
CONFIG_B43_PHY_LP=y
|
||||||
CONFIG_B43_PHY_N=y
|
CONFIG_B43_PHY_N=y
|
||||||
CONFIG_B43_PHY_HT=y
|
CONFIG_B43_PHY_HT=y
|
||||||
CONFIG_B43_PHY_G=y
|
CONFIG_B43_PHY_G=y
|
||||||
CONFIG_B43LEGACY=m
|
CONFIG_B43LEGACY=m
|
||||||
# CONFIG_B43LEGACY_DEBUG is not set
|
CONFIG_B43LEGACY_DEBUG=y
|
||||||
CONFIG_B43LEGACY_DMA=y
|
CONFIG_B43LEGACY_DMA=y
|
||||||
CONFIG_B43LEGACY_PIO=y
|
CONFIG_B43LEGACY_PIO=y
|
||||||
CONFIG_B43LEGACY_DMA_AND_PIO_MODE=y
|
CONFIG_B43LEGACY_DMA_AND_PIO_MODE=y
|
||||||
@ -4737,7 +4737,7 @@ CONFIG_PM_DEBUG=y
|
|||||||
# CONFIG_DPM_WATCHDOG is not set # revisit this in debug
|
# CONFIG_DPM_WATCHDOG is not set # revisit this in debug
|
||||||
CONFIG_PM_TRACE=y
|
CONFIG_PM_TRACE=y
|
||||||
CONFIG_PM_TRACE_RTC=y
|
CONFIG_PM_TRACE_RTC=y
|
||||||
# CONFIG_PM_TEST_SUSPEND is not set
|
CONFIG_PM_TEST_SUSPEND=y
|
||||||
CONFIG_PM_RUNTIME=y
|
CONFIG_PM_RUNTIME=y
|
||||||
# CONFIG_PM_OPP is not set
|
# CONFIG_PM_OPP is not set
|
||||||
# CONFIG_PM_AUTOSLEEP is not set
|
# CONFIG_PM_AUTOSLEEP is not set
|
||||||
@ -5219,6 +5219,7 @@ CONFIG_RCU_CPU_STALL_TIMEOUT=60
|
|||||||
# CONFIG_RCU_CPU_STALL_INFO is not set
|
# CONFIG_RCU_CPU_STALL_INFO is not set
|
||||||
# CONFIG_TASKS_RCU is not set
|
# CONFIG_TASKS_RCU is not set
|
||||||
# CONFIG_RCU_USER_QS is not set
|
# CONFIG_RCU_USER_QS is not set
|
||||||
|
CONFIG_RCU_KTHREAD_PRIO=0
|
||||||
CONFIG_SPARSE_RCU_POINTER=y
|
CONFIG_SPARSE_RCU_POINTER=y
|
||||||
|
|
||||||
CONFIG_KSM=y
|
CONFIG_KSM=y
|
||||||
|
112
config-nodebug
112
config-nodebug
@ -2,100 +2,100 @@ CONFIG_SND_VERBOSE_PRINTK=y
|
|||||||
CONFIG_SND_DEBUG=y
|
CONFIG_SND_DEBUG=y
|
||||||
CONFIG_SND_PCM_XRUN_DEBUG=y
|
CONFIG_SND_PCM_XRUN_DEBUG=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_ATOMIC_SLEEP is not set
|
CONFIG_DEBUG_ATOMIC_SLEEP=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_MUTEXES is not set
|
CONFIG_DEBUG_MUTEXES=y
|
||||||
# CONFIG_DEBUG_RT_MUTEXES is not set
|
CONFIG_DEBUG_RT_MUTEXES=y
|
||||||
# CONFIG_DEBUG_LOCK_ALLOC is not set
|
CONFIG_DEBUG_LOCK_ALLOC=y
|
||||||
# CONFIG_LOCK_TORTURE_TEST is not set
|
CONFIG_LOCK_TORTURE_TEST=m
|
||||||
# CONFIG_PROVE_LOCKING is not set
|
CONFIG_PROVE_LOCKING=y
|
||||||
# CONFIG_DEBUG_SPINLOCK is not set
|
CONFIG_DEBUG_SPINLOCK=y
|
||||||
# CONFIG_PROVE_RCU is not set
|
CONFIG_PROVE_RCU=y
|
||||||
# CONFIG_PROVE_RCU_REPEATEDLY is not set
|
# CONFIG_PROVE_RCU_REPEATEDLY is not set
|
||||||
# CONFIG_DEBUG_PER_CPU_MAPS is not set
|
CONFIG_DEBUG_PER_CPU_MAPS=y
|
||||||
CONFIG_CPUMASK_OFFSTACK=y
|
CONFIG_CPUMASK_OFFSTACK=y
|
||||||
|
|
||||||
# CONFIG_CPU_NOTIFIER_ERROR_INJECT is not set
|
CONFIG_CPU_NOTIFIER_ERROR_INJECT=m
|
||||||
|
|
||||||
# CONFIG_FAULT_INJECTION is not set
|
CONFIG_FAULT_INJECTION=y
|
||||||
# CONFIG_FAILSLAB is not set
|
CONFIG_FAILSLAB=y
|
||||||
# CONFIG_FAIL_PAGE_ALLOC is not set
|
CONFIG_FAIL_PAGE_ALLOC=y
|
||||||
# CONFIG_FAIL_MAKE_REQUEST is not set
|
CONFIG_FAIL_MAKE_REQUEST=y
|
||||||
# CONFIG_FAULT_INJECTION_DEBUG_FS is not set
|
CONFIG_FAULT_INJECTION_DEBUG_FS=y
|
||||||
# CONFIG_FAULT_INJECTION_STACKTRACE_FILTER is not set
|
CONFIG_FAULT_INJECTION_STACKTRACE_FILTER=y
|
||||||
# CONFIG_FAIL_IO_TIMEOUT is not set
|
CONFIG_FAIL_IO_TIMEOUT=y
|
||||||
# CONFIG_FAIL_MMC_REQUEST is not set
|
CONFIG_FAIL_MMC_REQUEST=y
|
||||||
|
|
||||||
# CONFIG_LOCK_STAT is not set
|
CONFIG_LOCK_STAT=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_STACK_USAGE is not set
|
CONFIG_DEBUG_STACK_USAGE=y
|
||||||
|
|
||||||
# CONFIG_ACPI_DEBUG is not set
|
CONFIG_ACPI_DEBUG=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_SG is not set
|
CONFIG_DEBUG_SG=y
|
||||||
# CONFIG_DEBUG_PI_LIST is not set
|
CONFIG_DEBUG_PI_LIST=y
|
||||||
|
|
||||||
# CONFIG_PAGE_EXTENSION is not set
|
# CONFIG_PAGE_EXTENSION is not set
|
||||||
# CONFIG_PAGE_OWNER is not set
|
# CONFIG_PAGE_OWNER is not set
|
||||||
# CONFIG_DEBUG_PAGEALLOC is not set
|
# CONFIG_DEBUG_PAGEALLOC is not set
|
||||||
|
|
||||||
# CONFIG_DEBUG_OBJECTS is not set
|
CONFIG_DEBUG_OBJECTS=y
|
||||||
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set
|
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set
|
||||||
# CONFIG_DEBUG_OBJECTS_FREE is not set
|
CONFIG_DEBUG_OBJECTS_FREE=y
|
||||||
# CONFIG_DEBUG_OBJECTS_TIMERS is not set
|
CONFIG_DEBUG_OBJECTS_TIMERS=y
|
||||||
# CONFIG_DEBUG_OBJECTS_RCU_HEAD is not set
|
CONFIG_DEBUG_OBJECTS_RCU_HEAD=y
|
||||||
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
|
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
|
||||||
|
|
||||||
CONFIG_X86_PTDUMP=y
|
CONFIG_X86_PTDUMP=y
|
||||||
# CONFIG_ARM64_PTDUMP is not set
|
CONFIG_ARM64_PTDUMP=y
|
||||||
# CONFIG_EFI_PGT_DUMP is not set
|
CONFIG_EFI_PGT_DUMP=y
|
||||||
|
|
||||||
# CONFIG_CAN_DEBUG_DEVICES is not set
|
CONFIG_CAN_DEBUG_DEVICES=y
|
||||||
|
|
||||||
# CONFIG_MODULE_FORCE_UNLOAD is not set
|
CONFIG_MODULE_FORCE_UNLOAD=y
|
||||||
|
|
||||||
|
|
||||||
# CONFIG_DEBUG_NOTIFIERS is not set
|
CONFIG_DEBUG_NOTIFIERS=y
|
||||||
|
|
||||||
# CONFIG_DMA_API_DEBUG is not set
|
CONFIG_DMA_API_DEBUG=y
|
||||||
|
|
||||||
# CONFIG_MMIOTRACE is not set
|
CONFIG_MMIOTRACE=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_CREDENTIALS is not set
|
CONFIG_DEBUG_CREDENTIALS=y
|
||||||
|
|
||||||
# off in both production debug and nodebug builds,
|
# off in both production debug and nodebug builds,
|
||||||
# on in rawhide nodebug builds
|
# on in rawhide nodebug builds
|
||||||
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set
|
CONFIG_DEBUG_FORCE_WEAK_PER_CPU=y
|
||||||
|
|
||||||
# CONFIG_EXT4_DEBUG is not set
|
CONFIG_EXT4_DEBUG=y
|
||||||
|
|
||||||
# CONFIG_XFS_WARN is not set
|
# CONFIG_XFS_WARN is not set
|
||||||
|
|
||||||
# CONFIG_DEBUG_PERF_USE_VMALLOC is not set
|
CONFIG_DEBUG_PERF_USE_VMALLOC=y
|
||||||
|
|
||||||
# CONFIG_JBD2_DEBUG is not set
|
CONFIG_JBD2_DEBUG=y
|
||||||
|
|
||||||
# CONFIG_NFSD_FAULT_INJECTION is not set
|
CONFIG_NFSD_FAULT_INJECTION=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_BLK_CGROUP is not set
|
CONFIG_DEBUG_BLK_CGROUP=y
|
||||||
|
|
||||||
# CONFIG_DRBD_FAULT_INJECTION is not set
|
CONFIG_DRBD_FAULT_INJECTION=y
|
||||||
|
|
||||||
# CONFIG_ATH_DEBUG is not set
|
CONFIG_ATH_DEBUG=y
|
||||||
# CONFIG_CARL9170_DEBUGFS is not set
|
CONFIG_CARL9170_DEBUGFS=y
|
||||||
# CONFIG_IWLWIFI_DEVICE_TRACING is not set
|
CONFIG_IWLWIFI_DEVICE_TRACING=y
|
||||||
|
|
||||||
# CONFIG_RTLWIFI_DEBUG is not set
|
# CONFIG_RTLWIFI_DEBUG is not set
|
||||||
|
|
||||||
# CONFIG_DEBUG_OBJECTS_WORK is not set
|
CONFIG_DEBUG_OBJECTS_WORK=y
|
||||||
|
|
||||||
# CONFIG_DMADEVICES_DEBUG is not set
|
CONFIG_DMADEVICES_DEBUG=y
|
||||||
# CONFIG_DMADEVICES_VDEBUG is not set
|
CONFIG_DMADEVICES_VDEBUG=y
|
||||||
|
|
||||||
CONFIG_PM_ADVANCED_DEBUG=y
|
CONFIG_PM_ADVANCED_DEBUG=y
|
||||||
|
|
||||||
# CONFIG_CEPH_LIB_PRETTYDEBUG is not set
|
CONFIG_CEPH_LIB_PRETTYDEBUG=y
|
||||||
# CONFIG_QUOTA_DEBUG is not set
|
CONFIG_QUOTA_DEBUG=y
|
||||||
|
|
||||||
|
|
||||||
CONFIG_KGDB_KDB=y
|
CONFIG_KGDB_KDB=y
|
||||||
@ -103,18 +103,18 @@ CONFIG_KDB_DEFAULT_ENABLE=0x0
|
|||||||
CONFIG_KDB_KEYBOARD=y
|
CONFIG_KDB_KEYBOARD=y
|
||||||
CONFIG_KDB_CONTINUE_CATASTROPHIC=0
|
CONFIG_KDB_CONTINUE_CATASTROPHIC=0
|
||||||
|
|
||||||
# CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER is not set
|
CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER=y
|
||||||
# CONFIG_PERCPU_TEST is not set
|
# CONFIG_PERCPU_TEST is not set
|
||||||
# CONFIG_TEST_LIST_SORT is not set
|
CONFIG_TEST_LIST_SORT=y
|
||||||
# CONFIG_TEST_STRING_HELPERS is not set
|
# CONFIG_TEST_STRING_HELPERS is not set
|
||||||
|
|
||||||
# CONFIG_DETECT_HUNG_TASK is not set
|
CONFIG_DETECT_HUNG_TASK=y
|
||||||
CONFIG_DEFAULT_HUNG_TASK_TIMEOUT=120
|
CONFIG_DEFAULT_HUNG_TASK_TIMEOUT=120
|
||||||
# CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set
|
# CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set
|
||||||
|
|
||||||
# CONFIG_X86_BOOTPARAM_MEMORY_CORRUPTION_CHECK is not set
|
CONFIG_X86_BOOTPARAM_MEMORY_CORRUPTION_CHECK=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_KMEMLEAK is not set
|
CONFIG_DEBUG_KMEMLEAK=y
|
||||||
CONFIG_DEBUG_KMEMLEAK_EARLY_LOG_SIZE=1024
|
CONFIG_DEBUG_KMEMLEAK_EARLY_LOG_SIZE=1024
|
||||||
# CONFIG_DEBUG_KMEMLEAK_TEST is not set
|
# CONFIG_DEBUG_KMEMLEAK_TEST is not set
|
||||||
CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=y
|
CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=y
|
||||||
@ -125,7 +125,7 @@ CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=y
|
|||||||
|
|
||||||
# CONFIG_SPI_DEBUG is not set
|
# CONFIG_SPI_DEBUG is not set
|
||||||
|
|
||||||
# CONFIG_X86_DEBUG_STATIC_CPU_HAS is not set
|
CONFIG_X86_DEBUG_STATIC_CPU_HAS=y
|
||||||
|
|
||||||
# CONFIG_SCHEDSTATS is not set
|
# CONFIG_SCHEDSTATS is not set
|
||||||
# CONFIG_LATENCYTOP is not set
|
# CONFIG_LATENCYTOP is not set
|
||||||
|
@ -347,7 +347,7 @@ CONFIG_SP5100_TCO=m
|
|||||||
|
|
||||||
# CONFIG_MEMTEST is not set
|
# CONFIG_MEMTEST is not set
|
||||||
# CONFIG_DEBUG_TLBFLUSH is not set
|
# CONFIG_DEBUG_TLBFLUSH is not set
|
||||||
# CONFIG_MAXSMP is not set
|
CONFIG_MAXSMP=y
|
||||||
|
|
||||||
|
|
||||||
CONFIG_HP_ILO=m
|
CONFIG_HP_ILO=m
|
||||||
|
@ -9,10 +9,10 @@ Upstream-status: Fedora mustard
|
|||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/init/Kconfig b/init/Kconfig
|
diff --git a/init/Kconfig b/init/Kconfig
|
||||||
index dac9ed0f01f7..31a29fe7c555 100644
|
index 5cdb1c323f62..a1c34718643d 100644
|
||||||
--- a/init/Kconfig
|
--- a/init/Kconfig
|
||||||
+++ b/init/Kconfig
|
+++ b/init/Kconfig
|
||||||
@@ -1128,7 +1128,7 @@ config DEBUG_BLK_CGROUP
|
@@ -1135,7 +1135,7 @@ config DEBUG_BLK_CGROUP
|
||||||
endif # CGROUPS
|
endif # CGROUPS
|
||||||
|
|
||||||
config CHECKPOINT_RESTORE
|
config CHECKPOINT_RESTORE
|
||||||
@ -21,7 +21,7 @@ index dac9ed0f01f7..31a29fe7c555 100644
|
|||||||
default n
|
default n
|
||||||
help
|
help
|
||||||
Enables additional kernel features in a sake of checkpoint/restore.
|
Enables additional kernel features in a sake of checkpoint/restore.
|
||||||
@@ -1139,7 +1139,7 @@ config CHECKPOINT_RESTORE
|
@@ -1146,7 +1146,7 @@ config CHECKPOINT_RESTORE
|
||||||
If unsure, say N here.
|
If unsure, say N here.
|
||||||
|
|
||||||
menuconfig NAMESPACES
|
menuconfig NAMESPACES
|
||||||
|
@ -12,10 +12,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
|||||||
2 files changed, 3 insertions(+)
|
2 files changed, 3 insertions(+)
|
||||||
|
|
||||||
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
||||||
index 5d52d67d5097..b40d6174242f 100644
|
index 90de17f70b16..c5a7fe1c197c 100644
|
||||||
--- a/arch/x86/kernel/setup.c
|
--- a/arch/x86/kernel/setup.c
|
||||||
+++ b/arch/x86/kernel/setup.c
|
+++ b/arch/x86/kernel/setup.c
|
||||||
@@ -1154,7 +1154,9 @@ void __init setup_arch(char **cmdline_p)
|
@@ -1152,7 +1152,9 @@ void __init setup_arch(char **cmdline_p)
|
||||||
|
|
||||||
#ifdef CONFIG_EFI_SECURE_BOOT_SIG_ENFORCE
|
#ifdef CONFIG_EFI_SECURE_BOOT_SIG_ENFORCE
|
||||||
if (boot_params.secure_boot) {
|
if (boot_params.secure_boot) {
|
||||||
@ -26,7 +26,7 @@ index 5d52d67d5097..b40d6174242f 100644
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||||
index 0238d612750e..16ec1c00919d 100644
|
index b674837e2b98..33d555e5d8e7 100644
|
||||||
--- a/include/linux/efi.h
|
--- a/include/linux/efi.h
|
||||||
+++ b/include/linux/efi.h
|
+++ b/include/linux/efi.h
|
||||||
@@ -940,6 +940,7 @@ extern int __init efi_setup_pcdp_console(char *);
|
@@ -940,6 +940,7 @@ extern int __init efi_setup_pcdp_console(char *);
|
||||||
|
@ -11,10 +11,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
|||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
|
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
|
||||||
index 58273956750d..e17f88ceaeab 100644
|
index aca51ef7f0db..0705833ee3a0 100644
|
||||||
--- a/arch/x86/Kconfig
|
--- a/arch/x86/Kconfig
|
||||||
+++ b/arch/x86/Kconfig
|
+++ b/arch/x86/Kconfig
|
||||||
@@ -1661,7 +1661,8 @@ config EFI_MIXED
|
@@ -1666,7 +1666,8 @@ config EFI_MIXED
|
||||||
If unsure, say N.
|
If unsure, say N.
|
||||||
|
|
||||||
config EFI_SECURE_BOOT_SIG_ENFORCE
|
config EFI_SECURE_BOOT_SIG_ENFORCE
|
||||||
|
@ -90,7 +90,7 @@ index 2a8ddfd12a5b..452ca53561fe 100644
|
|||||||
cmd_vdso64as = $(CC) $(a_flags) -c -o $@ $<
|
cmd_vdso64as = $(CC) $(a_flags) -c -o $@ $<
|
||||||
|
|
||||||
diff --git a/arch/x86/vdso/Makefile b/arch/x86/vdso/Makefile
|
diff --git a/arch/x86/vdso/Makefile b/arch/x86/vdso/Makefile
|
||||||
index 5a4affe025e8..8ff38ce94c8e 100644
|
index 09297c8e1fcd..d5a03d9d2ef2 100644
|
||||||
--- a/arch/x86/vdso/Makefile
|
--- a/arch/x86/vdso/Makefile
|
||||||
+++ b/arch/x86/vdso/Makefile
|
+++ b/arch/x86/vdso/Makefile
|
||||||
@@ -171,8 +171,9 @@ $(vdso32-images:%=$(obj)/%.dbg): $(obj)/vdso32-%.so.dbg: FORCE \
|
@@ -171,8 +171,9 @@ $(vdso32-images:%=$(obj)/%.dbg): $(obj)/vdso32-%.so.dbg: FORCE \
|
||||||
|
13
kernel.spec
13
kernel.spec
@ -6,9 +6,9 @@ Summary: The Linux kernel
|
|||||||
# For a stable, released kernel, released_kernel should be 1. For rawhide
|
# For a stable, released kernel, released_kernel should be 1. For rawhide
|
||||||
# and/or a kernel built from an rc or git snapshot, released_kernel should
|
# and/or a kernel built from an rc or git snapshot, released_kernel should
|
||||||
# be 0.
|
# be 0.
|
||||||
%global released_kernel 1
|
%global released_kernel 0
|
||||||
|
|
||||||
%global aarch64patches 1
|
%global aarch64patches 0
|
||||||
|
|
||||||
# Sign modules on x86. Make sure the config files match this setting if more
|
# Sign modules on x86. Make sure the config files match this setting if more
|
||||||
# architectures are added.
|
# architectures are added.
|
||||||
@ -69,7 +69,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 0
|
%define gitrev 1
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -124,7 +124,7 @@ Summary: The Linux kernel
|
|||||||
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
||||||
# and 0 for rawhide (all kernels are debug kernels).
|
# and 0 for rawhide (all kernels are debug kernels).
|
||||||
# See also 'make debug' and 'make release'.
|
# See also 'make debug' and 'make release'.
|
||||||
%define debugbuildsenabled 1
|
%define debugbuildsenabled 0
|
||||||
|
|
||||||
# Want to build a vanilla kernel build without any non-upstream patches?
|
# Want to build a vanilla kernel build without any non-upstream patches?
|
||||||
%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
|
%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
|
||||||
@ -2211,6 +2211,11 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 11 2015 Josh Boyer <jwboyer@fedoraproject.org> - 3.20.0-0.rc0.git1.1
|
||||||
|
- Linux v3.19-463-g3e8c04eb1174
|
||||||
|
- Reenable debugging options.
|
||||||
|
- Temporarily disable aarch64 patches
|
||||||
|
|
||||||
* Mon Feb 09 2015 Josh Boyer <jwboyer@fedoraproject.org> - 3.19.0-1
|
* Mon Feb 09 2015 Josh Boyer <jwboyer@fedoraproject.org> - 3.19.0-1
|
||||||
- Linux v3.19
|
- Linux v3.19
|
||||||
|
|
||||||
|
@ -25,7 +25,7 @@ Signed-off-by: John Stultz <john.stultz@linaro.org>
|
|||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/kernel/time/ntp.c b/kernel/time/ntp.c
|
diff --git a/kernel/time/ntp.c b/kernel/time/ntp.c
|
||||||
index 28bf91c60a0b..242774dd27a1 100644
|
index 4b585e0fdd22..a5f4d24c95cc 100644
|
||||||
--- a/kernel/time/ntp.c
|
--- a/kernel/time/ntp.c
|
||||||
+++ b/kernel/time/ntp.c
|
+++ b/kernel/time/ntp.c
|
||||||
@@ -634,9 +634,9 @@ int ntp_validate_timex(struct timex *txc)
|
@@ -634,9 +634,9 @@ int ntp_validate_timex(struct timex *txc)
|
||||||
|
Loading…
Reference in New Issue
Block a user