Linux v4.1-rc7
This commit is contained in:
parent
14846f6e6e
commit
1ea79ee0a4
@ -43,7 +43,7 @@ Signed-off-by: Josh Stone <jistone@redhat.com>
|
|||||||
2 files changed, 21 insertions(+), 1 deletion(-)
|
2 files changed, 21 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index aee7e5cb4c15..febebdf01b8b 100644
|
index 40a8b068ac26..6f53fdb40695 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -704,7 +704,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer
|
@@ -704,7 +704,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer
|
||||||
|
@ -326,6 +326,7 @@ CONFIG_SND_SOC_QCOM=m
|
|||||||
CONFIG_SND_SOC_LPASS_CPU=m
|
CONFIG_SND_SOC_LPASS_CPU=m
|
||||||
CONFIG_SND_SOC_LPASS_PLATFORM=m
|
CONFIG_SND_SOC_LPASS_PLATFORM=m
|
||||||
CONFIG_SND_SOC_STORM=m
|
CONFIG_SND_SOC_STORM=m
|
||||||
|
CONFIG_PHY_QCOM_UFS=m
|
||||||
|
|
||||||
# i.MX
|
# i.MX
|
||||||
# CONFIG_MXC_DEBUG_BOARD is not set
|
# CONFIG_MXC_DEBUG_BOARD is not set
|
||||||
|
13
kernel.spec
13
kernel.spec
@ -65,9 +65,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 6
|
%define rcrev 7
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 2
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 4.%{upstream_sublevel}.0
|
%define rpmversion 4.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -609,9 +609,6 @@ Patch26214: acpi_video-Add-enable_native_backlight-quirk-for-Mac.patch
|
|||||||
#rhbz 1225563
|
#rhbz 1225563
|
||||||
Patch26215: HID-lenovo-set-INPUT_PROP_POINTING_STICK.patch
|
Patch26215: HID-lenovo-set-INPUT_PROP_POINTING_STICK.patch
|
||||||
|
|
||||||
#rhbz 1188695
|
|
||||||
Patch26218: n_tty-Fix-auditing-support-for-cannonical-mode.patch
|
|
||||||
|
|
||||||
#rhbz 1133378
|
#rhbz 1133378
|
||||||
Patch26219: firmware-Drop-WARN-from-usermodehelper_read_trylock-.patch
|
Patch26219: firmware-Drop-WARN-from-usermodehelper_read_trylock-.patch
|
||||||
|
|
||||||
@ -1345,9 +1342,6 @@ ApplyPatch acpi_video-Add-enable_native_backlight-quirk-for-Mac.patch
|
|||||||
#rhbz 1225563
|
#rhbz 1225563
|
||||||
ApplyPatch HID-lenovo-set-INPUT_PROP_POINTING_STICK.patch
|
ApplyPatch HID-lenovo-set-INPUT_PROP_POINTING_STICK.patch
|
||||||
|
|
||||||
#rhbz 1188695
|
|
||||||
ApplyPatch n_tty-Fix-auditing-support-for-cannonical-mode.patch
|
|
||||||
|
|
||||||
#rhbz 1133378
|
#rhbz 1133378
|
||||||
ApplyPatch firmware-Drop-WARN-from-usermodehelper_read_trylock-.patch
|
ApplyPatch firmware-Drop-WARN-from-usermodehelper_read_trylock-.patch
|
||||||
|
|
||||||
@ -2218,6 +2212,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 08 2015 Josh Boyer <jwboyer@fedoraproject.org> - 4.1.0-0.rc7.git0.1
|
||||||
|
- Linux v4.1-rc7
|
||||||
|
|
||||||
* Thu Jun 04 2015 Josh Boyer <jwboyer@fedoraproject.org> - 4.1.0-0.rc6.git2.1
|
* Thu Jun 04 2015 Josh Boyer <jwboyer@fedoraproject.org> - 4.1.0-0.rc6.git2.1
|
||||||
- Linux v4.1-rc6-49-g8a7deb362b76
|
- Linux v4.1-rc6-49-g8a7deb362b76
|
||||||
|
|
||||||
|
@ -1,58 +0,0 @@
|
|||||||
From: Laura Abbott <labbott@fedoraproject.org>
|
|
||||||
Date: Wed, 13 May 2015 17:03:06 -0700
|
|
||||||
Subject: [PATCH] n_tty: Fix auditing support for cannonical mode
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Commit 32f13521ca68bc624ff6effc77f308a52b038bf0
|
|
||||||
("n_tty: Line copy to user buffer in canonical mode")
|
|
||||||
changed cannonical mode copying to use copy_to_user
|
|
||||||
but missed adding the call to the audit framework.
|
|
||||||
Add in the appropriate functions to get audit support.
|
|
||||||
|
|
||||||
Fixes: 32f13521ca68 ("n_tty: Line copy to user buffer in canonical mode")
|
|
||||||
Reported-by: Miloslav Trmač <mitr@redhat.com>
|
|
||||||
Signed-off-by: Laura Abbott <labbott@fedoraproject.org>
|
|
||||||
---
|
|
||||||
drivers/tty/n_tty.c | 17 ++++++++++++++---
|
|
||||||
1 file changed, 14 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/tty/n_tty.c b/drivers/tty/n_tty.c
|
|
||||||
index cc57a3a6b02b..eee40b5cb025 100644
|
|
||||||
--- a/drivers/tty/n_tty.c
|
|
||||||
+++ b/drivers/tty/n_tty.c
|
|
||||||
@@ -162,6 +162,17 @@ static inline int tty_put_user(struct tty_struct *tty, unsigned char x,
|
|
||||||
return put_user(x, ptr);
|
|
||||||
}
|
|
||||||
|
|
||||||
+static inline int tty_copy_to_user(struct tty_struct *tty,
|
|
||||||
+ void __user *to,
|
|
||||||
+ const void *from,
|
|
||||||
+ unsigned long n)
|
|
||||||
+{
|
|
||||||
+ struct n_tty_data *ldata = tty->disc_data;
|
|
||||||
+
|
|
||||||
+ tty_audit_add_data(tty, to, n, ldata->icanon);
|
|
||||||
+ return copy_to_user(to, from, n);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
/**
|
|
||||||
* n_tty_kick_worker - start input worker (if required)
|
|
||||||
* @tty: terminal
|
|
||||||
@@ -2084,12 +2095,12 @@ static int canon_copy_from_read_buf(struct tty_struct *tty,
|
|
||||||
__func__, eol, found, n, c, size, more);
|
|
||||||
|
|
||||||
if (n > size) {
|
|
||||||
- ret = copy_to_user(*b, read_buf_addr(ldata, tail), size);
|
|
||||||
+ ret = tty_copy_to_user(tty, *b, read_buf_addr(ldata, tail), size);
|
|
||||||
if (ret)
|
|
||||||
return -EFAULT;
|
|
||||||
- ret = copy_to_user(*b + size, ldata->read_buf, n - size);
|
|
||||||
+ ret = tty_copy_to_user(tty, *b + size, ldata->read_buf, n - size);
|
|
||||||
} else
|
|
||||||
- ret = copy_to_user(*b, read_buf_addr(ldata, tail), n);
|
|
||||||
+ ret = tty_copy_to_user(tty, *b, read_buf_addr(ldata, tail), n);
|
|
||||||
|
|
||||||
if (ret)
|
|
||||||
return -EFAULT;
|
|
3
sources
3
sources
@ -1,4 +1,3 @@
|
|||||||
a86916bd12798220da9eb4a1eec3616d linux-4.0.tar.xz
|
a86916bd12798220da9eb4a1eec3616d linux-4.0.tar.xz
|
||||||
d125eecce68ab6fb5f1f23523c2c04b8 perf-man-4.0.tar.gz
|
d125eecce68ab6fb5f1f23523c2c04b8 perf-man-4.0.tar.gz
|
||||||
85b103229fdd302a650adbd1d3473fd1 patch-4.1-rc6.xz
|
a831062aea035ee4bae52e59ccf0cf71 patch-4.1-rc7.xz
|
||||||
30c2793e3dc49a5daf699896d541e24d patch-4.1-rc6-git2.xz
|
|
||||||
|
Loading…
Reference in New Issue
Block a user