Linux v3.18
This commit is contained in:
parent
553d726e10
commit
1e63a382c1
@ -26,5 +26,5 @@ index c68e72414a67..4277938af700 100644
|
|||||||
/* parse the table header to get the table length */
|
/* parse the table header to get the table length */
|
||||||
if (count <= sizeof(struct acpi_table_header))
|
if (count <= sizeof(struct acpi_table_header))
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -27,5 +27,5 @@ index b649fef2e35d..fb89290710ad 100644
|
|||||||
* disconnected while waiting for the lock to succeed. */
|
* disconnected while waiting for the lock to succeed. */
|
||||||
usb_lock_device(hdev);
|
usb_lock_device(hdev);
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -52,5 +52,5 @@ index 130ba866a24a..58d7feadd149 100644
|
|||||||
* All runtime access to EFI goes through this structure:
|
* All runtime access to EFI goes through this structure:
|
||||||
*/
|
*/
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -174,5 +174,5 @@ index 58d7feadd149..b1d686e9175e 100644
|
|||||||
* efi_range_is_wc - check the WC bit on an address range
|
* efi_range_is_wc - check the WC bit on an address range
|
||||||
* @start: starting kvirt address
|
* @start: starting kvirt address
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -181,5 +181,5 @@ index 6507ffcb5445..cace4bd04956 100644
|
|||||||
{
|
{
|
||||||
#ifdef CONFIG_MODULE_SIG
|
#ifdef CONFIG_MODULE_SIG
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -59,5 +59,5 @@ index 88cec1ddb1e3..6507ffcb5445 100644
|
|||||||
+}
|
+}
|
||||||
+EXPORT_SYMBOL(secure_modules);
|
+EXPORT_SYMBOL(secure_modules);
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -244,5 +244,5 @@ index cace4bd04956..a33be993df25 100644
|
|||||||
static int param_set_bool_enable_only(const char *val,
|
static int param_set_bool_enable_only(const char *val,
|
||||||
const struct kernel_param *kp)
|
const struct kernel_param *kp)
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -80,5 +80,5 @@ index 552671ee7c5d..41814fced1cc 100644
|
|||||||
{ USB_VENDOR_ID_NEXIO, USB_DEVICE_ID_NEXIO_MULTITOUCH_PTI0750, HID_QUIRK_NO_INIT_REPORTS },
|
{ USB_VENDOR_ID_NEXIO, USB_DEVICE_ID_NEXIO_MULTITOUCH_PTI0750, HID_QUIRK_NO_INIT_REPORTS },
|
||||||
{ USB_VENDOR_ID_NOVATEK, USB_DEVICE_ID_NOVATEK_MOUSE, HID_QUIRK_NO_INIT_REPORTS },
|
{ USB_VENDOR_ID_NOVATEK, USB_DEVICE_ID_NOVATEK_MOUSE, HID_QUIRK_NO_INIT_REPORTS },
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -475,5 +475,5 @@ index 000000000000..ca196689f025
|
|||||||
+MODULE_DESCRIPTION("Goodix touchscreen driver");
|
+MODULE_DESCRIPTION("Goodix touchscreen driver");
|
||||||
+MODULE_LICENSE("GPL v2");
|
+MODULE_LICENSE("GPL v2");
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -107,5 +107,5 @@ index 875f64e8935b..c15e93f5a418 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -181,5 +181,5 @@ index 000000000000..94b0eb38a284
|
|||||||
+}
|
+}
|
||||||
+late_initcall(load_uefi_certs);
|
+late_initcall(load_uefi_certs);
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -79,5 +79,5 @@ index 94b0eb38a284..ae28b974d49a 100644
|
|||||||
|
|
||||||
mok = get_cert_list(L"MokListRT", &mok_var, &moksize);
|
mok = get_cert_list(L"MokListRT", &mok_var, &moksize);
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -112,5 +112,5 @@ index b91c4da68365..98f5637304d1 100644
|
|||||||
|
|
||||||
dev = pci_get_bus_and_slot(bus, dfn);
|
dev = pci_get_bus_and_slot(bus, dfn);
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -37,5 +37,5 @@ index c268e2581ed6..fb9ea1172ba8 100644
|
|||||||
unsigned long to_write = min_t(unsigned long, count,
|
unsigned long to_write = min_t(unsigned long, count,
|
||||||
(unsigned long)high_memory - p);
|
(unsigned long)high_memory - p);
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -41,5 +41,5 @@ index 9d75ead2a1f9..d7a0142cae8d 100644
|
|||||||
|
|
||||||
/*
|
/*
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -34,5 +34,5 @@ index 9964f70be98d..d95d258f606c 100644
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -41,5 +41,5 @@ index 4991a1664773..096ddbe4c4b3 100644
|
|||||||
pinctrl-single,pins = <
|
pinctrl-single,pins = <
|
||||||
0x1b4 (PIN_OUTPUT_PULLDOWN | MUX_MODE3) /* xdma_event_intr1.clkout2 */
|
0x1b4 (PIN_OUTPUT_PULLDOWN | MUX_MODE3) /* xdma_event_intr1.clkout2 */
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -65,5 +65,5 @@ index 6cc25ed912ee..754b96c5dbb1 100644
|
|||||||
|
|
||||||
/include/ "tps65217.dtsi"
|
/include/ "tps65217.dtsi"
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -175,5 +175,5 @@ index 754b96c5dbb1..4991a1664773 100644
|
|||||||
+ };
|
+ };
|
||||||
+};
|
+};
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -37,5 +37,5 @@ index 5dcdcd173572..38439e097b26 100644
|
|||||||
compatible = "ti,tilcdc,slave";
|
compatible = "ti,tilcdc,slave";
|
||||||
i2c = <&i2c0>;
|
i2c = <&i2c0>;
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -34,5 +34,5 @@ index 901739fcb85a..5dcdcd173572 100644
|
|||||||
};
|
};
|
||||||
};
|
};
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -209,5 +209,5 @@ index 000000000000..7214475a3c36
|
|||||||
+ };
|
+ };
|
||||||
+};
|
+};
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -56,5 +56,5 @@ index 07a09570175d..5db6d14fcd67 100644
|
|||||||
.init_machine = highbank_init,
|
.init_machine = highbank_init,
|
||||||
.dt_compat = highbank_match,
|
.dt_compat = highbank_match,
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -61,5 +61,5 @@ index 99b46f8030ad..8b6ddd16dcc5 100644
|
|||||||
+ status = "okay";
|
+ status = "okay";
|
||||||
+};
|
+};
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -49,5 +49,5 @@ index 21fc932da3a1..c6d42ad95c08 100644
|
|||||||
1, asus->debug.method_id,
|
1, asus->debug.method_id,
|
||||||
&input, &output);
|
&input, &output);
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -37,5 +37,5 @@ index 275205ab5f15..bb842623bdf6 100644
|
|||||||
"DMA failed to stop in %d ms AR_CR=0x%08x AR_DIAG_SW=0x%08x DMADBG_7=0x%08x\n",
|
"DMA failed to stop in %d ms AR_CR=0x%08x AR_DIAG_SW=0x%08x DMADBG_7=0x%08x\n",
|
||||||
AH_RX_STOP_DMA_TIMEOUT / 1000,
|
AH_RX_STOP_DMA_TIMEOUT / 1000,
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -505,5 +505,5 @@ index 000000000000..25ab9869d566
|
|||||||
+
|
+
|
||||||
+#endif /* __CRASH_H__ */
|
+#endif /* __CRASH_H__ */
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -31,5 +31,5 @@ index 9ef459bb44b2..cc096e258a4a 100644
|
|||||||
help
|
help
|
||||||
Provides the way to make tasks work with different objects using
|
Provides the way to make tasks work with different objects using
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -28,5 +28,5 @@ index 56d46ffb08e1..1c8db250df88 100644
|
|||||||
#else
|
#else
|
||||||
|
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -57,5 +57,5 @@ index 9bb95eab6926..4b5015f27f9e 100644
|
|||||||
if (err)
|
if (err)
|
||||||
return err;
|
return err;
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -14,10 +14,10 @@ Upstream-status: http://lists.freedesktop.org/archives/intel-gfx/2013-November/0
|
|||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
|
diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
|
||||||
index 8bcdb981d540..383390add737 100644
|
index 9cb5c95d5898..edf0d4b78d68 100644
|
||||||
--- a/drivers/gpu/drm/i915/intel_display.c
|
--- a/drivers/gpu/drm/i915/intel_display.c
|
||||||
+++ b/drivers/gpu/drm/i915/intel_display.c
|
+++ b/drivers/gpu/drm/i915/intel_display.c
|
||||||
@@ -10967,7 +10967,7 @@ check_crtc_state(struct drm_device *dev)
|
@@ -10965,7 +10965,7 @@ check_crtc_state(struct drm_device *dev)
|
||||||
|
|
||||||
if (active &&
|
if (active &&
|
||||||
!intel_pipe_config_compare(dev, &crtc->config, &pipe_config)) {
|
!intel_pipe_config_compare(dev, &crtc->config, &pipe_config)) {
|
||||||
@ -27,5 +27,5 @@ index 8bcdb981d540..383390add737 100644
|
|||||||
"[hw state]");
|
"[hw state]");
|
||||||
intel_dump_pipe_config(crtc, &crtc->config,
|
intel_dump_pipe_config(crtc, &crtc->config,
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -38,5 +38,5 @@ index 0949f9c7e872..130ba866a24a 100644
|
|||||||
#ifdef CONFIG_EFI
|
#ifdef CONFIG_EFI
|
||||||
/*
|
/*
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -53,5 +53,5 @@ index 6da2da7ac9c3..ba3cf70c7d5a 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -25,5 +25,5 @@ index 7b8969db8398..d1f4a3d88dfc 100644
|
|||||||
---help---
|
---help---
|
||||||
UEFI Secure Boot provides a mechanism for ensuring that the
|
UEFI Secure Boot provides a mechanism for ensuring that the
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -34,5 +34,5 @@ index 1f35a3478f3c..5e2472fc3dda 100644
|
|||||||
|
|
||||||
/**
|
/**
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -29,5 +29,5 @@ index 6f5d79569136..95469f6ecfa5 100644
|
|||||||
case ATKBD_RET_ERR:
|
case ATKBD_RET_ERR:
|
||||||
atkbd->err_count++;
|
atkbd->err_count++;
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -61,5 +61,5 @@ index ce82337521f6..a3fee4becc93 100644
|
|||||||
cp = can_get_proto(protocol);
|
cp = can_get_proto(protocol);
|
||||||
}
|
}
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -121,5 +121,5 @@ index 86a4fe75f453..161637ed5611 100755
|
|||||||
|
|
||||||
|
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
11
kernel.spec
11
kernel.spec
@ -6,7 +6,7 @@ Summary: The Linux kernel
|
|||||||
# For a stable, released kernel, released_kernel should be 1. For rawhide
|
# For a stable, released kernel, released_kernel should be 1. For rawhide
|
||||||
# and/or a kernel built from an rc or git snapshot, released_kernel should
|
# and/or a kernel built from an rc or git snapshot, released_kernel should
|
||||||
# be 0.
|
# be 0.
|
||||||
%global released_kernel 0
|
%global released_kernel 1
|
||||||
|
|
||||||
%global aarch64patches 1
|
%global aarch64patches 1
|
||||||
|
|
||||||
@ -48,7 +48,7 @@ Summary: The Linux kernel
|
|||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
# on top of -- for example, 3.1-rc7-git1 starts with a 3.0 base,
|
# on top of -- for example, 3.1-rc7-git1 starts with a 3.0 base,
|
||||||
# which yields a base_sublevel of 0.
|
# which yields a base_sublevel of 0.
|
||||||
%define base_sublevel 17
|
%define base_sublevel 18
|
||||||
|
|
||||||
## If this is a released kernel ##
|
## If this is a released kernel ##
|
||||||
%if 0%{?released_kernel}
|
%if 0%{?released_kernel}
|
||||||
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 7
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 3
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -2201,6 +2201,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 09 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.18.0-1
|
||||||
|
- Linux v3.18
|
||||||
|
|
||||||
* Fri Dec 05 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.18.0-0.rc7.git3.1
|
* Fri Dec 05 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.18.0-0.rc7.git3.1
|
||||||
- Linux v3.18-rc7-59-g56c67ce187a8
|
- Linux v3.18-rc7-59-g56c67ce187a8
|
||||||
|
|
||||||
|
@ -39,5 +39,5 @@ index 2abf9f6e9a61..417bd0599024 100644
|
|||||||
* This leaves us room for future extensions.
|
* This leaves us room for future extensions.
|
||||||
*/
|
*/
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -33,5 +33,5 @@ index 54cf309a92a5..64f8bb4882fb 100644
|
|||||||
Use dynamic allocation for cpumask_var_t, instead of putting
|
Use dynamic allocation for cpumask_var_t, instead of putting
|
||||||
them on the stack. This is a bit more expensive, but avoids
|
them on the stack. This is a bit more expensive, but avoids
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -74,5 +74,5 @@ index 3ef4627f9cb1..2b2d2e8e5eeb 100644
|
|||||||
return err;
|
return err;
|
||||||
|
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -21,5 +21,5 @@ index 674a2cfc3c0e..9a2807227c69 100644
|
|||||||
static int pcspkr_event(struct input_dev *dev, unsigned int type, unsigned int code, int value)
|
static int pcspkr_event(struct input_dev *dev, unsigned int type, unsigned int code, int value)
|
||||||
{
|
{
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -33,5 +33,5 @@ index fb94b772ad62..99668ad01b54 100644
|
|||||||
MODULE_AUTHOR("Tony Lindgren <tony@atomide.com>");
|
MODULE_AUTHOR("Tony Lindgren <tony@atomide.com>");
|
||||||
MODULE_DESCRIPTION("One-register-per-pin type device tree based pinctrl driver");
|
MODULE_DESCRIPTION("One-register-per-pin type device tree based pinctrl driver");
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -35,5 +35,5 @@ index ff765d8e1a09..864290243e46 100644
|
|||||||
};
|
};
|
||||||
MODULE_DEVICE_TABLE(dmi, samsung_dmi_table);
|
MODULE_DEVICE_TABLE(dmi, samsung_dmi_table);
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -33,5 +33,5 @@ index cfba74cd8e8b..5127df3cc064 100644
|
|||||||
* If the device is offline, don't try and read capacity or any
|
* If the device is offline, don't try and read capacity or any
|
||||||
* of the other niceties.
|
* of the other niceties.
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -51,5 +51,5 @@ index eb976ee3a02f..275f20a643f4 100644
|
|||||||
|
|
||||||
#ifdef MODULE
|
#ifdef MODULE
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
6
sources
6
sources
@ -1,4 +1,2 @@
|
|||||||
fb30d0f29214d75cddd2faa94f73d5cf linux-3.17.tar.xz
|
9e854df51ca3fef8bfe566dbd7b89241 linux-3.18.tar.xz
|
||||||
159e969cbc27201d8e2fa0f609dc722f perf-man-3.17.tar.gz
|
813ccb96f0b379d656e57442c2587ca3 perf-man-3.18.tar.gz
|
||||||
3f67a949be63d47b6286ec63e6194e54 patch-3.18-rc7.xz
|
|
||||||
671e959ab06dab1fb63280c12668a826 patch-3.18-rc7-git3.xz
|
|
||||||
|
@ -74,5 +74,5 @@ index 70bf11815f84..4eeb9923472b 100644
|
|||||||
|
|
||||||
if (watchdog_user_enabled)
|
if (watchdog_user_enabled)
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -66,5 +66,5 @@ index 524b707894ef..c268e2581ed6 100644
|
|||||||
return -EFAULT;
|
return -EFAULT;
|
||||||
while (count-- > 0 && i < 65536) {
|
while (count-- > 0 && i < 65536) {
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
@ -38,5 +38,5 @@ index c9603ac80de5..8bef43fc3f40 100644
|
|||||||
err = -EFAULT;
|
err = -EFAULT;
|
||||||
break;
|
break;
|
||||||
--
|
--
|
||||||
1.9.3
|
2.1.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user