backport some low-impact enablement for the pegatron tablets
This commit is contained in:
parent
ed7f8ddc67
commit
1d83b4aade
@ -0,0 +1,37 @@
|
||||
From: Andy Ross <andy.ross@windriver.com>
|
||||
Date: Mon, 9 May 2011 23:11:16 +0000 (-0700)
|
||||
Subject: Bluetooth: Device ids for ath3k on Pegatron Lucid tablets
|
||||
X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Fpadovan%2Fbluetooth-next-2.6.git;a=commitdiff_plain;h=2a7bccccdb9604a717c2128a931f022267d35629
|
||||
|
||||
Bluetooth: Device ids for ath3k on Pegatron Lucid tablets
|
||||
|
||||
New ath3k device IDs used on the Pegatron Lucid (ExoPC and WeTab) units.
|
||||
|
||||
Signed-off-by: Andy Ross <andy.ross@windriver.com>
|
||||
Signed-off-by: Gustavo F. Padovan <padovan@profusion.mobi>
|
||||
---
|
||||
|
||||
diff --git a/drivers/bluetooth/ath3k.c b/drivers/bluetooth/ath3k.c
|
||||
index 695d441..6bacef3 100644
|
||||
--- a/drivers/bluetooth/ath3k.c
|
||||
+++ b/drivers/bluetooth/ath3k.c
|
||||
@@ -62,6 +62,7 @@ static struct usb_device_id ath3k_table[] = {
|
||||
|
||||
/* Atheros AR3011 with sflash firmware*/
|
||||
{ USB_DEVICE(0x0CF3, 0x3002) },
|
||||
+ { USB_DEVICE(0x13d3, 0x3304) },
|
||||
|
||||
/* Atheros AR9285 Malbec with sflash firmware */
|
||||
{ USB_DEVICE(0x03F0, 0x311D) },
|
||||
diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
|
||||
index 762a510..c2de895 100644
|
||||
--- a/drivers/bluetooth/btusb.c
|
||||
+++ b/drivers/bluetooth/btusb.c
|
||||
@@ -104,6 +104,7 @@ static struct usb_device_id blacklist_table[] = {
|
||||
|
||||
/* Atheros 3011 with sflash firmware */
|
||||
{ USB_DEVICE(0x0cf3, 0x3002), .driver_info = BTUSB_IGNORE },
|
||||
+ { USB_DEVICE(0x13d3, 0x3304), .driver_info = BTUSB_IGNORE },
|
||||
|
||||
/* Atheros AR9285 Malbec with sflash firmware */
|
||||
{ USB_DEVICE(0x03f0, 0x311d), .driver_info = BTUSB_IGNORE },
|
80
hid-multitouch-add-support-for-elo-touchsystems.patch
Normal file
80
hid-multitouch-add-support-for-elo-touchsystems.patch
Normal file
@ -0,0 +1,80 @@
|
||||
From: Benjamin Tissoires <benjamin.tissoires@enac.fr>
|
||||
Date: Thu, 19 May 2011 09:37:29 +0000 (+0200)
|
||||
Subject: HID: hid-multitouch: add support for Elo TouchSystems 2515 IntelliTouch Plus
|
||||
X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Fjikos%2Fhid.git;a=commitdiff_plain;h=c04abeeff9d76a703cac1e6d312853b0fc8136f5
|
||||
|
||||
HID: hid-multitouch: add support for Elo TouchSystems 2515 IntelliTouch Plus
|
||||
|
||||
This patch adds support for Elo TouchSystems 2515 IntelliTouch Plus
|
||||
that can be found in Lenovo A700 all-in-one.
|
||||
|
||||
Signed-off-by: Benjamin Tissoires <benjamin.tissoires@enac.fr>
|
||||
Tested-by: Bastien Nocera <hadess@hadess.net>
|
||||
Signed-off-by: Jiri Kosina <jkosina@suse.cz>
|
||||
|
||||
--- linux-2.6.39.x86_64/drivers/hid/Kconfig 2011-05-19 00:06:34.000000000 -0400
|
||||
+++ linux-2.6.39.x86_64/drivers/hid/Kconfig 2011-05-24 10:17:13.007752208 -0400
|
||||
@@ -321,6 +321,7 @@
|
||||
|
||||
Say Y here if you have one of the following devices:
|
||||
- Cypress TrueTouch panels
|
||||
+ - Elo TouchSystems IntelliTouch Plus panels
|
||||
- Hanvon dual touch panels
|
||||
- IrTouch Infrared USB panels
|
||||
- Pixcir dual touch panels
|
||||
--- linux-2.6.39.x86_64/drivers/hid/hid-core.c 2011-05-24 10:14:17.000000000 -0400
|
||||
+++ linux-2.6.39.x86_64/drivers/hid/hid-core.c 2011-05-24 10:17:47.418905357 -0400
|
||||
@@ -1367,6 +1367,7 @@
|
||||
{ HID_USB_DEVICE(USB_VENDOR_ID_DWAV, USB_DEVICE_ID_DWAV_EGALAX_MULTITOUCH3) },
|
||||
{ HID_USB_DEVICE(USB_VENDOR_ID_DWAV, USB_DEVICE_ID_DWAV_EGALAX_MULTITOUCH4) },
|
||||
{ HID_BLUETOOTH_DEVICE(USB_VENDOR_ID_ELECOM, USB_DEVICE_ID_ELECOM_BM084) },
|
||||
+ { HID_USB_DEVICE(USB_VENDOR_ID_ELO, USB_DEVICE_ID_ELO_TS2515) },
|
||||
{ HID_USB_DEVICE(USB_VENDOR_ID_EMS, USB_DEVICE_ID_EMS_TRIO_LINKER_PLUS_II) },
|
||||
{ HID_USB_DEVICE(USB_VENDOR_ID_EZKEY, USB_DEVICE_ID_BTC_8193) },
|
||||
{ HID_USB_DEVICE(USB_VENDOR_ID_GAMERON, USB_DEVICE_ID_GAMERON_DUAL_PSX_ADAPTOR) },
|
||||
--- linux-2.6.39.x86_64/drivers/hid/hid-ids.h 2011-05-24 10:14:17.000000000 -0400
|
||||
+++ linux-2.6.39.x86_64/drivers/hid/hid-ids.h 2011-05-24 10:19:25.946345418 -0400
|
||||
@@ -223,6 +223,7 @@
|
||||
#define USB_VENDOR_ID_DREAM_CHEEKY 0x1d34
|
||||
|
||||
#define USB_VENDOR_ID_ELO 0x04E7
|
||||
+#define USB_DEVICE_ID_ELO_TS2515 0x0022
|
||||
#define USB_DEVICE_ID_ELO_TS2700 0x0020
|
||||
|
||||
#define USB_VENDOR_ID_EMS 0x2006
|
||||
--- linux-2.6.39.x86_64/drivers/hid/hid-multitouch.c 2011-05-19 00:06:34.000000000 -0400
|
||||
+++ linux-2.6.39.x86_64/drivers/hid/hid-multitouch.c 2011-05-24 10:22:32.505183658 -0400
|
||||
@@ -78,6 +78,7 @@
|
||||
#define MT_CLS_DUAL_INRANGE_CONTACTNUMBER 3
|
||||
#define MT_CLS_CYPRESS 4
|
||||
#define MT_CLS_EGALAX 5
|
||||
+#define MT_CLS_DUAL_NSMU_CONTACTID 6
|
||||
|
||||
/*
|
||||
* these device-dependent functions determine what slot corresponds
|
||||
@@ -136,6 +137,13 @@
|
||||
.sn_move = 4096,
|
||||
.sn_pressure = 32,
|
||||
},
|
||||
+
|
||||
+ { .name = MT_CLS_DUAL_NSMU_CONTACTID,
|
||||
+ .quirks = MT_QUIRK_NOT_SEEN_MEANS_UP |
|
||||
+ MT_QUIRK_SLOT_IS_CONTACTID,
|
||||
+ .maxcontacts = 2
|
||||
+ },
|
||||
+
|
||||
{ }
|
||||
};
|
||||
|
||||
@@ -493,6 +501,11 @@
|
||||
HID_USB_DEVICE(USB_VENDOR_ID_CYPRESS,
|
||||
USB_DEVICE_ID_CYPRESS_TRUETOUCH) },
|
||||
|
||||
+ /* Elo TouchSystems IntelliTouch Plus panel */
|
||||
+ { .driver_data = MT_CLS_DUAL_NSMU_CONTACTID,
|
||||
+ HID_USB_DEVICE(USB_VENDOR_ID_ELO,
|
||||
+ USB_DEVICE_ID_ELO_TS2515) },
|
||||
+
|
||||
/* GeneralTouch panel */
|
||||
{ .driver_data = MT_CLS_DUAL_INRANGE_CONTACTNUMBER,
|
||||
HID_USB_DEVICE(USB_VENDOR_ID_GENERAL_TOUCH,
|
11
kernel.spec
11
kernel.spec
@ -716,6 +716,9 @@ Patch12401: mm-slub-do-not-wake-kswapd-for-slubs-speculative-high-order-allocati
|
||||
Patch12402: mm-slub-do-not-take-expensive-steps-for-slubs-speculative-high-order-allocations.patch
|
||||
Patch12403: mm-vmscan-if-kswapd-has-been-running-too-long-allow-it-to-sleep.patch
|
||||
|
||||
Patch12410: hid-multitouch-add-support-for-elo-touchsystems.patch
|
||||
Patch12411: bluetooth-device-ids-for-ath3k-on-pegatron-lucid-tablets.patch
|
||||
|
||||
%endif
|
||||
|
||||
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
||||
@ -1326,6 +1329,9 @@ ApplyPatch mm-slub-do-not-wake-kswapd-for-slubs-speculative-high-order-allocatio
|
||||
ApplyPatch mm-slub-do-not-take-expensive-steps-for-slubs-speculative-high-order-allocations.patch
|
||||
ApplyPatch mm-vmscan-if-kswapd-has-been-running-too-long-allow-it-to-sleep.patch
|
||||
|
||||
ApplyPatch hid-multitouch-add-support-for-elo-touchsystems.patch
|
||||
ApplyPatch bluetooth-device-ids-for-ath3k-on-pegatron-lucid-tablets.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -1934,6 +1940,11 @@ fi
|
||||
# and build.
|
||||
|
||||
%changelog
|
||||
* Tue May 24 2011 Kyle McMartin <kmcmartin@redhat.com>
|
||||
- hid-multitouch: add support for elo touchsystems panels (requested
|
||||
by hadess, backported from hid-next)
|
||||
- bluetooth: add support for more ath3k devices (Ditto.)
|
||||
|
||||
* Fri May 20 2011 Chuck Ebbert <cebbert@redhat.com>
|
||||
- Drop broken fix for stalls on AMD processors.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user