Linux v3.13-rc2-295-g002acf1
- Add test fix patch for crypto backtrace (rhbz 1038472)
This commit is contained in:
parent
0a16078424
commit
1d5c4d2db1
16
crypto-backtrace-fix.patch
Normal file
16
crypto-backtrace-fix.patch
Normal file
@ -0,0 +1,16 @@
|
||||
Bugzilla: 1038472
|
||||
Upstream-status: test fix for 3.13 issue
|
||||
|
||||
diff --git a/include/crypto/scatterwalk.h b/include/crypto/scatterwalk.h
|
||||
index 64ebede..6a626a5 100644
|
||||
--- a/include/crypto/scatterwalk.h
|
||||
+++ b/include/crypto/scatterwalk.h
|
||||
@@ -44,7 +44,7 @@ static inline struct scatterlist *scatterwalk_sg_next(struct scatterlist *sg)
|
||||
if (sg_is_last(sg))
|
||||
return NULL;
|
||||
|
||||
- return (++sg)->length ? sg : (void *)sg_page(sg);
|
||||
+ return (++sg)->length ? sg : sg_chain_ptr(sg);
|
||||
}
|
||||
|
||||
static inline void scatterwalk_crypto_chain(struct scatterlist *head,
|
12
kernel.spec
12
kernel.spec
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 2
|
||||
# The git snapshot level
|
||||
%define gitrev 5
|
||||
%define gitrev 6
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -706,6 +706,9 @@ Patch25129: cpupower-Fix-segfault-due-to-incorrect-getopt_long-a.patch
|
||||
#CVE-2013-6382 rhbz 1033603 1034670
|
||||
Patch25157: xfs-underflow-bug-in-xfs_attrlist_by_handle.patch
|
||||
|
||||
#rhbz 1038472
|
||||
Patch25158: crypto-backtrace-fix.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -1378,6 +1381,9 @@ ApplyPatch cpupower-Fix-segfault-due-to-incorrect-getopt_long-a.patch
|
||||
#CVE-2013-6382 rhbz 1033603 1034670
|
||||
ApplyPatch xfs-underflow-bug-in-xfs_attrlist_by_handle.patch
|
||||
|
||||
#rhbz 1038472
|
||||
ApplyPatch crypto-backtrace-fix.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -2190,6 +2196,10 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Fri Dec 06 2013 Josh Boyer <jwboyer@fedoraproject.org> - 3.13.0-0.rc2.git6.1
|
||||
- Linux v3.13-rc2-295-g002acf1
|
||||
- Add test fix patch for crypto backtrace (rhbz 1038472)
|
||||
|
||||
* Thu Dec 05 2013 Josh Boyer <jwboyer@fedoraproject.org> - 3.13.0-0.rc2.git5.1
|
||||
- Linux v3.13-rc2-265-gef1e4e3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user