Linux v3.10-rc1-34-g1f63876
This commit is contained in:
parent
67a061c91e
commit
1a98835788
@ -1,56 +0,0 @@
|
|||||||
From 883e2c26855e19e19bfb985221ae5a09db26a1c4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Josh Boyer <jwboyer@obiwan.gha.chartermi.net>
|
|
||||||
Date: Fri, 3 May 2013 17:10:32 -0400
|
|
||||||
Subject: [PATCH] Revert "drm/i915: revert eDP bpp clamping code changes"
|
|
||||||
|
|
||||||
This reverts commit 57c219633275c7e7413f8bc7be250dc092887458.
|
|
||||||
---
|
|
||||||
drivers/gpu/drm/i915/intel_dp.c | 18 ++++--------------
|
|
||||||
1 file changed, 4 insertions(+), 14 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/intel_dp.c
|
|
||||||
index fb2fbc1..e0ee2ca 100644
|
|
||||||
--- a/drivers/gpu/drm/i915/intel_dp.c
|
|
||||||
+++ b/drivers/gpu/drm/i915/intel_dp.c
|
|
||||||
@@ -702,6 +702,9 @@ intel_dp_compute_config(struct intel_encoder *encoder,
|
|
||||||
/* Walk through all bpp values. Luckily they're all nicely spaced with 2
|
|
||||||
* bpc in between. */
|
|
||||||
bpp = min_t(int, 8*3, pipe_config->pipe_bpp);
|
|
||||||
+ if (is_edp(intel_dp) && dev_priv->edp.bpp)
|
|
||||||
+ bpp = min_t(int, bpp, dev_priv->edp.bpp);
|
|
||||||
+
|
|
||||||
for (; bpp >= 6*3; bpp -= 2*3) {
|
|
||||||
mode_rate = intel_dp_link_required(target_clock, bpp);
|
|
||||||
|
|
||||||
@@ -739,6 +742,7 @@ found:
|
|
||||||
intel_dp->link_bw = bws[clock];
|
|
||||||
intel_dp->lane_count = lane_count;
|
|
||||||
adjusted_mode->clock = drm_dp_bw_code_to_link_rate(intel_dp->link_bw);
|
|
||||||
+ pipe_config->pipe_bpp = bpp;
|
|
||||||
pipe_config->pixel_target_clock = target_clock;
|
|
||||||
|
|
||||||
DRM_DEBUG_KMS("DP link bw %02x lane count %d clock %d bpp %d\n",
|
|
||||||
@@ -751,20 +755,6 @@ found:
|
|
||||||
target_clock, adjusted_mode->clock,
|
|
||||||
&pipe_config->dp_m_n);
|
|
||||||
|
|
||||||
- /*
|
|
||||||
- * XXX: We have a strange regression where using the vbt edp bpp value
|
|
||||||
- * for the link bw computation results in black screens, the panel only
|
|
||||||
- * works when we do the computation at the usual 24bpp (but still
|
|
||||||
- * requires us to use 18bpp). Until that's fully debugged, stay
|
|
||||||
- * bug-for-bug compatible with the old code.
|
|
||||||
- */
|
|
||||||
- if (is_edp(intel_dp) && dev_priv->edp.bpp) {
|
|
||||||
- DRM_DEBUG_KMS("clamping display bpc (was %d) to eDP (%d)\n",
|
|
||||||
- bpp, dev_priv->edp.bpp);
|
|
||||||
- bpp = min_t(int, bpp, dev_priv->edp.bpp);
|
|
||||||
- }
|
|
||||||
- pipe_config->pipe_bpp = bpp;
|
|
||||||
-
|
|
||||||
return true;
|
|
||||||
}
|
|
||||||
|
|
||||||
--
|
|
||||||
1.8.2.1
|
|
||||||
|
|
13
kernel.spec
13
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 2
|
%global baserelease 1
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 1
|
%define rcrev 1
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 0
|
%define gitrev 1
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -729,9 +729,6 @@ Patch22001: selinux-apply-different-permission-to-ptrace-child.patch
|
|||||||
#rhbz 927469
|
#rhbz 927469
|
||||||
Patch23006: fix-child-thread-introspection.patch
|
Patch23006: fix-child-thread-introspection.patch
|
||||||
|
|
||||||
# Fix i915 on Macbook Pro 10,2 machines
|
|
||||||
Patch25015: 0001-Revert-drm-i915-revert-eDP-bpp-clamping-code-changes.patch
|
|
||||||
|
|
||||||
Patch25016: tglx.patch
|
Patch25016: tglx.patch
|
||||||
|
|
||||||
#rhbz 961527
|
#rhbz 961527
|
||||||
@ -1414,9 +1411,6 @@ ApplyPatch 0001-kmsg-Honor-dmesg_restrict-sysctl-on-dev-kmsg.patch
|
|||||||
#rhbz 927469
|
#rhbz 927469
|
||||||
ApplyPatch fix-child-thread-introspection.patch
|
ApplyPatch fix-child-thread-introspection.patch
|
||||||
|
|
||||||
# Fix i915 on Macbook Pro 10,2 machines
|
|
||||||
ApplyPatch 0001-Revert-drm-i915-revert-eDP-bpp-clamping-code-changes.patch
|
|
||||||
|
|
||||||
ApplyPatch tglx.patch
|
ApplyPatch tglx.patch
|
||||||
|
|
||||||
#rhbz 961527
|
#rhbz 961527
|
||||||
@ -2242,6 +2236,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 13 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc1.git1.1
|
||||||
|
- Linux v3.10-rc1-34-g1f63876
|
||||||
|
|
||||||
* Mon May 13 2013 Josh Boyer <jwboyer@redhat.com>
|
* Mon May 13 2013 Josh Boyer <jwboyer@redhat.com>
|
||||||
- Add radeon fixes for PCI-e gen2 speed issues (rhbz 961527)
|
- Add radeon fixes for PCI-e gen2 speed issues (rhbz 961527)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user