kernel-5.9.0-0.rc4.20200911git581cb3a26baf.7
* Fri Sep 11 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc4.20200911git581cb3a26baf.7] - Merge ark-patches Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
9f7f1a167a
commit
17c24014d8
34
0001-Filter-out-LTO-build-options-from-the-perl-ccopts.patch
Normal file
34
0001-Filter-out-LTO-build-options-from-the-perl-ccopts.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Justin M. Forbes" <jforbes@fedoraproject.org>
|
||||||
|
Date: Thu, 10 Sep 2020 16:39:54 -0500
|
||||||
|
Subject: [PATCH] Filter out LTO build options from the perl ccopts
|
||||||
|
|
||||||
|
Kernel tools currently does not build with LTO options enabled. We can
|
||||||
|
turn off the option in most places through the spec file, but for the
|
||||||
|
perl bindings, it auto detects what perl was built with and uses those.
|
||||||
|
This patch will filter out the lto options allowing kernel-tools
|
||||||
|
packages to build correctly. I expect this patch to go away when the
|
||||||
|
LTO issues are worked out upstream.
|
||||||
|
|
||||||
|
Upstream Status: Red Hat only
|
||||||
|
|
||||||
|
Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
|
||||||
|
---
|
||||||
|
tools/perf/Makefile.config | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/tools/perf/Makefile.config b/tools/perf/Makefile.config
|
||||||
|
index 190be4fa5c21..28beab03575a 100644
|
||||||
|
--- a/tools/perf/Makefile.config
|
||||||
|
+++ b/tools/perf/Makefile.config
|
||||||
|
@@ -748,6 +748,7 @@ else
|
||||||
|
PERL_EMBED_LIBADD = $(call grep-libs,$(PERL_EMBED_LDOPTS))
|
||||||
|
PERL_EMBED_CCOPTS = $(shell perl -MExtUtils::Embed -e ccopts 2>/dev/null)
|
||||||
|
PERL_EMBED_CCOPTS := $(filter-out -specs=%,$(PERL_EMBED_CCOPTS))
|
||||||
|
+ PERL_EMBED_CCOPTS := $(filter-out -flto=auto -ffat-lto-objects, $(PERL_EMBED_CCOPTS))
|
||||||
|
PERL_EMBED_LDOPTS := $(filter-out -specs=%,$(PERL_EMBED_LDOPTS))
|
||||||
|
FLAGS_PERL_EMBED=$(PERL_EMBED_CCOPTS) $(PERL_EMBED_LDOPTS)
|
||||||
|
|
||||||
|
--
|
||||||
|
2.28.0
|
||||||
|
|
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
|||||||
#
|
#
|
||||||
# Use this spot to avoid future merge conflicts.
|
# Use this spot to avoid future merge conflicts.
|
||||||
# Do not trim this comment.
|
# Do not trim this comment.
|
||||||
RHEL_RELEASE = 6
|
RHEL_RELEASE = 8
|
||||||
|
|
||||||
#
|
#
|
||||||
# Early y+1 numbering
|
# Early y+1 numbering
|
||||||
|
@ -71,3 +71,4 @@
|
|||||||
0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||||
0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
||||||
0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
||||||
|
0001-Filter-out-LTO-build-options-from-the-perl-ccopts.patch
|
||||||
|
34
kernel.spec
34
kernel.spec
@ -30,7 +30,7 @@ Summary: The Linux kernel
|
|||||||
# For a stable, released kernel, released_kernel should be 1.
|
# For a stable, released kernel, released_kernel should be 1.
|
||||||
%global released_kernel 0
|
%global released_kernel 0
|
||||||
|
|
||||||
%global distro_build 0.rc4.20200909git34d4ddd359db.6
|
%global distro_build 0.rc4.20200911git581cb3a26baf.8
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%define secure_boot_arch x86_64
|
%define secure_boot_arch x86_64
|
||||||
@ -69,13 +69,13 @@ Summary: The Linux kernel
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%define rpmversion 5.9.0
|
%define rpmversion 5.9.0
|
||||||
%define pkgrelease 0.rc4.20200909git34d4ddd359db.6
|
%define pkgrelease 0.rc4.20200911git581cb3a26baf.8
|
||||||
|
|
||||||
# This is needed to do merge window version magic
|
# This is needed to do merge window version magic
|
||||||
%define patchlevel 9
|
%define patchlevel 9
|
||||||
|
|
||||||
# allow pkg_release to have configurable %%{?dist} tag
|
# allow pkg_release to have configurable %%{?dist} tag
|
||||||
%define specrelease 0.rc4.20200909git34d4ddd359db.6%{?buildid}%{?dist}
|
%define specrelease 0.rc4.20200911git581cb3a26baf.8%{?buildid}%{?dist}
|
||||||
|
|
||||||
%define pkg_release %{specrelease}
|
%define pkg_release %{specrelease}
|
||||||
|
|
||||||
@ -181,11 +181,11 @@ Summary: The Linux kernel
|
|||||||
%define with_ipaclones 0
|
%define with_ipaclones 0
|
||||||
# no whitelist
|
# no whitelist
|
||||||
%define with_kernel_abi_whitelists 0
|
%define with_kernel_abi_whitelists 0
|
||||||
%endif
|
|
||||||
# Fedora builds these separately
|
# Fedora builds these separately
|
||||||
%define with_perf 0
|
%define with_perf 0
|
||||||
%define with_tools 0
|
%define with_tools 0
|
||||||
%define with_bpftool 0
|
%define with_bpftool 0
|
||||||
|
%endif
|
||||||
|
|
||||||
%if %{with_verbose}
|
%if %{with_verbose}
|
||||||
%define make_opts V=1
|
%define make_opts V=1
|
||||||
@ -353,7 +353,6 @@ Summary: The Linux kernel
|
|||||||
%define kernel_image vmlinux
|
%define kernel_image vmlinux
|
||||||
%define kernel_image_elf 1
|
%define kernel_image_elf 1
|
||||||
%define all_arch_configs kernel-%{version}-ppc64le*.config
|
%define all_arch_configs kernel-%{version}-ppc64le*.config
|
||||||
%define kcflags -O3
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%ifarch s390x
|
%ifarch s390x
|
||||||
@ -567,7 +566,7 @@ BuildRequires: asciidoc
|
|||||||
# exact git commit you can run
|
# exact git commit you can run
|
||||||
#
|
#
|
||||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||||
Source0: linux-20200909git34d4ddd359db.tar.xz
|
Source0: linux-20200911git581cb3a26baf.tar.xz
|
||||||
|
|
||||||
Source1: Makefile.rhelver
|
Source1: Makefile.rhelver
|
||||||
|
|
||||||
@ -789,6 +788,7 @@ Patch71: 0001-arch-x86-Remove-vendor-specific-CPU-ID-checks.patch
|
|||||||
Patch72: 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
Patch72: 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||||
Patch73: 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
Patch73: 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
||||||
Patch74: 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
Patch74: 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
||||||
|
Patch75: 0001-Filter-out-LTO-build-options-from-the-perl-ccopts.patch
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -1284,8 +1284,8 @@ ApplyOptionalPatch()
|
|||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
%setup -q -n kernel-20200909git34d4ddd359db -c
|
%setup -q -n kernel-20200911git581cb3a26baf -c
|
||||||
mv linux-20200909git34d4ddd359db linux-%{KVERREL}
|
mv linux-20200911git581cb3a26baf linux-%{KVERREL}
|
||||||
|
|
||||||
cd linux-%{KVERREL}
|
cd linux-%{KVERREL}
|
||||||
cp -a %{SOURCE1} .
|
cp -a %{SOURCE1} .
|
||||||
@ -1365,6 +1365,7 @@ ApplyOptionalPatch 0001-arch-x86-Remove-vendor-specific-CPU-ID-checks.patch
|
|||||||
ApplyOptionalPatch 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
ApplyOptionalPatch 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||||
ApplyOptionalPatch 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
ApplyOptionalPatch 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
||||||
ApplyOptionalPatch 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
ApplyOptionalPatch 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
||||||
|
ApplyOptionalPatch 0001-Filter-out-LTO-build-options-from-the-perl-ccopts.patch
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -2793,9 +2794,24 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Sep 09 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc4.20200909git34d4ddd359db.5]
|
* Fri Sep 11 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc4.20200911git581cb3a26baf.7]
|
||||||
- Merge ark-patches
|
- Merge ark-patches
|
||||||
|
|
||||||
|
* Fri Sep 11 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc4.20200911git581cb3a26baf.6.test]
|
||||||
|
- 581cb3a26baf rebase
|
||||||
|
- f2fs: Return EOF on unaligned end of file DIO read (Gabriel Krisman Bertazi)
|
||||||
|
- f2fs: fix indefinite loop scanning for free nid (Sahitya Tummala)
|
||||||
|
- f2fs: Fix type of section block count variables (Shin'ichiro Kawasaki)
|
||||||
|
|
||||||
|
* Thu Sep 10 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc4.20200910git7fe10096c150.5.test]
|
||||||
|
- 7fe10096c150 rebase
|
||||||
|
- kernel.spec: don't override upstream compiler flags for ppc64le (=?UTF-8?q?Dan=20Hor=C3=A1k?=)
|
||||||
|
- SUNRPC: stop printk reading past end of string ("J. Bruce Fields")
|
||||||
|
- NFS: Zero-stateid SETATTR should first return delegation (Chuck Lever)
|
||||||
|
- padata: fix possible padata_works_lock deadlock (Daniel Jordan)
|
||||||
|
- NFSv4.1 handle ERR_DELAY error reclaiming locking state on delegation recall (Olga Kornievskaia)
|
||||||
|
- xprtrdma: Release in-flight MRs on disconnect (Chuck Lever)
|
||||||
|
|
||||||
* Wed Sep 09 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc4.20200909git34d4ddd359db.4.test]
|
* Wed Sep 09 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc4.20200909git34d4ddd359db.4.test]
|
||||||
- 34d4ddd359db rebase
|
- 34d4ddd359db rebase
|
||||||
- Revert "drm/i915/gem: Delete unused code" (Dave Airlie)
|
- Revert "drm/i915/gem: Delete unused code" (Dave Airlie)
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (linux-20200909git34d4ddd359db.tar.xz) = cbcb42eaf278e2d97e376ddcf2bc88d65a3ef7af4066c1aacb9621612c53cdc3f274263a1e974a5d588f8999bf8e2fbac0161395ed5fd452434b5056f8fd32c1
|
SHA512 (linux-20200911git581cb3a26baf.tar.xz) = abfeb9885975fc137852a733b1cf6c5640051a64aafc2cd5269849d63318eae25877b166b1a99313a7139a83c2c53ea35d38fb1b7f8dc4b6c7be5c665c96fcac
|
||||||
SHA512 (kernel-abi-whitelists-5.9.0-0.rc4.20200909git34d4ddd359db.6.tar.bz2) = 811199485989af2ff29c0a2120208d0e7180c88a4f6a705be12e20cbab67c7bb602e4ea35e77a73698c8002a07d878cfa371c2182caffa427d096b443768935f
|
SHA512 (kernel-abi-whitelists-5.9.0-0.rc4.20200911git581cb3a26baf.8.tar.bz2) = 0478e7669b40c46f3c3fc200a23689f8aa33ba677734041aec6077b9865b552d95e539691a106fde0c0140f383355d558789a9b2b9f590dd7e0ae20586e4b5dc
|
||||||
SHA512 (kernel-kabi-dw-5.9.0-0.rc4.20200909git34d4ddd359db.6.tar.bz2) = f91b7c857ca70406d180151642539cf092bb18952caf13426844ad9e0eab34dbc94c703390b9cc4532941179094c241d048f25dd29ab2936e83a80baa43c25f2
|
SHA512 (kernel-kabi-dw-5.9.0-0.rc4.20200911git581cb3a26baf.8.tar.bz2) = 694f0d661f8e4202f87c706811a29593df5cefee47bcc8f000a97914ad5e5edf677152e888230d96848c0ce658f955581a90a3fdb2f71bb1a71fd4abe3f3f5dc
|
||||||
|
Loading…
Reference in New Issue
Block a user