kernel-6.0.0-0.rc2.19
* Mon Aug 22 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.0.0-0.rc2.19] - Linux v6.0.0-0.rc2 Resolves: Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
904abaf70b
commit
13685fe803
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 16
|
||||
RHEL_RELEASE = 19
|
||||
|
||||
#
|
||||
# ZSTREAM
|
||||
|
27
kernel.spec
27
kernel.spec
@ -120,17 +120,17 @@ Summary: The Linux kernel
|
||||
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
||||
# to build the base kernel using the debug configuration. (Specifying
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 0
|
||||
%define debugbuildsenabled 1
|
||||
# define buildid .local
|
||||
%define specversion 6.0.0
|
||||
%define patchversion 6.0
|
||||
%define pkgrelease 0.rc1.20220819git4c2d0b039c5c.16
|
||||
%define pkgrelease 0.rc2.19
|
||||
%define kversion 6
|
||||
%define tarfile_release 6.0-rc1-160-g4c2d0b039c5c
|
||||
%define tarfile_release 6.0-rc2
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 0
|
||||
# This allows pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc1.20220819git4c2d0b039c5c.16%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc2.19%{?buildid}%{?dist}
|
||||
# This defines the kabi tarball version
|
||||
%define kabiversion 6.0.0
|
||||
|
||||
@ -3147,6 +3147,25 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Mon Aug 22 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.0.0-0.rc2.19]
|
||||
- Linux v6.0.0-0.rc2
|
||||
|
||||
* Sun Aug 21 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.0.0-0.rc1.15b3f48a4339.18]
|
||||
- Linux v6.0.0-0.rc1.15b3f48a4339
|
||||
|
||||
* Sat Aug 20 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.0.0-0.rc1.50cd95ac4654.17]
|
||||
- redhat/docs: Add dist-brew BUILD_FLAGS information (Prarit Bhargava)
|
||||
- redhat: change the changelog item for upstream merges (Herton R. Krzesinski)
|
||||
- redhat: fix dist-release build number test (Herton R. Krzesinski)
|
||||
- redhat: fix release number bump when dist-release-changed runs (Herton R. Krzesinski)
|
||||
- redhat: use new genlog.sh script to detect changes for dist-release (Herton R. Krzesinski)
|
||||
- redhat: move changelog addition to the spec file back into genspec.sh (Herton R. Krzesinski)
|
||||
- redhat: always add a rebase entry when ark merges from upstream (Herton R. Krzesinski)
|
||||
- redhat: drop merge ark patches hack (Herton R. Krzesinski)
|
||||
- redhat: don't hardcode temporary changelog file (Herton R. Krzesinski)
|
||||
- redhat: split changelog generation from genspec.sh (Herton R. Krzesinski)
|
||||
- Linux v6.0.0-0.rc1.50cd95ac4654
|
||||
|
||||
* Thu Aug 18 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.0.0-0.rc1.3b06a2755758.14]
|
||||
- redhat: configs: Disable FIE on arm (Jeremy Linton) [2012226]
|
||||
|
||||
|
@ -121,7 +121,7 @@ index 000000000000..effb81d04bfd
|
||||
+
|
||||
+endmenu
|
||||
diff --git a/Makefile b/Makefile
|
||||
index f09673b6c11d..7b0556fac07d 100644
|
||||
index c7705f749601..605a6bbe1714 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -135,7 +135,7 @@ index f09673b6c11d..7b0556fac07d 100644
|
||||
# We are using a recursive build, so we need to do a little thinking
|
||||
# to get the ordering right.
|
||||
#
|
||||
@@ -1251,7 +1255,13 @@ define filechk_version.h
|
||||
@@ -1249,7 +1253,13 @@ define filechk_version.h
|
||||
((c) > 255 ? 255 : (c)))'; \
|
||||
echo \#define LINUX_VERSION_MAJOR $(VERSION); \
|
||||
echo \#define LINUX_VERSION_PATCHLEVEL $(PATCHLEVEL); \
|
||||
@ -2551,10 +2551,10 @@ index 1bc362cb413f..961600d0572d 100644
|
||||
|
||||
#if defined(CONFIG_SECURITY) && defined(CONFIG_WATCH_QUEUE)
|
||||
diff --git a/init/Kconfig b/init/Kconfig
|
||||
index 80fe60fa77fb..ab664cf7ed79 100644
|
||||
index 532362fcfe31..30d547537ea0 100644
|
||||
--- a/init/Kconfig
|
||||
+++ b/init/Kconfig
|
||||
@@ -1682,7 +1682,7 @@ config AIO
|
||||
@@ -1678,7 +1678,7 @@ config AIO
|
||||
this option saves about 7k.
|
||||
|
||||
config IO_URING
|
||||
@ -2906,7 +2906,7 @@ index 000000000000..586c3319f530
|
||||
+}
|
||||
+EXPORT_SYMBOL(mark_partner_supported);
|
||||
diff --git a/scripts/mod/modpost.c b/scripts/mod/modpost.c
|
||||
index 55e32af2e53f..eda59a076309 100644
|
||||
index 2c80da0220c3..18097b6e2fe7 100644
|
||||
--- a/scripts/mod/modpost.c
|
||||
+++ b/scripts/mod/modpost.c
|
||||
@@ -22,6 +22,7 @@
|
||||
@ -2917,7 +2917,7 @@ index 55e32af2e53f..eda59a076309 100644
|
||||
|
||||
/* Are we using CONFIG_MODVERSIONS? */
|
||||
static bool modversions;
|
||||
@@ -2132,6 +2133,12 @@ static void write_buf(struct buffer *b, const char *fname)
|
||||
@@ -2130,6 +2131,12 @@ static void write_buf(struct buffer *b, const char *fname)
|
||||
}
|
||||
}
|
||||
|
||||
@ -2930,7 +2930,7 @@ index 55e32af2e53f..eda59a076309 100644
|
||||
static void write_if_changed(struct buffer *b, const char *fname)
|
||||
{
|
||||
char *tmp;
|
||||
@@ -2195,6 +2202,7 @@ static void write_mod_c_file(struct module *mod)
|
||||
@@ -2193,6 +2200,7 @@ static void write_mod_c_file(struct module *mod)
|
||||
add_depends(&buf, mod);
|
||||
add_moddevtable(&buf, mod);
|
||||
add_srcversion(&buf, mod);
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-6.0-rc1-160-g4c2d0b039c5c.tar.xz) = bf70a7fce8a5153ce69630ea14309c24370ffc4e8715ed1bc7e846318178340bb2c4c4f3303f915122fd4da7ca61e08bfd46541d9b463f46d134977a83df7426
|
||||
SHA512 (kernel-abi-stablelists-6.0.0.tar.bz2) = f3f6a2008e4af908736cb2a34e85e54270b64c23c186c7ce7de88ed3b4bf2428c7343237cf0900a449bae4058584ebbe1542bdbe32c819eee90663dda76b96de
|
||||
SHA512 (kernel-kabi-dw-6.0.0.tar.bz2) = 37965343657b0a0cef9a0f018f1ed8450190fd26f8ec78d78be8a1a754c9d4eeb09d8b2d556cd64f2e1a694776b5a9ea86f80a43ba4f2f44bc2521d0e1a7e778
|
||||
SHA512 (linux-6.0-rc2.tar.xz) = 16475da408c9a2e93509033fa0df65ae1b92cca876c03024915e49b4c8883b07fb74a27dbef4d1934e0c0379583c86897a139fc6c0d8ffd780e978326dc95859
|
||||
SHA512 (kernel-abi-stablelists-6.0.0.tar.bz2) = 1c847d0c1cf15d996370f462122900e4e19badd5b077c8c9723b6bddec2bb28113c1d6dba6c4ad43b74c45c5bbcd665de3b0de3acf08a0e71c4bb01e1a379847
|
||||
SHA512 (kernel-kabi-dw-6.0.0.tar.bz2) = 22de7be64df3cdbd8d12938ad0907d204331cdec41082f0c0dceec086b02e0c85d4c70796fc5c18f9c2baa3f6ad74241c14e4b2b6c6fd58baf11cb110f67ef11
|
||||
|
Loading…
Reference in New Issue
Block a user