Linux v4.4-rc5-168-g73796d8
This commit is contained in:
parent
4f1a5f75b5
commit
13141e11de
2
gitrev
2
gitrev
@ -1 +1 @@
|
|||||||
a5e90b1b075f89f084047628d4ef181aded0bbfb
|
73796d8bf27372e26c2b79881947304c14c2d353
|
||||||
|
11
kernel.spec
11
kernel.spec
@ -67,7 +67,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 5
|
%define rcrev 5
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 2
|
%define gitrev 3
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 4.%{upstream_sublevel}.0
|
%define rpmversion 4.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -604,9 +604,6 @@ Patch572: alua_fix.patch
|
|||||||
#CVE-2015-7550 rhbz 1291197 1291198
|
#CVE-2015-7550 rhbz 1291197 1291198
|
||||||
Patch575: KEYS-Fix-race-between-read-and-revoke.patch
|
Patch575: KEYS-Fix-race-between-read-and-revoke.patch
|
||||||
|
|
||||||
#CVE-2015-8543 rhbz 1290475 1290477
|
|
||||||
Patch576: net-add-validation-for-the-socket-syscall-protocol-a.patch
|
|
||||||
|
|
||||||
#rhbz 1275718
|
#rhbz 1275718
|
||||||
Patch577: 0001-device-property-always-check-for-fwnode-type.patch
|
Patch577: 0001-device-property-always-check-for-fwnode-type.patch
|
||||||
Patch578: 0002-device-property-rename-helper-functions.patch
|
Patch578: 0002-device-property-rename-helper-functions.patch
|
||||||
@ -625,9 +622,6 @@ Patch590: 0014-mfd-intel-lpss-Pass-SDA-hold-time-to-I2C-host-contro.patch
|
|||||||
Patch591: 0015-mfd-intel-lpss-Pass-HSUART-configuration-via-propert.patch
|
Patch591: 0015-mfd-intel-lpss-Pass-HSUART-configuration-via-propert.patch
|
||||||
Patch592: 0016-i2c-designware-Convert-to-use-unified-device-propert.patch
|
Patch592: 0016-i2c-designware-Convert-to-use-unified-device-propert.patch
|
||||||
|
|
||||||
#CVE-2015-8569 rhbz 1292045 1292047
|
|
||||||
Patch600: pptp-verify-sockaddr_len-in-pptp_bind-and-pptp_conne.patch
|
|
||||||
|
|
||||||
# END OF PATCH DEFINITIONS
|
# END OF PATCH DEFINITIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -2071,6 +2065,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 18 2015 Laura Abbott <labbott@redhat.com> - 4.4.0-0.rc5.git3.1
|
||||||
|
- Linux v4.4-rc5-168-g73796d8
|
||||||
|
|
||||||
* Thu Dec 17 2015 Laura Abbott <labbott@redhat.com>
|
* Thu Dec 17 2015 Laura Abbott <labbott@redhat.com>
|
||||||
- Enable XEN_PVN support (rhbz 1211904)
|
- Enable XEN_PVN support (rhbz 1211904)
|
||||||
|
|
||||||
|
@ -1,139 +0,0 @@
|
|||||||
From 4da7dc22c91ad2c3144cb1d0d96e9611bc86da47 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Hannes Frederic Sowa <hannes@stressinduktion.org>
|
|
||||||
Date: Mon, 14 Dec 2015 22:03:39 +0100
|
|
||||||
Subject: [PATCH] net: add validation for the socket syscall protocol argument
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
郭永刚 reported that one could simply crash the kernel as root by
|
|
||||||
using a simple program:
|
|
||||||
|
|
||||||
int socket_fd;
|
|
||||||
struct sockaddr_in addr;
|
|
||||||
addr.sin_port = 0;
|
|
||||||
addr.sin_addr.s_addr = INADDR_ANY;
|
|
||||||
addr.sin_family = 10;
|
|
||||||
|
|
||||||
socket_fd = socket(10,3,0x40000000);
|
|
||||||
connect(socket_fd , &addr,16);
|
|
||||||
|
|
||||||
AF_INET, AF_INET6 sockets actually only support 8-bit protocol
|
|
||||||
identifiers. inet_sock's skc_protocol field thus is sized accordingly,
|
|
||||||
thus larger protocol identifiers simply cut off the higher bits and
|
|
||||||
store a zero in the protocol fields.
|
|
||||||
|
|
||||||
This could lead to e.g. NULL function pointer because as a result of
|
|
||||||
the cut off inet_num is zero and we call down to inet_autobind, which
|
|
||||||
is NULL for raw sockets.
|
|
||||||
|
|
||||||
kernel: Call Trace:
|
|
||||||
kernel: [<ffffffff816db90e>] ? inet_autobind+0x2e/0x70
|
|
||||||
kernel: [<ffffffff816db9a4>] inet_dgram_connect+0x54/0x80
|
|
||||||
kernel: [<ffffffff81645069>] SYSC_connect+0xd9/0x110
|
|
||||||
kernel: [<ffffffff810ac51b>] ? ptrace_notify+0x5b/0x80
|
|
||||||
kernel: [<ffffffff810236d8>] ? syscall_trace_enter_phase2+0x108/0x200
|
|
||||||
kernel: [<ffffffff81645e0e>] SyS_connect+0xe/0x10
|
|
||||||
kernel: [<ffffffff81779515>] tracesys_phase2+0x84/0x89
|
|
||||||
|
|
||||||
I found no particular commit which introduced this problem.
|
|
||||||
|
|
||||||
CVE: CVE-2015-8543
|
|
||||||
Cc: Cong Wang <cwang@twopensource.com>
|
|
||||||
Reported-by: 郭永刚 <guoyonggang@360.cn>
|
|
||||||
Signed-off-by: Hannes Frederic Sowa <hannes@stressinduktion.org>
|
|
||||||
Signed-off-by: David S. Miller <davem@davemloft.net>
|
|
||||||
---
|
|
||||||
include/net/sock.h | 1 +
|
|
||||||
net/ax25/af_ax25.c | 3 +++
|
|
||||||
net/decnet/af_decnet.c | 3 +++
|
|
||||||
net/ipv4/af_inet.c | 3 +++
|
|
||||||
net/ipv6/af_inet6.c | 3 +++
|
|
||||||
net/irda/af_irda.c | 3 +++
|
|
||||||
6 files changed, 16 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/include/net/sock.h b/include/net/sock.h
|
|
||||||
index 52d27ee924f4..2fa1fc00e8cb 100644
|
|
||||||
--- a/include/net/sock.h
|
|
||||||
+++ b/include/net/sock.h
|
|
||||||
@@ -403,6 +403,7 @@ struct sock {
|
|
||||||
sk_no_check_rx : 1,
|
|
||||||
sk_userlocks : 4,
|
|
||||||
sk_protocol : 8,
|
|
||||||
+#define SK_PROTOCOL_MAX U8_MAX
|
|
||||||
sk_type : 16;
|
|
||||||
kmemcheck_bitfield_end(flags);
|
|
||||||
int sk_wmem_queued;
|
|
||||||
diff --git a/net/ax25/af_ax25.c b/net/ax25/af_ax25.c
|
|
||||||
index ae3a47f9d1d5..fbd0acf80b13 100644
|
|
||||||
--- a/net/ax25/af_ax25.c
|
|
||||||
+++ b/net/ax25/af_ax25.c
|
|
||||||
@@ -805,6 +805,9 @@ static int ax25_create(struct net *net, struct socket *sock, int protocol,
|
|
||||||
struct sock *sk;
|
|
||||||
ax25_cb *ax25;
|
|
||||||
|
|
||||||
+ if (protocol < 0 || protocol > SK_PROTOCOL_MAX)
|
|
||||||
+ return -EINVAL;
|
|
||||||
+
|
|
||||||
if (!net_eq(net, &init_net))
|
|
||||||
return -EAFNOSUPPORT;
|
|
||||||
|
|
||||||
diff --git a/net/decnet/af_decnet.c b/net/decnet/af_decnet.c
|
|
||||||
index eebf5ac8ce18..13d6b1a6e0fc 100644
|
|
||||||
--- a/net/decnet/af_decnet.c
|
|
||||||
+++ b/net/decnet/af_decnet.c
|
|
||||||
@@ -678,6 +678,9 @@ static int dn_create(struct net *net, struct socket *sock, int protocol,
|
|
||||||
{
|
|
||||||
struct sock *sk;
|
|
||||||
|
|
||||||
+ if (protocol < 0 || protocol > SK_PROTOCOL_MAX)
|
|
||||||
+ return -EINVAL;
|
|
||||||
+
|
|
||||||
if (!net_eq(net, &init_net))
|
|
||||||
return -EAFNOSUPPORT;
|
|
||||||
|
|
||||||
diff --git a/net/ipv4/af_inet.c b/net/ipv4/af_inet.c
|
|
||||||
index 11c4ca13ec3b..5c5db6636704 100644
|
|
||||||
--- a/net/ipv4/af_inet.c
|
|
||||||
+++ b/net/ipv4/af_inet.c
|
|
||||||
@@ -257,6 +257,9 @@ static int inet_create(struct net *net, struct socket *sock, int protocol,
|
|
||||||
int try_loading_module = 0;
|
|
||||||
int err;
|
|
||||||
|
|
||||||
+ if (protocol < 0 || protocol >= IPPROTO_MAX)
|
|
||||||
+ return -EINVAL;
|
|
||||||
+
|
|
||||||
sock->state = SS_UNCONNECTED;
|
|
||||||
|
|
||||||
/* Look for the requested type/protocol pair. */
|
|
||||||
diff --git a/net/ipv6/af_inet6.c b/net/ipv6/af_inet6.c
|
|
||||||
index 8ec0df75f1c4..9f5137cd604e 100644
|
|
||||||
--- a/net/ipv6/af_inet6.c
|
|
||||||
+++ b/net/ipv6/af_inet6.c
|
|
||||||
@@ -109,6 +109,9 @@ static int inet6_create(struct net *net, struct socket *sock, int protocol,
|
|
||||||
int try_loading_module = 0;
|
|
||||||
int err;
|
|
||||||
|
|
||||||
+ if (protocol < 0 || protocol >= IPPROTO_MAX)
|
|
||||||
+ return -EINVAL;
|
|
||||||
+
|
|
||||||
/* Look for the requested type/protocol pair. */
|
|
||||||
lookup_protocol:
|
|
||||||
err = -ESOCKTNOSUPPORT;
|
|
||||||
diff --git a/net/irda/af_irda.c b/net/irda/af_irda.c
|
|
||||||
index e6aa48b5395c..923abd6b3064 100644
|
|
||||||
--- a/net/irda/af_irda.c
|
|
||||||
+++ b/net/irda/af_irda.c
|
|
||||||
@@ -1086,6 +1086,9 @@ static int irda_create(struct net *net, struct socket *sock, int protocol,
|
|
||||||
struct sock *sk;
|
|
||||||
struct irda_sock *self;
|
|
||||||
|
|
||||||
+ if (protocol < 0 || protocol > SK_PROTOCOL_MAX)
|
|
||||||
+ return -EINVAL;
|
|
||||||
+
|
|
||||||
if (net != &init_net)
|
|
||||||
return -EAFNOSUPPORT;
|
|
||||||
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
@ -1,39 +0,0 @@
|
|||||||
From 16c5a158e97d5b1f6c8bf86b006c1349f025d4e0 Mon Sep 17 00:00:00 2001
|
|
||||||
From: WANG Cong <xiyou.wangcong@gmail.com>
|
|
||||||
Date: Mon, 14 Dec 2015 13:48:36 -0800
|
|
||||||
Subject: [PATCH] pptp: verify sockaddr_len in pptp_bind() and pptp_connect()
|
|
||||||
|
|
||||||
Reported-by: Dmitry Vyukov <dvyukov@gmail.com>
|
|
||||||
Signed-off-by: Cong Wang <xiyou.wangcong@gmail.com>
|
|
||||||
Signed-off-by: David S. Miller <davem@davemloft.net>
|
|
||||||
---
|
|
||||||
drivers/net/ppp/pptp.c | 6 ++++++
|
|
||||||
1 file changed, 6 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/drivers/net/ppp/pptp.c b/drivers/net/ppp/pptp.c
|
|
||||||
index fc69e41d0950..597c53e0a2ec 100644
|
|
||||||
--- a/drivers/net/ppp/pptp.c
|
|
||||||
+++ b/drivers/net/ppp/pptp.c
|
|
||||||
@@ -419,6 +419,9 @@ static int pptp_bind(struct socket *sock, struct sockaddr *uservaddr,
|
|
||||||
struct pptp_opt *opt = &po->proto.pptp;
|
|
||||||
int error = 0;
|
|
||||||
|
|
||||||
+ if (sockaddr_len < sizeof(struct sockaddr_pppox))
|
|
||||||
+ return -EINVAL;
|
|
||||||
+
|
|
||||||
lock_sock(sk);
|
|
||||||
|
|
||||||
opt->src_addr = sp->sa_addr.pptp;
|
|
||||||
@@ -440,6 +443,9 @@ static int pptp_connect(struct socket *sock, struct sockaddr *uservaddr,
|
|
||||||
struct flowi4 fl4;
|
|
||||||
int error = 0;
|
|
||||||
|
|
||||||
+ if (sockaddr_len < sizeof(struct sockaddr_pppox))
|
|
||||||
+ return -EINVAL;
|
|
||||||
+
|
|
||||||
if (sp->sa_protocol != PX_PROTO_PPTP)
|
|
||||||
return -EINVAL;
|
|
||||||
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
|||||||
58b35794eee3b6d52ce7be39357801e7 linux-4.3.tar.xz
|
58b35794eee3b6d52ce7be39357801e7 linux-4.3.tar.xz
|
||||||
7c516c9528b9f9aac0136944b0200b7e perf-man-4.3.tar.gz
|
7c516c9528b9f9aac0136944b0200b7e perf-man-4.3.tar.gz
|
||||||
c00e702d178da6eead9bd089a96bbba5 patch-4.4-rc5.xz
|
c00e702d178da6eead9bd089a96bbba5 patch-4.4-rc5.xz
|
||||||
748e5a597bafe3246a1c40487d16e322 patch-4.4-rc5-git1.xz
|
34c179504504f3acaf5e8f792c482f28 patch-4.4-rc5-git3.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user