Linux v3.15-rc2-69-g1aae31c8306e
This commit is contained in:
parent
d57a191a76
commit
0c4590d0bd
@ -1,99 +0,0 @@
|
|||||||
From 555b84220a7c84c2faa1964d19733d867d7bf61f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Hans de Goede <hdegoede@redhat.com>
|
|
||||||
Date: Thu, 10 Apr 2014 11:36:14 +0200
|
|
||||||
Subject: [PATCH v3] synaptics: Add min/max quirk for ThinkPad T431s, L440,
|
|
||||||
L540, S1 Yoga and X1
|
|
||||||
|
|
||||||
We expect that all the Haswell series will need such quirks, sigh.
|
|
||||||
|
|
||||||
The T431s seems to be T430 hardware in a T440s case, using the T440s touchpad,
|
|
||||||
with the same min/max issue.
|
|
||||||
|
|
||||||
The X1 Carbon 3rd generation name says 2nd while it is a 3rd generation.
|
|
||||||
|
|
||||||
The X1 and T431s share a PnPID with the T540p, but the reported ranges are
|
|
||||||
closer to those of the T440s.
|
|
||||||
|
|
||||||
HdG: Squashed 5 quirk patches into one. T431s + L440 + L540 are written by me,
|
|
||||||
S1 Yoga and X1 are written by Benjamin Tissoires.
|
|
||||||
|
|
||||||
Hdg: Standardized S1 Yoga and X1 values, Yoga uses the same touchpad as the
|
|
||||||
X240, X1 uses the same touchpad as the T440.
|
|
||||||
|
|
||||||
Cc: stable@vger.kernel.org
|
|
||||||
Signed-off-by: Benjamin Tissoires <benjamin.tissoires@redhat.com>
|
|
||||||
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
|
||||||
---
|
|
||||||
drivers/input/mouse/synaptics.c | 42 +++++++++++++++++++++++++++++++++++++++++
|
|
||||||
1 file changed, 42 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/drivers/input/mouse/synaptics.c b/drivers/input/mouse/synaptics.c
|
|
||||||
index a8b57d7..7c9f509 100644
|
|
||||||
--- a/drivers/input/mouse/synaptics.c
|
|
||||||
+++ b/drivers/input/mouse/synaptics.c
|
|
||||||
@@ -1566,6 +1566,14 @@ static const struct dmi_system_id min_max_dmi_table[] __initconst = {
|
|
||||||
.driver_data = (int []){1232, 5710, 1156, 4696},
|
|
||||||
},
|
|
||||||
{
|
|
||||||
+ /* Lenovo ThinkPad T431s */
|
|
||||||
+ .matches = {
|
|
||||||
+ DMI_MATCH(DMI_SYS_VENDOR, "LENOVO"),
|
|
||||||
+ DMI_MATCH(DMI_PRODUCT_VERSION, "ThinkPad T431"),
|
|
||||||
+ },
|
|
||||||
+ .driver_data = (int []){1024, 5112, 2024, 4832},
|
|
||||||
+ },
|
|
||||||
+ {
|
|
||||||
/* Lenovo ThinkPad T440s */
|
|
||||||
.matches = {
|
|
||||||
DMI_MATCH(DMI_SYS_VENDOR, "LENOVO"),
|
|
||||||
@@ -1574,6 +1582,14 @@ static const struct dmi_system_id min_max_dmi_table[] __initconst = {
|
|
||||||
.driver_data = (int []){1024, 5112, 2024, 4832},
|
|
||||||
},
|
|
||||||
{
|
|
||||||
+ /* Lenovo ThinkPad L440 */
|
|
||||||
+ .matches = {
|
|
||||||
+ DMI_MATCH(DMI_SYS_VENDOR, "LENOVO"),
|
|
||||||
+ DMI_MATCH(DMI_PRODUCT_VERSION, "ThinkPad L440"),
|
|
||||||
+ },
|
|
||||||
+ .driver_data = (int []){1024, 5112, 2024, 4832},
|
|
||||||
+ },
|
|
||||||
+ {
|
|
||||||
/* Lenovo ThinkPad T540p */
|
|
||||||
.matches = {
|
|
||||||
DMI_MATCH(DMI_SYS_VENDOR, "LENOVO"),
|
|
||||||
@@ -1581,6 +1597,32 @@ static const struct dmi_system_id min_max_dmi_table[] __initconst = {
|
|
||||||
},
|
|
||||||
.driver_data = (int []){1024, 5056, 2058, 4832},
|
|
||||||
},
|
|
||||||
+ {
|
|
||||||
+ /* Lenovo ThinkPad L540 */
|
|
||||||
+ .matches = {
|
|
||||||
+ DMI_MATCH(DMI_SYS_VENDOR, "LENOVO"),
|
|
||||||
+ DMI_MATCH(DMI_PRODUCT_VERSION, "ThinkPad L540"),
|
|
||||||
+ },
|
|
||||||
+ .driver_data = (int []){1024, 5112, 2024, 4832},
|
|
||||||
+ },
|
|
||||||
+ {
|
|
||||||
+ /* Lenovo Yoga S1 */
|
|
||||||
+ .matches = {
|
|
||||||
+ DMI_MATCH(DMI_SYS_VENDOR, "LENOVO"),
|
|
||||||
+ DMI_EXACT_MATCH(DMI_PRODUCT_VERSION,
|
|
||||||
+ "ThinkPad S1 Yoga"),
|
|
||||||
+ },
|
|
||||||
+ .driver_data = (int []){1232, 5710, 1156, 4696},
|
|
||||||
+ },
|
|
||||||
+ {
|
|
||||||
+ /* Lenovo ThinkPad X1 Carbon Haswell (3rd generation) */
|
|
||||||
+ .matches = {
|
|
||||||
+ DMI_MATCH(DMI_SYS_VENDOR, "LENOVO"),
|
|
||||||
+ DMI_MATCH(DMI_PRODUCT_VERSION,
|
|
||||||
+ "ThinkPad X1 Carbon 2nd"),
|
|
||||||
+ },
|
|
||||||
+ .driver_data = (int []){1024, 5112, 2024, 4832},
|
|
||||||
+ },
|
|
||||||
#endif
|
|
||||||
{ }
|
|
||||||
};
|
|
||||||
--
|
|
||||||
1.9.0
|
|
||||||
|
|
11
kernel.spec
11
kernel.spec
@ -61,7 +61,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 2
|
%define rcrev 2
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 1
|
%define gitrev 2
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -626,9 +626,6 @@ Patch22000: weird-root-dentry-name-debug.patch
|
|||||||
|
|
||||||
Patch25047: drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
Patch25047: drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
||||||
|
|
||||||
#rhbz 1085582 1085697
|
|
||||||
Patch25049: 0001-synaptics-Add-min-max-quirk-for-ThinkPad-T431s-L440-.patch
|
|
||||||
|
|
||||||
Patch25062: gpio-ich-set-regs-and-reglen-for-i3100-and-ich6-chipset.patch
|
Patch25062: gpio-ich-set-regs-and-reglen-for-i3100-and-ich6-chipset.patch
|
||||||
|
|
||||||
#rhbz 1025603
|
#rhbz 1025603
|
||||||
@ -1280,9 +1277,6 @@ ApplyPatch 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
|
|||||||
#rhbz 1089583
|
#rhbz 1089583
|
||||||
ApplyPatch 0001-HID-rmi-do-not-handle-touchscreens-through-hid-rmi.patch
|
ApplyPatch 0001-HID-rmi-do-not-handle-touchscreens-through-hid-rmi.patch
|
||||||
|
|
||||||
#rhbz 1085582 1085697
|
|
||||||
ApplyPatch 0001-synaptics-Add-min-max-quirk-for-ThinkPad-T431s-L440-.patch
|
|
||||||
|
|
||||||
ApplyPatch gpio-ich-set-regs-and-reglen-for-i3100-and-ich6-chipset.patch
|
ApplyPatch gpio-ich-set-regs-and-reglen-for-i3100-and-ich6-chipset.patch
|
||||||
|
|
||||||
#rhbz 1025603
|
#rhbz 1025603
|
||||||
@ -2067,6 +2061,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 23 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc2.git2.1
|
||||||
|
- Linux v3.15-rc2-69-g1aae31c8306e
|
||||||
|
|
||||||
* Tue Apr 22 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc2.git1.1
|
* Tue Apr 22 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc2.git1.1
|
||||||
- Linux v3.15-rc2-42-g4d0fa8a0f012
|
- Linux v3.15-rc2-42-g4d0fa8a0f012
|
||||||
- Reenable debugging options.
|
- Reenable debugging options.
|
||||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
|||||||
b621207b3f6ecbb67db18b13258f8ea8 linux-3.14.tar.xz
|
b621207b3f6ecbb67db18b13258f8ea8 linux-3.14.tar.xz
|
||||||
d36baf2d62de5aa61f10a976d00d2d2a perf-man-3.14.tar.gz
|
d36baf2d62de5aa61f10a976d00d2d2a perf-man-3.14.tar.gz
|
||||||
f8adc3ee2a7490a403ae1971597c0d0e patch-3.15-rc2.xz
|
f8adc3ee2a7490a403ae1971597c0d0e patch-3.15-rc2.xz
|
||||||
dc9d72f4ca8908aee3bd7014f4d9f032 patch-3.15-rc2-git1.xz
|
ce09f7908d29c0ad122238a8b260f825 patch-3.15-rc2-git2.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user