3.1-rc2-git7 snapshot. Fix provides/obsoletes for cpupowerutils-devel
This commit is contained in:
parent
7aac3ebb1e
commit
0ad3713581
@ -359,6 +359,7 @@ CONFIG_CISS_SCSI_TAPE=y
|
||||
CONFIG_BLK_DEV_DAC960=m
|
||||
CONFIG_BLK_DEV_UMEM=m
|
||||
CONFIG_BLK_DEV_LOOP=y
|
||||
CONFIG_BLK_DEV_LOOP_MIN_COUNT=8
|
||||
CONFIG_BLK_DEV_CRYPTOLOOP=m
|
||||
CONFIG_BLK_DEV_NBD=m
|
||||
CONFIG_BLK_DEV_OSD=m
|
||||
@ -375,6 +376,7 @@ CONFIG_BLK_DEV_DELKIN=m
|
||||
# CONFIG_BLK_DEV_TC86C001 is not set
|
||||
CONFIG_LBDAF=y
|
||||
CONFIG_BLK_DEV_BSG=y
|
||||
CONFIG_BLK_DEV_BSGLIB=y
|
||||
CONFIG_BLK_DEV_INTEGRITY=y
|
||||
CONFIG_BLK_DEV_THROTTLING=y
|
||||
|
||||
|
10
kernel.spec
10
kernel.spec
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 2
|
||||
# The git snapshot level
|
||||
%define gitrev 5
|
||||
%define gitrev 7
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -678,7 +678,6 @@ Patch800: linux-2.6-crash-driver.patch
|
||||
|
||||
# virt + ksm patches
|
||||
Patch1555: fix_xen_guest_on_old_EC2.patch
|
||||
Patch1556: xen-blkfront-name-adjust.patch
|
||||
|
||||
# DRM
|
||||
|
||||
@ -823,6 +822,8 @@ Summary: Assortment of tools for the Linux kernel
|
||||
Group: Development/System
|
||||
License: GPLv2
|
||||
Requires: kernel-tools = %{version}-%{release}
|
||||
Provides: cpupowerutils-devel = 1:009-0.6.p1
|
||||
Obsoletes: cpupowerutils-devel < 1:009-0.6.p1
|
||||
%description -n kernel-tools-devel
|
||||
This package contains the development files for the tools/ directory from
|
||||
the kernel source.
|
||||
@ -1311,7 +1312,6 @@ ApplyPatch linux-2.6-e1000-ich9-montevina.patch
|
||||
|
||||
# Assorted Virt Fixes
|
||||
ApplyPatch fix_xen_guest_on_old_EC2.patch
|
||||
ApplyPatch xen-blkfront-name-adjust.patch
|
||||
|
||||
# DRM core
|
||||
|
||||
@ -2074,6 +2074,10 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Sat Aug 20 2011 Josh Boyer <jwboyer@redhat.com>
|
||||
- Linux 3.1-rc2-git7
|
||||
- Add a provides/obsoletes for cpupowerutils-devel
|
||||
|
||||
* Fri Aug 19 2011 Josh Boyer <jwboyer@redhat.com>
|
||||
- Add patch from upstream to fix 64-bit divide error in btrfs
|
||||
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
398e95866794def22b12dfbc15ce89c0 linux-3.0.tar.bz2
|
||||
f358c354ab6d3b0da1265b504f85ec50 patch-3.1-rc2.bz2
|
||||
93c566575ae1dc33be4bc345177e4a7d patch-3.1-rc2-git5.bz2
|
||||
a617a4b89580d5e4e5be5033f8c3285b patch-3.1-rc2-git7.bz2
|
||||
|
@ -1,30 +0,0 @@
|
||||
commit 196cfe2ae8fcdc03b3c7d627e7dfe8c0ce7229f9
|
||||
Author: Stefan Bader <stefan.bader@canonical.com>
|
||||
Date: Thu Jul 14 15:30:22 2011 +0200
|
||||
|
||||
xen-blkfront: Drop name and minor adjustments for emulated scsi devices
|
||||
|
||||
These were intended to avoid the namespace clash when representing
|
||||
emulated IDE and SCSI devices. However that seems to confuse users
|
||||
more than expected (a disk defined as sda becomes xvde).
|
||||
So for now go back to the scheme which does no adjustments. This
|
||||
will break when mixing IDE and SCSI names in the configuration of
|
||||
guests but should be by now expected.
|
||||
|
||||
Acked-by: Stefano Stabellini <stefano.stabellini@eu.citrix.com>
|
||||
Signed-off-by: Stefan Bader <stefan.bader@canonical.com>
|
||||
Signed-off-by: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
|
||||
|
||||
--- linux-2.6.39.noarch/drivers/block/xen-blkfront.c~ 2011-08-11 11:54:25.656150889 -0400
|
||||
+++ linux-2.6.39.noarch/drivers/block/xen-blkfront.c 2011-08-11 11:54:54.573046334 -0400
|
||||
@@ -123,8 +123,8 @@ static DEFINE_SPINLOCK(minor_lock);
|
||||
#define BLKIF_MINOR_EXT(dev) ((dev)&(~EXTENDED))
|
||||
#define EMULATED_HD_DISK_MINOR_OFFSET (0)
|
||||
#define EMULATED_HD_DISK_NAME_OFFSET (EMULATED_HD_DISK_MINOR_OFFSET / 256)
|
||||
-#define EMULATED_SD_DISK_MINOR_OFFSET (EMULATED_HD_DISK_MINOR_OFFSET + (4 * 16))
|
||||
-#define EMULATED_SD_DISK_NAME_OFFSET (EMULATED_HD_DISK_NAME_OFFSET + 4)
|
||||
+#define EMULATED_SD_DISK_MINOR_OFFSET (0)
|
||||
+#define EMULATED_SD_DISK_NAME_OFFSET (EMULATED_SD_DISK_MINOR_OFFSET / 256)
|
||||
|
||||
#define DEV_NAME "xvd" /* name in /dev */
|
||||
|
Loading…
Reference in New Issue
Block a user