kernel-5.12.0-0.rc3.20210320git1c273e10bc0c.173
* Sat Mar 20 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.12.0-0.rc3.20210320git1c273e10bc0c.173] - CONFIG_VFIO now selects IOMMU_API instead of depending on it, causing several config mismatches for the zfcpdump kernel (Justin M. Forbes) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
eb496a694b
commit
0a067cf60a
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 172
|
||||
RHEL_RELEASE = 175
|
||||
|
||||
#
|
||||
# Early y+1 numbering
|
||||
|
17
kernel.spec
17
kernel.spec
@ -64,7 +64,7 @@ Summary: The Linux kernel
|
||||
# For a stable, released kernel, released_kernel should be 1.
|
||||
%global released_kernel 0
|
||||
|
||||
%global distro_build 0.rc3.20210319git8b12a62a4e3e.172
|
||||
%global distro_build 0.rc4.175
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -105,13 +105,13 @@ Summary: The Linux kernel
|
||||
%endif
|
||||
|
||||
%define rpmversion 5.12.0
|
||||
%define pkgrelease 0.rc3.20210319git8b12a62a4e3e.172
|
||||
%define pkgrelease 0.rc4.175
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 12
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc3.20210319git8b12a62a4e3e.172%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc4.175%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -201,7 +201,7 @@ Summary: The Linux kernel
|
||||
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
||||
# and 0 for rawhide (all kernels are debug kernels).
|
||||
# See also 'make debug' and 'make release'.
|
||||
%define debugbuildsenabled 0
|
||||
%define debugbuildsenabled 1
|
||||
|
||||
# The kernel tarball/base version
|
||||
%define kversion 5.12
|
||||
@ -602,7 +602,7 @@ BuildRequires: asciidoc
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-20210319git8b12a62a4e3e.tar.xz
|
||||
Source0: linux-5.12-rc4.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -1250,8 +1250,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-20210319git8b12a62a4e3e -c
|
||||
mv linux-20210319git8b12a62a4e3e linux-%{KVERREL}
|
||||
%setup -q -n kernel-5.12-rc4 -c
|
||||
mv linux-5.12-rc4 linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -2764,6 +2764,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Sat Mar 20 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.12.0-0.rc3.20210320git1c273e10bc0c.173]
|
||||
- CONFIG_VFIO now selects IOMMU_API instead of depending on it, causing several config mismatches for the zfcpdump kernel (Justin M. Forbes)
|
||||
|
||||
* Thu Mar 18 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.12.0-0.rc3.20210318git6417f03132a6.171]
|
||||
- Turn off weak-modules for Fedora (Justin M. Forbes)
|
||||
- redhat: enable CONFIG_FW_LOADER_COMPRESS for ARK (Herton R. Krzesinski) [1939095]
|
||||
|
@ -138,7 +138,7 @@ index 000000000000..effb81d04bfd
|
||||
+
|
||||
+endmenu
|
||||
diff --git a/Makefile b/Makefile
|
||||
index a28bb374663d..02c6a9b5180f 100644
|
||||
index d4784d181123..ba1efc2609e3 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -589,7 +589,7 @@ index 467e94259679..9b6f5b8e5397 100644
|
||||
obj-$(CONFIG_EFI_RCI2_TABLE) += rci2-table.o
|
||||
obj-$(CONFIG_EFI_EMBEDDED_FIRMWARE) += embedded-firmware.o
|
||||
diff --git a/drivers/firmware/efi/efi.c b/drivers/firmware/efi/efi.c
|
||||
index df3f9bcab581..8d5b6eb36467 100644
|
||||
index 4b7ee3fa9224..64b31d852d20 100644
|
||||
--- a/drivers/firmware/efi/efi.c
|
||||
+++ b/drivers/firmware/efi/efi.c
|
||||
@@ -31,6 +31,7 @@
|
||||
@ -1452,7 +1452,7 @@ index 63a4f48bdc75..786af4c41caf 100644
|
||||
/* Fusion */
|
||||
{PCI_DEVICE(PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_LSI_PLASMA)},
|
||||
diff --git a/drivers/scsi/mpt3sas/mpt3sas_scsih.c b/drivers/scsi/mpt3sas/mpt3sas_scsih.c
|
||||
index ffca03064797..f6ef73bf2161 100644
|
||||
index 6aa6de729187..10d2ea521280 100644
|
||||
--- a/drivers/scsi/mpt3sas/mpt3sas_scsih.c
|
||||
+++ b/drivers/scsi/mpt3sas/mpt3sas_scsih.c
|
||||
@@ -12309,6 +12309,7 @@ bool scsih_ncq_prio_supp(struct scsi_device *sdev)
|
||||
@ -1587,7 +1587,7 @@ index 7f71218cc1e5..283fc0f41cd2 100644
|
||||
* disconnected while waiting for the lock to succeed. */
|
||||
usb_lock_device(hdev);
|
||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||
index 8710f5710c1d..2203dfb1fb1f 100644
|
||||
index 6b5d36babfcc..fd4a5d66a9d0 100644
|
||||
--- a/include/linux/efi.h
|
||||
+++ b/include/linux/efi.h
|
||||
@@ -43,6 +43,8 @@
|
||||
@ -1599,7 +1599,7 @@ index 8710f5710c1d..2203dfb1fb1f 100644
|
||||
typedef unsigned long efi_status_t;
|
||||
typedef u8 efi_bool_t;
|
||||
typedef u16 efi_char16_t; /* UNICODE character */
|
||||
@@ -780,6 +782,14 @@ extern int __init efi_setup_pcdp_console(char *);
|
||||
@@ -782,6 +784,14 @@ extern int __init efi_setup_pcdp_console(char *);
|
||||
#define EFI_MEM_ATTR 10 /* Did firmware publish an EFI_MEMORY_ATTRIBUTES table? */
|
||||
#define EFI_MEM_NO_SOFT_RESERVE 11 /* Is the kernel configured to ignore soft reservations? */
|
||||
#define EFI_PRESERVE_BS_REGIONS 12 /* Are EFI boot-services memory segments available? */
|
||||
@ -1614,7 +1614,7 @@ index 8710f5710c1d..2203dfb1fb1f 100644
|
||||
|
||||
#ifdef CONFIG_EFI
|
||||
/*
|
||||
@@ -791,6 +801,8 @@ static inline bool efi_enabled(int feature)
|
||||
@@ -793,6 +803,8 @@ static inline bool efi_enabled(int feature)
|
||||
}
|
||||
extern void efi_reboot(enum reboot_mode reboot_mode, const char *__unused);
|
||||
|
||||
@ -1623,7 +1623,7 @@ index 8710f5710c1d..2203dfb1fb1f 100644
|
||||
bool __pure __efi_soft_reserve_enabled(void);
|
||||
|
||||
static inline bool __pure efi_soft_reserve_enabled(void)
|
||||
@@ -811,6 +823,8 @@ static inline bool efi_enabled(int feature)
|
||||
@@ -813,6 +825,8 @@ static inline bool efi_enabled(int feature)
|
||||
static inline void
|
||||
efi_reboot(enum reboot_mode reboot_mode, const char *__unused) {}
|
||||
|
||||
@ -1632,7 +1632,7 @@ index 8710f5710c1d..2203dfb1fb1f 100644
|
||||
static inline bool efi_soft_reserve_enabled(void)
|
||||
{
|
||||
return false;
|
||||
@@ -823,6 +837,7 @@ static inline bool efi_rt_services_supported(unsigned int mask)
|
||||
@@ -825,6 +839,7 @@ static inline bool efi_rt_services_supported(unsigned int mask)
|
||||
#endif
|
||||
|
||||
extern int efi_status_to_err(efi_status_t status);
|
||||
@ -1640,7 +1640,7 @@ index 8710f5710c1d..2203dfb1fb1f 100644
|
||||
|
||||
/*
|
||||
* Variable Attributes
|
||||
@@ -1075,13 +1090,6 @@ static inline bool efi_runtime_disabled(void) { return true; }
|
||||
@@ -1077,13 +1092,6 @@ static inline bool efi_runtime_disabled(void) { return true; }
|
||||
extern void efi_call_virt_check_flags(unsigned long flags, const char *call);
|
||||
extern unsigned long efi_call_virt_save_flags(void);
|
||||
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-20210319git8b12a62a4e3e.tar.xz) = 899482f0398ec21cfef0d0d90f298d2adee972d490ee0826af1579122549fb0b5b63617a43638a3a3991a6ce84c0aebedcfe224c0eb74e7ef33e13d77410cc30
|
||||
SHA512 (kernel-abi-whitelists-5.12.0-0.rc3.20210319git8b12a62a4e3e.172.tar.bz2) = 7b76b2f82f19f070e7deaf025d213e99686f69acc91aadaf91bb9d4b2eca2dcdeb50ebaf1347c5fd6063687e0a4e1410f050d5037cffa0104bc5dd2b7b812b48
|
||||
SHA512 (kernel-kabi-dw-5.12.0-0.rc3.20210319git8b12a62a4e3e.172.tar.bz2) = 190366dbe2789ae8d1b36bac8d32706f4c9048021c4bc767ec69f3d7b7b0fda129982d0056c4b46b0cdc8e32c2d103f4fc949f6f94e6fa3d0d5ad6ad0456c788
|
||||
SHA512 (linux-5.12-rc4.tar.xz) = 5f157a2fd004bdde480499e52d384ff67958dbc4c18863c25e541543661fb6f1238e5e35e45ff59d3d3782900a32bd7de5cbdddb6ca27b40154d2b478a391327
|
||||
SHA512 (kernel-abi-whitelists-5.12.0-0.rc4.175.tar.bz2) = 0dd26906c0b0ea50e3b67e9cb17cbddc00136615928d908cec7e8cc60241fc3af7367089cbaa5f743ace695f1059fbfa0fad4c13a10b1a88733fa245f0adadf2
|
||||
SHA512 (kernel-kabi-dw-5.12.0-0.rc4.175.tar.bz2) = 4345cec974e50905c6586a4ab0d1ef778d272952cd9234f4c83efde9cb6ea0c240dc69cdb6fc884344f06de4cd716809fc777d530584616accab2c3d3f198558
|
||||
|
Loading…
Reference in New Issue
Block a user