Add patch to fix Synaptics touchscreens and HID rmi driver (rhbz 1089583)
This commit is contained in:
parent
86439e5e88
commit
054e8e3755
102
0001-HID-rmi-do-not-handle-touchscreens-through-hid-rmi.patch
Normal file
102
0001-HID-rmi-do-not-handle-touchscreens-through-hid-rmi.patch
Normal file
@ -0,0 +1,102 @@
|
||||
Bugzilla: 1089583
|
||||
Upstream-status: Sent for 3.15
|
||||
|
||||
From 4cebb979af8d7bd1ec463406eaf57a44bd5b9f04 Mon Sep 17 00:00:00 2001
|
||||
From: Benjamin Tissoires <benjamin.tissoires@redhat.com>
|
||||
Date: Tue, 22 Apr 2014 11:21:00 -0400
|
||||
Subject: [PATCH] HID: rmi: do not handle touchscreens through hid-rmi
|
||||
|
||||
Currently, hid-rmi drives every Synaptics product, but the touchscreens
|
||||
on the Windows tablets should be handled through hid-multitouch.
|
||||
|
||||
Instead of providing a long list of PIDs, rely on the scan_report
|
||||
capability to detect which should go to hid-multitouch, and which
|
||||
should not go to hid-rmi.
|
||||
|
||||
We introduce a generic HID_GROUP_HAVE_SPECIAL_DRIVER which can be reused
|
||||
amoung other drivers if they want to have a catch rule but still
|
||||
have multitouch devices handled through hid-multitouch.
|
||||
|
||||
related bug:
|
||||
https://bugzilla.kernel.org/show_bug.cgi?id=74241
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1089583
|
||||
|
||||
Signed-off-by: Benjamin Tissoires <benjamin.tissoires@redhat.com>
|
||||
---
|
||||
drivers/hid/hid-core.c | 10 ++++++++--
|
||||
drivers/hid/hid-rmi.c | 6 ++++--
|
||||
include/linux/hid.h | 13 +++++++++++++
|
||||
3 files changed, 25 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/drivers/hid/hid-core.c b/drivers/hid/hid-core.c
|
||||
index 6ba2fd0..ea18639 100644
|
||||
--- a/drivers/hid/hid-core.c
|
||||
+++ b/drivers/hid/hid-core.c
|
||||
@@ -776,6 +776,14 @@ static int hid_scan_report(struct hid_device *hid)
|
||||
(hid->group == HID_GROUP_MULTITOUCH))
|
||||
hid->group = HID_GROUP_MULTITOUCH_WIN_8;
|
||||
|
||||
+ /*
|
||||
+ * Vendor specific handlings
|
||||
+ */
|
||||
+ if ((hid->vendor == USB_VENDOR_ID_SYNAPTICS) &&
|
||||
+ (hid->group == HID_GROUP_GENERIC))
|
||||
+ /* hid-rmi should take care of them, not hid-generic */
|
||||
+ hid->group = HID_GROUP_HAVE_SPECIAL_DRIVER;
|
||||
+
|
||||
vfree(parser);
|
||||
return 0;
|
||||
}
|
||||
@@ -1840,8 +1848,6 @@ static const struct hid_device_id hid_have_special_driver[] = {
|
||||
{ HID_USB_DEVICE(USB_VENDOR_ID_SONY, USB_DEVICE_ID_SONY_VAIO_VGP_MOUSE) },
|
||||
{ HID_USB_DEVICE(USB_VENDOR_ID_STEELSERIES, USB_DEVICE_ID_STEELSERIES_SRWS1) },
|
||||
{ HID_USB_DEVICE(USB_VENDOR_ID_SUNPLUS, USB_DEVICE_ID_SUNPLUS_WDESKTOP) },
|
||||
- { HID_USB_DEVICE(USB_VENDOR_ID_SYNAPTICS, HID_ANY_ID) },
|
||||
- { HID_I2C_DEVICE(USB_VENDOR_ID_SYNAPTICS, HID_ANY_ID) },
|
||||
{ HID_USB_DEVICE(USB_VENDOR_ID_THINGM, USB_DEVICE_ID_BLINK1) },
|
||||
{ HID_USB_DEVICE(USB_VENDOR_ID_THRUSTMASTER, 0xb300) },
|
||||
{ HID_USB_DEVICE(USB_VENDOR_ID_THRUSTMASTER, 0xb304) },
|
||||
diff --git a/drivers/hid/hid-rmi.c b/drivers/hid/hid-rmi.c
|
||||
index a4f04d4..a97a373 100644
|
||||
--- a/drivers/hid/hid-rmi.c
|
||||
+++ b/drivers/hid/hid-rmi.c
|
||||
@@ -863,8 +863,10 @@ static void rmi_remove(struct hid_device *hdev)
|
||||
}
|
||||
|
||||
static const struct hid_device_id rmi_id[] = {
|
||||
- { HID_I2C_DEVICE(USB_VENDOR_ID_SYNAPTICS, HID_ANY_ID) },
|
||||
- { HID_USB_DEVICE(USB_VENDOR_ID_SYNAPTICS, HID_ANY_ID) },
|
||||
+ { HID_DEVICE(BUS_I2C, HID_GROUP_HAVE_SPECIAL_DRIVER,
|
||||
+ USB_VENDOR_ID_SYNAPTICS, HID_ANY_ID) },
|
||||
+ { HID_DEVICE(BUS_USB, HID_GROUP_HAVE_SPECIAL_DRIVER,
|
||||
+ USB_VENDOR_ID_SYNAPTICS, HID_ANY_ID) },
|
||||
{ }
|
||||
};
|
||||
MODULE_DEVICE_TABLE(hid, rmi_id);
|
||||
diff --git a/include/linux/hid.h b/include/linux/hid.h
|
||||
index 1b5f1e9..2fdd612 100644
|
||||
--- a/include/linux/hid.h
|
||||
+++ b/include/linux/hid.h
|
||||
@@ -299,6 +299,19 @@ struct hid_item {
|
||||
#define HID_GROUP_MULTITOUCH 0x0002
|
||||
#define HID_GROUP_SENSOR_HUB 0x0003
|
||||
#define HID_GROUP_MULTITOUCH_WIN_8 0x0004
|
||||
+#define HID_GROUP_HAVE_SPECIAL_DRIVER 0xffff
|
||||
+/*
|
||||
+ * HID_GROUP_HAVE_SPECIAL_DRIVER should be used when the device needs to be
|
||||
+ * scanned in case it is handled by either hid-multitouch, hid-generic,
|
||||
+ * hid-sensor-hub or any other generic hid driver.
|
||||
+ *
|
||||
+ * Devices declared in hid_have_special_driver[] in hid-core.c can use
|
||||
+ * HID_GROUP_ANY instead because there will be not overlap between their
|
||||
+ * specific driver and a generic one.
|
||||
+ *
|
||||
+ * Note: HID_GROUP_ANY is declared in linux/mod_devicetable.h
|
||||
+ * and has a value of 0x0000
|
||||
+ */
|
||||
|
||||
/*
|
||||
* This is the global environment of the parser. This information is
|
||||
--
|
||||
1.9.0
|
||||
|
14
kernel.spec
14
kernel.spec
@ -626,9 +626,6 @@ Patch22000: weird-root-dentry-name-debug.patch
|
||||
|
||||
Patch25047: drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
||||
|
||||
#rhbz 1048314
|
||||
Patch25048: 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
|
||||
|
||||
#rhbz 1085582 1085697
|
||||
Patch25049: 0001-synaptics-Add-min-max-quirk-for-ThinkPad-T431s-L440-.patch
|
||||
|
||||
@ -638,6 +635,12 @@ Patch25062: gpio-ich-set-regs-and-reglen-for-i3100-and-ich6-chipset.patch
|
||||
#rhbz 1025603
|
||||
Patch25063: disable-libdw-unwind-on-non-x86.patch
|
||||
|
||||
#rhbz 1048314
|
||||
Patch25048: 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
|
||||
|
||||
#rhbz 1089583
|
||||
Patch25064: 0001-HID-rmi-do-not-handle-touchscreens-through-hid-rmi.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -1275,6 +1278,8 @@ ApplyPatch drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
||||
|
||||
#rhbz 1048314
|
||||
ApplyPatch 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
|
||||
#rhbz 1089583
|
||||
ApplyPatch 0001-HID-rmi-do-not-handle-touchscreens-through-hid-rmi.patch
|
||||
|
||||
#rhbz 1085582 1085697
|
||||
ApplyPatch 0001-synaptics-Add-min-max-quirk-for-ThinkPad-T431s-L440-.patch
|
||||
@ -2064,6 +2069,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Tue Apr 22 2014 Josh Boyer <jwboyer@fedoraproject.org>
|
||||
- Add patch to fix Synaptics touchscreens and HID rmi driver (rhbz 1089583)
|
||||
|
||||
* Mon Apr 21 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc2.git0.1
|
||||
- Linux v3.15-rc2
|
||||
- Disable debugging options.
|
||||
|
Loading…
Reference in New Issue
Block a user