Fix esrt build on aarch64
Tested via cross build with: [jwboyer@vader linux]$ aarch64-linux-gnu-gcc --version aarch64-linux-gnu-gcc (GCC) 4.9.1 20140717 (Red Hat Cross 4.9.1-1)
This commit is contained in:
parent
10b2b756c8
commit
02a7d0ba14
@ -28,10 +28,10 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
|||||||
Documentation/ABI/testing/sysfs-firmware-efi-esrt | 81 ++++
|
Documentation/ABI/testing/sysfs-firmware-efi-esrt | 81 ++++
|
||||||
arch/x86/platform/efi/efi.c | 2 +
|
arch/x86/platform/efi/efi.c | 2 +
|
||||||
drivers/firmware/efi/Makefile | 2 +-
|
drivers/firmware/efi/Makefile | 2 +-
|
||||||
drivers/firmware/efi/efi.c | 66 +++-
|
drivers/firmware/efi/efi.c | 66 ++-
|
||||||
drivers/firmware/efi/esrt.c | 461 ++++++++++++++++++++++
|
drivers/firmware/efi/esrt.c | 464 ++++++++++++++++++++++
|
||||||
include/linux/efi.h | 8 +
|
include/linux/efi.h | 8 +
|
||||||
6 files changed, 618 insertions(+), 2 deletions(-)
|
6 files changed, 621 insertions(+), 2 deletions(-)
|
||||||
create mode 100644 Documentation/ABI/testing/sysfs-firmware-efi-esrt
|
create mode 100644 Documentation/ABI/testing/sysfs-firmware-efi-esrt
|
||||||
create mode 100644 drivers/firmware/efi/esrt.c
|
create mode 100644 drivers/firmware/efi/esrt.c
|
||||||
|
|
||||||
@ -248,10 +248,10 @@ index 3061bb8629dc..e54ea20dfb42 100644
|
|||||||
|
|
||||||
diff --git a/drivers/firmware/efi/esrt.c b/drivers/firmware/efi/esrt.c
|
diff --git a/drivers/firmware/efi/esrt.c b/drivers/firmware/efi/esrt.c
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 000000000000..1053b38f7e46
|
index 000000000000..20c0cbdb1c60
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/drivers/firmware/efi/esrt.c
|
+++ b/drivers/firmware/efi/esrt.c
|
||||||
@@ -0,0 +1,461 @@
|
@@ -0,0 +1,464 @@
|
||||||
+/*
|
+/*
|
||||||
+ * esrt.c
|
+ * esrt.c
|
||||||
+ *
|
+ *
|
||||||
@ -278,6 +278,9 @@ index 000000000000..1053b38f7e46
|
|||||||
+#include <linux/slab.h>
|
+#include <linux/slab.h>
|
||||||
+#include <linux/types.h>
|
+#include <linux/types.h>
|
||||||
+
|
+
|
||||||
|
+#include <asm/io.h>
|
||||||
|
+#include <asm/early_ioremap.h>
|
||||||
|
+
|
||||||
+struct efi_system_resource_entry_v1 {
|
+struct efi_system_resource_entry_v1 {
|
||||||
+ efi_guid_t fw_class;
|
+ efi_guid_t fw_class;
|
||||||
+ u32 fw_type;
|
+ u32 fw_type;
|
||||||
|
@ -1427,8 +1427,6 @@ ApplyPatch arm64-revert-tlb-rcu_table_free.patch
|
|||||||
%ifnarch aarch64 # this is stupid, but i want to notice before secondary koji does.
|
%ifnarch aarch64 # this is stupid, but i want to notice before secondary koji does.
|
||||||
ApplyPatch kernel-arm64.patch -R
|
ApplyPatch kernel-arm64.patch -R
|
||||||
ApplyPatch arm64-revert-tlb-rcu_table_free.patch -R
|
ApplyPatch arm64-revert-tlb-rcu_table_free.patch -R
|
||||||
%else
|
|
||||||
ApplyPatch efi-Add-esrt-support.patch -R
|
|
||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -2282,6 +2280,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 13 2015 Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
|
- Fix esrt build on aarch64
|
||||||
|
|
||||||
* Fri Mar 13 2015 Kyle McMartin <kyle@fedoraproject.org>
|
* Fri Mar 13 2015 Kyle McMartin <kyle@fedoraproject.org>
|
||||||
- arm64-revert-tlb-rcu_table_free.patch: revert 5e5f6dc1 which
|
- arm64-revert-tlb-rcu_table_free.patch: revert 5e5f6dc1 which
|
||||||
causes lockups on arm64 machines.
|
causes lockups on arm64 machines.
|
||||||
|
Loading…
Reference in New Issue
Block a user