Update to 1.1.15.
This commit is contained in:
parent
d9fb121198
commit
d24efed392
@ -1 +1 @@
|
|||||||
keepalived-1.1.14.tar.gz
|
keepalived-1.1.15.tar.gz
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
diff -Naupr keepalived-1.1.14.orig/genhash/Makefile.in keepalived-1.1.14/genhash/Makefile.in
|
|
||||||
--- keepalived-1.1.14.orig/genhash/Makefile.in 2007-09-13 16:47:12.000000000 +0200
|
|
||||||
+++ keepalived-1.1.14/genhash/Makefile.in 2007-09-13 18:48:23.000000000 +0200
|
|
||||||
@@ -39,13 +39,13 @@ distclean: clean
|
|
||||||
|
|
||||||
uninstall:
|
|
||||||
rm -f $(DESTDIR)$(bindir)/$(EXEC)
|
|
||||||
- rm -f $(DESTDIR)$(mandir)/man/man1/genhash.1
|
|
||||||
+ rm -f $(DESTDIR)$(mandir)/man1/genhash.1
|
|
||||||
|
|
||||||
install:
|
|
||||||
install -d $(DESTDIR)$(bindir)
|
|
||||||
install -m 755 $(BIN)/$(EXEC) $(DESTDIR)$(bindir)/
|
|
||||||
- install -d $(DESTDIR)$(mandir)/man/man1
|
|
||||||
- install -m 644 ../doc/man/man1/genhash.1 $(DESTDIR)$(mandir)/man/man1
|
|
||||||
+ install -d $(DESTDIR)$(mandir)/man1
|
|
||||||
+ install -m 644 ../doc/man/man1/genhash.1 $(DESTDIR)$(mandir)/man1
|
|
||||||
|
|
||||||
mrproper: clean distclean
|
|
||||||
rm -f config.*
|
|
@ -1,45 +0,0 @@
|
|||||||
diff -Naupr keepalived-1.1.14.orig/lib/parser.c keepalived-1.1.14/lib/parser.c
|
|
||||||
--- keepalived-1.1.14.orig/lib/parser.c 2007-09-13 17:14:16.000000000 +0200
|
|
||||||
+++ keepalived-1.1.14/lib/parser.c 2007-09-14 16:14:26.000000000 +0200
|
|
||||||
@@ -33,6 +33,7 @@
|
|
||||||
|
|
||||||
/* global vars */
|
|
||||||
vector keywords;
|
|
||||||
+vector current_keywords;
|
|
||||||
FILE *current_stream;
|
|
||||||
char *current_conf_file;
|
|
||||||
int reload = 0;
|
|
||||||
@@ -213,7 +214,7 @@ void read_conf_file(char *conf_file)
|
|
||||||
char *confpath = strdup(globbuf.gl_pathv[i]);
|
|
||||||
dirname(confpath);
|
|
||||||
chdir(confpath);
|
|
||||||
- process_stream(keywords);
|
|
||||||
+ process_stream(current_keywords);
|
|
||||||
fclose(stream);
|
|
||||||
|
|
||||||
chdir(prev_path);
|
|
||||||
@@ -388,6 +389,8 @@ process_stream(vector keywords_vec)
|
|
||||||
char *str;
|
|
||||||
char *buf;
|
|
||||||
vector strvec;
|
|
||||||
+ vector prev_keywords = current_keywords;
|
|
||||||
+ current_keywords = keywords_vec;
|
|
||||||
|
|
||||||
buf = zalloc(MAXBUF);
|
|
||||||
while (read_line(buf, MAXBUF)) {
|
|
||||||
@@ -423,6 +426,7 @@ process_stream(vector keywords_vec)
|
|
||||||
free_strvec(strvec);
|
|
||||||
}
|
|
||||||
|
|
||||||
+ current_keywords = prev_keywords;
|
|
||||||
free(buf);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
@@ -442,6 +446,7 @@ init_data(char *conf_file, vector (*init
|
|
||||||
#endif
|
|
||||||
|
|
||||||
/* Stream handling */
|
|
||||||
+ current_keywords = keywords;
|
|
||||||
read_conf_file((conf_file) ? conf_file : CONF);
|
|
||||||
free_keywords(keywords);
|
|
||||||
}
|
|
@ -3,15 +3,13 @@
|
|||||||
|
|
||||||
Summary: HA monitor built upon LVS, VRRP and service pollers
|
Summary: HA monitor built upon LVS, VRRP and service pollers
|
||||||
Name: keepalived
|
Name: keepalived
|
||||||
Version: 1.1.14
|
Version: 1.1.15
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://www.keepalived.org/
|
URL: http://www.keepalived.org/
|
||||||
Source: http://www.keepalived.org/software/keepalived-%{version}.tar.gz
|
Source: http://www.keepalived.org/software/keepalived-%{version}.tar.gz
|
||||||
Patch0: keepalived-1.1.14-genhashman.patch
|
Patch0: keepalived-1.1.14-installmodes.patch
|
||||||
Patch1: keepalived-1.1.14-installmodes.patch
|
|
||||||
Patch2: keepalived-1.1.14-include.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
Requires(post): /sbin/chkconfig
|
Requires(post): /sbin/chkconfig
|
||||||
Requires(preun): /sbin/service, /sbin/chkconfig
|
Requires(preun): /sbin/service, /sbin/chkconfig
|
||||||
@ -39,9 +37,7 @@ healthchecks and LVS directors failover.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .genhashman
|
%patch0 -p1 -b .installmodes
|
||||||
%patch1 -p1 -b .installmodes
|
|
||||||
%patch2 -p1 -b .include
|
|
||||||
# Fix file mode (600 as of 1.1.13)
|
# Fix file mode (600 as of 1.1.13)
|
||||||
%{__chmod} a+r doc/samples/sample.misccheck.smbcheck.sh
|
%{__chmod} a+r doc/samples/sample.misccheck.smbcheck.sh
|
||||||
# Included as doc, so disable its dependencies
|
# Included as doc, so disable its dependencies
|
||||||
@ -104,6 +100,10 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 17 2007 Matthias Saou <http://freshrpms.net/> 1.1.15-1
|
||||||
|
- Update to 1.1.15.
|
||||||
|
- Remove merged genhashman and include patches.
|
||||||
|
|
||||||
* Fri Sep 14 2007 Matthias Saou <http://freshrpms.net/> 1.1.14-2
|
* Fri Sep 14 2007 Matthias Saou <http://freshrpms.net/> 1.1.14-2
|
||||||
- Include patch from Shinji Tanaka to fix conf include from inside some
|
- Include patch from Shinji Tanaka to fix conf include from inside some
|
||||||
directives like vrrp_instance.
|
directives like vrrp_instance.
|
||||||
|
Loading…
Reference in New Issue
Block a user