Update to recent git snapshot

This commit is contained in:
Björn Esser 2020-04-14 21:26:35 +02:00
parent 8cb40082a1
commit b1cb72f38b
3 changed files with 6 additions and 39 deletions

View File

@ -1,34 +0,0 @@
From 053eaa61d7f69dec0b9d744809b189c80583150b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
Date: Tue, 14 Apr 2020 20:42:32 +0200
Subject: [PATCH] Fix CMake tests for enforced strict prototypes.
---
CMakeLists.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 04d21f9..c645d58 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -260,7 +260,7 @@ if (NOT ("${CMAKE_C_COMPILER_ID}" STREQUAL "MSVC"))
/* uClibc toolchains without threading barf when _REENTRANT is defined */
#define _REENTRANT 1
#include <sys/types.h>
- int main ()
+ int main (void)
{
return 0;
}
@@ -276,7 +276,7 @@ if (NOT ("${CMAKE_C_COMPILER_ID}" STREQUAL "MSVC"))
list(APPEND CMAKE_REQUIRED_LIBRARIES "-Wl,-Bsymbolic-functions")
check_c_source_compiles(
[=[
- int main ()
+ int main (void)
{
return 0;
}
--
2.26.0

View File

@ -5,7 +5,7 @@
# Use 'commit' for snapshots and 'tag' for releases.
%global commit ab5425a6a600807d2c17eaa7d1dc7b4093f794aa
%global commit 7fb8d56458b77a6701e8dd5217016cce3d886008
#global tag json-c-0.13.1-20180305
%global forgeurl https://github.com/json-c/json-c
%forgemeta
@ -13,15 +13,13 @@
Name: json-c
Version: 0.13.99
Release: 0.1%{?dist}
Release: 0.2%{?dist}
Summary: JSON implementation in C
License: MIT
URL: %{forgeurl}
Source0: %{forgesource}
Patch0001: 0001-Fix-CMake-tests-for-enforced-strict-prototypes.patch
BuildRequires: cmake
BuildRequires: gcc
BuildRequires: make
@ -118,6 +116,9 @@ popd
%changelog
* Tue Apr 14 2020 Björn Esser <besser82@fedoraproject.org> - 0.13.99-0.2.20200414git7fb8d56
- Update to recent git snapshot
* Tue Apr 14 2020 Björn Esser <besser82@fedoraproject.org> - 0.13.99-0.1.20200414gitab5425a
- Update to recent git snapshot using forge macros

View File

@ -1 +1 @@
SHA512 (json-c-ab5425a6a600807d2c17eaa7d1dc7b4093f794aa.tar.gz) = 435fa8435d2fb5da33f09e5afb55a217d01bbae159b525be636078c20f5a5e714315c40bb820b9eedb4f5777a1b3992bdb8c77ad6a8604419240713a9a8239dd
SHA512 (json-c-7fb8d56458b77a6701e8dd5217016cce3d886008.tar.gz) = 2e7e0d11c6a525b977e427fb40acc5becf01adbcb2cddfefa88c20b909bbf8ac6bf647d2c41398281a261ea9ae973cee58b7f2e44b35286476a33f302e0ec3f6