json-c/0001-Fix-CMake-tests-for-enforced-strict-prototypes.patch
2020-04-14 20:55:18 +02:00

35 lines
925 B
Diff

From 053eaa61d7f69dec0b9d744809b189c80583150b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
Date: Tue, 14 Apr 2020 20:42:32 +0200
Subject: [PATCH] Fix CMake tests for enforced strict prototypes.
---
CMakeLists.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 04d21f9..c645d58 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -260,7 +260,7 @@ if (NOT ("${CMAKE_C_COMPILER_ID}" STREQUAL "MSVC"))
/* uClibc toolchains without threading barf when _REENTRANT is defined */
#define _REENTRANT 1
#include <sys/types.h>
- int main ()
+ int main (void)
{
return 0;
}
@@ -276,7 +276,7 @@ if (NOT ("${CMAKE_C_COMPILER_ID}" STREQUAL "MSVC"))
list(APPEND CMAKE_REQUIRED_LIBRARIES "-Wl,-Bsymbolic-functions")
check_c_source_compiles(
[=[
- int main ()
+ int main (void)
{
return 0;
}
--
2.26.0