Fix generation of JAR manifest
Resolves: rhbz#1472494
This commit is contained in:
parent
288c87db8d
commit
3ea41eb943
@ -1,4 +1,4 @@
|
||||
From 5c381240cdb037e26fd26be5aa0f0d4567f41773 Mon Sep 17 00:00:00 2001
|
||||
From 2f4dd94744a4367b5022837f64b7b113923580e8 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Mon, 10 Jul 2017 11:48:43 +0200
|
||||
Subject: [PATCH 5/5] Fix duplicate manifest entry
|
||||
@ -9,7 +9,7 @@ Resolves https://bugzilla.redhat.com/show_bug.cgi?id=1469022
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/build.xml b/build.xml
|
||||
index 457e0fb..d1f673c 100644
|
||||
index 457e0fb..366cba2 100644
|
||||
--- a/build.xml
|
||||
+++ b/build.xml
|
||||
@@ -541,9 +541,9 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||
@ -17,7 +17,7 @@ index 457e0fb..d1f673c 100644
|
||||
prefix="com/sun/jna/w32ce-arm"/>
|
||||
</jar>
|
||||
- <zip zipfile="${build}/${minjar}">
|
||||
+ <jar zipfile="${build}/${minjar}">
|
||||
+ <jar zipfile="${build}/${minjar}" filesetmanifest="merge">
|
||||
<zipfileset src="${build}/${jar}" excludes="**/*jnidispatch*"/>
|
||||
- </zip>
|
||||
+ </jar>
|
||||
|
6
jna.spec
6
jna.spec
@ -1,6 +1,6 @@
|
||||
Name: jna
|
||||
Version: 4.4.0
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: Pure Java access to native libraries
|
||||
# Most of code is dual-licensed under either LGPL 2.1 only or Apache
|
||||
# License 2.0. WeakIdentityHashMap.java was taken from Apache CXF,
|
||||
@ -126,6 +126,10 @@ install -m 755 build/native*/libjnidispatch*.so %{buildroot}%{_libdir}/%{name}/
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jul 19 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 4.4.0-5
|
||||
- Fix generation of JAR manifest
|
||||
- Resolves: rhbz#1472494
|
||||
|
||||
* Mon Jul 10 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 4.4.0-4
|
||||
- Fix duplicate manifest bug
|
||||
- Resolves: rhbz#1469022
|
||||
|
Loading…
Reference in New Issue
Block a user