Fix duplicate manifest bug
Resolves: rhbz#1469022
This commit is contained in:
parent
e2a30d1571
commit
288c87db8d
@ -1,14 +1,14 @@
|
||||
From c38ff2904958eeae70e3d47b7b2363f9f181013b Mon Sep 17 00:00:00 2001
|
||||
From c72c148b343d0071cb89bb71caa56ce8c73cdd8f Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Mon, 16 Jan 2017 11:29:06 +0100
|
||||
Subject: [PATCH 1/4] Adapt build
|
||||
Subject: [PATCH 1/5] Adapt build
|
||||
|
||||
---
|
||||
native/Makefile | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/native/Makefile b/native/Makefile
|
||||
index fb5ac4b..be1b452 100644
|
||||
index a465660..1325d8c 100644
|
||||
--- a/native/Makefile
|
||||
+++ b/native/Makefile
|
||||
@@ -107,7 +107,7 @@ CDEFINES=-D_REENTRANT
|
||||
@ -20,7 +20,7 @@ index fb5ac4b..be1b452 100644
|
||||
ifeq ($(DYNAMIC_LIBFFI),true)
|
||||
CFLAGS += $(shell pkg-config --cflags libffi 2>/dev/null || echo)
|
||||
LIBS += $(shell pkg-config --libs libffi 2>/dev/null || echo -lffi)
|
||||
@@ -442,7 +442,6 @@ $(BUILD)/$(JNA_JNI_VERSION).stamp:
|
||||
@@ -432,7 +432,6 @@ $(BUILD)/$(JNA_JNI_VERSION).stamp:
|
||||
|
||||
$(LIBRARY): $(JNIDISPATCH_OBJS) $(FFI_LIB)
|
||||
$(LD) $(LDFLAGS) $(JNIDISPATCH_OBJS) $(FFI_LIB) $(LIBS)
|
||||
|
@ -1,17 +1,17 @@
|
||||
From 3f48354a76a0d24fb21e9132482d9ff7af6df8b4 Mon Sep 17 00:00:00 2001
|
||||
From a94220ca2121dc886a2f1f643bc53ac56575701d Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Mon, 16 Jan 2017 11:31:32 +0100
|
||||
Subject: [PATCH 2/4] Load system library
|
||||
Subject: [PATCH 2/5] Load system library
|
||||
|
||||
---
|
||||
src/com/sun/jna/Native.java | 97 ++-------------------------------------------
|
||||
1 file changed, 4 insertions(+), 93 deletions(-)
|
||||
|
||||
diff --git a/src/com/sun/jna/Native.java b/src/com/sun/jna/Native.java
|
||||
index f51a152..b3ddbc3 100644
|
||||
index 274bb78..39c57f4 100644
|
||||
--- a/src/com/sun/jna/Native.java
|
||||
+++ b/src/com/sun/jna/Native.java
|
||||
@@ -788,101 +788,12 @@ public final class Native implements Version {
|
||||
@@ -829,101 +829,12 @@ public final class Native implements Version {
|
||||
|
||||
/**
|
||||
* Loads the JNA stub library.
|
||||
|
@ -1,17 +1,17 @@
|
||||
From 4a4aae7689b217a0057608667eb03d2eea3f3eba Mon Sep 17 00:00:00 2001
|
||||
From 22264992b93d5f0d92cef180fa491311b53dcd19 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Mon, 16 Jan 2017 11:32:32 +0100
|
||||
Subject: [PATCH 3/4] Tests headless
|
||||
Subject: [PATCH 3/5] Tests headless
|
||||
|
||||
---
|
||||
build.xml | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/build.xml b/build.xml
|
||||
index 09aeac2..d9be501 100644
|
||||
index 051bdaa..121d7c8 100644
|
||||
--- a/build.xml
|
||||
+++ b/build.xml
|
||||
@@ -1008,6 +1008,7 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||
@@ -1088,6 +1088,7 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||
<sysproperty key="jna.builddir" file="${build}"/>
|
||||
<sysproperty key="jna.nativedir" file="${build.native}"/>
|
||||
<jvmarg value="${vmopt.arch}"/>
|
||||
|
@ -1,17 +1,17 @@
|
||||
From 5fb86e7e8a37d8215d16480672a39e3ba75bd79d Mon Sep 17 00:00:00 2001
|
||||
From cbcbf6e6e47a1a9b6548314c2981290da4737c9c Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Tue, 31 Jan 2017 14:21:19 +0100
|
||||
Subject: [PATCH 4/4] Fix javadoc build
|
||||
Subject: [PATCH 4/5] Fix javadoc build
|
||||
|
||||
---
|
||||
build.xml | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/build.xml b/build.xml
|
||||
index d9be501..bbb93a3 100644
|
||||
index 121d7c8..457e0fb 100644
|
||||
--- a/build.xml
|
||||
+++ b/build.xml
|
||||
@@ -1113,6 +1113,7 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||
@@ -1193,6 +1193,7 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||
<group title="Platform Specific" packages="com.sun.jna.platform.*"/>
|
||||
|
||||
<arg value="-notimestamp"/>
|
||||
|
29
0005-Fix-duplicate-manifest-entry.patch
Normal file
29
0005-Fix-duplicate-manifest-entry.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From 5c381240cdb037e26fd26be5aa0f0d4567f41773 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Mon, 10 Jul 2017 11:48:43 +0200
|
||||
Subject: [PATCH 5/5] Fix duplicate manifest entry
|
||||
|
||||
Resolves https://bugzilla.redhat.com/show_bug.cgi?id=1469022
|
||||
---
|
||||
build.xml | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/build.xml b/build.xml
|
||||
index 457e0fb..d1f673c 100644
|
||||
--- a/build.xml
|
||||
+++ b/build.xml
|
||||
@@ -541,9 +541,9 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||
includes="*jnidispatch*"
|
||||
prefix="com/sun/jna/w32ce-arm"/>
|
||||
</jar>
|
||||
- <zip zipfile="${build}/${minjar}">
|
||||
+ <jar zipfile="${build}/${minjar}">
|
||||
<zipfileset src="${build}/${jar}" excludes="**/*jnidispatch*"/>
|
||||
- </zip>
|
||||
+ </jar>
|
||||
</target>
|
||||
|
||||
<target name="aar" depends="jar" description="Build Android Archive">
|
||||
--
|
||||
2.9.3
|
||||
|
10
jna.spec
10
jna.spec
@ -1,6 +1,6 @@
|
||||
Name: jna
|
||||
Version: 4.4.0
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: Pure Java access to native libraries
|
||||
# Most of code is dual-licensed under either LGPL 2.1 only or Apache
|
||||
# License 2.0. WeakIdentityHashMap.java was taken from Apache CXF,
|
||||
@ -22,6 +22,9 @@ Patch1: 0002-Load-system-library.patch
|
||||
Patch2: 0003-Tests-headless.patch
|
||||
# Adds --allow-script-in-comments arg to javadoc to avoid error
|
||||
Patch3: 0004-Fix-javadoc-build.patch
|
||||
# Avoid generating duplicate manifest entry
|
||||
# See https://bugzilla.redhat.com/show_bug.cgi?id=1469022
|
||||
Patch4: 0005-Fix-duplicate-manifest-entry.patch
|
||||
|
||||
# We manually require libffi because find-requires doesn't work
|
||||
# inside jars.
|
||||
@ -69,6 +72,7 @@ cp %{SOURCE1} .
|
||||
%patch1 -p1 -b .loadlib
|
||||
%patch2 -p1 -b .tests-headless
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
chmod -Rf a+rX,u+w,g-w,o-w .
|
||||
sed -i 's|@LIBDIR@|%{_libdir}/%{name}|' src/com/sun/jna/Native.java
|
||||
@ -122,6 +126,10 @@ install -m 755 build/native*/libjnidispatch*.so %{buildroot}%{_libdir}/%{name}/
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jul 10 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 4.4.0-4
|
||||
- Fix duplicate manifest bug
|
||||
- Resolves: rhbz#1469022
|
||||
|
||||
* Fri Jul 07 2017 Michael Simacek <msimacek@redhat.com> - 4.4.0-3
|
||||
- Temporarily add symlink to javadir
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user