Initial import (#843404)
This commit is contained in:
parent
2dd4bf2f94
commit
77c7b56310
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
||||
/javaparser-1.0.8-src.zip
|
18
javaparser-1.0.8-remove-wagon-svn.patch
Normal file
18
javaparser-1.0.8-remove-wagon-svn.patch
Normal file
@ -0,0 +1,18 @@
|
||||
--- pom.xml 2010-03-28 22:21:45.000000000 +0200
|
||||
+++ pom.xml-gil 2012-07-26 10:36:23.199603016 +0200
|
||||
@@ -62,13 +62,13 @@
|
||||
<testSourceDirectory>test</testSourceDirectory>
|
||||
<outputDirectory>bin</outputDirectory>
|
||||
<testOutputDirectory>bin</testOutputDirectory>
|
||||
- <extensions>
|
||||
+ <!--extensions>
|
||||
<extension>
|
||||
<groupId>org.jvnet.wagon-svn</groupId>
|
||||
<artifactId>wagon-svn</artifactId>
|
||||
<version>1.9</version>
|
||||
</extension>
|
||||
- </extensions>
|
||||
+ </extensions-->
|
||||
<plugins>
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
112
javaparser-1.0.8.pom
Normal file
112
javaparser-1.0.8.pom
Normal file
@ -0,0 +1,112 @@
|
||||
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
|
||||
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
<groupId>com.google.code.javaparser</groupId>
|
||||
<artifactId>javaparser</artifactId>
|
||||
<packaging>jar</packaging>
|
||||
<name>Java 1.5 Parser and AST</name>
|
||||
<version>1.0.8</version>
|
||||
<description>A Java 1.5 Parser with AST generation and visitor support. The AST records the source code structure, javadoc and comments. It is also possible to change the AST nodes or create new ones to modify the source code.</description>
|
||||
<url>http://code.google.com/p/javaparser/</url>
|
||||
<issueManagement>
|
||||
<system>Google Code</system>
|
||||
<url>http://code.google.com/p/javaparser/issues/</url>
|
||||
</issueManagement>
|
||||
<licenses>
|
||||
<license>
|
||||
<name>GNU Lesser General Public License</name>
|
||||
<url>http://www.gnu.org/licenses/lgpl.html</url>
|
||||
<distribution>repo</distribution>
|
||||
</license>
|
||||
</licenses>
|
||||
<scm>
|
||||
<url>http://code.google.com/p/javaparser/source/browse/</url>
|
||||
<connection>http://javaparser.googlecode.com/svn/trunk/</connection>
|
||||
</scm>
|
||||
<inceptionYear>2007</inceptionYear>
|
||||
<developers>
|
||||
<developer>
|
||||
<name>Júlio Vilmar Gesser</name>
|
||||
<email>jgesser@gmail.com</email>
|
||||
</developer>
|
||||
</developers>
|
||||
<contributors>
|
||||
<contributor>
|
||||
<name>Hendy Irawan</name>
|
||||
<email>hendy@soluvas.com</email>
|
||||
<url>http://www.HendyIrawan.com/</url>
|
||||
<organization>Soluvas</organization>
|
||||
<organizationUrl>http://www.Soluvas.com/</organizationUrl>
|
||||
</contributor>
|
||||
</contributors>
|
||||
<distributionManagement>
|
||||
<site>
|
||||
<id>javaparser-site</id>
|
||||
<name>JavaParser</name>
|
||||
<url>http://code.google.com/p/javaparser</url>
|
||||
</site>
|
||||
<downloadUrl>http://code.google.com/p/javaparser/downloads/</downloadUrl>
|
||||
<repository>
|
||||
<id>javaparser-release</id>
|
||||
<name>JavaParser Maven Releases Repository</name>
|
||||
<url>svn:https://javaparser.googlecode.com/svn/maven2</url>
|
||||
</repository>
|
||||
<snapshotRepository>
|
||||
<id>javaparser-snapshots</id>
|
||||
<name>JavaParser Maven Snapshots Repository</name>
|
||||
<url>svn:https://javaparser.googlecode.com/svn/maven2-snapshots</url>
|
||||
</snapshotRepository>
|
||||
</distributionManagement>
|
||||
<build>
|
||||
<sourceDirectory>src</sourceDirectory>
|
||||
<testSourceDirectory>test</testSourceDirectory>
|
||||
<outputDirectory>bin</outputDirectory>
|
||||
<testOutputDirectory>bin</testOutputDirectory>
|
||||
<extensions>
|
||||
<extension>
|
||||
<groupId>org.jvnet.wagon-svn</groupId>
|
||||
<artifactId>wagon-svn</artifactId>
|
||||
<version>1.9</version>
|
||||
</extension>
|
||||
</extensions>
|
||||
<plugins>
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-compiler-plugin</artifactId>
|
||||
<configuration>
|
||||
<source>1.5</source>
|
||||
<target>1.5</target>
|
||||
</configuration>
|
||||
</plugin>
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-surefire-plugin</artifactId>
|
||||
<configuration>
|
||||
<excludes>
|
||||
<exclude>ignore/**</exclude>
|
||||
<exclude>**/*$*</exclude>
|
||||
</excludes>
|
||||
</configuration>
|
||||
</plugin>
|
||||
</plugins>
|
||||
<resources>
|
||||
</resources>
|
||||
</build>
|
||||
<dependencies>
|
||||
<dependency>
|
||||
<groupId>junit</groupId>
|
||||
<artifactId>junit</artifactId>
|
||||
<version>4.8.1</version>
|
||||
<scope>test</scope>
|
||||
</dependency>
|
||||
</dependencies>
|
||||
<repositories>
|
||||
<repository>
|
||||
<id>java.net.m2</id>
|
||||
<url>http://download.java.net/maven/2</url>
|
||||
<snapshots>
|
||||
<enabled>false</enabled>
|
||||
</snapshots>
|
||||
</repository>
|
||||
</repositories>
|
||||
</project>
|
100
javaparser.spec
Normal file
100
javaparser.spec
Normal file
@ -0,0 +1,100 @@
|
||||
Name: javaparser
|
||||
Version: 1.0.8
|
||||
Release: 1%{?dist}
|
||||
Summary: Java 1.5 Parser and AST
|
||||
Group: Development/Libraries
|
||||
License: GPLv3+ and LGPLv3+
|
||||
URL: http://code.google.com/p/javaparser/
|
||||
Source0: http://javaparser.googlecode.com/files/%{name}-%{version}-src.zip
|
||||
Source1: http://%{name}.googlecode.com/svn/maven2/com/google/code/%{name}/%{name}/%{version}/%{name}-%{version}.pom
|
||||
# remove org.jvnet.wagon-svn wagon-svn 1.9
|
||||
Patch0: %{name}-%{version}-remove-wagon-svn.patch
|
||||
|
||||
BuildRequires: java-devel
|
||||
BuildRequires: jpackage-utils
|
||||
|
||||
# test deps
|
||||
BuildRequires: junit
|
||||
|
||||
BuildRequires: javacc
|
||||
BuildRequires: maven
|
||||
BuildRequires: maven-compiler-plugin
|
||||
BuildRequires: maven-install-plugin
|
||||
BuildRequires: maven-jar-plugin
|
||||
BuildRequires: maven-javadoc-plugin
|
||||
BuildRequires: maven-resources-plugin
|
||||
BuildRequires: maven-surefire-plugin
|
||||
# BuildRequires: maven-surefire-provider-junit4
|
||||
BuildRequires: sonatype-oss-parent
|
||||
|
||||
Requires: java
|
||||
Requires: jpackage-utils
|
||||
BuildArch: noarch
|
||||
|
||||
%description
|
||||
A Java 1.5 Parser with AST generation and visitor support.
|
||||
The AST records the source code structure, java doc and
|
||||
comments. It is also possible to change the AST nodes or
|
||||
create new ones to modify the source code.
|
||||
|
||||
%package javadoc
|
||||
Group: Documentation
|
||||
Summary: Javadoc for %{name}
|
||||
Requires: jpackage-utils
|
||||
|
||||
%description javadoc
|
||||
This package contains javadoc for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -c
|
||||
|
||||
cp -p %{SOURCE1} pom.xml
|
||||
%patch0 -p0
|
||||
|
||||
for s in $(find . -name "*.java");do
|
||||
native2ascii -encoding UTF8 ${s} ${s}
|
||||
done
|
||||
|
||||
for d in COPYING readme.txt ; do
|
||||
iconv -f iso8859-1 -t utf-8 $d > $d.conv && mv -f $d.conv $d
|
||||
sed -i 's/\r//' $d
|
||||
done
|
||||
|
||||
sed -i 's/\r//' COPYING.LESSER
|
||||
|
||||
%build
|
||||
|
||||
(
|
||||
cd src/japa/parser
|
||||
rm JavaCharStream.java ParseException.java Token.java TokenMgrError.java
|
||||
javacc.sh java_1_5.jj
|
||||
)
|
||||
|
||||
# test skip http://code.google.com/p/javaparser/issues/detail?id=43
|
||||
mvn-rpmbuild -Dproject.build.sourceEncoding=UTF-8 -Dmaven.test.skip=true install javadoc:aggregate
|
||||
|
||||
%install
|
||||
|
||||
mkdir -p %{buildroot}%{_javadir}
|
||||
install -m 644 target/%{name}-%{version}.jar %{buildroot}%{_javadir}/%{name}.jar
|
||||
|
||||
mkdir -p %{buildroot}%{_mavenpomdir}
|
||||
install -pm 644 pom.xml %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
|
||||
%add_maven_depmap JPP-%{name}.pom %{name}.jar
|
||||
|
||||
mkdir -p %{buildroot}%{_javadocdir}/%{name}
|
||||
cp -pr target/site/apidocs/* %{buildroot}%{_javadocdir}/%{name}
|
||||
|
||||
%files
|
||||
%{_javadir}/%{name}.jar
|
||||
%{_mavenpomdir}/JPP-%{name}.pom
|
||||
%{_mavendepmapfragdir}/%{name}
|
||||
%doc COPYING COPYING.LESSER readme.txt
|
||||
|
||||
%files javadoc
|
||||
%{_javadocdir}/%{name}
|
||||
%doc COPYING COPYING.LESSER readme.txt
|
||||
|
||||
%changelog
|
||||
* Thu Jul 26 2012 gil cattaneo <puntogil@libero.it> 1.0.8-1
|
||||
- initial rpm
|
Loading…
Reference in New Issue
Block a user