diff --git a/.gitignore b/.gitignore
index e69de29..e824af2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -0,0 +1 @@
+/javaparser-1.0.8-src.zip
diff --git a/javaparser-1.0.8-remove-wagon-svn.patch b/javaparser-1.0.8-remove-wagon-svn.patch
new file mode 100644
index 0000000..634493d
--- /dev/null
+++ b/javaparser-1.0.8-remove-wagon-svn.patch
@@ -0,0 +1,18 @@
+--- pom.xml 2010-03-28 22:21:45.000000000 +0200
++++ pom.xml-gil 2012-07-26 10:36:23.199603016 +0200
+@@ -62,13 +62,13 @@
+ test
+ bin
+ bin
+-
++
+
+
+ org.apache.maven.plugins
diff --git a/javaparser-1.0.8.pom b/javaparser-1.0.8.pom
new file mode 100644
index 0000000..601e713
--- /dev/null
+++ b/javaparser-1.0.8.pom
@@ -0,0 +1,112 @@
+
+ 4.0.0
+ com.google.code.javaparser
+ javaparser
+ jar
+ Java 1.5 Parser and AST
+ 1.0.8
+ A Java 1.5 Parser with AST generation and visitor support. The AST records the source code structure, javadoc and comments. It is also possible to change the AST nodes or create new ones to modify the source code.
+ http://code.google.com/p/javaparser/
+
+ Google Code
+ http://code.google.com/p/javaparser/issues/
+
+
+
+ GNU Lesser General Public License
+ http://www.gnu.org/licenses/lgpl.html
+ repo
+
+
+
+ http://code.google.com/p/javaparser/source/browse/
+ http://javaparser.googlecode.com/svn/trunk/
+
+ 2007
+
+
+ JĂșlio Vilmar Gesser
+ jgesser@gmail.com
+
+
+
+
+ Hendy Irawan
+ hendy@soluvas.com
+ http://www.HendyIrawan.com/
+ Soluvas
+ http://www.Soluvas.com/
+
+
+
+
+ javaparser-site
+ JavaParser
+ http://code.google.com/p/javaparser
+
+ http://code.google.com/p/javaparser/downloads/
+
+ javaparser-release
+ JavaParser Maven Releases Repository
+ svn:https://javaparser.googlecode.com/svn/maven2
+
+
+ javaparser-snapshots
+ JavaParser Maven Snapshots Repository
+ svn:https://javaparser.googlecode.com/svn/maven2-snapshots
+
+
+
+ src
+ test
+ bin
+ bin
+
+
+ org.jvnet.wagon-svn
+ wagon-svn
+ 1.9
+
+
+
+
+ org.apache.maven.plugins
+ maven-compiler-plugin
+
+ 1.5
+ 1.5
+
+
+
+ org.apache.maven.plugins
+ maven-surefire-plugin
+
+
+ ignore/**
+ **/*$*
+
+
+
+
+
+
+
+
+
+ junit
+ junit
+ 4.8.1
+ test
+
+
+
+
+ java.net.m2
+ http://download.java.net/maven/2
+
+ false
+
+
+
+
\ No newline at end of file
diff --git a/javaparser.spec b/javaparser.spec
new file mode 100644
index 0000000..970a91d
--- /dev/null
+++ b/javaparser.spec
@@ -0,0 +1,100 @@
+Name: javaparser
+Version: 1.0.8
+Release: 1%{?dist}
+Summary: Java 1.5 Parser and AST
+Group: Development/Libraries
+License: GPLv3+ and LGPLv3+
+URL: http://code.google.com/p/javaparser/
+Source0: http://javaparser.googlecode.com/files/%{name}-%{version}-src.zip
+Source1: http://%{name}.googlecode.com/svn/maven2/com/google/code/%{name}/%{name}/%{version}/%{name}-%{version}.pom
+# remove org.jvnet.wagon-svn wagon-svn 1.9
+Patch0: %{name}-%{version}-remove-wagon-svn.patch
+
+BuildRequires: java-devel
+BuildRequires: jpackage-utils
+
+# test deps
+BuildRequires: junit
+
+BuildRequires: javacc
+BuildRequires: maven
+BuildRequires: maven-compiler-plugin
+BuildRequires: maven-install-plugin
+BuildRequires: maven-jar-plugin
+BuildRequires: maven-javadoc-plugin
+BuildRequires: maven-resources-plugin
+BuildRequires: maven-surefire-plugin
+# BuildRequires: maven-surefire-provider-junit4
+BuildRequires: sonatype-oss-parent
+
+Requires: java
+Requires: jpackage-utils
+BuildArch: noarch
+
+%description
+A Java 1.5 Parser with AST generation and visitor support.
+The AST records the source code structure, java doc and
+comments. It is also possible to change the AST nodes or
+create new ones to modify the source code.
+
+%package javadoc
+Group: Documentation
+Summary: Javadoc for %{name}
+Requires: jpackage-utils
+
+%description javadoc
+This package contains javadoc for %{name}.
+
+%prep
+%setup -q -c
+
+cp -p %{SOURCE1} pom.xml
+%patch0 -p0
+
+for s in $(find . -name "*.java");do
+ native2ascii -encoding UTF8 ${s} ${s}
+done
+
+for d in COPYING readme.txt ; do
+ iconv -f iso8859-1 -t utf-8 $d > $d.conv && mv -f $d.conv $d
+ sed -i 's/\r//' $d
+done
+
+sed -i 's/\r//' COPYING.LESSER
+
+%build
+
+(
+ cd src/japa/parser
+ rm JavaCharStream.java ParseException.java Token.java TokenMgrError.java
+ javacc.sh java_1_5.jj
+)
+
+# test skip http://code.google.com/p/javaparser/issues/detail?id=43
+mvn-rpmbuild -Dproject.build.sourceEncoding=UTF-8 -Dmaven.test.skip=true install javadoc:aggregate
+
+%install
+
+mkdir -p %{buildroot}%{_javadir}
+install -m 644 target/%{name}-%{version}.jar %{buildroot}%{_javadir}/%{name}.jar
+
+mkdir -p %{buildroot}%{_mavenpomdir}
+install -pm 644 pom.xml %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
+%add_maven_depmap JPP-%{name}.pom %{name}.jar
+
+mkdir -p %{buildroot}%{_javadocdir}/%{name}
+cp -pr target/site/apidocs/* %{buildroot}%{_javadocdir}/%{name}
+
+%files
+%{_javadir}/%{name}.jar
+%{_mavenpomdir}/JPP-%{name}.pom
+%{_mavendepmapfragdir}/%{name}
+%doc COPYING COPYING.LESSER readme.txt
+
+%files javadoc
+%{_javadocdir}/%{name}
+%doc COPYING COPYING.LESSER readme.txt
+
+%changelog
+* Thu Jul 26 2012 gil cattaneo 1.0.8-1
+- initial rpm
\ No newline at end of file
diff --git a/sources b/sources
index e69de29..565508d 100644
--- a/sources
+++ b/sources
@@ -0,0 +1 @@
+84b3df6e8cf6331e6d3f7eaebbd70140 javaparser-1.0.8-src.zip