996271ca29
Update release notes to 17.0.7.0+7 Require tzdata 2023c due to local inclusion of JDK-8274864 & JDK-8305113 Update generate_tarball.sh to add support for passing a boot JDK to the configure run Add POSIX-friendly error codes to generate_tarball.sh and fix whitespace Remove .jcheck and GitHub support when generating tarballs, as done in upstream release tarballs Update FIPS support against 17.0.7+6 and bring in latest changes: - * RH2134669: Add missing attributes when registering services in FIPS mode. - * test/jdk/sun/security/pkcs11/fips/VerifyMissingAttributes.java: fixed jtreg main class - * RH1940064: Enable XML Signature provider in FIPS mode - * RH2173781: Avoid calling C_GetInfo() too early, before cryptoki is initialized Fix trailing '.' in tarball name Use portablerelease in vendor version to avoid inclusion of dist tag Replace local copies of JDK portable binaries with build dependencies Include the java-17-openjdk-portable.spec file with instructions on how to rebuild. ** This tarball is embargoed until 2023-04-18 @ 1pm PT. ** Resolves: rhbz#2185182 Resolves: rhbz#2189326 Resolves: rhbz#2186803 Resolves: rhbz#2186810 Resolves: rhbz#2186806
54 lines
2.8 KiB
Diff
54 lines
2.8 KiB
Diff
commit 1b3825db8631e55771fb723d4fcd10040ea15b7e
|
|
Author: duke <duke@openjdk.org>
|
|
Date: Wed Apr 12 17:25:27 2023 +0000
|
|
|
|
Backport ec199072c5867624d66840238cc8828e16ae8da7
|
|
|
|
diff --git a/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java b/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java
|
|
index 6f6e190efcd..ef278203182 100644
|
|
--- a/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java
|
|
+++ b/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java
|
|
@@ -608,34 +608,6 @@ public final class ZoneInfoFile {
|
|
params[8] = endRule.secondOfDay * 1000;
|
|
params[9] = toSTZTime[endRule.timeDefinition];
|
|
dstSavings = (startRule.offsetAfter - startRule.offsetBefore) * 1000;
|
|
-
|
|
- // Note: known mismatching -> Asia/Amman
|
|
- // ZoneInfo : startDayOfWeek=5 <= Thursday
|
|
- // startTime=86400000 <= 24 hours
|
|
- // This: startDayOfWeek=6
|
|
- // startTime=0
|
|
- // Similar workaround needs to be applied to Africa/Cairo and
|
|
- // its endDayOfWeek and endTime
|
|
- // Below is the workarounds, it probably slows down everyone a little
|
|
- if (params[2] == 6 && params[3] == 0 &&
|
|
- (zoneId.equals("Asia/Amman"))) {
|
|
- params[2] = 5;
|
|
- params[3] = 86400000;
|
|
- }
|
|
- // Additional check for startDayOfWeek=6 and starTime=86400000
|
|
- // is needed for Asia/Amman;
|
|
- if (params[2] == 7 && params[3] == 0 &&
|
|
- (zoneId.equals("Asia/Amman"))) {
|
|
- params[2] = 6; // Friday
|
|
- params[3] = 86400000; // 24h
|
|
- }
|
|
- //endDayOfWeek and endTime workaround
|
|
- if (params[7] == 6 && params[8] == 0 &&
|
|
- (zoneId.equals("Africa/Cairo"))) {
|
|
- params[7] = 5;
|
|
- params[8] = 86400000;
|
|
- }
|
|
-
|
|
} else if (nTrans > 0) { // only do this if there is something in table already
|
|
if (lastyear < LASTYEAR) {
|
|
// ZoneInfo has an ending entry for 2037
|
|
@@ -908,7 +880,6 @@ public final class ZoneInfoFile {
|
|
this.dow = dowByte == 0 ? -1 : dowByte;
|
|
this.secondOfDay = timeByte == 31 ? in.readInt() : timeByte * 3600;
|
|
this.timeDefinition = (data & (3 << 12)) >>> 12;
|
|
-
|
|
this.standardOffset = stdByte == 255 ? in.readInt() : (stdByte - 128) * 900;
|
|
this.offsetBefore = beforeByte == 3 ? in.readInt() : standardOffset + beforeByte * 1800;
|
|
this.offsetAfter = afterByte == 3 ? in.readInt() : standardOffset + afterByte * 1800;
|