Update to jdk-17.0.7.0+7

Update release notes to 17.0.7.0+7
Require tzdata 2023c due to local inclusion of JDK-8274864 & JDK-8305113
Update generate_tarball.sh to add support for passing a boot JDK to the configure run
Add POSIX-friendly error codes to generate_tarball.sh and fix whitespace
Remove .jcheck and GitHub support when generating tarballs, as done in upstream release tarballs
Update FIPS support against 17.0.7+6 and bring in latest changes:
- * RH2134669: Add missing attributes when registering services in FIPS mode.
- * test/jdk/sun/security/pkcs11/fips/VerifyMissingAttributes.java: fixed jtreg main class
- * RH1940064: Enable XML Signature provider in FIPS mode
- * RH2173781: Avoid calling C_GetInfo() too early, before cryptoki is initialized
Fix trailing '.' in tarball name
Use portablerelease in vendor version to avoid inclusion of dist tag
Replace local copies of JDK portable binaries with build dependencies
Include the java-17-openjdk-portable.spec file with instructions on how to rebuild.

** This tarball is embargoed until 2023-04-18 @ 1pm PT. **

Resolves: rhbz#2185182
Resolves: rhbz#2189326
Resolves: rhbz#2186803
Resolves: rhbz#2186810
Resolves: rhbz#2186806
This commit is contained in:
Andrew Hughes 2023-04-27 18:55:51 +01:00
parent b0792766eb
commit 996271ca29
9 changed files with 4754 additions and 295 deletions

1
.gitignore vendored
View File

@ -53,3 +53,4 @@
/java-17-openjdk-17.0.6.0.10-6.portable.unstripped.jdk.el.ppc64le.tar.xz
/java-17-openjdk-17.0.6.0.10-6.portable.unstripped.jdk.el.s390x.tar.xz
/java-17-openjdk-17.0.6.0.10-6.portable.unstripped.jdk.el.x86_64.tar.xz
/openjdk-jdk17u-jdk-17.0.7+7.tar.xz

View File

@ -9,3 +9,33 @@ release page for OpenJDK 17 and the preceding interim releases:
* 15: https://openjdk.java.net/projects/jdk/15/
* 16: https://openjdk.java.net/projects/jdk/16/
* 17: https://openjdk.java.net/projects/jdk/17/
# Rebuilding the OpenJDK package
The OpenJDK packages are now created from a single build which is then
packaged for different major versions of Red Hat Enterprise Linux
(RHEL). This allows the OpenJDK team to focus their efforts on the
development and testing of this single build, rather than having
multiple builds which only differ by the platform they were built on.
This does make rebuilding the package slightly more complicated than a
normal package. Modifications should be made to the
`java-17-openjdk-portable.specfile` file, which can be found with this
README file in the source RPM or installed in the documentation tree
by the `java-17-openjdk-headless` RPM.
Once the modified `java-17-openjdk-portable` RPMs are built, they
should be installed and will produce a number of tarballs in the
`/usr/lib/jvm` directory. The `java-17-openjdk` RPMs can then be
built, which will use these tarballs to create the usual RPMs found in
RHEL. The `java-17-openjdk-portable` RPMs can be uninstalled once the
desired final RPMs are produced.
Note that the `java-17-openjdk.spec` file has a hard requirement on
the exact version of java-17-openjdk-portable to use, so this will
need to be modified if the version or rpmrelease values are changed in
`java-17-openjdk-portable.specfile`.
To reduce the number of RPMs involved, the `fastdebug` and `slowdebug`
builds may be disabled using `--without fastdebug` and `--without
slowdebug`.

File diff suppressed because it is too large Load Diff

View File

@ -17,7 +17,7 @@
# PROJECT_NAME=release
# OPENJDK_URL=http://icedtea.classpath.org/hg/
# TO_COMPRESS="*/tapset"
#
#
# They are used to create correct name and are used in construction of sources url (unless REPO_ROOT is set)
# This script creates a single source tarball out of the repository
@ -50,26 +50,55 @@ if [ "x$1" = "xhelp" ] ; then
echo "FILE_NAME_ROOT - name of the archive, minus extensions (optional; defaults to PROJECT_NAME-REPO_NAME-VERSION)"
echo "TO_COMPRESS - what part of clone to pack (default is openjdk)"
echo "PR3823 - the path to the PR3823 patch to apply (optional; downloaded if unavailable)"
echo "BOOT_JDK - the bootstrap JDK to satisfy the configure run"
exit 1;
fi
if [ "x$VERSION" = "x" ] ; then
echo "No VERSION specified"
exit -2
exit 2
fi
echo "Version: ${VERSION}"
NUM_VER=${VERSION##jdk-}
RELEASE_VER=${NUM_VER%%+*}
BUILD_VER=${NUM_VER##*+}
MAJOR_VER=${RELEASE_VER%%.*}
echo "Major version is ${MAJOR_VER}, release ${RELEASE_VER}, build ${BUILD_VER}"
if [ "x$BOOT_JDK" = "x" ] ; then
echo "No boot JDK specified".
BOOT_JDK=/usr/lib/jvm/java-${MAJOR_VER}-openjdk;
echo -n "Checking for ${BOOT_JDK}...";
if [ -d ${BOOT_JDK} -a -x ${BOOT_JDK}/bin/java ] ; then
echo "Boot JDK found at ${BOOT_JDK}";
else
echo "Not found";
PREV_VER=$((${MAJOR_VER} - 1));
BOOT_JDK=/usr/lib/jvm/java-${PREV_VER}-openjdk;
echo -n "Checking for ${BOOT_JDK}...";
if [ -d ${BOOT_JDK} -a -x ${BOOT_JDK}/bin/java ] ; then
echo "Boot JDK found at ${BOOT_JDK}";
else
echo "Not found";
exit 4;
fi
fi
else
echo "Boot JDK: ${BOOT_JDK}";
fi
# REPO_NAME is only needed when we default on REPO_ROOT and FILE_NAME_ROOT
if [ "x$FILE_NAME_ROOT" = "x" -o "x$REPO_ROOT" = "x" ] ; then
if [ "x$PROJECT_NAME" = "x" ] ; then
echo "No PROJECT_NAME specified"
exit -1
exit 1
fi
echo "Project name: ${PROJECT_NAME}"
if [ "x$REPO_NAME" = "x" ] ; then
echo "No REPO_NAME specified"
exit -3
exit 3
fi
echo "Repository name: ${REPO_NAME}"
fi
@ -98,7 +127,7 @@ fi;
if [ "x$TO_COMPRESS" = "x" ] ; then
TO_COMPRESS="openjdk"
echo "No to be compressed targets specified, ; default to ${TO_COMPRESS}"
echo "No targets to be compressed specified, ; default to ${TO_COMPRESS}"
fi;
if [ -d ${FILE_NAME_ROOT} ] ; then
@ -113,31 +142,31 @@ else
popd
fi
pushd "${FILE_NAME_ROOT}"
if [ -d openjdk/src ]; then
if [ -d openjdk/src ]; then
pushd openjdk
echo "Removing EC source code we don't build"
CRYPTO_PATH=src/jdk.crypto.ec/share/native/libsunec/impl
rm -vf ${CRYPTO_PATH}/ec2.h
rm -vf ${CRYPTO_PATH}/ec2_163.c
rm -vf ${CRYPTO_PATH}/ec2_193.c
rm -vf ${CRYPTO_PATH}/ec2_233.c
rm -vf ${CRYPTO_PATH}/ec2_aff.c
rm -vf ${CRYPTO_PATH}/ec2_mont.c
rm -vf ${CRYPTO_PATH}/ecp_192.c
rm -vf ${CRYPTO_PATH}/ecp_224.c
rm -vf ${CRYPTO_PATH}/ec2.h
rm -vf ${CRYPTO_PATH}/ec2_163.c
rm -vf ${CRYPTO_PATH}/ec2_193.c
rm -vf ${CRYPTO_PATH}/ec2_233.c
rm -vf ${CRYPTO_PATH}/ec2_aff.c
rm -vf ${CRYPTO_PATH}/ec2_mont.c
rm -vf ${CRYPTO_PATH}/ecp_192.c
rm -vf ${CRYPTO_PATH}/ecp_224.c
echo "Syncing EC list with NSS"
if [ "x$PR3823" = "x" ] ; then
# get PR3823.patch (from https://github.com/icedtea-git/icedtea) in the ${ICEDTEA_VERSION} branch
# Do not push it or publish it
echo "PR3823 not found. Downloading..."
wget -v https://github.com/icedtea-git/icedtea/raw/${ICEDTEA_VERSION}/patches/pr3823.patch
echo "Applying ${PWD}/pr3823.patch"
patch -Np1 < pr3823.patch
rm pr3823.patch
else
echo "Applying ${PR3823}"
patch -Np1 < $PR3823
echo "PR3823 not found. Downloading..."
wget -v https://github.com/icedtea-git/icedtea/raw/${ICEDTEA_VERSION}/patches/pr3823.patch
echo "Applying ${PWD}/pr3823.patch"
patch -Np1 < pr3823.patch
rm pr3823.patch
else
echo "Applying ${PR3823}"
patch -Np1 < $PR3823
fi;
find . -name '*.orig' -exec rm -vf '{}' ';'
popd
@ -146,11 +175,29 @@ pushd "${FILE_NAME_ROOT}"
# Generate .src-rev so build has knowledge of the revision the tarball was created from
mkdir build
pushd build
sh ${PWD}/../openjdk/configure
sh ${PWD}/../openjdk/configure --with-boot-jdk=${BOOT_JDK}
make store-source-revision
popd
rm -rf build
# Remove commit checks
echo "Removing $(find openjdk -name '.jcheck' -print)"
find openjdk -name '.jcheck' -print0 | xargs -0 rm -r
# Remove history and GHA
echo "find openjdk -name '.hgtags'"
find openjdk -name '.hgtags' -exec rm -v '{}' '+'
echo "find openjdk -name '.hgignore'"
find openjdk -name '.hgignore' -exec rm -v '{}' '+'
echo "find openjdk -name '.gitattributes'"
find openjdk -name '.gitattributes' -exec rm -v '{}' '+'
echo "find openjdk -name '.gitignore'"
find openjdk -name '.gitignore' -exec rm -v '{}' '+'
echo "find openjdk -name '.git'"
find openjdk -name '.git' -exec rm -rv '{}' '+'
echo "find openjdk -name '.github'"
find openjdk -name '.github' -exec rm -rv '{}' '+'
echo "Compressing remaining forest"
if [ "X$COMPRESSION" = "Xxz" ] ; then
SWITCH=cJf

File diff suppressed because it is too large Load Diff

View File

@ -313,7 +313,7 @@
# New Version-String scheme-style defines
%global featurever 17
%global interimver 0
%global updatever 6
%global updatever 7
%global patchver 0
# buildjdkver is usually same as %%{featurever},
# but in time of bootstrap of next jdk, it is featurever-1,
@ -348,23 +348,23 @@
%endif
%endif
%endif
%global oj_vendor_version (Red_Hat-%{version}-%{release})
%global oj_vendor_version (Red_Hat-%{version}-%{portablerelease})
# Define IcedTea version used for SystemTap tapsets and desktop file
%global icedteaver 6.0.0pre00-c848b93a8598
# Define current Git revision for the FIPS support patches
%global fipsver 257d544b594
%global fipsver bf363eecce3
# Standard JPackage naming and versioning defines
%global origin openjdk
%global origin_nice OpenJDK
%global top_level_dir_name %{origin}
%global top_level_dir_name_backup %{top_level_dir_name}-backup
%global buildver 10
%global rpmrelease 4
%global buildver 7
%global rpmrelease 3
# Settings used by the portable build
%global portablerelease 6
%global portablesuffix el7openjdkportable
%global portablerelease 2
%global portablesuffix el8
%global portablebuilddir /builddir/build/BUILD
# Priority must be 8 digits in total; up to openjdk 1.8, we were using 18..... so when we moved to 11, we had to add another digit
@ -798,6 +798,8 @@ exit 0
%define files_jre_headless() %{expand:
%license %{_jvmdir}/%{sdkdir -- %{?1}}/legal
%doc %{_defaultdocdir}/%{uniquejavadocdir -- %{?1}}/NEWS
%doc %{_defaultdocdir}/%{uniquejavadocdir -- %{?1}}/README.md
%doc %{_defaultdocdir}/%{uniquejavadocdir -- %{?1}}/java-%{featurever}-openjdk-portable.specfile
%dir %{_sysconfdir}/.java/.systemPrefs
%dir %{_sysconfdir}/.java
%dir %{_jvmdir}/%{sdkdir -- %{?1}}
@ -1308,88 +1310,19 @@ Source16: CheckVendor.java
# Ensure translations are available for new timezones
Source18: TestTranslations.java
# TODO: Portable packages are not yet available in buildroot
# Temporarily add them as sources
# aarch64
Source1000: java-17-openjdk-17.0.6.0.10-6.portable.unstripped.jdk.el.aarch64.tar.xz
Source1001: java-17-openjdk-17.0.6.0.10-6.portable.static-libs.el.aarch64.tar.xz
Source1002: java-17-openjdk-17.0.6.0.10-6.portable.docs.el.aarch64.tar.xz
Source1003: java-17-openjdk-17.0.6.0.10-6.portable.misc.el.aarch64.tar.xz
Source1004: java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.jdk.el.aarch64.tar.xz
Source1005: java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.static-libs.el.aarch64.tar.xz
Source1006: java-17-openjdk-17.0.6.0.10-6.portable.fastdebug.jdk.el.aarch64.tar.xz
Source1007: java-17-openjdk-17.0.6.0.10-6.portable.fastdebug.static-libs.el.aarch64.tar.xz
# ppc64le
Source2000: java-17-openjdk-17.0.6.0.10-6.portable.unstripped.jdk.el.ppc64le.tar.xz
Source2001: java-17-openjdk-17.0.6.0.10-6.portable.static-libs.el.ppc64le.tar.xz
Source2002: java-17-openjdk-17.0.6.0.10-6.portable.docs.el.ppc64le.tar.xz
Source2003: java-17-openjdk-17.0.6.0.10-6.portable.misc.el.ppc64le.tar.xz
Source2004: java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.jdk.el.ppc64le.tar.xz
Source2005: java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.static-libs.el.ppc64le.tar.xz
Source2006: java-17-openjdk-17.0.6.0.10-6.portable.fastdebug.jdk.el.ppc64le.tar.xz
Source2007: java-17-openjdk-17.0.6.0.10-6.portable.fastdebug.static-libs.el.ppc64le.tar.xz
# s390x
Source3000: java-17-openjdk-17.0.6.0.10-6.portable.unstripped.jdk.el.s390x.tar.xz
Source3001: java-17-openjdk-17.0.6.0.10-6.portable.static-libs.el.s390x.tar.xz
Source3002: java-17-openjdk-17.0.6.0.10-6.portable.docs.el.s390x.tar.xz
Source3003: java-17-openjdk-17.0.6.0.10-6.portable.misc.el.s390x.tar.xz
Source3004: java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.jdk.el.s390x.tar.xz
Source3005: java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.static-libs.el.s390x.tar.xz
# x86_64
Source4000: java-17-openjdk-17.0.6.0.10-6.portable.unstripped.jdk.el.x86_64.tar.xz
Source4001: java-17-openjdk-17.0.6.0.10-6.portable.static-libs.el.x86_64.tar.xz
Source4002: java-17-openjdk-17.0.6.0.10-6.portable.docs.el.x86_64.tar.xz
Source4003: java-17-openjdk-17.0.6.0.10-6.portable.misc.el.x86_64.tar.xz
Source4004: java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.jdk.el.x86_64.tar.xz
Source4005: java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.static-libs.el.x86_64.tar.xz
Source4006: java-17-openjdk-17.0.6.0.10-6.portable.fastdebug.jdk.el.x86_64.tar.xz
Source4007: java-17-openjdk-17.0.6.0.10-6.portable.fastdebug.static-libs.el.x86_64.tar.xz
# Include portable spec and instructions on how to rebuild
Source19: README.md
Source20: java-%{featurever}-openjdk-portable.specfile
# Setup variables to reference correct sources
%ifarch %{aarch64}
%global releasezip %{SOURCE1000}
%global staticlibzip %{SOURCE1001}
%global docszip %{SOURCE1002}
%global misczip %{SOURCE1003}
%global slowdebugzip %{SOURCE1004}
%global slowdebugstaticlibzip %{SOURCE1005}
%global fastdebugzip %{SOURCE1006}
%global fastdebugstaticlibzip %{SOURCE1007}
%endif
%ifarch %{ppc64le}
%global releasezip %{SOURCE2000}
%global staticlibzip %{SOURCE2001}
%global docszip %{SOURCE2002}
%global misczip %{SOURCE2003}
%global slowdebugzip %{SOURCE2004}
%global slowdebugstaticlibzip %{SOURCE2005}
%global fastdebugzip %{SOURCE2006}
%global fastdebugstaticlibzip %{SOURCE2007}
%endif
%ifarch s390x
%global releasezip %{SOURCE3000}
%global staticlibzip %{SOURCE3001}
%global docszip %{SOURCE3002}
%global misczip %{SOURCE3003}
%global slowdebugzip %{SOURCE3004}
%global slowdebugstaticlibzip %{SOURCE3005}
%global fastdebugzip %{nil}
%global fastdebugstaticlibzip %{nil}
%endif
%ifarch x86_64
%global releasezip %{SOURCE4000}
%global staticlibzip %{SOURCE4001}
%global docszip %{SOURCE4002}
%global misczip %{SOURCE4003}
%global slowdebugzip %{SOURCE4004}
%global slowdebugstaticlibzip %{SOURCE4005}
%global fastdebugzip %{SOURCE4006}
%global fastdebugstaticlibzip %{SOURCE4007}
%endif
%global releasezip %{_jvmdir}/%{name}-%{version}-%{portablerelease}.portable.unstripped.jdk.%{_arch}.tar.xz
%global staticlibzip %{_jvmdir}/%{name}-%{version}-%{portablerelease}.portable.static-libs.%{_arch}.tar.xz
%global docszip %{_jvmdir}/%{name}-%{version}-%{portablerelease}.portable.docs.%{_arch}.tar.xz
%global misczip %{_jvmdir}/%{name}-%{version}-%{portablerelease}.portable.misc.%{_arch}.tar.xz
%global slowdebugzip %{_jvmdir}/%{name}-%{version}-%{portablerelease}.portable.slowdebug.jdk.%{_arch}.tar.xz
%global slowdebugstaticlibzip %{_jvmdir}/%{name}-%{version}-%{portablerelease}.portable.slowdebug.static-libs.%{_arch}.tar.xz
%global fastdebugzip %{_jvmdir}/%{name}-%{version}-%{portablerelease}.portable.fastdebug.jdk.%{_arch}.tar.xz
%global fastdebugstaticlibzip %{_jvmdir}/%{name}-%{version}-%{portablerelease}.portable.fastdebug.static-libs.%{_arch}.tar.xz
############################################
#
@ -1413,7 +1346,7 @@ Patch6: rh1684077-openjdk_should_depend_on_pcsc-lite-libs_instead_of_pcsc-lite-d
# Crypto policy and FIPS support patches
# Patch is generated from the fips-17u tree at https://github.com/rh-openjdk/jdk/tree/fips-17u
# as follows: git diff %%{vcstag} src make > fips-17u-$(git show -s --format=%h HEAD).patch
# as follows: git diff %%{vcstag} src make test > fips-17u-$(git show -s --format=%h HEAD).patch
# Diff is limited to src and make subdirectories to exclude .github changes
# Fixes currently included:
# PR3183, RH1340845: Follow system wide crypto policy
@ -1443,6 +1376,10 @@ Patch6: rh1684077-openjdk_should_depend_on_pcsc-lite-libs_instead_of_pcsc-lite-d
# RH2117972: Extend the support for NSS DBs (PKCS11) in FIPS mode
# Remove forgotten dead code from RH2020290 and RH2104724
# OJ1357: Fix issue on FIPS with a SecurityManager in place
# RH2134669: Add missing attributes when registering services in FIPS mode.
# test/jdk/sun/security/pkcs11/fips/VerifyMissingAttributes.java: fixed jtreg main class
# RH1940064: Enable XML Signature provider in FIPS mode
# RH2173781: Avoid calling C_GetInfo() too early, before cryptoki is initialized
Patch1001: fips-17u-%{fipsver}.patch
#############################################
@ -1453,15 +1390,13 @@ Patch1001: fips-17u-%{fipsver}.patch
#############################################
#
# OpenJDK patches appearing in 17.0.3
#
#############################################
#############################################
#
# OpenJDK patches targetted for 17.0.6
# OpenJDK patches targetted for 17.0.8
#
#############################################
# JDK-8274864: Remove Amman/Cairo hacks in ZoneInfoFile
Patch2001: jdk8274864-remove_amman_cairo_hacks.patch
# JDK-8305113: (tz) Update Timezone Data to 2023c
Patch2002: jdk8305113-tzdata2023c.patch
BuildRequires: autoconf
BuildRequires: automake
@ -1490,19 +1425,26 @@ BuildRequires: pkgconfig
BuildRequires: xorg-x11-proto-devel
BuildRequires: zip
BuildRequires: javapackages-filesystem
# TODO: Portable packages are not yet available in buildroot
#BuildRequires: java-%{featurever}-openjdk-portable-unstripped = %{version}
#BuildRequires: java-%{featurever}-openjdk-portable-static-libs = %{version}
#BuildRequires: java-%{featurever}-openjdk-portable-devel-fastdebug = %{version}
#BuildRequires: java-%{featurever}-openjdk-portable-static-libs-fastdebug = %{version}
#BuildRequires: java-%{featurever}-openjdk-portable-devel-slowdebug = %{version}
#BuildRequires: java-%{featurever}-openjdk-portable-static-libs-slowdebug = %{version}
%if %{include_normal_build}
BuildRequires: java-%{featurever}-openjdk-portable-unstripped = %{epoch}:%{version}-%{portablerelease}.%{portablesuffix}
BuildRequires: java-%{featurever}-openjdk-portable-static-libs = %{epoch}:%{version}-%{portablerelease}.%{portablesuffix}
%endif
%if %{include_fastdebug_build}
BuildRequires: java-%{featurever}-openjdk-portable-devel-fastdebug = %{epoch}:%{version}-%{portablerelease}.%{portablesuffix}
BuildRequires: java-%{featurever}-openjdk-portable-static-libs-fastdebug = %{epoch}:%{version}-%{portablerelease}.%{portablesuffix}
%endif
%if %{include_debug_build}
BuildRequires: java-%{featurever}-openjdk-portable-devel-slowdebug = %{epoch}:%{version}-%{portablerelease}.%{portablesuffix}
BuildRequires: java-%{featurever}-openjdk-portable-static-libs-slowdebug = %{epoch}:%{version}-%{portablerelease}.%{portablesuffix}
%endif
BuildRequires: java-%{featurever}-openjdk-portable-docs = %{epoch}:%{version}-%{portablerelease}.%{portablesuffix}
BuildRequires: java-%{featurever}-openjdk-portable-misc = %{epoch}:%{version}-%{portablerelease}.%{portablesuffix}
# Zero-assembler build requirement
%ifarch %{zero_arches}
BuildRequires: libffi-devel
%endif
# 2022g required as of JDK-8297804
BuildRequires: tzdata-java >= 2022g
# 2023c required as of JDK-8305113
BuildRequires: tzdata-java >= 2023c
# Earlier versions have a bug in tree vectorization on PPC
BuildRequires: gcc >= 4.8.3-8
@ -1898,6 +1840,9 @@ pushd %{top_level_dir_name}
%patch1001 -p1
# nss.cfg PKCS11 support; must come last as it also alters java.security
%patch1000 -p1
# tzdata update
%patch2001 -p1
%patch2002 -p1
popd # openjdk
%patch600
@ -2183,10 +2128,11 @@ jdk_image=$(pwd)/%{installoutputdir -- ${suffix}}
docdir=$(pwd)/%{installoutputdir -- "-docs"}
miscdir=%{installoutputdir -- "-misc"}
# Install release notes
# Install release notes and rebuild instructions
commondocdir=${RPM_BUILD_ROOT}%{_defaultdocdir}/%{uniquejavadocdir -- $suffix}
install -d -m 755 ${commondocdir}
mv ${jdk_image}/NEWS ${commondocdir}
cp -a %{SOURCE19} %{SOURCE20} ${commondocdir}
# Install the jdk
mkdir -p $RPM_BUILD_ROOT%{_jvmdir}
@ -2533,6 +2479,38 @@ cjc.mainProgram(args)
%endif
%changelog
* Wed Apr 26 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.7.0.7-3
- Sync portable spec file with current version
- Related: rhbz#2189326
* Wed Apr 26 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.7.0.7-2
- Update to jdk-17.0.7.0+7
- Update release notes to 17.0.7.0+7
- Require tzdata 2023c due to local inclusion of JDK-8274864 & JDK-8305113
- Update generate_tarball.sh to add support for passing a boot JDK to the configure run
- Add POSIX-friendly error codes to generate_tarball.sh and fix whitespace
- Remove .jcheck and GitHub support when generating tarballs, as done in upstream release tarballs
- Update FIPS support against 17.0.7+6 and bring in latest changes:
- * RH2134669: Add missing attributes when registering services in FIPS mode.
- * test/jdk/sun/security/pkcs11/fips/VerifyMissingAttributes.java: fixed jtreg main class
- * RH1940064: Enable XML Signature provider in FIPS mode
- * RH2173781: Avoid calling C_GetInfo() too early, before cryptoki is initialized
- Fix trailing '.' in tarball name
- Use portablerelease in vendor version to avoid inclusion of dist tag
- ** This tarball is embargoed until 2023-04-18 @ 1pm PT. **
- Resolves: rhbz#2185182
- Resolves: rhbz#2186803
- Resolves: rhbz#2186810
- Resolves: rhbz#2186806
* Wed Apr 26 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.6.0.10-6
- Include the java-17-openjdk-portable.spec file with instructions on how to rebuild.
- Related: rhbz#2189326
* Tue Apr 25 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.6.0.10-5
- Replace local copies of JDK portable binaries with build dependencies
- Resolves: rhbz#2189326
* Wed Feb 15 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.6.0.10-4
- Replace build section with extraction of existing builds from portables
- Resolves: rhbz#2150200

View File

@ -0,0 +1,53 @@
commit 1b3825db8631e55771fb723d4fcd10040ea15b7e
Author: duke <duke@openjdk.org>
Date: Wed Apr 12 17:25:27 2023 +0000
Backport ec199072c5867624d66840238cc8828e16ae8da7
diff --git a/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java b/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java
index 6f6e190efcd..ef278203182 100644
--- a/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java
+++ b/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java
@@ -608,34 +608,6 @@ public final class ZoneInfoFile {
params[8] = endRule.secondOfDay * 1000;
params[9] = toSTZTime[endRule.timeDefinition];
dstSavings = (startRule.offsetAfter - startRule.offsetBefore) * 1000;
-
- // Note: known mismatching -> Asia/Amman
- // ZoneInfo : startDayOfWeek=5 <= Thursday
- // startTime=86400000 <= 24 hours
- // This: startDayOfWeek=6
- // startTime=0
- // Similar workaround needs to be applied to Africa/Cairo and
- // its endDayOfWeek and endTime
- // Below is the workarounds, it probably slows down everyone a little
- if (params[2] == 6 && params[3] == 0 &&
- (zoneId.equals("Asia/Amman"))) {
- params[2] = 5;
- params[3] = 86400000;
- }
- // Additional check for startDayOfWeek=6 and starTime=86400000
- // is needed for Asia/Amman;
- if (params[2] == 7 && params[3] == 0 &&
- (zoneId.equals("Asia/Amman"))) {
- params[2] = 6; // Friday
- params[3] = 86400000; // 24h
- }
- //endDayOfWeek and endTime workaround
- if (params[7] == 6 && params[8] == 0 &&
- (zoneId.equals("Africa/Cairo"))) {
- params[7] = 5;
- params[8] = 86400000;
- }
-
} else if (nTrans > 0) { // only do this if there is something in table already
if (lastyear < LASTYEAR) {
// ZoneInfo has an ending entry for 2037
@@ -908,7 +880,6 @@ public final class ZoneInfoFile {
this.dow = dowByte == 0 ? -1 : dowByte;
this.secondOfDay = timeByte == 31 ? in.readInt() : timeByte * 3600;
this.timeDefinition = (data & (3 << 12)) >>> 12;
-
this.standardOffset = stdByte == 255 ? in.readInt() : (stdByte - 128) * 900;
this.offsetBefore = beforeByte == 3 ? in.readInt() : standardOffset + beforeByte * 1800;
this.offsetAfter = afterByte == 3 ? in.readInt() : standardOffset + afterByte * 1800;

1098
jdk8305113-tzdata2023c.patch Normal file

File diff suppressed because it is too large Load Diff

32
sources
View File

@ -1,32 +1,2 @@
SHA512 (tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz) = 97d026212363b3c83f6a04100ad7f6fdde833d16579717f8756e2b8c2eb70e144a41a330cb9ccde9c3badd37a2d54fdf4650a950ec21d8b686d545ecb2a64d30
SHA512 (openjdk-jdk17u-jdk-17.0.6+10.tar.xz) = 2878aae52e2f49146b9631e3b0379370dce1a0a620dc5c5b763d1432b82e705e3aa33a83008391b4845bf0cb493b08179e7ac3419f597fb80fd65df393e12cf1
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.docs.el.aarch64.tar.xz) = d3e8b4c8cb8197b7a9023235f10ef142a5f865de1e05c43ebae9b20e3f38836c9d098317315c2ef465bacf3248d4953cd2ef84b7fccf808a4c8904999cd8d289
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.docs.el.ppc64le.tar.xz) = 80bf8db3245dd4f075b58da2f80df774c89988cf88da288b56e9118c9c759ec41c377341fad9d03672fad657ca02d04859e78e021d42b654f0c4690c1905bab5
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.docs.el.s390x.tar.xz) = 6753fb7288a737eacb41206c2de09ed673e2f852b23b6ded3d6ded78ec37a84719385087ea64712c7c3be9c6c1c2c9dffafb3dae0f5cd9e998febc39657c0537
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.docs.el.x86_64.tar.xz) = 423c964d0f351bbfc06fbcc7f3eba87d763b147a984b1e5fc54ee357a1b71bf0e2a67a446d7fc3596f054b5aaecc3b0a1e043a06a4dcb29598221c2d83e16613
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.fastdebug.jdk.el.aarch64.tar.xz) = e0062a9ed4dfc99c5f309cd33911b98988093e9afd287538c95ad0146b2cd74edf6b537b0f57db7d6b86e4cb0b0075975285736b217e0de1dee4c51a32614f31
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.fastdebug.jdk.el.ppc64le.tar.xz) = 170d5d3e2af07c2e2a2cf897a0ea215d4be146d501d9bc0ba91b0b369aebdc342c721a02417fb7f81d43b3bd684c82e9c6858407729cb5420a5a212fd68350ab
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.fastdebug.jdk.el.x86_64.tar.xz) = e1d360b26640a343b7f28e3ad665e17cd233ea4c34dedefa481b2d589a3b3a824d2c29529dfb0515f56aaa3d932924bbe6087e3f4f52ae37d6c8bcfac3c8475a
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.fastdebug.static-libs.el.aarch64.tar.xz) = 1eba570b6d1b2339b964e9019f95f7313731e75742b31d8c279a90ea9b59ab0d15f2001356164f1c88f231841bdfdd78b7db4193b4eeab4f09f16bee42fe0bbc
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.fastdebug.static-libs.el.ppc64le.tar.xz) = c2cc1e85756a8e1fd226177452ffff4d0e031a8dfc553d31defd95cb69b2041a991ea28d18d8ffb456f03069c774e78ca84bc7a2954ec6a2e3be601fc32e0e65
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.fastdebug.static-libs.el.x86_64.tar.xz) = ae0f202c18a80a41e2a9d5e44cf12f4026a7864018adbeeb0cff38f882fa2cee62ce568fef77100aed3bcd545193248efac8c2065a4cbe7c43e78f6030918b6f
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.misc.el.aarch64.tar.xz) = 91433ef5f1e8b11c8cd8a55b2eceb724d32f7781190a1404c0e637323e62fc6ed8af140e3d2bde4483fc3f92055d92d6d06bbee76136f22c041c35096ad1d19d
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.misc.el.ppc64le.tar.xz) = dca4fdac80f12f2bbf2ebdf13a1dceca42d8b2c401a32665c15667e447d5b2493cb41c16cf9cac2d4919b8fd35e5546803f2d1ec51599b010a82c16d1ef9c185
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.misc.el.s390x.tar.xz) = b9e7ac0ae220cb6fd04dc83adff6158bc3beea289ddd10109a1b8640379d367333a65ab6097339b8f988a9cdee369eb41ce5a41cde579b17f0f4d39118fbff84
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.misc.el.x86_64.tar.xz) = 1cbd58b6aa4c9c19d1f6e987af1092285c43e4c56202519dd4b75a4ff4d68cd07633ba09e22e7d2a62e91ceb0e3629a4878de943cf7a90ed01c74749bff597d5
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.jdk.el.aarch64.tar.xz) = 6e9d71bfcd5499b18e8503213201b4a918d3c3cbfb32f9d6e67f5a9b0de8ee9df349617ecd8935a38080eae59f2230d1b78dbd91135fba8b65e620da3e1538cf
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.jdk.el.ppc64le.tar.xz) = f5fb6a3bba17d36a4dcdc9a91916f4d0dde5a232e0f3c80297c45ff741efd8978bc96f661513ac9518b6e1d21607e5f751807d5803b998be2a68b5f0ee6b83f3
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.jdk.el.s390x.tar.xz) = 7d564c48a0299ac61c8cfa09b579c81a46ca0373ecf62dd6ae86268632e5672c9fa5e6f4ee5a6ff2e8d8b6fa75a7ba7e7203a432a6a34d2a10f2238395e12c40
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.jdk.el.x86_64.tar.xz) = 29e7d7c9a7a57bfe5bd0397adf8a70e466e8a6dc8dd7045851331990d496d4e8ba6ca0b633dd7add4aa29c1c60e01391461dc37ed787dd4f64a20445c83529c9
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.static-libs.el.aarch64.tar.xz) = ce658bc5b3a3503b7548f02ce8b3fef21ca819dc345a69e4551242a6310fdd858ebe54dd25ed8336bdbfc4ffc408f83a1630ffbd61da006cc71d53602d4181b2
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.static-libs.el.ppc64le.tar.xz) = 5f16ead60b099f8bdad44c187406107ff8767aca8d4172919883017b22dd454c44d3e70c339c1d6439d9e8f39f1a040f87ee5ea56dfb13b89638a7f02648bbbc
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.static-libs.el.s390x.tar.xz) = a1308681c47f32b63b896611989acc3f1230a3ad161b618cc1af0524e0990d95b6d851df1d5a93d8cb20dc27ca1aad374bba60198530e2f65045f443bc44ccc9
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.slowdebug.static-libs.el.x86_64.tar.xz) = 9e481ca7367dc6bf25b85c6d68f6a3ea1a684d4d80e1535fa59ab0adebd6f13f12c95fc2f08a039ed2ec1bac749255ca033ca290e7fc553cc93da496768f7419
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.static-libs.el.aarch64.tar.xz) = 3d57209da953e084c7633c13fe6ec6f808f13486648b054e344a6dd1aadac5025c9c95275b01b3fb83539cb86a36cd8845a38758d70749596e237ced492a9b63
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.static-libs.el.ppc64le.tar.xz) = eaf9d01e19852d75bf99fc6b9b60499285405a6b328dd2ca9d080f1cf28da59e925bec802c248544415e3f1f023f64148a95faece98318d0e2e59c7425f3f033
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.static-libs.el.s390x.tar.xz) = 6d57b3fad5fd2015050c441cca5bd1c47c1ffed4e15842386c302936c123690f95293c7ef01cf17b588b0520e939fb362ac3781f9ae9d7194add6172ab1bd423
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.static-libs.el.x86_64.tar.xz) = 7cf2b2645310f6d61fd38c1d8400a97e9f5ce118c607d455f97e897c903828d01711aedcede3ece052da52ceae39fe93e9897f4d4f315a5de7c1c0b505e4144b
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.unstripped.jdk.el.aarch64.tar.xz) = bc317b65efefb0e62819e2f182bcc6b28648c1f5b1ebf1314ee818aa7b96dba0735ba15f08125f0f9fbc0bcdb97ebf46551d9d2c09362f642221c45169282bfe
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.unstripped.jdk.el.ppc64le.tar.xz) = 3d871a04a201b29fac74c9ad33b7f43c31dd3d6353bad33dab5fdda218284bb0d0367b96a2f7e0d11c95ae2fa9cba2c5103247b6d05035f1c71e0fac7ae921e7
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.unstripped.jdk.el.s390x.tar.xz) = 3b97c4a23929e5e8d9da10bf2853003af66cb92b33f54d6702c7f8aa4096e78f0f3b4449c9a63eff7fc4c1ddb6cda1a32393a6bf52c592b096fca2767bd634ac
SHA512 (java-17-openjdk-17.0.6.0.10-6.portable.unstripped.jdk.el.x86_64.tar.xz) = 5c12f586ac9f00bfc62948716def3d880af46519a8972a5722c8f1869fc69e2f03974248f89c4053aa340d08d9873fd6c3a5b5ba2f6e538771c2164a6c836f69
SHA512 (openjdk-jdk17u-jdk-17.0.7+7.tar.xz) = 2f231e83fabef6299b16beee1e0c8d52501e22fd71a26ed2ace6fadabe38e73e66f3b8fb8bc994e8b2b9bbdb91d1143661941f623bb94793500f4f3b6495bf58