Sync with f23 - security update to u60b23
This commit is contained in:
parent
dd0a8d38f7
commit
deb3d7b44a
2
.gitignore
vendored
2
.gitignore
vendored
@ -41,3 +41,5 @@
|
||||
/jdk8u45-jdk8u45-b13.tar.xz
|
||||
/jdk8u45-jdk8u45-b14.tar.xz
|
||||
/jdk8u-jdk8u60-b16.tar.xz
|
||||
/jdk8u-aarch64-jdk8u51-b16.tar.xz
|
||||
/jdk8u-jdk8u60-b24.tar.xz
|
||||
|
@ -1,35 +0,0 @@
|
||||
diff --git a/src/share/vm/opto/type.cpp b/src/share/vm/opto/type.cpp
|
||||
--- jdk8/hotspot/src/share/vm/opto/type.cpp
|
||||
+++ jdk8/hotspot/src/share/vm/opto/type.cpp
|
||||
@@ -1158,11 +1158,11 @@
|
||||
// Certain normalizations keep us sane when comparing types.
|
||||
// The 'SMALLINT' covers constants and also CC and its relatives.
|
||||
if (lo <= hi) {
|
||||
- if ((juint)(hi - lo) <= SMALLINT) w = Type::WidenMin;
|
||||
- if ((juint)(hi - lo) >= max_juint) w = Type::WidenMax; // TypeInt::INT
|
||||
+ if ((juint)hi - lo <= SMALLINT) w = Type::WidenMin;
|
||||
+ if ((juint)hi - lo >= max_juint) w = Type::WidenMax; // TypeInt::INT
|
||||
} else {
|
||||
- if ((juint)(lo - hi) <= SMALLINT) w = Type::WidenMin;
|
||||
- if ((juint)(lo - hi) >= max_juint) w = Type::WidenMin; // dual TypeInt::INT
|
||||
+ if ((juint)lo - hi <= SMALLINT) w = Type::WidenMin;
|
||||
+ if ((juint)lo - hi >= max_juint) w = Type::WidenMin; // dual TypeInt::INT
|
||||
}
|
||||
return w;
|
||||
}
|
||||
@@ -1416,11 +1416,11 @@
|
||||
// Certain normalizations keep us sane when comparing types.
|
||||
// The 'SMALLINT' covers constants.
|
||||
if (lo <= hi) {
|
||||
- if ((julong)(hi - lo) <= SMALLINT) w = Type::WidenMin;
|
||||
- if ((julong)(hi - lo) >= max_julong) w = Type::WidenMax; // TypeLong::LONG
|
||||
+ if ((julong)hi - lo <= SMALLINT) w = Type::WidenMin;
|
||||
+ if ((julong)hi - lo >= max_julong) w = Type::WidenMax; // TypeLong::LONG
|
||||
} else {
|
||||
- if ((julong)(lo - hi) <= SMALLINT) w = Type::WidenMin;
|
||||
- if ((julong)(lo - hi) >= max_julong) w = Type::WidenMin; // dual TypeLong::LONG
|
||||
+ if ((julong)lo - hi <= SMALLINT) w = Type::WidenMin;
|
||||
+ if ((julong)lo - hi >= max_julong) w = Type::WidenMin; // dual TypeLong::LONG
|
||||
}
|
||||
return w;
|
||||
}
|
@ -1,5 +1,4 @@
|
||||
#!/bin/bash
|
||||
|
||||
# Generates the 'source tarball' for JDK 8 projects.
|
||||
#
|
||||
# Usage: generate_source_tarball.sh project_name repo_name tag
|
||||
@ -12,7 +11,7 @@
|
||||
#
|
||||
# This script creates a single source tarball out of the repository
|
||||
# based on the given tag and removes code not allowed in fedora. For
|
||||
# consistency, the source tarball will always contain 'jdk8' as the top
|
||||
# consistency, the source tarball will always contain 'openjdk' as the top
|
||||
# level folder.
|
||||
|
||||
set -e
|
||||
@ -44,8 +43,8 @@ wget "${REPO_ROOT}/archive/${VERSION}.tar.gz"
|
||||
tar xf "${VERSION}.tar.gz"
|
||||
rm "${VERSION}.tar.gz"
|
||||
|
||||
mv "${REPO_NAME}-${VERSION}" jdk8
|
||||
pushd jdk8
|
||||
mv "${REPO_NAME}-${VERSION}" openjdk
|
||||
pushd openjdk
|
||||
|
||||
repos="corba hotspot jdk jaxws jaxp langtools nashorn"
|
||||
if [ aarch64-port = $PROJECT_NAME ] ; then
|
||||
@ -60,12 +59,19 @@ do
|
||||
mv "${subrepo}-${VERSION}" "${subrepo}"
|
||||
done
|
||||
|
||||
if [ -e jdk ] ; then
|
||||
rm -vr jdk/src/share/native/sun/security/ec/impl
|
||||
fi
|
||||
echo "Removing EC source code we don't build"
|
||||
rm -vrf jdk/src/share/native/sun/security/ec/impl
|
||||
|
||||
#get this file http://icedtea.classpath.org/hg/icedtea/raw-file/tip/patches/pr2126.patch (from http://icedtea.classpath.org//hg/icedtea?cmd=changeset;node=8d2c9a898f50)
|
||||
#from most correct tag
|
||||
#and use it like below. Do not push it or publish it (see http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=2126)
|
||||
pwd
|
||||
echo "Syncing EC list with NSS"
|
||||
patch -Np1 < ../../pr2126.patch
|
||||
|
||||
popd
|
||||
|
||||
tar cJf ${REPO_NAME}-${VERSION}.tar.xz jdk8
|
||||
tar cJf ${REPO_NAME}-${VERSION}.tar.xz openjdk
|
||||
|
||||
popd
|
||||
|
||||
|
20
gif4.1.patch
20
gif4.1.patch
@ -1,20 +0,0 @@
|
||||
--- jdk8/jdk/src/share/native/sun/awt/splashscreen/splashscreen_gif.c
|
||||
+++ jdk8/jdk/src/share/native/sun/awt/splashscreen/splashscreen_gif.c
|
||||
@@ -296,7 +296,7 @@
|
||||
free(pBitmapBits);
|
||||
free(pOldBitmapBits);
|
||||
|
||||
- DGifCloseFile(gif, NULL);
|
||||
+ DGifCloseFile(gif);
|
||||
|
||||
return 1;
|
||||
}
|
||||
@@ -304,7 +304,7 @@
|
||||
int
|
||||
SplashDecodeGifStream(Splash * splash, SplashStream * stream)
|
||||
{
|
||||
- GifFileType *gif = DGifOpen((void *) stream, SplashStreamGifInputFunc, NULL);
|
||||
+ GifFileType *gif = DGifOpen((void *) stream, SplashStreamGifInputFunc);
|
||||
|
||||
if (!gif)
|
||||
return 0;
|
@ -1,12 +0,0 @@
|
||||
diff -up jdk8/hotspot/make/linux/Makefile.linux4 jdk8/hotspot/make/linux/Makefile
|
||||
--- jdk8/hotspot/make/linux/Makefile.linux4 2015-06-09 10:14:48.000000000 -0400
|
||||
+++ jdk8/hotspot/make/linux/Makefile 2015-06-09 10:14:54.000000000 -0400
|
||||
@@ -229,7 +229,7 @@ checks: check_os_version check_j2se_vers
|
||||
# Solaris 2.5.1, 2.6).
|
||||
# Disable this check by setting DISABLE_HOTSPOT_OS_VERSION_CHECK=ok.
|
||||
|
||||
-SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3%
|
||||
+SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3% 4%
|
||||
OS_VERSION := $(shell uname -r)
|
||||
EMPTY_IF_NOT_SUPPORTED = $(filter $(SUPPORTED_OS_VERSION),$(OS_VERSION))
|
||||
|
40
java-1.8.0-openjdk-rh1191652-hotspot-aarch64.patch
Normal file
40
java-1.8.0-openjdk-rh1191652-hotspot-aarch64.patch
Normal file
@ -0,0 +1,40 @@
|
||||
# HG changeset patch
|
||||
# User andrew
|
||||
# Date 1424102734 0
|
||||
# Mon Feb 16 16:05:34 2015 +0000
|
||||
# Node ID 4fdaf786d977aa77afdb68b8829579d31069e39c
|
||||
# Parent 01a0011cc101f3308c5876db8282c0fc5e3ba2e6
|
||||
PR2236: ppc64le should report its os.arch as ppc64le so tools can detect it
|
||||
Summary: Use ppc64le as the arch directory on that platform and report it in os.arch
|
||||
|
||||
--- openjdk/hotspot/make/defs.make.orig 2015-03-03 17:05:51.000000000 -0500
|
||||
+++ openjdk/hotspot/make/defs.make 2015-03-03 19:18:20.000000000 -0500
|
||||
@@ -319,6 +319,13 @@
|
||||
LIBARCH/arm = arm
|
||||
LIBARCH/zero = $(ZERO_LIBARCH)
|
||||
|
||||
+ # Override LIBARCH for ppc64le
|
||||
+ ifeq ($(ARCH), ppc64)
|
||||
+ ifeq ($(OPENJDK_TARGET_CPU_ENDIAN), little)
|
||||
+ LIBARCH = ppc64le
|
||||
+ endif
|
||||
+ endif
|
||||
+
|
||||
LP64_ARCH = sparcv9 amd64 ppc64 aarch64 ia64 zero
|
||||
endif
|
||||
|
||||
diff -r 01a0011cc101 -r 4fdaf786d977 src/os/linux/vm/os_linux.cpp
|
||||
--- openjdk/hotspot/src/os/linux/vm/os_linux.cpp Mon Feb 16 13:18:10 2015 +0000
|
||||
+++ openjdk/hotspot/src/os/linux/vm/os_linux.cpp Mon Feb 16 16:05:34 2015 +0000
|
||||
@@ -305,7 +305,11 @@
|
||||
#elif defined(PPC32)
|
||||
static char cpu_arch[] = "ppc";
|
||||
#elif defined(PPC64)
|
||||
+#if defined(VM_LITTLE_ENDIAN)
|
||||
+static char cpu_arch[] = "ppc64le";
|
||||
+#else
|
||||
static char cpu_arch[] = "ppc64";
|
||||
+#endif
|
||||
#elif defined(SPARC)
|
||||
# ifdef _LP64
|
||||
static char cpu_arch[] = "sparcv9";
|
17
java-1.8.0-openjdk-rh1191652-hotspot.patch
Normal file
17
java-1.8.0-openjdk-rh1191652-hotspot.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff -r 9d6eb2757167 make/defs.make
|
||||
--- openjdk/hotspot/make/defs.make Wed Feb 11 18:56:26 2015 -0800
|
||||
+++ openjdk/hotspot/make/defs.make Tue Feb 17 16:39:22 2015 +0000
|
||||
@@ -317,6 +317,13 @@
|
||||
LIBARCH/ppc64 = ppc64
|
||||
LIBARCH/zero = $(ZERO_LIBARCH)
|
||||
|
||||
+ # Override LIBARCH for ppc64le
|
||||
+ ifeq ($(ARCH), ppc64)
|
||||
+ ifeq ($(OPENJDK_TARGET_CPU_ENDIAN), little)
|
||||
+ LIBARCH = ppc64le
|
||||
+ endif
|
||||
+ endif
|
||||
+
|
||||
LP64_ARCH += sparcv9 amd64 ia64 ppc64 zero
|
||||
endif
|
||||
|
62
java-1.8.0-openjdk-rh1191652-jdk.patch
Normal file
62
java-1.8.0-openjdk-rh1191652-jdk.patch
Normal file
@ -0,0 +1,62 @@
|
||||
--- openjdk/jdk/make/lib/SoundLibraries.gmk.orig 2015-03-03 20:52:33.000000000 -0500
|
||||
+++ openjdk/jdk/make/lib/SoundLibraries.gmk 2015-03-03 20:54:39.000000000 -0500
|
||||
@@ -140,6 +140,10 @@
|
||||
LIBJSOUND_CFLAGS += -DX_ARCH=X_PPC64
|
||||
endif
|
||||
|
||||
+ ifeq ($(OPENJDK_TARGET_CPU), ppc64le)
|
||||
+ LIBJSOUND_CFLAGS += -DX_ARCH=X_PPC64LE
|
||||
+ endif
|
||||
+
|
||||
ifeq ($(OPENJDK_TARGET_CPU), aarch64)
|
||||
LIBJSOUND_CFLAGS += -DX_ARCH=X_AARCH64
|
||||
endif
|
||||
diff -r 87c95759b92b src/share/native/com/sun/media/sound/SoundDefs.h
|
||||
--- openjdk/jdk/src/share/native/com/sun/media/sound/SoundDefs.h Wed Feb 11 18:55:05 2015 -0800
|
||||
+++ openjdk/jdk/src/share/native/com/sun/media/sound/SoundDefs.h Tue Feb 17 18:25:01 2015 +0000
|
||||
@@ -43,6 +43,8 @@
|
||||
#define X_ZERO 6
|
||||
#define X_ARM 7
|
||||
#define X_PPC 8
|
||||
+#define X_PPC64 9
|
||||
+#define X_PPC64LE 10
|
||||
|
||||
// **********************************
|
||||
// Make sure you set X_PLATFORM and X_ARCH defines correctly.
|
||||
diff -r 87c95759b92b src/solaris/bin/ppc64le/jvm.cfg
|
||||
--- /dev/null Thu Jan 01 00:00:00 1970 +0000
|
||||
+++ openjdk/jdk/src/solaris/bin/ppc64le/jvm.cfg Tue Feb 17 18:25:01 2015 +0000
|
||||
@@ -0,0 +1,33 @@
|
||||
+# Copyright (c) 2011, Oracle and/or its affiliates. All rights reserved.
|
||||
+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
||||
+#
|
||||
+# This code is free software; you can redistribute it and/or modify it
|
||||
+# under the terms of the GNU General Public License version 2 only, as
|
||||
+# published by the Free Software Foundation. Oracle designates this
|
||||
+# particular file as subject to the "Classpath" exception as provided
|
||||
+# by Oracle in the LICENSE file that accompanied this code.
|
||||
+#
|
||||
+# This code is distributed in the hope that it will be useful, but WITHOUT
|
||||
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
|
||||
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
|
||||
+# version 2 for more details (a copy is included in the LICENSE file that
|
||||
+# accompanied this code).
|
||||
+#
|
||||
+# You should have received a copy of the GNU General Public License version
|
||||
+# 2 along with this work; if not, write to the Free Software Foundation,
|
||||
+# Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
|
||||
+#
|
||||
+# Please contact Oracle, 500 Oracle Parkway, Redwood Shores, CA 94065 USA
|
||||
+# or visit www.oracle.com if you need additional information or have any
|
||||
+# questions.
|
||||
+#
|
||||
+# List of JVMs that can be used as an option to java, javac, etc.
|
||||
+# Order is important -- first in this list is the default JVM.
|
||||
+# NOTE that this both this file and its format are UNSUPPORTED and
|
||||
+# WILL GO AWAY in a future release.
|
||||
+#
|
||||
+# You may also select a JVM in an arbitrary location with the
|
||||
+# "-XXaltjvm=<jvm_dir>" option, but that too is unsupported
|
||||
+# and may not be available in a future release.
|
||||
+#
|
||||
+-server KNOWN
|
50
java-1.8.0-openjdk-rh1191652-root.patch
Normal file
50
java-1.8.0-openjdk-rh1191652-root.patch
Normal file
@ -0,0 +1,50 @@
|
||||
diff -r 590cc3ca1fec common/autoconf/hotspot-spec.gmk.in
|
||||
--- openjdk///common/autoconf/hotspot-spec.gmk.in Wed Feb 11 12:18:34 2015 -0800
|
||||
+++ openjdk///common/autoconf/hotspot-spec.gmk.in Wed Feb 18 12:10:19 2015 +0000
|
||||
@@ -71,6 +71,10 @@
|
||||
LIBARCH=$(OPENJDK_TARGET_CPU_LEGACY_LIB)
|
||||
# Old name for OPENJDK_TARGET_CPU, uses i586 and amd64, instead of x86 and x86_64.
|
||||
ARCH=$(OPENJDK_TARGET_CPU_LEGACY)
|
||||
+# ppc64le uses the HotSpot ppc64 build
|
||||
+ifeq ($(OPENJDK_TARGET_CPU), ppc64le)
|
||||
+ ARCH=ppc64
|
||||
+endif
|
||||
# Legacy setting for building for a 64 bit machine.
|
||||
# If yes then this expands to _LP64:=1
|
||||
@LP64@
|
||||
--- openjdk/common/autoconf/jdk-options.m4.orig 2015-03-03 20:13:00.000000000 -0500
|
||||
+++ openjdk/common/autoconf/jdk-options.m4 2015-03-03 20:36:17.000000000 -0500
|
||||
@@ -153,7 +153,7 @@
|
||||
if test "x$JVM_VARIANT_ZEROSHARK" = xtrue ; then
|
||||
INCLUDE_SA=false
|
||||
fi
|
||||
- if test "x$VAR_CPU" = xppc64 ; then
|
||||
+ if test "x$VAR_CPU" = xppc64 -o "x$VAR_CPU" = xppc64le ; then
|
||||
INCLUDE_SA=false
|
||||
fi
|
||||
if test "x$OPENJDK_TARGET_CPU" = xaarch64; then
|
||||
diff -r 590cc3ca1fec common/autoconf/platform.m4
|
||||
--- openjdk///common/autoconf/platform.m4 Wed Feb 11 12:18:34 2015 -0800
|
||||
+++ openjdk///common/autoconf/platform.m4 Wed Feb 18 12:10:19 2015 +0000
|
||||
@@ -61,7 +61,7 @@
|
||||
VAR_CPU_ENDIAN=big
|
||||
;;
|
||||
powerpc64le)
|
||||
- VAR_CPU=ppc64
|
||||
+ VAR_CPU=ppc64le
|
||||
VAR_CPU_ARCH=ppc
|
||||
VAR_CPU_BITS=64
|
||||
VAR_CPU_ENDIAN=little
|
||||
diff -r 590cc3ca1fec common/autoconf/toolchain.m4
|
||||
--- openjdk///common/autoconf/toolchain.m4 Wed Feb 11 12:18:34 2015 -0800
|
||||
+++ openjdk///common/autoconf/toolchain.m4 Wed Feb 18 12:10:19 2015 +0000
|
||||
@@ -1056,6 +1056,9 @@
|
||||
else
|
||||
CCXXFLAGS_JDK="$CCXXFLAGS_JDK -D_BIG_ENDIAN"
|
||||
fi
|
||||
+ if test "x$OPENJDK_TARGET_CPU" = xppc64le; then
|
||||
+ CCXXFLAGS_JDK="$CCXXFLAGS_JDK -DABI_ELFv2"
|
||||
+ fi
|
||||
if test "x$OPENJDK_TARGET_OS" = xlinux; then
|
||||
CCXXFLAGS_JDK="$CCXXFLAGS_JDK -DLINUX"
|
||||
fi
|
@ -117,10 +117,10 @@
|
||||
# Standard JPackage naming and versioning defines.
|
||||
%global origin openjdk
|
||||
%global updatever 60
|
||||
%global buildver b16
|
||||
%global aarch64_updatever 45
|
||||
%global aarch64_buildver b13
|
||||
%global aarch64_changesetid aarch64-jdk8u45-b13
|
||||
%global buildver b24
|
||||
%global aarch64_updatever 51
|
||||
%global aarch64_buildver b16
|
||||
%global aarch64_changesetid aarch64-jdk8u51-b16
|
||||
# priority must be 7 digits in total
|
||||
%global priority 18000%{updatever}
|
||||
%global javaver 1.8.0
|
||||
@ -130,7 +130,7 @@
|
||||
#images stub
|
||||
%global j2sdkimage j2sdk-image
|
||||
# output dir stub
|
||||
%global buildoutputdir() %{expand:jdk8/build/jdk8.build%1}
|
||||
%global buildoutputdir() %{expand:openjdk/build/jdk8.build%1}
|
||||
#we can copy the javadoc to not arched dir, or made it not noarch
|
||||
%global uniquejavadocdir() %{expand:%{fullversion}%1}
|
||||
#main id and dir of this jdk
|
||||
@ -171,6 +171,24 @@ exit 0
|
||||
%global post_headless() %{expand:
|
||||
# FIXME: identical binaries are copied, not linked. This needs to be
|
||||
# fixed upstream.
|
||||
# The pretrans lua scriptlet prevents an unmodified java.security
|
||||
# from being replaced via an update. It gets created as
|
||||
# java.security.rpmnew instead. This invalidates the patch of
|
||||
# JDK-8061210 of the January 2015 CPU or JDK-8043201 of the
|
||||
# July 2015 CPU. We fix this via a post scriptlet which runs on updates.
|
||||
if [ "$1" -gt 1 ]; then
|
||||
javasecurity="%{_jvmdir}/%{uniquesuffix}/jre/lib/security/java.security"
|
||||
sum=$(md5sum "${javasecurity}" | cut -d' ' -f1)
|
||||
# This is the md5sum of an unmodified java.security file
|
||||
if [ "${sum}" = '1690ac33955594f71dc952c9e83fd396' -o \\
|
||||
"${sum}" = 'b138695d0c0ea947e64a21a627d973ba' -o \\
|
||||
"${sum}" = 'd17958676bdb9f9d941c8a59655311fb' ]; then
|
||||
if [ -f "${javasecurity}.rpmnew" ]; then
|
||||
mv -f "${javasecurity}.rpmnew" "${javasecurity}"
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
|
||||
%ifarch %{jit_arches}
|
||||
# MetaspaceShared::generate_vtable_methods not implemented for PPC JIT
|
||||
%ifnarch %{power64}
|
||||
@ -643,7 +661,7 @@ Obsoletes: java-1.7.0-openjdk-accessibility%1
|
||||
|
||||
Name: java-%{javaver}-%{origin}
|
||||
Version: %{javaver}.%{updatever}
|
||||
Release: 7.%{buildver}%{?dist}
|
||||
Release: 3.%{buildver}%{?dist}
|
||||
# java-1.5.0-ibm from jpackage.org set Epoch to 1 for unknown reasons,
|
||||
# and this change was brought into RHEL-4. java-1.5.0-ibm packages
|
||||
# also included the epoch in their virtual provides. This created a
|
||||
@ -665,7 +683,7 @@ URL: http://openjdk.java.net/
|
||||
# ./generate_source_tarball.sh jdk8u jdk8u jdk8u%%{updatever}-%%{buildver}
|
||||
# ./generate_source_tarball.sh aarch64-port jdk8 %%{aarch64_hg_tag}
|
||||
Source0: jdk8u-jdk8u%{updatever}-%{buildver}.tar.xz
|
||||
Source1: jdk8-jdk8u%{aarch64_updatever}-%{aarch64_buildver}-%{aarch64_changesetid}.tar.xz
|
||||
Source1: jdk8u-%{aarch64_changesetid}.tar.xz
|
||||
|
||||
# Custom README for -src subpackage
|
||||
Source2: README.src
|
||||
@ -716,9 +734,6 @@ Patch13: libjpeg-turbo-1.4-compat.patch
|
||||
# OpenJDK specific patches
|
||||
#
|
||||
|
||||
# http://hg.openjdk.java.net/jdk9/hs/hotspot/rev/471b684ff43e
|
||||
# allow build on Linux 4.x kernels
|
||||
Patch99: java-1.8.0-openjdk-linux-4.x.patch
|
||||
# JVM heap size changes for s390 (thanks to aph)
|
||||
Patch100: %{name}-s390-java-opts.patch
|
||||
# Type fixing for s390
|
||||
@ -732,11 +747,17 @@ Patch300: jstack-pr1845.patch
|
||||
|
||||
# Fixes StackOverflowError on ARM32 bit Zero. See RHBZ#1206656
|
||||
Patch403: rhbz1206656_fix_current_stack_pointer.patch
|
||||
Patch503: d318d83c4e74.patch
|
||||
# Patch for upstream JDK-8078666 (RHBZ#1208369)
|
||||
Patch505: 1208369_memory_leak_gcc5.patch
|
||||
Patch506: gif4.1.patch
|
||||
|
||||
# PR2095, RH1163501: 2048-bit DH upper bound too small for Fedora infrastructure (sync with IcedTea 2.x)
|
||||
Patch504: rh1163501.patch
|
||||
# S4890063, PR2304, RH1214835: HPROF: default text truncated when using doe=n option (upstreaming post-CPU 2015/07)
|
||||
Patch511: rh1214835.patch
|
||||
|
||||
# RH1191652; fix name of ppc64le architecture
|
||||
Patch600: %{name}-rh1191652-hotspot.patch
|
||||
Patch601: %{name}-rh1191652-root.patch
|
||||
Patch602: %{name}-rh1191652-jdk.patch
|
||||
Patch603: %{name}-rh1191652-hotspot-aarch64.patch
|
||||
|
||||
Patch9999: enableArm64.patch
|
||||
|
||||
@ -971,9 +992,11 @@ if [ $prioritylength -ne 7 ] ; then
|
||||
echo "priority must be 7 digits in total, violated"
|
||||
exit 14
|
||||
fi
|
||||
ln -s jdk8 openjdk
|
||||
# For old patches
|
||||
ln -s openjdk jdk8
|
||||
# Swap HotSpot for AArch64 port
|
||||
%ifarch %{aarch64}
|
||||
pushd jdk8
|
||||
pushd openjdk
|
||||
rm -r hotspot
|
||||
tar xf %{SOURCE1}
|
||||
popd
|
||||
@ -984,16 +1007,14 @@ cp %{SOURCE2} .
|
||||
#
|
||||
# the configure macro will do this too, but it also passes a few flags not
|
||||
# supported by openjdk configure script
|
||||
cp %{SOURCE100} jdk8/common/autoconf/build-aux/
|
||||
cp %{SOURCE101} jdk8/common/autoconf/build-aux/
|
||||
cp %{SOURCE100} openjdk/common/autoconf/build-aux/
|
||||
cp %{SOURCE101} openjdk/common/autoconf/build-aux/
|
||||
|
||||
# OpenJDK patches
|
||||
|
||||
# Remove libraries that are linked
|
||||
sh %{SOURCE12}
|
||||
|
||||
%patch99
|
||||
|
||||
# Add AArch64 support to configure & JDK build
|
||||
%patch9999
|
||||
|
||||
@ -1020,9 +1041,19 @@ sh %{SOURCE12}
|
||||
# Zero PPC fixes.
|
||||
%patch403
|
||||
|
||||
%patch503
|
||||
%patch505
|
||||
%patch506
|
||||
# HotSpot ppc64le patch is different depending
|
||||
# on whether we are using 2.5 or 2.6 HotSpot.
|
||||
%ifarch %{aarch64}
|
||||
%patch603
|
||||
%else
|
||||
%patch600
|
||||
%endif
|
||||
|
||||
%patch601
|
||||
%patch602
|
||||
|
||||
%patch504
|
||||
%patch511
|
||||
|
||||
# Extract systemtap tapsets
|
||||
%if %{with_systemtap}
|
||||
@ -1090,7 +1121,7 @@ EXTRA_CFLAGS="$EXTRA_CFLAGS -fno-strict-aliasing"
|
||||
%endif
|
||||
export EXTRA_CFLAGS
|
||||
|
||||
(cd jdk8/common/autoconf
|
||||
(cd openjdk/common/autoconf
|
||||
bash ./autogen.sh
|
||||
)
|
||||
|
||||
@ -1319,7 +1350,7 @@ cp -a %{buildoutputdir $suffix}/docs $RPM_BUILD_ROOT%{_javadocdir}/%{uniquejavad
|
||||
# Install icons and menu entries.
|
||||
for s in 16 24 32 48 ; do
|
||||
install -D -p -m 644 \
|
||||
jdk8/jdk/src/solaris/classes/sun/awt/X11/java-icon${s}.png \
|
||||
openjdk/jdk/src/solaris/classes/sun/awt/X11/java-icon${s}.png \
|
||||
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${s}x${s}/apps/java-%{javaver}.png
|
||||
done
|
||||
|
||||
@ -1707,6 +1738,24 @@ end
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Jul 17 2015 Jiri Vanek <jvanek@redhat.com> - 1:1.8.0.60-3.b24
|
||||
- added one more md5sum test (thanx to Severin!)
|
||||
- I guess one more missing
|
||||
- doubled slash in md5sum test in post
|
||||
|
||||
* Thu Jul 16 2015 Jiri Vanek <jvanek@redhat.com> - 1:1.8.0.60-2.b24
|
||||
- updated to security u60-b24
|
||||
- moved to openjdk instead of jdk8 topdir in sources
|
||||
- removed upstreamed patch99 java-1.8.0-openjdk-linux-4.x.patch
|
||||
- removed upstreamed patch503 pr2444.patch
|
||||
- removed upstreamed patch505 1208369_memory_leak_gcc5.patch
|
||||
- removed upstreamed patch506: gif4.1.patch
|
||||
- note: usptream version is suspicious
|
||||
GIFLIB_MAJOR >= 5 SplashStreamGifInputFunc, NULL
|
||||
ELSE SplashStreamGifInputFunc
|
||||
- but the condition seems to be viceversa
|
||||
|
||||
|
||||
* Mon Jun 22 2015 Omair Majid <omajid@redhat.com> - 1:1.8.0.60-7.b16
|
||||
- Require javapackages-tools instead of jpackage-utils.
|
||||
|
||||
|
@ -1,5 +1,6 @@
|
||||
--- jdk8/jdk/src/share/lib/security/java.security-linux
|
||||
+++ jdk8/jdk/src/share/lib/security/java.security-linux
|
||||
diff -r 135101850ef1 src/share/lib/security/java.security-linux
|
||||
--- openjdk/jdk/src/share/lib/security/java.security-linux Wed Jun 03 20:23:19 2015 -0700
|
||||
+++ openjdk/jdk/src/share/lib/security/java.security-linux Thu Jul 02 04:02:18 2015 +0100
|
||||
@@ -67,13 +67,13 @@
|
||||
#
|
||||
security.provider.1=sun.security.provider.Sun
|
||||
@ -21,9 +22,12 @@
|
||||
|
||||
#
|
||||
# Sun Provider SecureRandom seed source.
|
||||
@@ -504,4 +504,4 @@
|
||||
@@ -500,7 +500,7 @@
|
||||
#
|
||||
# Example:
|
||||
# jdk.tls.disabledAlgorithms=MD5, SSLv3, DSA, RSA keySize < 2048
|
||||
-jdk.tls.disabledAlgorithms=SSLv3, RC4
|
||||
+jdk.tls.disabledAlgorithms=SSLv3,RC4,EC,ECDHE,ECDH
|
||||
-jdk.tls.disabledAlgorithms=SSLv3, RC4, DH keySize < 768
|
||||
+jdk.tls.disabledAlgorithms=SSLv3, RC4, DH keySize < 768, EC, ECDHE, ECDH
|
||||
|
||||
# Legacy algorithms for Secure Socket Layer/Transport Layer Security (SSL/TLS)
|
||||
# processing in JSSE implementation.
|
||||
|
20
rh1214835.patch
Normal file
20
rh1214835.patch
Normal file
@ -0,0 +1,20 @@
|
||||
# HG changeset patch
|
||||
# User andrew
|
||||
# Date 1429893959 -3600
|
||||
# Fri Apr 24 17:45:59 2015 +0100
|
||||
# Node ID 6e3f4784affc0de360d763ad69979690b2650a98
|
||||
# Parent 75acb9c0991bc118463debed137d38ce40358bc0
|
||||
4890063, PR2304, RH1214835: HPROF: default text truncated when using doe=n option
|
||||
|
||||
diff -r 75acb9c0991b -r 6e3f4784affc src/share/demo/jvmti/hprof/hprof_init.c
|
||||
--- openjdk/jdk/src/share/demo/jvmti/hprof/hprof_init.c Thu Jun 04 18:00:35 2015 +0100
|
||||
+++ openjdk/jdk/src/share/demo/jvmti/hprof/hprof_init.c Fri Apr 24 17:45:59 2015 +0100
|
||||
@@ -1361,7 +1361,7 @@
|
||||
} rawMonitorExit(gdata->dump_lock);
|
||||
|
||||
/* Dump everything if we need to */
|
||||
- if (gdata->dump_on_exit && need_to_dump) {
|
||||
+ if (gdata->dump_on_exit || need_to_dump) {
|
||||
|
||||
dump_all_data(env);
|
||||
}
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
||||
94ca5a45c3cb3b85c4577d0891166007 systemtap-tapset.tar.gz
|
||||
753feced879e36b1250fb37aa45cea75 jdk8-jdk8u45-b13-aarch64-jdk8u45-b13.tar.xz
|
||||
033b0b67913cdd1981910a0ee19cfc74 jdk8u-jdk8u60-b16.tar.xz
|
||||
fbfc2b2a5a3bfda9851dd355388a8dd0 jdk8u-aarch64-jdk8u51-b16.tar.xz
|
||||
280ff4b4a324cea18d0670d66a32f9b8 jdk8u-jdk8u60-b24.tar.xz
|
||||
|
Loading…
Reference in New Issue
Block a user