- fixup build issues introduced by geojasper integration
This commit is contained in:
parent
cd2a97a80b
commit
422270cf90
@ -9,14 +9,3 @@
|
|||||||
echo "$as_me:$LINENO: checking for glutInit in -lglut" >&5
|
echo "$as_me:$LINENO: checking for glutInit in -lglut" >&5
|
||||||
echo $ECHO_N "checking for glutInit in -lglut... $ECHO_C" >&6
|
echo $ECHO_N "checking for glutInit in -lglut... $ECHO_C" >&6
|
||||||
if test "${ac_cv_lib_glut_glutInit+set}" = set; then
|
if test "${ac_cv_lib_glut_glutInit+set}" = set; then
|
||||||
--- jasper-1.701.0.GEO/configure.ac.GL 2006-02-20 19:58:02.000000000 -0600
|
|
||||||
+++ jasper-1.701.0.GEO/configure.ac 2006-02-24 07:40:38.000000000 -0600
|
|
||||||
@@ -242,7 +242,7 @@
|
|
||||||
OPENGL_LIBS=""
|
|
||||||
if test $ENABLE_OPENGL = yes; then
|
|
||||||
if test $HAVE_OPENGL = no; then
|
|
||||||
- TMPLIBS="-lglut -lGL -lGLU $X_PRE_LIBS -lX11 -lXmu -lXi -lXext -lXt $X_EXTRA_LIBS $X_LIBS"
|
|
||||||
+ TMPLIBS="-lglut"
|
|
||||||
AC_CHECK_LIB(glut, glutInit, [HAVE_OPENGL=yes;
|
|
||||||
OPENGL_LIBS=$TMPLIBS], HAVE_OPENGL=no, $TMPLIBS)
|
|
||||||
fi
|
|
||||||
|
@ -12,7 +12,7 @@ Summary: Implementation of the JPEG-2000 standard, Part 1
|
|||||||
Name: jasper
|
Name: jasper
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Version: 1.701.0
|
Version: 1.701.0
|
||||||
Release: 10%{?dist}
|
Release: 11%{?dist}
|
||||||
|
|
||||||
License: JasPer License Version 2.0
|
License: JasPer License Version 2.0
|
||||||
%if "%{?geo:1}" == "1"
|
%if "%{?geo:1}" == "1"
|
||||||
@ -27,6 +27,8 @@ Source: http://www.ece.uvic.ca/~mdadams/jasper/software/jasper-1.701.0.zip
|
|||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Patch1: jasper-1.701.0-GL.patch
|
Patch1: jasper-1.701.0-GL.patch
|
||||||
|
# autoconf/automake bits of patch1
|
||||||
|
Patch2: jasper-1.701.0-GL-ac.patch
|
||||||
|
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
BuildRequires: libjpeg-devel
|
BuildRequires: libjpeg-devel
|
||||||
@ -57,6 +59,7 @@ Requires: libjpeg-devel
|
|||||||
|
|
||||||
%if "%{?geo:1}" == "1"
|
%if "%{?geo:1}" == "1"
|
||||||
chmod +x configure configure.ac
|
chmod +x configure configure.ac
|
||||||
|
%patch2 -p1 -b .GL-ac
|
||||||
libtoolize --force
|
libtoolize --force
|
||||||
aclocal
|
aclocal
|
||||||
autoconf
|
autoconf
|
||||||
@ -115,6 +118,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 1 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.701.0-11
|
||||||
|
- fixup build issues introduced by geojasper integration
|
||||||
|
|
||||||
* Wed Mar 1 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.701.0-10
|
* Wed Mar 1 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.701.0-10
|
||||||
- support/use geojasper (optional, default no)
|
- support/use geojasper (optional, default no)
|
||||||
- fc5: gcc/glibc respin
|
- fc5: gcc/glibc respin
|
||||||
|
Loading…
Reference in New Issue
Block a user