- support/use geojasper (optional, default no)
- fc5: gcc/glibc respin
This commit is contained in:
parent
b7ce063379
commit
cd2a97a80b
@ -1,6 +1,6 @@
|
||||
--- jasper-1.701.0/configure.GL 2004-02-08 19:44:12.000000000 -0600
|
||||
+++ jasper-1.701.0/configure 2005-10-18 08:09:38.000000000 -0500
|
||||
@@ -9465,7 +9465,7 @@
|
||||
--- jasper-1.701.0.GEO/configure.GL 2006-02-20 20:01:30.000000000 -0600
|
||||
+++ jasper-1.701.0.GEO/configure 2006-02-24 07:40:46.000000000 -0600
|
||||
@@ -9464,7 +9464,7 @@
|
||||
OPENGL_LIBS=""
|
||||
if test $ENABLE_OPENGL = yes; then
|
||||
if test $HAVE_OPENGL = no; then
|
||||
@ -9,3 +9,14 @@
|
||||
echo "$as_me:$LINENO: checking for glutInit in -lglut" >&5
|
||||
echo $ECHO_N "checking for glutInit in -lglut... $ECHO_C" >&6
|
||||
if test "${ac_cv_lib_glut_glutInit+set}" = set; then
|
||||
--- jasper-1.701.0.GEO/configure.ac.GL 2006-02-20 19:58:02.000000000 -0600
|
||||
+++ jasper-1.701.0.GEO/configure.ac 2006-02-24 07:40:38.000000000 -0600
|
||||
@@ -242,7 +242,7 @@
|
||||
OPENGL_LIBS=""
|
||||
if test $ENABLE_OPENGL = yes; then
|
||||
if test $HAVE_OPENGL = no; then
|
||||
- TMPLIBS="-lglut -lGL -lGLU $X_PRE_LIBS -lX11 -lXmu -lXi -lXext -lXt $X_EXTRA_LIBS $X_LIBS"
|
||||
+ TMPLIBS="-lglut"
|
||||
AC_CHECK_LIB(glut, glutInit, [HAVE_OPENGL=yes;
|
||||
OPENGL_LIBS=$TMPLIBS], HAVE_OPENGL=no, $TMPLIBS)
|
||||
fi
|
||||
|
37
jasper.spec
37
jasper.spec
@ -5,19 +5,30 @@
|
||||
# koffice
|
||||
# netpbm
|
||||
|
||||
# define to use GeoJasper
|
||||
#define geo 1
|
||||
|
||||
Summary: Implementation of the JPEG-2000 standard, Part 1
|
||||
Name: jasper
|
||||
Group: System Environment/Libraries
|
||||
Version: 1.701.0
|
||||
Release: 9%{?dist}.1
|
||||
Release: 10%{?dist}
|
||||
|
||||
License: JasPer License Version 2.0
|
||||
%if "%{?geo:1}" == "1"
|
||||
%define geojasper_ver 1.2.9
|
||||
URL: http://www.dimin.net/software/utils.html
|
||||
Source: http://dimin.m6.net/software/utils/geojasper_src.zip
|
||||
Provides: geojasper = %{geojasper_ver}
|
||||
%else
|
||||
URL: http://www.ece.uvic.ca/~mdadams/jasper/
|
||||
Source: http://www.ece.uvic.ca/~mdadams/jasper/software/jasper-1.701.0.zip
|
||||
%endif
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Patch1: jasper-1.701.0-GL.patch
|
||||
|
||||
BuildRequires: automake
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: freeglut-devel
|
||||
# workaround:
|
||||
@ -40,12 +51,22 @@ Requires: libjpeg-devel
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%setup -q -n %{name}-%{version}%{?geo:.GEO}
|
||||
|
||||
%patch1 -p1 -b .GL
|
||||
|
||||
%if "%{?geo:1}" == "1"
|
||||
chmod +x configure configure.ac
|
||||
libtoolize --force
|
||||
aclocal
|
||||
autoconf
|
||||
autoheader
|
||||
automake -a
|
||||
%endif
|
||||
|
||||
|
||||
%build
|
||||
|
||||
%configure \
|
||||
--enable-shared \
|
||||
--disable-static
|
||||
@ -67,10 +88,6 @@ rm -f doc/README
|
||||
rm -f $RPM_BUILD_ROOT%{_bindir}/%{_target_platform}*
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
|
||||
|
||||
# avoid conflict(s) with tomcat
|
||||
# not needed anymore, see bz #176773
|
||||
# mv $RPM_BUILD_ROOT%{_bindir}/jasper $RPM_BUILD_ROOT%{_bindir}/jaspertool
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
@ -78,13 +95,13 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
|
||||
%{_bindir}/imgcmp
|
||||
%{_bindir}/jiv
|
||||
%{_bindir}/imginfo
|
||||
%{_bindir}/jasper*
|
||||
%{_bindir}/*jasper*
|
||||
%{_libdir}/lib*.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%doc doc/*
|
||||
%{_includedir}/*
|
||||
%{_includedir}/jasper/
|
||||
%{_libdir}/lib*.so
|
||||
|
||||
|
||||
@ -98,6 +115,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Mar 1 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.701.0-10
|
||||
- support/use geojasper (optional, default no)
|
||||
- fc5: gcc/glibc respin
|
||||
|
||||
* Fri Feb 10 2006 Rex Dieter <rexdieter[AT]users.sf.net>
|
||||
- fc5: gcc/glibc respin
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user