re-import sources as agreed with the maintainer
This commit is contained in:
parent
b1abaa9b71
commit
9c35783ef6
@ -1 +0,0 @@
|
|||||||
1
|
|
10
.gitignore
vendored
10
.gitignore
vendored
@ -1,2 +1,10 @@
|
|||||||
SOURCES/jansi-project-1.18.tar.gz
|
/jansi-1.6.tar.xz
|
||||||
|
/jansi-1.9.tar.xz
|
||||||
|
/jansi-1.11.tar.xz
|
||||||
|
/noarch
|
||||||
|
/.build-*.log
|
||||||
|
/*.src.rpm
|
||||||
|
/jansi-project-1.16.tar.gz
|
||||||
|
/jansi-project-1.17.tar.gz
|
||||||
|
/jansi-project-1.17.1.tar.gz
|
||||||
/jansi-project-1.18.tar.gz
|
/jansi-project-1.18.tar.gz
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
From d94c5832e14504d44abeba47866dfa7dac5992b5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Guillaume Nodet <gnodet@gmail.com>
|
|
||||||
Date: Fri, 23 Jul 2021 09:22:19 +0200
|
|
||||||
Subject: [PATCH] Avoid possible NPE, fixes #214
|
|
||||||
|
|
||||||
---
|
|
||||||
src/main/java/org/fusesource/jansi/AnsiPrintStream.java | 6 +++++-
|
|
||||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/main/java/org/fusesource/jansi/AnsiPrintStream.java b/src/main/java/org/fusesource/jansi/AnsiPrintStream.java
|
|
||||||
index e153c43..df6e5a6 100644
|
|
||||||
--- a/src/main/java/org/fusesource/jansi/AnsiPrintStream.java
|
|
||||||
+++ b/src/main/java/org/fusesource/jansi/AnsiPrintStream.java
|
|
||||||
@@ -76,7 +76,11 @@ public void install() throws IOException {
|
|
||||||
}
|
|
||||||
|
|
||||||
public void uninstall() throws IOException {
|
|
||||||
- getOut().uninstall();
|
|
||||||
+ // If the system output stream has been closed, out should be null, so avoid a NPE
|
|
||||||
+ AnsiOutputStream out = getOut();
|
|
||||||
+ if (out != null) {
|
|
||||||
+ out.uninstall();
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
@Override
|
|
@ -1,9 +0,0 @@
|
|||||||
--- !Policy
|
|
||||||
product_versions:
|
|
||||||
- rhel-9
|
|
||||||
decision_contexts:
|
|
||||||
- osci_compose_gate
|
|
||||||
rules:
|
|
||||||
- !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}
|
|
||||||
# https://docs.engineering.redhat.com/display/RHELPLAN/Maven+Bootstrap+manual+gating+test
|
|
||||||
- !PassingTestCaseRule {test_case_name: manual.sst_cs_apps.maven.bootstrap}
|
|
@ -1,20 +0,0 @@
|
|||||||
#!/bin/bash
|
|
||||||
set -e
|
|
||||||
|
|
||||||
name=jansi
|
|
||||||
version="$(sed -n 's/Version:\s*//p' *.spec)"
|
|
||||||
|
|
||||||
# RETRIEVE
|
|
||||||
wget "https://github.com/fusesource/jansi/archive/jansi-${version}.tar.gz" -O "${name}-${version}.orig.tar.gz"
|
|
||||||
|
|
||||||
rm -rf tarball-tmp
|
|
||||||
mkdir tarball-tmp
|
|
||||||
pushd tarball-tmp
|
|
||||||
tar xf "../${name}-${version}.orig.tar.gz"
|
|
||||||
|
|
||||||
# CLEAN TARBALL
|
|
||||||
rm -r */src/main/native/inc_{mac,win}/
|
|
||||||
|
|
||||||
tar -czf "../${name}-${version}.tar.gz" *
|
|
||||||
popd
|
|
||||||
rm -r tarball-tmp "${name}-${version}.orig.tar.gz"
|
|
@ -1,14 +0,0 @@
|
|||||||
--- a/src/main/java/org/fusesource/jansi/internal/JansiLoader.java 2020-12-15 03:03:00.000000000 -0700
|
|
||||||
+++ b/src/main/java/org/fusesource/jansi/internal/JansiLoader.java 2020-12-15 07:57:30.238720226 -0700
|
|
||||||
@@ -295,6 +295,11 @@ public class JansiLoader {
|
|
||||||
} else {
|
|
||||||
triedPaths.add(jansiNativeLibraryPath);
|
|
||||||
}
|
|
||||||
+ } else {
|
|
||||||
+ if (loadNativeLibrary(new File("@LIBDIR@/jansi", jansiNativeLibraryName))) {
|
|
||||||
+ extracted = true;
|
|
||||||
+ return;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
// Load the os-dependent library from the jar file
|
|
Binary file not shown.
@ -1,8 +0,0 @@
|
|||||||
// Compile with:
|
|
||||||
// $ javac -cp /usr/lib/java/jansi/jansi.jar JansiLoadLibrary.java
|
|
||||||
|
|
||||||
class JansiLoadLibrary {
|
|
||||||
public static void main(String[] args) {
|
|
||||||
org.fusesource.jansi.internal.JansiLoader.initialize();
|
|
||||||
}
|
|
||||||
}
|
|
@ -1,5 +0,0 @@
|
|||||||
summary: Basic smoke test
|
|
||||||
execute:
|
|
||||||
script:
|
|
||||||
- dnf -y install java-11-openjdk-headless
|
|
||||||
- /usr/lib/jvm/jre-11-openjdk/bin/java -cp /usr/lib/java/jansi/jansi.jar:plans JansiLoadLibrary
|
|
Loading…
Reference in New Issue
Block a user