Initial import.
This commit is contained in:
parent
9d6c5f81d6
commit
634aee7f76
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
|||||||
|
/jansi-1.6.tar.xz
|
33
jansi-1.6-pom.patch
Normal file
33
jansi-1.6-pom.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
diff -Naur jansi-1.6/jansi/pom.xml jansi-1.6-work/jansi/pom.xml
|
||||||
|
--- jansi-1.6/jansi/pom.xml 2011-06-19 10:51:32.000000000 -0400
|
||||||
|
+++ jansi-1.6-work/jansi/pom.xml 2011-08-25 08:24:42.950756822 -0400
|
||||||
|
@@ -94,19 +94,6 @@
|
||||||
|
<version>2.3</version>
|
||||||
|
</plugin>
|
||||||
|
|
||||||
|
- <!-- include all the dependencies into the jar so it can run standalone -->
|
||||||
|
- <plugin>
|
||||||
|
- <groupId>org.fusesource.mvnplugins</groupId>
|
||||||
|
- <artifactId>maven-uberize-plugin</artifactId>
|
||||||
|
- <version>1.5</version>
|
||||||
|
- <executions>
|
||||||
|
- <execution>
|
||||||
|
- <phase>package</phase>
|
||||||
|
- <goals><goal>uberize</goal></goals>
|
||||||
|
- </execution>
|
||||||
|
- </executions>
|
||||||
|
- </plugin>
|
||||||
|
-
|
||||||
|
<plugin>
|
||||||
|
<groupId>org.apache.maven.plugins</groupId>
|
||||||
|
<artifactId>maven-surefire-plugin</artifactId>
|
||||||
|
diff -Naur jansi-1.6/pom.xml jansi-1.6-work/pom.xml
|
||||||
|
--- jansi-1.6/pom.xml 2011-06-19 10:51:32.000000000 -0400
|
||||||
|
+++ jansi-1.6-work/pom.xml 2011-08-25 08:25:51.005754781 -0400
|
||||||
|
@@ -132,6 +132,5 @@
|
||||||
|
|
||||||
|
<modules>
|
||||||
|
<module>jansi</module>
|
||||||
|
- <module>jansi-website</module>
|
||||||
|
</modules>
|
||||||
|
</project>
|
94
jansi.spec
Normal file
94
jansi.spec
Normal file
@ -0,0 +1,94 @@
|
|||||||
|
Name: jansi
|
||||||
|
Version: 1.6
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Jansi is a java library for generating and interpreting ANSI escape sequences
|
||||||
|
Group: Development/Libraries
|
||||||
|
License: ASL 2.0
|
||||||
|
URL: http://jansi.fusesource.org/
|
||||||
|
|
||||||
|
# git clone git://github.com/fusesource/jansi.git
|
||||||
|
# cd jansi && git archive --format=tar --prefix=jansi-1.6/ jansi-project-1.6 | xz > jansi-1.6.tar.xz
|
||||||
|
Source0: %{name}-%{version}.tar.xz
|
||||||
|
Patch0: %{name}-%{version}-pom.patch
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
BuildRequires: jpackage-utils
|
||||||
|
BuildRequires: java-devel
|
||||||
|
BuildRequires: maven
|
||||||
|
BuildRequires: maven-compiler-plugin
|
||||||
|
BuildRequires: maven-license-plugin
|
||||||
|
BuildRequires: maven-install-plugin
|
||||||
|
BuildRequires: maven-jar-plugin
|
||||||
|
BuildRequires: maven-javadoc-plugin
|
||||||
|
BuildRequires: maven-release-plugin
|
||||||
|
BuildRequires: maven-surefire-plugin
|
||||||
|
BuildRequires: jansi-native
|
||||||
|
BuildRequires: maven-clean-plugin
|
||||||
|
BuildRequires: maven-plugin-bundle
|
||||||
|
BuildRequires: junit4
|
||||||
|
BuildRequires: fusesource-pom
|
||||||
|
BuildRequires: maven-surefire-provider-junit4
|
||||||
|
|
||||||
|
Requires: java
|
||||||
|
Requires: jpackage-utils
|
||||||
|
Requires: jansi-native
|
||||||
|
Requires: hawtjni
|
||||||
|
|
||||||
|
%description
|
||||||
|
Jansi is a small java library that allows you to use ANSI escape sequences
|
||||||
|
in your Java console applications. It implements ANSI support on platforms
|
||||||
|
which don't support it like Windows and provides graceful degradation for
|
||||||
|
when output is being sent to output devices which cannot support ANSI sequences.
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Summary: Javadocs for %{name}
|
||||||
|
Group: Documentation
|
||||||
|
Requires: jpackage-utils
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
This package contains the API documentation for %{name}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
mvn-rpmbuild install javadoc:aggregate
|
||||||
|
|
||||||
|
%install
|
||||||
|
# JAR
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_javadir}
|
||||||
|
cp -p %{name}/target/%{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
|
||||||
|
|
||||||
|
# JAVADOC
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||||
|
cp -rp target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||||
|
|
||||||
|
# POM
|
||||||
|
install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir}
|
||||||
|
install -pm 644 pom.xml $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-%{name}-project.pom
|
||||||
|
install -pm 644 %{name}/pom.xml $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-%{name}.pom
|
||||||
|
|
||||||
|
# DEPMAP
|
||||||
|
%add_maven_depmap JPP-%{name}-project.pom
|
||||||
|
%add_maven_depmap JPP-%{name}.pom %{name}.jar
|
||||||
|
|
||||||
|
%files
|
||||||
|
%{_mavenpomdir}/*
|
||||||
|
%{_mavendepmapfragdir}/*
|
||||||
|
%{_javadir}/*
|
||||||
|
%doc readme.md license.txt changelog.md
|
||||||
|
|
||||||
|
%files javadoc
|
||||||
|
%{_javadocdir}/%{name}
|
||||||
|
%doc license.txt
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Aug 25 2011 Marek Goldmann <mgoldman@redhat.com> 1.6-1
|
||||||
|
- Upstream release 1.6
|
||||||
|
- Spec file cleanup
|
||||||
|
|
||||||
|
* Fri May 27 2011 Marek Goldmann <mgoldman@redhat.com> 1.5-1
|
||||||
|
- Initial packaging
|
||||||
|
|
Loading…
Reference in New Issue
Block a user