828cc1621a
drop patches that have been merged upstream, as well as several patches that are replaced by configuration options with the new build system
51 lines
1.6 KiB
Diff
51 lines
1.6 KiB
Diff
From 08eb07147f8285dd8d986ae5e1528c8a09b68dc8 Mon Sep 17 00:00:00 2001
|
|
From: rpm-build <rpm-build>
|
|
Date: Fri, 30 Jun 2023 22:19:23 +0000
|
|
Subject: [PATCH 1/1] libiscsi build fixes
|
|
|
|
---
|
|
Makefile | 4 ++++
|
|
libiscsi/Makefile | 4 ++--
|
|
2 files changed, 6 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 7ae461a..e3bfab6 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -58,6 +58,10 @@ deprecation_msg:
|
|
@echo "*** Please see the README file for more information."
|
|
@echo "***"
|
|
|
|
+.PHONY: libiscsi
|
|
+libiscsi:
|
|
+ $(MAKE) $(MFLAGS) -C libiscsi
|
|
+
|
|
user: deprecation_msg iscsiuio/Makefile
|
|
$(MAKE) $(MFLAGS) -C libopeniscsiusr
|
|
$(MAKE) $(MFLAGS) -C sysdeps
|
|
diff --git a/libiscsi/Makefile b/libiscsi/Makefile
|
|
index 7f5d371..c31b25b 100644
|
|
--- a/libiscsi/Makefile
|
|
+++ b/libiscsi/Makefile
|
|
@@ -19,7 +19,7 @@ CFLAGS += -DSBINDIR=\"$(SBINDIR)\"
|
|
CFLAGS += -DISCSI_DB_ROOT=\"$(DBROOT)\"
|
|
CFLAGS += -DISCSI_VERSION_STR=\"$(ISCSI_VERSION_STR)\"
|
|
|
|
-LDFLAGS = -L../libopeniscsiusr -lopeniscsiusr -lkmod -lcrypto
|
|
+LDFLAGS = -L../redhat-linux-build -lopeniscsiusr -lkmod -lcrypto
|
|
|
|
LIB = libiscsi.so.0
|
|
TESTS = tests/test_discovery_sendtargets tests/test_discovery_firmware
|
|
@@ -59,7 +59,7 @@ fw-objs/%.o: ../usr/fwparam_ibft/%.c
|
|
$(CC) $(CFLAGS) -c $< -o $@
|
|
|
|
$(LIB): $(COMMON_OBJS) $(FW_OBJS) $(USR_OBJS) libiscsi.o
|
|
- $(CC) $(CFLAGS) -shared -Wl,-soname,$(LIB) $^ -o $@ -L$(TOPDIR)/libopeniscsiusr -lopeniscsiusr
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(LIB) $^ -o $@
|
|
ln -s -f $(LIB) libiscsi.so
|
|
|
|
$(TESTS): $(FW_OBJS) $(COMMON_OBJS) $(USR_OBJS) $(LIB)
|
|
--
|
|
2.41.0
|
|
|