0047874487
Resolves: #1040343
27 lines
850 B
Diff
27 lines
850 B
Diff
diff --git a/iscsiuio/configure b/iscsiuio/configure
|
|
index 50cfd90..c930b67 100755
|
|
--- a/iscsiuio/configure
|
|
+++ b/iscsiuio/configure
|
|
@@ -22782,7 +22782,7 @@ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
|
|
|
|
|
|
|
-CFLAGS="${CFLAGS} -O2 -Wall"
|
|
+CFLAGS="${CFLAGS} -O2 -Wall -fno-strict-aliasing"
|
|
## check for --enable-debug first before checking CFLAGS before
|
|
## so that we don't mix -O and -g
|
|
# Check whether --enable-debug was given.
|
|
diff --git a/iscsiuio/configure.ac b/iscsiuio/configure.ac
|
|
index e4af3b2..551a513 100644
|
|
--- a/iscsiuio/configure.ac
|
|
+++ b/iscsiuio/configure.ac
|
|
@@ -52,7 +52,7 @@ AC_LIBTOOL_DLOPEN
|
|
# libtool stuff
|
|
AC_PROG_LIBTOOL
|
|
|
|
-CFLAGS="${CFLAGS} -O2 -Wall"
|
|
+CFLAGS="${CFLAGS} -O2 -Wall -fno-strict-aliasing"
|
|
## check for --enable-debug first before checking CFLAGS before
|
|
## so that we don't mix -O and -g
|
|
AC_ARG_ENABLE(debug,
|