Resolves: #593269
This commit is contained in:
parent
a094452bde
commit
e16d7fc569
39
iscsi-initiator-utils-disable-crypto.patch
Normal file
39
iscsi-initiator-utils-disable-crypto.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
diff -aurp open-iscsi-2.0-872-rc4-bnx2i/Makefile open-iscsi-2.0-872-rc4-bnx2i.work/Makefile
|
||||||
|
--- open-iscsi-2.0-872-rc4-bnx2i/Makefile 2011-04-18 12:50:45.000000000 -0500
|
||||||
|
+++ open-iscsi-2.0-872-rc4-bnx2i.work/Makefile 2011-04-19 21:16:13.000000000 -0500
|
||||||
|
@@ -27,7 +27,7 @@ IFACEFILES = etc/iface.example
|
||||||
|
all: user kernel
|
||||||
|
|
||||||
|
user: ;
|
||||||
|
- cd utils/open-isns; ./configure; $(MAKE)
|
||||||
|
+ cd utils/open-isns; ./configure --with-security=no; $(MAKE)
|
||||||
|
$(MAKE) -C utils/sysdeps
|
||||||
|
$(MAKE) -C utils/fwparam_ibft
|
||||||
|
$(MAKE) -C usr
|
||||||
|
diff -aurp open-iscsi-2.0-872-rc4-bnx2i/usr/Makefile open-iscsi-2.0-872-rc4-bnx2i.work/usr/Makefile
|
||||||
|
--- open-iscsi-2.0-872-rc4-bnx2i/usr/Makefile 2011-04-18 12:50:45.000000000 -0500
|
||||||
|
+++ open-iscsi-2.0-872-rc4-bnx2i.work/usr/Makefile 2011-04-19 21:16:13.000000000 -0500
|
||||||
|
@@ -56,10 +56,10 @@ all: $(PROGRAMS)
|
||||||
|
|
||||||
|
iscsid: $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(DISCOVERY_SRCS) \
|
||||||
|
iscsid.o session_mgmt.o discoveryd.o
|
||||||
|
- $(CC) $(CFLAGS) $^ -o $@ -L../utils/open-isns -lisns -lcrypto
|
||||||
|
+ $(CC) $(CFLAGS) $^ -o $@ -L../utils/open-isns -lisns
|
||||||
|
|
||||||
|
iscsiadm: $(ISCSI_LIB_SRCS) $(DISCOVERY_SRCS) iscsiadm.o session_mgmt.o
|
||||||
|
- $(CC) $(CFLAGS) $^ -o $@ -L../utils/open-isns -lisns -lcrypto
|
||||||
|
+ $(CC) $(CFLAGS) $^ -o $@ -L../utils/open-isns -lisns
|
||||||
|
|
||||||
|
iscsistart: $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(FW_BOOT_SRCS) \
|
||||||
|
iscsistart.o statics.o
|
||||||
|
diff -aurp open-iscsi-2.0-872-rc4-bnx2i/utils/open-isns/Makefile.in open-iscsi-2.0-872-rc4-bnx2i.work/utils/open-isns/Makefile.in
|
||||||
|
--- open-iscsi-2.0-872-rc4-bnx2i/utils/open-isns/Makefile.in 2011-04-18 12:50:45.000000000 -0500
|
||||||
|
+++ open-iscsi-2.0-872-rc4-bnx2i.work/utils/open-isns/Makefile.in 2011-04-19 21:16:13.000000000 -0500
|
||||||
|
@@ -32,7 +32,6 @@ LIBOBJS = server.o \
|
||||||
|
security.o \
|
||||||
|
authblock.o \
|
||||||
|
policy.o \
|
||||||
|
- pki.o \
|
||||||
|
register.o \
|
||||||
|
query.o \
|
||||||
|
getnext.o \
|
@ -3,7 +3,7 @@
|
|||||||
Summary: iSCSI daemon and utility programs
|
Summary: iSCSI daemon and utility programs
|
||||||
Name: iscsi-initiator-utils
|
Name: iscsi-initiator-utils
|
||||||
Version: 6.2.0.872
|
Version: 6.2.0.872
|
||||||
Release: 20%{?dist}
|
Release: 21%{?dist}
|
||||||
Source0: http://people.redhat.com/mchristi/iscsi/rhel6.0/source/open-iscsi-2.0-872-rc4-bnx2i.tar.gz
|
Source0: http://people.redhat.com/mchristi/iscsi/rhel6.0/source/open-iscsi-2.0-872-rc4-bnx2i.tar.gz
|
||||||
Source1: iscsid.init
|
Source1: iscsid.init
|
||||||
Source2: iscsidevs.init
|
Source2: iscsidevs.init
|
||||||
@ -47,6 +47,8 @@ Patch15: iscsi-initiator-utils-fixes.patch
|
|||||||
Patch16: iscsi-initiator-utils-node-hostname.patch
|
Patch16: iscsi-initiator-utils-node-hostname.patch
|
||||||
# created offload boot session if ibft and iscsi_host mac match
|
# created offload boot session if ibft and iscsi_host mac match
|
||||||
Patch17: iscsi-initiator-utils-fix-bnx2i-mac-match.patch
|
Patch17: iscsi-initiator-utils-fix-bnx2i-mac-match.patch
|
||||||
|
# pki is not used by isns so do not build with it
|
||||||
|
Patch18: iscsi-initiator-utils-disable-crypto.patch
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
@ -92,6 +94,7 @@ developing applications that use %{name}.
|
|||||||
%patch15 -p1 -b .fixes
|
%patch15 -p1 -b .fixes
|
||||||
%patch16 -p1 -b .node-hostname
|
%patch16 -p1 -b .node-hostname
|
||||||
%patch17 -p1 -b .fix-bnx2i-mac-match
|
%patch17 -p1 -b .fix-bnx2i-mac-match
|
||||||
|
%patch18 -p1 -b .disable-crypto
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cd utils/open-isns
|
cd utils/open-isns
|
||||||
@ -210,6 +213,11 @@ fi
|
|||||||
%{_includedir}/libiscsi.h
|
%{_includedir}/libiscsi.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 19 2011 Mike Christie <mcrhsit@redhat.com> 6.2.0.872.21
|
||||||
|
- 593269 iscsi was built against libcrypto, but was not using the code
|
||||||
|
so this disabled the building of that code [patch from .14 got dropped
|
||||||
|
due to mismerge].
|
||||||
|
|
||||||
* Mon Apr 18 2011 Mike Christie <mcrhsit@redhat.com> 6.2.0.872.20
|
* Mon Apr 18 2011 Mike Christie <mcrhsit@redhat.com> 6.2.0.872.20
|
||||||
- 696267 Create a offloaded session if the iscsi_host MAC and ibft
|
- 696267 Create a offloaded session if the iscsi_host MAC and ibft
|
||||||
MAC match. This enables support for Broadcoms hba boot mode.
|
MAC match. This enables support for Broadcoms hba boot mode.
|
||||||
|
Loading…
Reference in New Issue
Block a user